Autor Tema: 2 interfaces conectadas a la misma red cada una con su IP. ¿Por qué no funciona?  (Leído 264 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado peperfus

  • *****
  • Mensajes: 167
Hola.

Citar
Edito: He cambiado el título a uno más descriptivo de la situación.
El router en cuestión es un comtrend ar5387un, el negro de jazztel.
No estoy usando la wifi como repetidor, ni entutada ni nada, sólo como cliente. Eth0 conectada a la misma red.
Seguramente será una tontería, pero no sé por qué...
Tengo un router con wifi en modo cliente, con DHCP y coge IP perfectamente.
Pero cuando lo conecto también por cable, también con DHCP, no la coge.
(El cable lo tengo conectado a un PLC, al que le llega conectividad de red, confirmado).

¿Alguien sabe por qué puede ser?  ???
Openwrt 18.06.5
Firewall desactivado en ambas.
vlan desactivado.
IPv6 desactivado.

Edito: si pongo la IP estática, no funciona. No hay conectividad.
Voy a probarlo sin el PLC a ver si fuera eso...
Se pierde la conexión. Ni por wifi ni por cable.

Como siempre, gracias.


« Última modificación: 05-12-2019, 12:04 (Jueves) por peperfus »

Desconectado eduperez

  • **
  • Mensajes: 39
A ver... conectas el router secundario por wifi y cable contra el mismo router principal?

Desconectado peperfus

  • *****
  • Mensajes: 167
(Gracias por la respuesta)

A ver... conectas el router secundario por wifi y cable contra el mismo router principal?
Sí.
Son interfaces independientes: eth0 y wlan0
Cada una con su configuración IP (de la misma red)
« Última modificación: 03-12-2019, 23:42 (Martes) por peperfus »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
(Gracias por la respuesta)

A ver... conectas el router secundario por wifi y cable contra el mismo router principal?
Sí.
Son interfaces independientes: eth0 y wlan0
Cada una con su configuración IP (de la misma red)

Si haces 2 conexiones al mismo dispositivo en la misma red, haces un bucle.
¿Qué pretendes haciendo esas dos conexiones? Porque si lo que pretendes hacer es "sumar" la velocidad de dos conexiones, no se hace así...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Desconectado peperfus

  • *****
  • Mensajes: 167
Sé que se hace un bucle, pero tenía entendido que eso sólo era en caso de un switch (misma tarjeta de red, con varios puertos). Sin embargo, en este caso son tarjetas de red distintas (cable y wifi) y ni siquiera están puenteadas. Cada una tiene su propia configuración IP.

Lo que pretendía era tener 2 formas de acceso al router, por si una de ellas cae.

Intentando refrescar la memoria sobre conocimientos de redes....
Si no recuerdo mal, cuando se pone un cable de red de puerto a puerto, del mismo switch (y ya no digamos de los prehistóricos hubs), se hacía un bucle, aunque no recuerdo el motivo.

Pero esto son tarjetas de red distintas y tampoco conectadas entre sí. No entiendo por qué se haría un bucle. Simplemente son 2 formas de conectar al mismo router. Y cada una tiene su propia IP (distintas).

Desconectado eduperez

  • **
  • Mensajes: 39
En el router secundario tendrás dos interfaces, con dos direcciones IP distintas, pero en la misma red, ¿no? Eso ya es un problema.

Desconectado peperfus

  • *****
  • Mensajes: 167
¿Por qué es un problema? Yo no le veo ninguno.
Al fin y al cabo, una misma tarjeta de red puede tener varias IPs al mismo tiempo, incluso.

Los portátiles, por ejemplo, se pueden conectar por cable y wifi a la misma red, al mismo tiempo.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1955
Los portátiles, por ejemplo, se pueden conectar por cable y wifi a la misma red, al mismo tiempo.

Y sólo por uno de ellos irá el tráfico... no se agregan velocidades, ni se balancea la carga...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

Desconectado peperfus

  • *****
  • Mensajes: 167
Los portátiles, por ejemplo, se pueden conectar por cable y wifi a la misma red, al mismo tiempo.

Y sólo por uno de ellos irá el tráfico... no se agregan velocidades, ni se balancea la carga...

No pretendo que funcione de otra manera. Lo que quiero es "tener 2 puertas para poder entrar a la misma habitación", pudiendo entrar/salir por cualquiera de ellas, aunque obviamente no a la vez.
Dicho esto, estoy empezando a sospechar que pueda ser causa del enrutamiento. Creo que se pierde la conexión porque no sabe por dónde ir. A lo mejor definiendo una ruta estática ??
Cuando lo pruebe lo comentaré.
« Última modificación: 11-12-2019, 11:54 (Miércoles) por peperfus »

Desconectado peperfus

  • *****
  • Mensajes: 167
Acabo de conseguirlo en una máquina virtual con dos interfaces de red: eth0 y eth1.
Aquí lo que he hecho:
Ambas configuradas con DHCP.
Firewall desactivado (disabled).
IPv6 desactivado.
(No he tocado nada de rutas)

Hago un copy paste de los archivos de config, para referencia:
/etc/config/network:
Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option ipv6 'off'

config globals 'globals'

config interface 'lan0'
        option ifname 'eth0'
        option proto 'dhcp'
        option delegate '0'

config interface 'lan1'
        option ifname 'eth1'
        option proto 'dhcp'
        option delegate '0'

/etc/dhcp:
Código: [Seleccionar]
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan0'
        option interface 'lan0'
        option ignore '1'

config dhcp 'lan1'
        option interface 'lan1'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

Salida de route:
Código: [Seleccionar]
root@OpenWrt:/etc/config# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.0.254   0.0.0.0         UG    0      0        0 eth0
192.168.0.0     *               255.255.255.0   U     0      0        0 eth1
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0

No sé por qué no lo conseguí cuando lo hice en el router físico. Volveré a probarlo otro día a ver si doy en el clavo. Se me ocurre ahora, por experimentar, añadir más interfaces (eth2 y eth3), a ver si también rula.
Volveré con documentación.


Edito, después de la prueba en cuestión:
Rula.  :D


(No sé por qué se ve tan borroso, pero en fin. Se entiende la idea.)
Cada interfaz conectada a la misma red. Cada una con su IP, independiente de las demás.
« Última modificación: 11-12-2019, 13:38 (Miércoles) por peperfus »

//FINAL Y MÁS DOS RESPUESTAS