Autor Tema: [Tutorial] OpenWrt en Western Digital My Net N750  (Leído 36388 veces)

0 Usuarios y 1 Visitante están viendo este tema.

eskasi

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #20 en: 07-04-2014, 17:54 (Lunes) »
Jar229,
por que propones 2 versiones del firmware: una si tienes firmware original y otra si ya tenemos openwrt?
Que pasa si me equivoco?



Pteridium

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #21 en: 07-04-2014, 18:10 (Lunes) »
Jar229,
por que propones 2 versiones del firmware: una si tienes firmware original y otra si ya tenemos openwrt?
http://wiki.openwrt.org/toh/wd/n750#installation
Que pasa si me equivoco?
No creo que quieras saberlo... Yo metí la pata con un TP-Link TL-MR3220v2 y estuve a un tris de tener que tirarlo a la basura (la taurina es mala cuando vas a soldar).  >:D
« Última modificación: 07-04-2014, 18:14 (Lunes) por Pteridium »

vk496

  • Visitante
Re: Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #22 en: 07-04-2014, 18:28 (Lunes) »
(la taurina es mala cuando vas a soldar).  >:D

A mi con 2 Monsters me dió por eliminar todas las carpetas vacías de mi Linux... (ya sabes, optimizar cosas)

Un comando de 40 seg. y 6 horas de intentos por recuperar el sistema. Al final tuve que formatear... Jajajaja

Salu2

eskasi

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #23 en: 08-04-2014, 10:36 (Martes) »
Jar229,
por que propones 2 versiones del firmware: una si tienes firmware original y otra si ya tenemos openwrt?
http://wiki.openwrt.org/toh/wd/n750#installation
Que pasa si me equivoco?
No creo que quieras saberlo... Yo metí la pata con un TP-Link TL-MR3220v2 y estuve a un tris de tener que tirarlo a la basura (la taurina es mala cuando vas a soldar).  >:D

El link que me propones es el del trunk. Ya lo habia leido e instale el trunk sobre el firmware original. Es mas, con el metodo recovery,  sobreescribi con el trunk un primer flasheo del trunk al que deje mal la configuracion.

Si luego quiero actualizar una de las compilaciones, puedo sobreescribirlo con la version trunk?
Si no es asi, que es lo que cambian las compilaciones de jar229 para utilizar una u otra?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #24 en: 08-04-2014, 11:18 (Martes) »
Jar229,
por que propones 2 versiones del firmware: una si tienes firmware original y otra si ya tenemos openwrt?
http://wiki.openwrt.org/toh/wd/n750#installation
Que pasa si me equivoco?
No creo que quieras saberlo... Yo metí la pata con un TP-Link TL-MR3220v2 y estuve a un tris de tener que tirarlo a la basura (la taurina es mala cuando vas a soldar).  >:D

El link que me propones es el del trunk. Ya lo habia leido e instale el trunk sobre el firmware original. Es mas, con el metodo recovery,  sobreescribi con el trunk un primer flasheo del trunk al que deje mal la configuracion.

Si luego quiero actualizar una de las compilaciones, puedo sobreescribirlo con la version trunk?
Si no es asi, que es lo que cambian las compilaciones de jar229 para utilizar una u otra?

Creo que tienes un pequeño lío montado ... o yo no te entiendo bien ...  ;D

De momento, este router sólo tiene soporte en la rama de desarrollo (trunk), así que obligatoriamente tienes que usar un firmware de esta rama.

La diferencia está en que si es la primera vez que vas a instalar OpenWrt en el router, tienes que usar el firmware que tiene la 'coletilla' factory. Una vez que ya tienes OpenWrt en él, y quieras actualizarlo, debes usar las que tienen la 'coletilla' sysupgrade.
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #25 en: 29-04-2014, 23:06 (Martes) »
Hola, acabo de comprar el NE620, se que no es el mismo del que estais hablando pero es similar. Le he puesto Openwrt en su version by mk13139 r40572 / LuCI Trunk (svn-r9977).

Lo estoy intentando configurar para sustituir el router de fibra de movistar y lo unico que necesito es configurar uno de los puertos (el wan) haciando tagging de la vlan 6.

No me aclaro mucho de como debo configurarlo via ssh. Os dejo lo que tengo ahora mismo para ver si me podeis ayudar.

Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdcc:46eb:e387::/48'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

Por lo que he leido (bastante) tengo que quitar el puerto 0 del switch y crear otro con la vlan 6 pero no se realmente como hacerlo.

Un saludo.

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #26 en: 29-04-2014, 23:33 (Martes) »
Me contesto, he usado el script de Noltari de https://foro.seguridadwireless.net/openwrt/(tutorial)-movistar-ftth-con-openwrt/ pero he tenido que poner el puerto 1 con la vlan para que el script me dejara continuar porque me decia que el puerto 0 estaba siendo usado por la CPU. Ahora mismo lo tengo ya funcionando directamente contra la ONT de fibra, pero lo que me gustaria es recuperar el puerto 1 para poder usarlo (ahora me he quedado solo con tres para la lan).

¿Cual es el puerto WAN de este router?

Esta es la config que me ha dejado:

Código: [Seleccionar]
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1t'
        option vid '6'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '6'
        option ports '1t 0t'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.6'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'

Un saludo y gracias por adelantado.
« Última modificación: 29-04-2014, 23:35 (Martes) por sergisat »

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #27 en: 29-04-2014, 23:56 (Martes) »
Pues solucionado, por si le sirve a alguien en un futuro:

Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'auto'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '0t 1 2 3 4'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.6'
        option proto 'pppoe'
        option username 'adslppp@telefonicanetpa'
        option password 'adslppp'

Un saludo


sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #28 en: 05-05-2014, 00:06 (Lunes) »
Hola, ¿podéis probar a poner en el N750 la wifi de 2,4Ghz en el modo HT40? Si lo activo en mi NE600 la wifi se me queda en estado Unknown. Si lo vuelvo a poner en el modo HT20 funciona perfectamente. El problema si no lo activo es que la wifi n del portatil se me conecta únicamente a 65.0 Mbit/s en vez de los 150Mb que se me conecta con el router de movistar de fibra.

Un saludo y gracias.
« Última modificación: 05-05-2014, 10:00 (Lunes) por sergisat »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #29 en: 05-05-2014, 07:43 (Lunes) »
A ver si me acuerdo y lo miro esta tarde al llegar a casa.

Enviado desde mi CUBOT GT99

Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

sergisat

  • Visitante
Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #30 en: 05-05-2014, 10:01 (Lunes) »
A ver si me acuerdo y lo miro esta tarde al llegar a casa.

Enviado desde mi CUBOT GT99



Muchas gracias, no paro de hacer cambios en la configuración de la wifi a ver cual puede ser el problema pero no doy con ello.

El resto todo perfecto.

Muchas gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #31 en: 05-05-2014, 12:59 (Lunes) »
Hola, ¿podéis probar a poner en el N750 la wifi de 2,4Ghz en el modo HT40? Si lo activo en mi NE600 la wifi se me queda en estado Unknown. Si lo vuelvo a poner en el modo HT20 funciona perfectamente. El problema si no lo activo es que la wifi n del portatil se me conecta únicamente a 65.0 Mbit/s en vez de los 150Mb que se me conecta con el router de movistar de fibra.

Un saludo y gracias.

Probado y todo funciona perfectamente  ^-^

Estás usando un firmware muy antiguo, quizás ?
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #32 en: 05-05-2014, 22:01 (Lunes) »
La versión es OpenWrt by mk13139 r40572 / LuCI Trunk (svn-r9977) cogida de https://forum.openwrt.org/viewtopic.php?id=47382 del 27 de abril por lo que no es antigua

¿Puedes decirme la versión que tienes para poner la misma?

¿Puedes poner la configuración de la wifi que tienes para ver las diferencias?

He visto a mas gente con el mismo problema incluso con el 750 en algún post.

Un saludo y muchas gracias por adelantado.
« Última modificación: 05-05-2014, 22:03 (Lunes) por sergisat »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #33 en: 07-05-2014, 11:45 (Miércoles) »
La versión es OpenWrt by mk13139 r40572 / LuCI Trunk (svn-r9977) cogida de https://forum.openwrt.org/viewtopic.php?id=47382 del 27 de abril por lo que no es antigua

¿Puedes decirme la versión que tienes para poner la misma?

¿Puedes poner la configuración de la wifi que tienes para ver las diferencias?

He visto a mas gente con el mismo problema incluso con el 750 en algún post.

Un saludo y muchas gracias por adelantado.

Estoy usando la compilación del primer post de este hilo  ;)
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #34 en: 07-05-2014, 13:19 (Miércoles) »
La versión es OpenWrt by mk13139 r40572 / LuCI Trunk (svn-r9977) cogida de https://forum.openwrt.org/viewtopic.php?id=47382 del 27 de abril por lo que no es antigua

¿Puedes decirme la versión que tienes para poner la misma?

¿Puedes poner la configuración de la wifi que tienes para ver las diferencias?

He visto a mas gente con el mismo problema incluso con el 750 en algún post.

Un saludo y muchas gracias por adelantado.

Estoy usando la compilación del primer post de este hilo  ;)

Gracias, pero el problema es que ahí apuntan a la ultima versión del trunk por lo que habría que saber el día que la cogiste para irme yo a ese día también. Si es la compilada y personalizada necesitaría saber la fecha de cuando se cogieron los fuentes para su compilación.

Supongo que en la pagina de login de luci podrás ver la revisión como en la mía. La mía es la r40572. Si me dices ese numero pongo la misma versión en el mio y lo compruebo.

Muchas gracias por todo.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #35 en: 07-05-2014, 14:08 (Miércoles) »
La versión es OpenWrt by mk13139 r40572 / LuCI Trunk (svn-r9977) cogida de https://forum.openwrt.org/viewtopic.php?id=47382 del 27 de abril por lo que no es antigua

¿Puedes decirme la versión que tienes para poner la misma?

¿Puedes poner la configuración de la wifi que tienes para ver las diferencias?

He visto a mas gente con el mismo problema incluso con el 750 en algún post.

Un saludo y muchas gracias por adelantado.

Estoy usando la compilación del primer post de este hilo  ;)

Gracias, pero el problema es que ahí apuntan a la ultima versión del trunk por lo que habría que saber el día que la cogiste para irme yo a ese día también. Si es la compilada y personalizada necesitaría saber la fecha de cuando se cogieron los fuentes para su compilación.

Supongo que en la pagina de login de luci podrás ver la revisión como en la mía. La mía es la r40572. Si me dices ese numero pongo la misma versión en el mio y lo compruebo.

Muchas gracias por todo.

En el primer mensaje de este hilo (repito), tienes la compilación (y el número) del firmware que estoy usando ... si es que no leemos con calma ;D

De todas formas, el fimware que colgué es sólo para el wd750  ;)
« Última modificación: 07-05-2014, 14:12 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #36 en: 07-05-2014, 16:07 (Miércoles) »
La versión es OpenWrt by mk13139 r40572 / LuCI Trunk (svn-r9977) cogida de https://forum.openwrt.org/viewtopic.php?id=47382 del 27 de abril por lo que no es antigua

¿Puedes decirme la versión que tienes para poner la misma?

¿Puedes poner la configuración de la wifi que tienes para ver las diferencias?

He visto a mas gente con el mismo problema incluso con el 750 en algún post.

Un saludo y muchas gracias por adelantado.

Estoy usando la compilación del primer post de este hilo  ;)

Gracias, pero el problema es que ahí apuntan a la ultima versión del trunk por lo que habría que saber el día que la cogiste para irme yo a ese día también. Si es la compilada y personalizada necesitaría saber la fecha de cuando se cogieron los fuentes para su compilación.

Supongo que en la pagina de login de luci podrás ver la revisión como en la mía. La mía es la r40572. Si me dices ese numero pongo la misma versión en el mio y lo compruebo.

Muchas gracias por todo.

En el primer mensaje de este hilo (repito), tienes la compilación (y el número) del firmware que estoy usando ... si es que no leemos con calma ;D

De todas formas, el fimware que colgué es sólo para el wd750  ;)

 :-X

Pondré esa revisión cogida del trunk para mi modelo.

Mil gracias. ;)

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #37 en: 07-05-2014, 17:16 (Miércoles) »
Pues después de tocar un poco la configuración he conseguido hacer funcionar el HT40, ya tengo el portátil conectado a la wifi con los siguientes valores:

-67 dBm   -95 dBm   135.0 Mbit/s, MCS 7, 40MHz

El problema es que sigue con baja velocidad.

Con cable de red hago el test de velocidad y me quedo en unos 95Mb, con la wifi se me queda en 20Mb.

¿Alguien con 100Mb puede probar con este router?

sergisat

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #38 en: 07-05-2014, 17:29 (Miércoles) »
He activado la opción: option wmm '1' y por lo menos ahora he conseguido llegar a 55Mbps por lo que por ahora me doy por satisfecho.

Realmente no necesito mas en el portátil y para descargar ya tengo transmission en el router con un disco duro enganchado para las descargas y mediante dlna poder ver las películas/series en la TV.

Un saludo.

vk496

  • Visitante
Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #39 en: 12-05-2014, 23:20 (Lunes) »
Tengo problemas con caracteres raros, como tildes, para crear carpetas y nombrar archivos... Solo me pasa a mi?

Salu2

Enviado desde mi GT-I5800 usando Tapatalk 2


//FINAL Y MÁS DOS RESPUESTAS