Autor Tema: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.  (Leído 541101 veces)

0 Usuarios y 1 Visitante están viendo este tema.

cenit

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #80 en: 02-03-2012, 14:37 (Viernes) »
 :D gracias por la aclaracion, bueno no queda mas que volver a empezar y rezar para que no tenga mas problemas.

un saludo y gracias macho por toda la ayuda.


ciao



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #81 en: 06-03-2012, 21:51 (Martes) »
Por si interesa: nueva compilación (r30770) con nueva versión de transmission (2.50), y las opciones de siempre ... driver propietario broadcom, FPU emulation, LuCi, servidor ftp, etc.: http://www.mediafire.com/?6kd3hjpbuc469z1
« Última modificación: 27-07-2012, 12:38 (Viernes) por jar229 »
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

electroque

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #82 en: 10-03-2012, 07:51 (Sábado) »
Hola, os comento el problema que tengo con este router:
Siguiendo los pasos de este post le carge el openwrt (el primero del post), pero no he conseguido que se ponga en marcha. Segun he leido tarda bastante en estar operativo ( media hora y nada). No puedo entrar por telnet, haciendo ping a 192.168.1.1 me dice que no hay host...Al encenderlo esta unos segundos con la luz azul, y despues cambia a rojo.
¿Se ha quedado 'frito'?, si es asi, ¿hay alguna manera de recuperarlo?
He intentado ponerlo de nuevo para cargar un nuevo firm (30 segundos en el boton de reset )y no hace nada (la luz se qued en rojo y desde el navegador no puedo acceder).
En otro router (CT5631) lo he instalado y configurado sin problemas.
Gracias por vuestra ayuda.

gmtii

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #83 en: 10-03-2012, 10:52 (Sábado) »
muchísimas gracias... voy a probarlo.

desde luego este router va muy bien si no fuera porque muy a menudo se queda en el cfe y se pierde toda la flash.. Hay algún ticket sobre la cuestión? alguien está mirando el tema? Ocurre tanto en la version squashfs como jffs2 y parece que tuviera más posibilidades de ocurrir en cuanto tengas más llena la partición...

lo dicho, una pena porque aguanta minidlna y transmission en simultáneo...



Por si interesa: nueva compilación (r30770) con nueva versión de transmission (2.50), y las opciones de siempre ... driver propietario broadcom, FPU emulation, LuCi, servidor ftp, etc.: http://www.mediafire.com/?6kd3hjpbuc469z1

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #84 en: 10-03-2012, 20:10 (Sábado) »
He intentado ponerlo de nuevo para cargar un nuevo firm (30 segundos en el boton de reset )y no hace nada (la luz se qued en rojo y desde el navegador no puedo acceder).
En otro router (CT5631) lo he instalado y configurado sin problemas.
Gracias por vuestra ayuda.


Si la luz de power pasa a color rojo, en teoría es que está funcionando OpenWRT.
Vuelve a intentar entrar al modo rescate. Si lo haces bien, la luz del power se quedará en azul y ya podrás entrar al CFE.

muchísimas gracias... voy a probarlo.

desde luego este router va muy bien si no fuera porque muy a menudo se queda en el cfe y se pierde toda la flash.. Hay algún ticket sobre la cuestión? alguien está mirando el tema? Ocurre tanto en la version squashfs como jffs2 y parece que tuviera más posibilidades de ocurrir en cuanto tengas más llena la partición...

lo dicho, una pena porque aguanta minidlna y transmission en simultáneo...

Yo lo reporté en el foro de OpenWRT, pero no he abierto ningún ticket.
Y sí, es una putada tener que reinstalar/configurar de tanto en tanto  :P
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

electroque

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #85 en: 11-03-2012, 21:18 (Domingo) »
Gracias jar229 por responder. Con un poco de paciencia he conseguido volver a ponerlo en modo rescate y meterle el ultimo firmware que has colgado (evidentemente algo estaba haciendo algo mal). Comentar que debido a una mala configuracion de red he tenido,la cual no me dejaba acceder al router, he tenido que empezar de nuevo con el modo rescate, etc..Me ha dado bastante guerra porque me volvia al modo rescate. Siguiendo las indicaciones anteriores en este post le he metido el firm de kisumu, y despues el último que has colgado. De momento todo bien. Ha seguir trasteando.

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #86 en: 11-03-2012, 22:02 (Domingo) »
Muy buenas, yo también he conseguido meter esta compilación (r30770), pero estoy perdidisimo con openwrt , quiero ponerlo en modo cliente y de momento nanai... :(, en fin esto va para largo...

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #87 en: 12-03-2012, 09:26 (Lunes) »
Nueva compilación (r30875) http://www.mediafire.com/download.php?2h9bdylt4s9x1hv
Como siempre con FPU emulation, driver broadcom propietario, LuCi, pure-ftpd, transmission, samba, etc.
Esta vez no he incluido soporte NTFS ni Fat. El que le haga falta, pues a instalarlo (al principio del hilo está explicado) ;)

Muy buenas, yo también he conseguido meter esta compilación (r30770), pero estoy perdidisimo con openwrt , quiero ponerlo en modo cliente y de momento nanai... :(, en fin esto va para largo...

Con este driver, te conectaras en modo "cliente bridge" (cliente dentro del mismo rango de ip's que el router principal).
Desde LuCi, te vas a Red/Wifi y la activas.
Despues, le das a editar, rellenas los datos con el nombre de la red a la que quieres conectar, el tipo de cifrado, etc. Guardas y aplicas los cambios, y listos.
Logicamente, antes deberias haber rellenado correctamente los campos de la red (Red/Interfaces/LAN)  ;)
« Última modificación: 27-07-2012, 12:40 (Viernes) por jar229 »
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #88 en: 12-03-2012, 12:55 (Lunes) »
Empece de nuevo desde la pagina 1 (tengo la r30871), algo ha mejorado la cosa veo mas opciones que antes.

Los errores que me dieron al inicio, al seguir los pasos de la pagina 1 fueron:
/etc/init.d/dhcp: not found
wifi down, wifi ...error too many arguments at line 26 byte3.

Logro entrar a Lucy y en Network Interfaces me sale esto:

/usr/lib/lua/luci/dispatcher.lua:449: Failed to execute arcombine dispatcher target for entry '/admin/network/network'.
The called action terminated with an exception:
/usr/lib/lua/luci/cbi.lua:336: Unable to read UCI data: network
stack traceback:
   [C]: in function 'assert'
   /usr/lib/lua/luci/dispatcher.lua:449: in function 'dispatch'
   /usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

En Network wifi...parece todo correcto..pero no conecto con mi router con encriptacion wap2 aes.
Saludos...seguiremos en a pelea.. ;) menudo vicio...
« Última modificación: 12-03-2012, 13:03 (Lunes) por feluco »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #89 en: 12-03-2012, 14:37 (Lunes) »
Si estás usando la compilación 30875, olvídate de las instrucciones de la primera página.
Y hazlo siguiendo las indicaciones de mi último post.
Si no te aclaras, pon por aquí el contenido de los ficheros network y wireless (están en /etc/config).
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #90 en: 12-03-2012, 17:36 (Lunes) »
Vamos con ello:

config interface loopback
option ifname  lo
option proto   static
option ipaddr   127.0.0.1
option netmask  255.0.0.0

config interface lan
option type bridge
option ifname  eth1
option proto static
option ipaddr  192.168.0.201
option netmask  255.255.255.0
option gateway  192.168.0.1
option dns          192.168.0.1

config interface wan
option ifname eth0
option proto dhcp

config interface wwan
option proto dhcp

config interface stabridge
option proto relay
option network lan wwan
option ipaddr   192.168.0.201


ahora con el wireless

config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option macaddr ''00:26:b6:2c.....
option disable '0'
option txpower '20'
option country 'ES'
option distance '20'

config wifi-iface
option device 'radio0'
option mode 'sta'
option ssid 'vodafone E556...'
option encryptacion 'psk2'
option key 'miclave'
option bssid ''mac del router adsl'

Mi router adsl tiene ip 192.168.0.1 con wap2 aes....con dhcp activado.....saludos  ;)
« Última modificación: 12-03-2012, 17:41 (Lunes) por feluco »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #91 en: 13-03-2012, 08:53 (Martes) »
Antes de indicarte nada, necesito saber qué compilación estás usando y si es alguna de las mías, o te la has bajado del trunk de OpenWRT.
« Última modificación: 13-03-2012, 10:26 (Martes) por jar229 »
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #92 en: 13-03-2012, 09:22 (Martes) »
Estoy usando la (r30871), y la bajé buscandola por internet pues tu enlace en el inicio me envia a la misma página.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #93 en: 13-03-2012, 10:35 (Martes) »
Citar
config interface lan
option type bridge
option ifname  eth1
option proto static
option ipaddr  192.168.0.201
option netmask  255.255.255.0
option gateway  192.168.0.1
option dns          192.168.0.1


Cambia la línea por esta: option ipaddr 192.168.1.201
No puedes tener la misma ip en el interface lan que en el stabridge.

Después de hacerlo, rebota el router y prueba.
Si no te funcionara, a partir de ahí, para acceder de nuevo al hg553 tienes que hacerlo por la ip 192.168.1.201
Si sigue sin funcionarte, cambia la encriptación del router principal a wpa-psk

De todas formas, con esa compilación estás usando el driver opensource. Para hacer funcionar el modo puente cliente hay que servirse  del paquete relayd, que no funciona bien con todos los routers (yo tenía problemas al conectarme a un huawei hg532c).

Finalmente, puedes probar con la última compilación que he puesto, en la que no hay que usar relayd, ya que el driver propietario de broadcom, hace un puente cliente sin ninguna complicación (sobraría toda a configuración del interface wwan y stabridge).

Ves probando y me cuentas ... ;)
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #94 en: 13-03-2012, 12:26 (Martes) »
No ha funcionado...ni cambiando la ip ni cambiando la clave del router.....

Estoy intentando meter la ultima compilacion...pero desde la interfaz Luci no la pilla...me dice que no es un formato valido, no me coge ninguna...The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.
intentaré metersela reseteando el router...

Parece que desde el modo de recuperacion ha cogido la ultima (r30875)(luz en rojo), pero ahora no accedo ni a Luci y pot putty, no se que ip puede tener...
« Última modificación: 13-03-2012, 12:54 (Martes) por feluco »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #95 en: 13-03-2012, 14:36 (Martes) »
Debería tener la 192.168.1.1 ... ???

Para actualizar yo normalmente utilizo este método:

Citar
cd /tmp/
wget http://downloads.openwrt.org/snapshots/trunk/brcm63xx/openwrt-HW553-jffs2-64k-cfe.bin
mtd write /tmp/openwrt-HW553-jffs2-64k-cfe.bin linux && reboot

Solo que en lugar de descargar nada, lo paso a /tmp usando Winscp
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #96 en: 13-03-2012, 17:48 (Martes) »
Por fin tengo la ultima version  :D, ahora la interfaz Luci esta completa...

mas tarde configuro las opciones, a ver que pasa.....

Mira que aguanta leña este cacharro...no se como no se ha colgado con lo bruto que es uno... ;), toquemos madera.

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #97 en: 13-03-2012, 23:02 (Martes) »
Gracias jar229....ya tengo internet conectado como cliente.... :D, por fin.
Ahora a trastear con las demas opciones, cliente torrent y demas....poco a poco.

De nuevo gracias, seguro que sigo preguntando cosas.... un saludo

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4582
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #98 en: 14-03-2012, 08:57 (Miércoles) »
Me alegra que, finalmente, lo hayas conseguido  ;)
Valoraciones positivas en compra/venta:
121 en Htcmania
147 en Har2mano
19 en elchapuzasinformatico
10 en gsmspain
 ....
 
Mis portátiles en venta: https://drive.google.com/open?id=1MTlgSAbTP08EL7ujiamnJVy31be9LogZ

feluco

  • Visitante
Re: Instalación (fácil) de OpenWRT en Huawei 553
« Respuesta #99 en: 14-03-2012, 17:39 (Miércoles) »
Empezamos con Samba;  al instalar me tira error usbtils y e2fsprogs:


root@OpenWrt:~# opkg install luci-app-samba
Package luci-app-samba (trunk+svn8349-1) installed in root is up to date.
root@OpenWrt:~# opkg install luci-app-p910nd
Package luci-app-p910nd (trunk+svn8349-1) installed in root is up to date.
root@OpenWrt:~# opkg install kmod-usb-printer
Package kmod-usb-printer (3.0.18-1) installed in root is up to date.
root@OpenWrt:~# opkg install kmod-usb2
Package kmod-usb2 (3.0.18-1) installed in root is up to date.
root@OpenWrt:~# opkg install kmod-usb-core
Package kmod-usb-core (3.0.18-1) installed in root is up to date.
root@OpenWrt:~# opkg install kmod-usb-ohci
Package kmod-usb-ohci (3.0.18-1) installed in root is up to date.
root@OpenWrt:~# opkg install usbutils
Unknown package 'usbutils'.
Collected errors:
 * opkg_install_cmd: Cannot install package usbutils.
root@OpenWrt:~# opkg install kmod-usb-storage e2fsprogs kmod-fs-vfat kmod-nls-cp
437 kmod-nls-iso8859-1
Package kmod-usb-storage (3.0.18-1) installed in root is up to date.
Unknown package 'e2fsprogs'.
Unknown package 'kmod-fs-vfat'.
Package kmod-nls-cp437 (3.0.18-1) installed in root is up to date.
Package kmod-nls-iso8859-1 (3.0.18-1) installed in root is up to date.
Collected errors:
 * opkg_install_cmd: Cannot install package e2fsprogs.
 * opkg_install_cmd: Cannot install package kmod-fs-vfat.
root@OpenWrt:~# opkg install ntfs-3g kmod-fs-ext4


Seguire mirando la web de openwrt a ver si consigo instalarlo..... ;)