Autor Tema: [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.  (Leído 625276 veces)

0 Usuarios y 1 Visitante están viendo este tema.

xurxo

  • Visitante
Muchisimas gracias  >:(, la primera vez que puedo hacer un update package, porfin puedo instalar todo lo que quiero :), ya os contaré los baches que pille, aunque los intentare solucionar por mi mismo  ^-^.



Sir-Stephen

  • Visitante
Le pasa a alguien mas que con el nuevo archivo .bin que aparece en la nueva localización, el 553 se queda "tonto", y es necesario incluso pasar por cargar el firm original de vodafone?  ???

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Muchisimas gracias  >:(, la primera vez que puedo hacer un update package, porfin puedo instalar todo lo que quiero :), ya os contaré los baches que pille, aunque los intentare solucionar por mi mismo  ^-^.


Me alegro que lo hayas conseguido ;)

Enviado desde mi U30GT-H usando Tapatalk 2

sir.atreyu

  • Visitante
Os van los repositorios??

Dice que no encontrado...

Me refiero al usar la orden:

opkg update



Es sólo a mí??


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Os van los repositorios??

Dice que no encontrado...

Me refiero al usar la orden:

opkg update



Es sólo a mí??

Mira 4 mensajes más atrás y tendrás la respuesta a tu pregunta >:(

Enviado desde mi U30GT-H usando Tapatalk 2

DjThD

  • Visitante
Yo ya le meti como 20 versiones distintas de openWrt (incluyendo la del trunk) y nada de nada, no pude hacer andar ni una (solamente me anduvieron las oficiales de garrafone y las modificadas de kisumu, pero de openWrt no hubo co.jones de echarlo a andar). Solo se queda encendida fija la luz del power en rojo, y tengo que reiniciar en rescue mode para poder introducirle otro firm. Tambien he probado a esperar mas de 5 minutos, y de ahi no sale. Me extraña que esto solo me pase a mi, ¿puede que haya mas de una version de huawei Hg553? Gracias y un saludo
« Última modificación: 08-10-2012, 22:31 (Lunes) por DjThD »

DjThD

  • Visitante
Me respondo a mi mismo, si que funcionaba, solo que en 192.168.1.1 en lugar de la IP por defecto (192.168.0.1). Lo dejo aqui como nota, por si alguien al ver la luz roja piensa que el firm no funciona xDD

Saludos

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Me respondo a mi mismo, si que funcionaba, solo que en 192.168.1.1 en lugar de la IP por defecto (192.168.0.1). Lo dejo aqui como nota, por si alguien al ver la luz roja piensa que el firm no funciona xDD

Saludos

Del primer mensaje del hilo:
Citar
Configuramos la ip de nuestra tarjeta de red dentro del rango 192.168.1.x (podemos usar la 192.168.1.2 en adelante) con máscara de red
255.255.0.0 (no es necesario configurar puerta de enlace ni nada más).
Abrimos nuestro navegador y tecleamos la ip 192.168.1.1

Ay, si leyéramos un poquito antes de desesperarnos ...  ^-^

sankosme

  • Visitante
Pregunta....se pueden crear perfiles wifi???. Me explico...estoy conectado al punto de acceso 1, por algún motivo falla.. el router conecta automaticamente al punto de acceso 2 sin que yo tenga que entrar al router y configurarlo. Vamos como en windows....si te falla la red wifi, se intenta conectar al siguiente que tengas en la lista. ¿Es posible?

Salu2

Sir-Stephen

  • Visitante
En la nueva version del firmware estoy encontrando dificultades:  A veces parece que se queda muerto, y algunos de los paquetes de USB que aparecen ahora dan errores de dependencias al instalarlo.  Si hacemos --force-depends, finalizando la instalación se queda "colgado" y ya no hay forma de hacer nada mas con él, ni siquiera conectarse a él, debiendo volver a cargarse el firmware de nuevo.

Le esta pasando a alguien lo mismo?
« Última modificación: 09-10-2012, 16:29 (Martes) por Sir-Stephen »

raphik

  • Visitante
Pregunta....se pueden crear perfiles wifi???. Me explico...estoy conectado al punto de acceso 1, por algún motivo falla.. el router conecta automaticamente al punto de acceso 2 sin que yo tenga que entrar al router y configurarlo. Vamos como en windows....si te falla la red wifi, se intenta conectar al siguiente que tengas en la lista. ¿Es posible?

Salu2
Algo hay, aunque yo nunca lo he probado. Al parecer, OpenWrt puede trabajar con varias WAN, ya sea de forma simultánea (load balance) o alternativa (round robin).
De cualquier modo, no creo que sea difícil escribir un script que detecte la falta de conectividad con un AP y conecte automáticamente con el siguiente de la lista.

peterpunk

  • Visitante
Re: OpenWRT en Huawei 553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #511 en: 10-10-2012, 12:37 (Miércoles) »
Hola.
Tengo un problema estraño con el SAMBA.
En teoria esta bien configurado. Se accede al dir, pero no me deja modificarlo. Da error de permisos.
Al acceder al directorio por el PC se encuentra duplicado.


¿Porque?

Aqui dejo los ficheros de configuración del samba.

root@OpenWrt:/etc/config# cat samba
config samba
        option 'name'                   'OpenWrt'
        option 'workgroup'              'WORKGROUP'
        option 'description'            'OpenWrt'
        option 'homes'                  '1'

config 'sambashare'
   option 'name' 'usb'
   option 'path' '/mnt/usb'
   option 'read_only' 'no'
   option 'writeable' 'yes'
   option 'create_mask' '0777'
   option 'dir_mask' '0777'
   option 'guest_ok' 'no'
   option 'users' 'samba'

root@OpenWrt:/etc/config# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
rootfs                    8448       572      7876   7% /
/dev/root                 4864      4864         0 100% /rom
tmpfs                    31000       368     30632   1% /tmp
tmpfs                      512         0       512   0% /dev
/dev/mtdblock3            8448       572      7876   7% /overlay
overlayfs:/overlay        8448       572      7876   7% /
/dev/sda1              1031936    694300    337636  67% /mnt/usb


El dir del usb tiene permisos de escritura, si se accede por ftp si se puede escribir.
Creo que no importa pero es un 665 en lugar del 553
Pero este era el hilo que trataba el SAMBA, me parecia el correcto.

Gracias a todos.
« Última modificación: 10-10-2012, 13:05 (Miércoles) por peterpunk »

cimbor

  • Visitante
Re: OpenWRT en Huawei 553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc.
« Respuesta #512 en: 10-10-2012, 21:51 (Miércoles) »
Usa el mismo usuario en windows que en samba, en option 'users' 'samba' pon el usuario con el que entres a windows en lugar de 'samba'. También tendrás que poner el usuario correcto al hacer el smbpasswd

milola

  • Visitante
hola a todos denuevo tengo un problemilla estaves es con el pur-ftpd no consigo que funcione lo ise como en el primer pos dise pero el puerto 21 no se abre  el firewall lo tengo desactibado y tambien samba no se si puede tener algo que ver ???


peterpunk

  • Visitante
Siguendo con los problemas del SAMBA
Usa el mismo usuario en windows que en samba, en option 'users' 'samba' pon el usuario con el que entres a windows en lugar de 'samba'. También tendrás que poner el usuario correcto al hacer el smbpasswd
Creo que no es ese el problema. He creado el usuario igual que en el PC y continuo sin poder grabar. Creo que el problema es de los permisos del dir.

El dir sin montar tiene permisos para el usuario, lo cierto es que para todos.
root@OpenWrt:/# ls -ltr /mnt
drwxrwxrwx    2 MFG      nogroup          0 Oct  6 16:46 usb
Cuando monto el usb, se me cambian los permisos.
root@OpenWrt:/# mount -t vfat -o rw /dev/sda1 /mnt/usb
root@OpenWrt:/# ls -ltr /mnt
drwxr-xr-x    7 root     root          4096 Jan  1  1970 usb

Creo que por eso no me deja escribir.

Con el nuevo usuario, no me deja montar el disco (NORMAL)
MFG@OpenWrt:~$ mount -t vfat /dev/sda1 /mnt/usb
mount: permission denied (are you root?)

Por cierto en este Linux como se hace el comando: "su - user"? O es necesario hacer un: "ssh usuario@localhost"

Como veo que no soy capaz de entrar como escritura, he añadido root a samba. "option 'users' 'root'"
le añado la clave: " smbpasswd -a root"  la misma que el sistema operativo. Pues no entra de ninguna manera.

Lo cierto es que creo que vfat tiene que tener algun que otro problema...
porque dudo que el problema sea chmod...
root@OpenWrt:/mnt# ls -ltr
drwxr-xr-x    7 root     root          4096 Jan  1  1970 usb
drwxr-xr-x    2 root     root             0 Oct  9 16:45 sdb1
drwxr-xr-x    2 root     root             0 Oct  9 16:49 sdc1
root@OpenWrt:/mnt# chmod -R 777 usb
root@OpenWrt:/mnt# ls -ltr
drwxr-xr-x    7 root     root          4096 Jan  1  1970 usb
drwxr-xr-x    2 root     root             0 Oct  9 16:45 sdb1
drwxr-xr-x    2 root     root             0 Oct  9 16:49 sdc1

Saludos y gracias.
« Última modificación: 11-10-2012, 23:12 (Jueves) por peterpunk »

cimbor

  • Visitante
No es lo del root, donde yo monto mi disco esta igual:

drwxr-xrwx   12 root     root          4096 Oct  9 20:32 hdd

Es normal, porque al montarlo con root por seguridad se le cambian los permisos para que nadie ajeno  pueda modificar el disco.

En la configuracion de samba a lo mejor te falta alguna opcion, yo la tengo asi:

config samba
        option 'name'                   'OpenWrt'
        option 'workgroup'              'WORKGROUP'
        option 'description'            'OpenWrt'
        option 'homes'                  '1'
config 'sambashare'
   option 'name' 'disco640'
   option 'path' '/mnt/hdd'   
   option 'read_only' 'no'     
   option 'writeable' 'yes'         
   option 'create_mask' '0777'           
   option 'dir_mask' '0777'               
   option 'guest_ok' 'no'                 
   option 'users' 'cimbor' 

Y en /etc/passwd el usuario cimbor con el home en el punto de montaje /mnt/hdd.

Prueba a instalar la utilidad sudo, para poder ejecutar como root comandos con el usuario

milola

  • Visitante
hola a todos sigo sin conseguir entrar en mi ftp os cuento como lo ago aver en que me equiboco
istalo el pure-ftpd lo inisio y lo pongo en el arranque y reinisio
por su configuracion creo que se puede entrar como anonimus sin user ni pas asi que inisi el filesilla  y intento entrar directamente como anonimus pero no se conecta compruebo que se abrio el puerto 21 y todo esta correcto
talves deva crear un user y pass para el pure-ftpd pero no se aserlo
no se si tiene algo que ver perro lo unico que cambie es el samba que lo quite por que no me gusta manias que tiene uno
cualquier sujerencia se agradese de antemano que paseis un buen dia

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4605
Has editado el fichero de configuración como se explica en el primer post ?
Ponlo por aquí, que lo veamos.

Enviado desde mi U30GT-H usando Tapatalk 2

milola

  • Visitante
es el mismo que ay en el primer pos donde es esplica su istalacion
config pure-ftpd
   option port             '21'
   option noanonymous      '1'
   option chrooteveryone   '1'
   option maxclientsperip  '10'
   option maxclientsnumber '4'
   option peruserlimits    '3:4'
   option umask            '133:022'
   option authentication   'unix'
   option enabled          '1'

el filesilla inisia pero despues dise error critico y corta dise esto

Response:   220---------- Welcome to Pure-FTPd [privsep] ----------
Response:   220-You are user number 1 of 10 allowed.
Response:   220-Local time is now 11:41. Server port: 21.
Response:   220-This is a private system - No anonymous login
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:   USER anonymous
Response:   331 User anonymous OK. Password required
Command:   PASS **************
Response:   530 Login authentication failed
Error:   Critical error
Error:   Could not connect to server

como dise lo de login fallido imajino que con un user podre entrar pero no se configurarlo ???

milola

  • Visitante
rebisando la configuracion veo que el 
 option noanonymous      '1
lo cambie para probar a 0
 option noanonymous      '0'
y estaves el firesilla lanza esto

Response:   220---------- Welcome to Pure-FTPd [privsep] ----------
Response:   220-You are user number 1 of 10 allowed.
Response:   220-Local time is now 12:00. Server port: 21.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:   USER anonymous
Response:   421 Can't change directory to /home/ftp/ [/]
Error:   Could not connect to server

asi parese que conecta como anonimus pero no asede al directorio talves tenga que cambiar el directorio pero no se donde aserlo solo se me ocure en passwor donde tengo
'
root:x:0:0:root:/root:/bin/ash
daemon:*:1:1:daemon:/var:/bin/false
ftp:*:55:55:ftp:/home/ftp:/bin/false
network:*:101:101:network:/var:/bin/false
nobody:*:65534:65534:nobody:/var:/bin/false

a porque ay dos passwd tengo otro con  passwwd-