Autor Tema: [Desarrollo] OpenWrt en Huawei HG556a  (Leído 2024257 veces)

0 Usuarios y 1 Visitante están viendo este tema.

JoseDKZ

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2140 en: 01-06-2014, 19:47 (Domingo) »
Buenas a todos, y espero que no esté dicho (al menos yo no lo he encontrado)

Resulta que tengo este router y también tengo una impresora USB. Ahora os pongo lo que me gustaría que me ayudarais a hacer. A grandes rasgos quiero hacer que ésta impresora sea Wi-Fi conectándola al HG556a y éste, esté conectado a mi red e imprimir desde cualquier PC/Mac.

Router ADSL con mi red Wi-Fi <-> HG556a--USB--Impresora.

Ésto se puede hacer? ¿Cómo? Espero haberme explicado bien.

Muchas gracias.



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: Re: Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2141 en: 01-06-2014, 22:07 (Domingo) »
Buenas a todos, y espero que no esté dicho (al menos yo no lo he encontrado)

Resulta que tengo este router y también tengo una impresora USB. Ahora os pongo lo que me gustaría que me ayudarais a hacer. A grandes rasgos quiero hacer que ésta impresora sea Wi-Fi conectándola al HG556a y éste, esté conectado a mi red e imprimir desde cualquier PC/Mac.

Router ADSL con mi red Wi-Fi <-> HG556a--USB--Impresora.

Ésto se puede hacer? ¿Cómo? Espero haberme explicado bien.

Muchas gracias.

Tendrías que conseguir que todos los equipos estén en la misma subred (para esto necesitas relayd) y posteriormente instalar un servidor de impresión.

Ambos temas están tratados en el foro. Mira el recopilario de los hilos más relevantes.

Enviado desde mi CUBOT GT99


JoseDKZ

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2142 en: 07-06-2014, 13:57 (Sábado) »
Si te soy sincero, me quedo igual, no sé por dónde meterle mano al asunto.

Todos mis equipos se mueven en 192.168.1.XX. Lo que yo quiero es que el router con OpenWRT se conecte a esta red y me meta una impresora por USB para imprimir desde cualquier equipo.

Si miro el primer post hay una tabla con un montón de versiones y no sé cual poner, tengo un HG556a versión C.

A ver si alguien me puede dar un poco más de información sobre como configurarlo.

Saludos.

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2143 en: 07-06-2014, 16:06 (Sábado) »
jar229 estás seguro de que para la impresora necesitas relayd? yo creo que no ya que va conectada al propio router por usb, y el router hace de cliente tal como haríamos en un PC, ningún paquete se routea a la interfaz LAN. Quizás sería necesario solo modificar el firewall de Openwrt para permitir conexión al server.

Así que con conectar en modo cliente usando luci, con todas las opciones por defecto, y teniendo instalada la aplicación luci-app-p910nd, luego poco más habría que hacer.

JoseDKZ Puedes usar el backport AA, pero ojo deberías cambiar la IP por defecto de Openwrt para estar en una subred diferente, p.ej 192.168.7.x
https://docs.google.com/uc?export=download&id=0B-EMoBe-_OdBdU5VTHc5Q2o2aEU

Una vez flasheado y habiendo conectado en modo cliente a tu red la cual presupongo tiene conectividad a internet, instalas el paquete
Código: [Seleccionar]
opkg update
opkg install  luci-app-p910nd
y el resto ya es cosa tuya. Nunca hice esto la verdad

Detalle importante: la impresora USB ha de ser compatible, no todas permiten enchufarlas como server en red a través de USB. Sino es compatible aun quedaría una posibilidad un poco más compleja, que sería usar USB over IP
« Última modificación: 07-06-2014, 16:08 (Sábado) por danitool »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2144 en: 07-06-2014, 16:32 (Sábado) »
jar229 estás seguro de que para la impresora necesitas relayd? yo creo que no ya que va conectada al propio router por usb, y el router hace de cliente tal como haríamos en un PC, ningún paquete se routea a la interfaz LAN. Quizás sería necesario solo modificar el firewall de Openwrt para permitir conexión al server.

Puede ser, pero es probable que si no están en la misma subred, no funcione ...  >:D

danitool

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2145 en: 07-06-2014, 16:44 (Sábado) »
Puede ser, pero es probable que si no están en la misma subred, no funcione ...  >:D
Date cuenta que la interfaz wlan está en la misma subred a pesar de actuar como WAN, ya que en este caso cogería la IP por dhcp. Quien no lo está en la misma subred es lan, y todo lo que conectemos a través de lan no tiene ninguna transparencia hacia su subred local que actualmente usa JoseDKZ

Es más incluso podemos deshacernos de iptables, y del firewall de openwrt para acabar teniendo un router tonto pero autónomo y todo lo que conectes en el tiene absolutamente total transparencia en sus interfaces de red, pero sin posibilidad de pasar tráfico de una interfaz a otra  ;).

Espero que esto aclare algo, o tal vez confunda más...  ;D
« Última modificación: 07-06-2014, 16:46 (Sábado) por danitool »

JoseDKZ

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2146 en: 07-06-2014, 19:31 (Sábado) »
Buenas, voy a meterle mano ahora durante toda la tarde.

Ya tenia OpenWRT, este concretamente r39304usb

He ido a meterle el BlackPort que me habéis puesto pero no se como hacerlo, mediante el método de pulsar el boton Restart ya no funciona :-S, ahora no se como xD

Saludos.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2147 en: 07-06-2014, 20:03 (Sábado) »
Buenas, voy a meterle mano ahora durante toda la tarde.

Ya tenia OpenWRT, este concretamente r39304usb

He ido a meterle el BlackPort que me habéis puesto pero no se como hacerlo, mediante el método de pulsar el boton Restart ya no funciona :-S, ahora no se como xD

Saludos.

Con el método del botón de Reset, tiene que funcionar, sí o sí  ;D

JoseDKZ

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2148 en: 08-06-2014, 11:33 (Domingo) »
Si, ya lo he conseguido jajaja, se ve que la primera vez no lo hice bien y me llevé un mal ratillo.

Pero sigo muy perdido con OpenWRT, tiene un montón de funciones y aun me quedan horas para averiguar, consigo conectar el HG a mi red como cliente, pero ya está de ahí ahora mismo no paso. No consigo dar internet al que va por LAN aun cambiándole la subred 192.168.2.XX

Saludos.

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2149 en: 09-06-2014, 12:15 (Lunes) »
Buenas, tengo un problema que me está volviendo loco, a ver si se os ocurre algo.
Resulta que tengo instalado el openwrt (Barrier Breaker r38774) y me funcionaba de lujo.
El caso es que hoy he reiniciado el router desde putty con el comando reboot y desde entonces no hay forma de que funcione la wifi.
El router recibe internet por cable y redistribuye por su propia wifi. Lleva meses funcionando perfectamente y hoy sin tocar nada ha dejado de funcionar tras el reinicio.
El caso es que miro la configuración y todo parece estar bien, lo único raro que veo es que desde luci si entro en Red/Wifi me dice Modo:Client y pone Red inalámbirica desconectada o no asociada. Si le doy a activar hace el proceso de rearrancar la wifi y vuelve a quedarse igual, si entro en Editar veo que la está configurada como Punto de acceso pero en estado pone modo:client y debajo 0% red inalámbrica desconectada o no asociada. y debajo pone red inalámbrica conectada y el botón para desactivar.
He tratado de desactivarla, volver a activarla, cambiar el modo de la red, borrarla de todo y volver a instalarla pero nada, siempre el mismo resultado :(

¿Se os ocurre que le habrá podido pasar? ¿por qué no entra en modo punto de acceso?

Gracias y saludos.

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2150 en: 09-06-2014, 12:53 (Lunes) »
Un detalle más, tengo instalado el ext-root y tengo el sistema en una usb, el caso es que si arranco sin la usb la wifi funciona perfectamente...
Total, que me voy a lo bruto, copio la carpeta /etc/config del sistema de archivos del router y la pego en /etc de la usb sobreescribiendo la anterior, resultado NADA sigue haciendo lo mismo...

¿Dónde demonios puede estar el problema?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2235
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2151 en: 09-06-2014, 13:27 (Lunes) »
Un detalle más, tengo instalado el ext-root y tengo el sistema en una usb, el caso es que si arranco sin la usb la wifi funciona perfectamente...
Total, que me voy a lo bruto, copio la carpeta /etc/config del sistema de archivos del router y la pego en /etc de la usb sobreescribiendo la anterior, resultado NADA sigue haciendo lo mismo...

¿Dónde demonios puede estar el problema?

Prueba a copiar también la carpeta /lib, a ver si es cosa de algún firmware o algún módulo que se haya corrompido.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2152 en: 09-06-2014, 13:29 (Lunes) »
Buenas, tengo un problema que me está volviendo loco, a ver si se os ocurre algo.
Resulta que tengo instalado el openwrt (Barrier Breaker r38774) y me funcionaba de lujo.
El caso es que hoy he reiniciado el router desde putty con el comando reboot y desde entonces no hay forma de que funcione la wifi.
El router recibe internet por cable y redistribuye por su propia wifi. Lleva meses funcionando perfectamente y hoy sin tocar nada ha dejado de funcionar tras el reinicio.
El caso es que miro la configuración y todo parece estar bien, lo único raro que veo es que desde luci si entro en Red/Wifi me dice Modo:Client y pone Red inalámbirica desconectada o no asociada. Si le doy a activar hace el proceso de rearrancar la wifi y vuelve a quedarse igual, si entro en Editar veo que la está configurada como Punto de acceso pero en estado pone modo:client y debajo 0% red inalámbrica desconectada o no asociada. y debajo pone red inalámbrica conectada y el botón para desactivar.
He tratado de desactivarla, volver a activarla, cambiar el modo de la red, borrarla de todo y volver a instalarla pero nada, siempre el mismo resultado :(

¿Se os ocurre que le habrá podido pasar? ¿por qué no entra en modo punto de acceso?

Gracias y saludos.

Yo borraría el fichero de configuración de la wifi

Código: [Seleccionar]
rm /etc/config/wireless
Y lo volvería a generar (y después a configurar)

Código: [Seleccionar]
wifi detect > /etc/config/wireless

parotris

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2153 en: 09-06-2014, 13:51 (Lunes) »
Gracias a los 2 pero no funcionó :(
Finalmente he vuelto a copiar todo el sistema de archivos a la usb y solucionado... Aunque ahora toca configurar todo de nuevo :(
Algún archivo se habrá vuelto tonto, pero a saber cual.

Saludos y gracias.

pgrillo79

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2154 en: 16-06-2014, 22:26 (Lunes) »
Buenas noches. Antes de nada pedir disculpas, pero soy nuevo en este mundillo y tengo una necesidad, espero que me puedan ayudar. Después de horas dándole vueltas he optado por la opción de preguntar a expertos. Mi cuestión es: Tengo un HG556a como pisapapeles en casa y necesito usarlo en la planta de arriba de mi casa como repetidor wifi (llega poca señal) y a la vez, utilizando esta conexión wifi, usarlo como switch para red cableada dentro de esta misma lan. Esto se puede conseguir? Algún enlace donde se explique paso a paso, y en modo novato como hacerlo?

Gracias de antemano.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2155 en: 17-06-2014, 08:16 (Martes) »
Buenas noches. Antes de nada pedir disculpas, pero soy nuevo en este mundillo y tengo una necesidad, espero que me puedan ayudar. Después de horas dándole vueltas he optado por la opción de preguntar a expertos. Mi cuestión es: Tengo un HG556a como pisapapeles en casa y necesito usarlo en la planta de arriba de mi casa como repetidor wifi (llega poca señal) y a la vez, utilizando esta conexión wifi, usarlo como switch para red cableada dentro de esta misma lan. Esto se puede conseguir? Algún enlace donde se explique paso a paso, y en modo novato como hacerlo?

Gracias de antemano.


https://foro.seguridadwireless.net/openwrt/(tutorial)-modo-clienterepetidor-openwrt/

https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-(-openwrt)/


pgrillo79

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2156 en: 17-06-2014, 08:42 (Martes) »
Buenas noches. Antes de nada pedir disculpas, pero soy nuevo en este mundillo y tengo una necesidad, espero que me puedan ayudar. Después de horas dándole vueltas he optado por la opción de preguntar a expertos. Mi cuestión es: Tengo un HG556a como pisapapeles en casa y necesito usarlo en la planta de arriba de mi casa como repetidor wifi (llega poca señal) y a la vez, utilizando esta conexión wifi, usarlo como switch para red cableada dentro de esta misma lan. Esto se puede conseguir? Algún enlace donde se explique paso a paso, y en modo novato como hacerlo?

Gracias de antemano.


https://foro.seguridadwireless.net/openwrt/(tutorial)-modo-clienterepetidor-openwrt/

https://foro.seguridadwireless.net/openwrt/huawei-hg556a-modo-repetidor-(-openwrt)/



Muchas Gracias. Vamos al lio.

Edito: Funcionando. Sois unos cracks. Muchas gracias
« Última modificación: 19-06-2014, 11:27 (Jueves) por pgrillo79 »

SergioTC16

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2157 en: 18-06-2014, 00:57 (Miércoles) »
Hola, he cargado el firmware con LuCI incluido que habeis dejado aquí para mi HG556a 128k.
El caso es que quiero configurarlo como HotSpot para una cafetería y que todo el mundo que se conecte al router sea redireccionado a una URL en concreto. Esa URL será la IP del ordenador enchufado a este HG556a por ejemplo 192.168.1.105.
He leido algo de HTTP Redirect pero no se como configurarlo a través de LuCI... si pudierais iluminarme...
Muchas gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4606
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2158 en: 18-06-2014, 09:17 (Miércoles) »
Hola, he cargado el firmware con LuCI incluido que habeis dejado aquí para mi HG556a 128k.
El caso es que quiero configurarlo como HotSpot para una cafetería y que todo el mundo que se conecte al router sea redireccionado a una URL en concreto. Esa URL será la IP del ordenador enchufado a este HG556a por ejemplo 192.168.1.105.
He leido algo de HTTP Redirect pero no se como configurarlo a través de LuCI... si pudierais iluminarme...
Muchas gracias.

El router NO va actuar como HotSpot, sino como AP. Lo que quieres es que este reenvíe las peticiones http a otro equipo (este es el que actúa como HotSpot).

SergioTC16

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2159 en: 18-06-2014, 13:03 (Miércoles) »
Creo que me he equivocado al hablar del router como HotSpot.
« Última modificación: 18-06-2014, 13:09 (Miércoles) por SergioTC16 »