Autor Tema: [Desarrollo] OpenWrt en Comtrend AR-5387un  (Leído 623815 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: Re: Openwrt en Comtrend ar5387un
« Respuesta #120 en: 12-11-2012, 19:03 (Lunes) »
Usa screen. Mírate el hilo del hg553 si tienes dudas de cómo usarlo.

Enviado desde mi Cube U30GT (ROM: Decontaminate v. 2.1) usando Tapatalk 2


Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #121 en: 18-11-2012, 23:04 (Domingo) »
de que manera podemos actualizar transmission a la ultima version?

http://www.transmissionbt.com/download/

no sabria ni que descargar ni como instalarla

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #122 en: 19-11-2012, 08:11 (Lunes) »
Para actualizar a la última versión disponible en el repositorio de OpenWrt (que no tiene porqué coincidir con la última versión de su web):

Lo primero, nos aseguramos de que transmission está parado.

Desde putty:

Código: [Seleccionar]
/etc/init.d/transmission stop
Actualizamos la lista de paquetes

Código: [Seleccionar]
opkg update
Ahora, instalamos la última versión

Código: [Seleccionar]
opkg install transmission-daemon transmission-remote transmission-web
Te avisará (al terminar), que el nuevo fichero de configuración se ha guardado en 'tal' sitio y con 'tal' nombre ...
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #123 en: 19-11-2012, 11:22 (Lunes) »
Ok muchas gracias.

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #124 en: 25-11-2012, 03:21 (Domingo) »
Actualizados los parches para el SVN del primer post.
Llevo un par de semanas MUY LIADO con la universidad, por lo que no tengo mucho tiempo...
Así que si alguien quiere compilar un firmware con los parches y subirlo se lo agradecería.
Os recuerdo que los parches son los mismos que para el ADB P.DG A4001N y el AR-5387un, por lo que podría subir los firmwares para esos routers también.

Saludos.
« Última modificación: 25-11-2012, 12:28 (Domingo) por Noltari »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #125 en: 25-11-2012, 10:14 (Domingo) »
Si nadie lo hace antes, el martes (estoy fuera de casa) hago las compilaciones pertinentes :-\
Como siempre, gracias por tu trabajo :D

Enviado desde mi Cube U30GT (ROM: Infected v.1.5) usando Tapatalk 2
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

falconwar

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #126 en: 25-11-2012, 14:05 (Domingo) »
Buenas,

Primero de todo, dar las gracias al creador de la compilación para este router y a todos los que habéis participado en el hilo. He conseguido instalar el openwrt y configurar como cliente mi ar5387un.

Lo que querría ahora es instalar el paquete kmod-usb-printer para compartir una impresora, pero el paquete publicado es para un kernel más nuevo y claro no deja.   ¿Sabéis si hay alguna versión compilada 3.3.8-1? Y otra cosa, ¿cómo se instala el parche svn? He estado buscando y no me aclaro...  :-\

Muchas gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #127 en: 25-11-2012, 14:28 (Domingo) »
El parche es para compilar el firmware.
Si no tienes demasiada prisa, espérate al martes o miércoles, que publicaré una nueva compilación, en la que irá incluído (entre otras muchas cosas), el soporte para impresoras USB.

Enviado desde mi Cube U30GT (ROM: Infected v.1.5) usando Tapatalk 2
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

falconwar

  • Visitante
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #128 en: 25-11-2012, 19:58 (Domingo) »
El parche es para compilar el firmware.
Si no tienes demasiada prisa, espérate al martes o miércoles, que publicaré una nueva compilación, en la que irá incluído (entre otras muchas cosas), el soporte para impresoras USB.

Enviado desde mi Cube U30GT (ROM: Infected v.1.5) usando Tapatalk 2

Hola!

Pues perfecto entonces. No me corre mucha prisa y si encima lo puedo hacer con un firmware mas nuevo pues mejor. Estare al tanto del hilo.

Muchas gracias!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #129 en: 27-11-2012, 09:59 (Martes) »
Pues no hay manera de conseguir una compilación sin errores  :-[
Habrá que esperar un par de días más.
O que algún otro lo intente a ver si tiene más suerte  ???
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

Noltari

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #130 en: 27-11-2012, 10:40 (Martes) »
Pues no hay manera de conseguir una compilación sin errores  :-[
Habrá que esperar un par de días más.
O que algún otro lo intente a ver si tiene más suerte  ???
Por algún motivo los "checks" que comprueban si se debe compilar o no "b43-tools" no funcionan, así que para poder compilar el firmware con soporte WiFi sin errores tienes que editar el fichero "tools/Makefile", quitando los checks y habilitándolo siempre.


Se lo diré a jogo un día de estos, pero es que últimamente le he reportado demasiados bugs y en la mayoría acababa arreglándolos al cabo de unos días.

Saludos!
« Última modificación: 27-11-2012, 10:42 (Martes) por Noltari »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #131 en: 27-11-2012, 11:44 (Martes) »
Pero ese problema tendría lógica si estuviera compilando con el driver wifi b43, pero yo estaba compilando con brcmsmac. Me equivoco ?
Yo creo que es un problema de alguno de los paquetes 'extras' que suelo añadir.
En cualquier caso, en un rato lo pruebo de nuevo  ;)
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

meke

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #132 en: 27-11-2012, 13:47 (Martes) »
Hola! He intentado compilar el firmware como siempre y me ha dado un error.
Me podríais explicar exactamente como se aplican los parches? Es por si lo hago mal saber como se hace.
Muchas gracias por vuestro trabajo, soy nuevo en esto y cada día estoy mas emocionado con Openwrt.
Un Saludo!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #133 en: 27-11-2012, 20:10 (Martes) »
Bueno, al final sí conseguí hacer la compilación. Mañana, cuando la haya testeado en mi router la pongo por aquí.

Enviado desde mi Cube U30GT (ROM: Infected v.1.5) usando Tapatalk 2
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #134 en: 28-11-2012, 09:36 (Miércoles) »
Le ponga el driver wifi que le ponga (a la hora de compilar), luego el interface wifi no 'aparece' por ningún sitio  ???
Voy a volver a intentarlo (ahora mismo estoy en ello), a ver si es que me he despistado en algo  ^-^
Noltari, las líneas que decías ya estaban 'descomentadas'.

En un rato, aviso de los progresos.
Si la cosa no se arregla, ya pondré un bootlog.
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #135 en: 28-11-2012, 18:32 (Miércoles) »
Esta visto que hoy no es mi día. Ahora las compilaciones no dejan de dar error.
Mañana lo volveré a intentar ...:-\

Enviado desde mi Cube U30GT (ROM: Infected v.1.5) usando Tapatalk 2
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

mikolatero

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #136 en: 30-11-2012, 11:19 (Viernes) »
Buenas, serian tan amables de subir un .config "funcional"? He intentado compilar varias veces openwrt para el dispositivo y siempre me da error de compilación.

He intentado con el svn del trunk, el git del compañero noltari y sin/con aplicar el parche que hay en el post principal (dan error al aplicarle el parche a los archivos config-3.3 y config-3.6, estos dos archivos los parcheo a mano). El parche lo aplico con " patch -p1 < nombre_parche.patch " tal y como lo hago en el kernel linux, supongo que aquí sera igual. Pero aun asi, siempre me da error, unas veces en un lado y otras veces en otro, pero siempre error...


Saludos y muchas gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4578
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #137 en: 30-11-2012, 13:12 (Viernes) »
Yo llevo un par de días intentando compilar (rama trunk) sin suerte  ^-^
La forma de parchear que indicas, es la correcta.
Valoraciones positivas en compra/venta:
114 en Htcmania
100 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

mikolatero

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #138 en: 30-11-2012, 14:20 (Viernes) »
Yo llevo un par de días intentando compilar (rama trunk) sin suerte  ^-^
La forma de parchear que indicas, es la correcta.


Es un consuelo para mi xD Ya pensaba que no sabia ni compilar xDD

Esta tarde seguiré haciendo pruebas.

Salu2

Jestern

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #139 en: 02-12-2012, 16:07 (Domingo) »
Hola a todos, hoy he conseguido compilar el firmware después de quejarse primero el parche con la configuración del kernel y después por no encontrar el archivo "broadcom-wl-5.100.138.tar.bz2", pero al final ha salido. ^-^
 El problema es que el wifi no funciona. Aquí os dejo el dmesg.
Código: [Seleccionar]
[    0.000000] Linux version 3.6.8 (jestern@-) (gcc version 4.6.4 20121106 (prerelease) (Linaro GCC 4.6-2012.11) ) #1 Sun Dec 2 15:21:13 CET 2012
[    0.000000] Detected Broadcom 0x6328 CPU revision 10b0
[    0.000000] CPU frequency is 320 MHz
[    0.000000] 64MB of RAM installed
[    0.000000] registering 32 GPIOs
[    0.000000] board_bcm963xx: Boot address 0xb8000000
[    0.000000] board_bcm963xx: CFE version: 1.0.37-110.11
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a075 (Broadcom BMIPS4350)
[    0.000000] board_bcm963xx: board name: 96328A-1441N1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x03ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x03ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 802c27d0, node_mem_map 81000000
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16256 pages, LIFO batch:3
[    0.000000] Reserving 0MB of memory at 0MB for crashkernel
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes.
[    0.000000] Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] __ex_table already sorted, skipping sort
[    0.000000] Memory: 61608k/65536k available (2324k kernel code, 3928k reserved, 439k data, 208k init, 0k highmem)
[    0.000000] NR_IRQS:128
[    0.036000] Calibrating delay loop... 318.46 BogoMIPS (lpj=636928)
[    0.036000] pid_max: default: 32768 minimum: 301
[    0.040000] Mount-cache hash table entries: 512
[    0.048000] NET: Registered protocol family 16
[    0.276000] registering PCI controller with io_map_base unset
[    0.288000] bio: create slab <bio-0> at 0
[    0.296000] PCI host bridge to bus 0000:00
[    0.300000] pci_bus 0000:00: root bus resource [mem 0x10f00000-0x11efffff]
[    0.304000] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.308000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.312000] pci_bus 0000:00: busn_res: [bus 00-ff] is inserted under domain [bus 00-ff]
[    0.312000] pci 0000:00:00.0: [14e4:6328] type 01 class 0x060400
[    0.312000] pci 0000:00:00.0: PME# supported from D0 D3hot
[    0.312000] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.316000] pci_bus 0000:01: busn_res: [bus 01-ff] is inserted under [bus 00-ff]
[    0.316000] pci 0000:01:00.0: [14e4:a8d8] type 00 class 0x028000
[    0.316000] pci 0000:01:00.0: reg 10: [mem 0x00000000-0x00003fff 64bit]
[    0.316000] pci 0000:01:00.0: supports D1 D2
[    0.316000] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.316000] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 01
[    0.316000] pci 0000:00:00.0: BAR 8: assigned [mem 0x10f00000-0x10ffffff]
[    0.320000] pci 0000:01:00.0: BAR 0: assigned [mem 0x10f00000-0x10f03fff 64bit]
[    0.324000] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.328000] pci 0000:00:00.0:   bridge window [mem 0x10f00000-0x10ffffff]
[    0.332000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[    0.336000] Switching to clocksource MIPS
[    0.344000] PCI: Enabling device 0000:01:00.0 (0000 -> 0002)
[    0.352000] bcma: bus0: Found chip with id 0xA8D9, rev 0x01 and package 0x0A
[    0.360000] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x22, class 0x0)
[    0.368000] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x17, class 0x0)
[    0.376000] bcma: bus0: Core 2 found: PCIe (manuf 0x4BF, id 0x820, rev 0x0F, class 0x0)
[    0.384000] bcma: bus0: Found rev 6 PMU (capabilities 0x108C2606)
[    0.384000] bcma: bus0: SPROM offset 0x800
[    0.424000] bcma: bus0: invalid sprom read from the PCIe card, try to use fallback sprom
[    0.432000] bcma: bus0: Using fallback SPROM failed (err -2)
[    0.440000] bcma: bus0: No SPROM available
[    0.444000] bcma: bus0: PMU resource config unknown or not needed for device 0xA8D9
[    0.444000] bcma: bus0: Workarounds unknown or not needed for device 0xA8D9
[    0.452000] bcma: bus0: Bus registered
[    0.456000] NET: Registered protocol family 2
[    0.464000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.472000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.476000] TCP: Hash tables configured (established 2048 bind 2048)
[    0.484000] TCP: reno registered
[    0.488000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.492000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.500000] NET: Registered protocol family 1
[    0.504000] PCI: CLS 0 bytes, default 16
[    0.508000] audit: initializing netlink socket (disabled)
[    0.512000] type=2000 audit(0.512:1): initialized
[    0.520000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.524000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.536000] msgmni has been set to 120
[    0.540000] io scheduler noop registered
[    0.544000] io scheduler deadline registered (default)
[    0.552000] bcm63xx_uart.0: ttyS0 at MMIO 0xb0000100 (irq = 36) is a bcm63xx_uart
[    0.560000] console [ttyS0] enabled, bootconsole disabled
[    0.576000] m25p80 spi0.0: found mx25l12805d, expected m25p80
[    0.584000] m25p80 spi0.0: mx25l12805d (16384 Kbytes)
[    0.588000] bcm63xxpart: CFE boot tag found with version 6 and board type 96328A-1441N1
[    0.596000] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000
[    0.604000] bcm63xxpart: Partition 1 is kernel offset 10100 and length fff00
[    0.612000] bcm63xxpart: Partition 2 is rootfs offset 110000 and length ee0000
[    0.616000] bcm63xxpart: Partition 3 is nvram offset ff0000 and length 10000
[    0.624000] bcm63xxpart: Partition 4 is linux offset 10000 and length fe0000
[    0.632000] bcm63xxpart: Spare partition is offset 340004 and length cafffc
[    0.640000] 5 bcm63xxpart partitions found on MTD device spi0.0
[    0.644000] Creating 5 MTD partitions on "spi0.0":
[    0.652000] 0x000000000000-0x000000010000 : "CFE"
[    0.660000] 0x000000010100-0x000000110000 : "kernel"
[    0.664000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.680000] 0x000000110000-0x000000ff0000 : "rootfs"
[    0.688000] mtd: partition "rootfs" set to be root filesystem
[    0.692000] mtd: partition "rootfs_data" created automatically, ofs=340000, len=CB0000
[    0.700000] 0x000000340000-0x000000ff0000 : "rootfs_data"
[    0.708000] 0x000000ff0000-0x000001000000 : "nvram"
[    0.716000] 0x000000010000-0x000000ff0000 : "linux"
[    0.760000] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    0.768000] Registered led device: 96328A-1441N1:green:power
[    0.768000] Registered led device: 96328A-1441N1:red:power
[    0.768000] Registered led device: 96328A-1441N1:green:inet
[    0.772000] Registered led device: 96328A-1441N1:red:inet
[    0.772000] Registered led device: 96328A-1441N1:green:dsl
[    0.772000] TCP: cubic registered
[    0.776000] NET: Registered protocol family 17
[    0.780000] 8021q: 802.1Q VLAN Support v1.8
[    0.796000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    0.804000] Freeing unused kernel memory: 208k freed
[    3.472000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 1, 100Mbps, full-duplex
[    3.716000] roboswitch: Probing device eth0:
[    3.720000] bcm63xx_enet: could not find a used port with phy_id 0, assuming phy is external
[    3.728000] No Robo switch in managed mode found, phy_id = 0xffffffff
[    3.736000] roboswitch: Probing device eth1: No such device
[    3.740000] roboswitch: Probing device eth2: No such device
[    3.748000] roboswitch: Probing device eth3: No such device
[    6.256000] Button Hotplug driver version 0.4.1
[    6.284000] input: gpio-keys-polled as /devices/platform/gpio-keys-polled.0/input/input0
[   13.324000] Compat-drivers backport release: compat-drivers-2012-09-04-2-gddac993
[   13.332000] Backport based on wireless-testing.git master-2012-09-07
[   13.336000] compat.git: wireless-testing.git
[   13.400000] cfg80211: Calling CRDA to update world regulatory domain
[   13.404000] cfg80211: World regulatory domain updated:
[   13.412000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   13.420000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.428000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   13.436000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   13.444000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.452000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   13.852000] NET: Registered protocol family 10
[   14.320000] SCSI subsystem initialized
[   14.368000] There is already a switch registered on the device 'eth0'
[   14.376000] roboswitch: Probing device eth1: No such device
[   14.380000] roboswitch: Probing device eth2: No such device
[   14.388000] roboswitch: Probing device eth3: No such device
[   14.736000] usbcore: registered new interface driver usbfs
[   14.744000] usbcore: registered new interface driver hub
[   14.752000] usbcore: registered new device driver usb
[   16.136000] PPP generic driver version 2.4.2
[   16.580000] brcmsmac bcma0:0: mfg 4bf core 812 rev 23 class 0 irq 31
[   17.216000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   17.280000] bcma: bus0: Switched to core: 0x812
[   17.280000] ieee80211 phy0: wl0: brcms_b_attach: Unsupported Broadcom board type (0xa8d8) or revision level (0x0)
[   17.292000] ieee80211 phy0: wl0: brcms_b_attach: failed with err 15
[   17.300000] ieee80211 phy0: wl0: brcms_c_attach: failed with err 15
[   17.304000] ieee80211 phy0: brcmsmac: attach() failed with code 15
[   17.312000] brcmsmac: brcms_bcma_probe: brcms_attach failed!
[   17.764000] NET: Registered protocol family 24
[   17.944000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   18.056000] bcm63xx_ehci bcm63xx_ehci.0: BCM63XX integrated EHCI controller
[   18.060000] bcm63xx_ehci bcm63xx_ehci.0: new USB bus registered, assigned bus number 1
[   18.092000] bcm63xx_ehci bcm63xx_ehci.0: irq 50, io mem 0xb0002500
[   18.108000] bcm63xx_ehci bcm63xx_ehci.0: USB 2.0 started, EHCI 1.00, overcurrent ignored
[   18.116000] hub 1-0:1.0: USB hub found
[   18.120000] hub 1-0:1.0: 1 port detected
[   18.296000] nf_conntrack version 0.5.0 (965 buckets, 3860 max)
[   19.232000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   19.504000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   19.616000] bcm63xx_ohci bcm63xx_ohci.0: BCM63XX integrated OHCI controller
[   19.620000] bcm63xx_ohci bcm63xx_ohci.0: new USB bus registered, assigned bus number 2
[   19.628000] bcm63xx_ohci bcm63xx_ohci.0: irq 49, io mem 0xb0002600
[   19.696000] hub 2-0:1.0: USB hub found
[   19.700000] hub 2-0:1.0: 1 port detected
[   19.824000] uhci_hcd: USB Universal Host Controller Interface driver
[   19.872000] Initializing USB Mass Storage driver...
[   19.876000] usbcore: registered new interface driver usb-storage
[   19.884000] USB Mass Storage support registered.
[   19.912000] usbcore: registered new interface driver ums-alauda
[   19.940000] usbcore: registered new interface driver ums-cypress
[   19.972000] usbcore: registered new interface driver ums-datafab
[   20.000000] usbcore: registered new interface driver ums-freecom
[   20.032000] usbcore: registered new interface driver ums-isd200
[   20.060000] usbcore: registered new interface driver ums-jumpshot
[   20.092000] usbcore: registered new interface driver ums-karma
[   20.120000] usbcore: registered new interface driver ums-sddr09
[   20.152000] usbcore: registered new interface driver ums-sddr55
[   20.184000] usbcore: registered new interface driver ums-usbat
[   25.700000] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 1, 100Mbps, full-duplex
[   25.716000] device eth0 entered promiscuous mode
[   25.720000] br-lan: port 1(eth0) entered forwarding state
[   25.728000] br-lan: port 1(eth0) entered forwarding state
[   27.732000] br-lan: port 1(eth0) entered forwarding state

Ésta es la parte donde falla.
Código: [Seleccionar]
[   17.280000] bcma: bus0: Switched to core: 0x812
[   17.280000] ieee80211 phy0: wl0: brcms_b_attach: Unsupported Broadcom board type (0xa8d8) or revision level (0x0)
[   17.292000] ieee80211 phy0: wl0: brcms_b_attach: failed with err 15
[   17.300000] ieee80211 phy0: wl0: brcms_c_attach: failed with err 15
[   17.304000] ieee80211 phy0: brcmsmac: attach() failed with code 15
[   17.312000] brcmsmac: brcms_bcma_probe: brcms_attach failed!

EDITO: He probado a compilarlo con el kernel 3.3.8 y da el mismo error.
« Última modificación: 03-12-2012, 16:27 (Lunes) por Jestern »