Autor Tema: [Desarrollo] OpenWrt en Comtrend AR-5387un  (Leído 636474 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1953
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1100 en: 29-10-2014, 14:12 (Miércoles) »
Tengo un problemilla que me gustaria solucionar, tiene que ver con el servicio que viene por defecto en Barrier Breaker 14.07-rc3, me refiero a Dinamic DNS.

He activado una cuenta NOIP para acceder a transmission que ya esta instalado y funcionando correctamente. Desde la IP y el puerto del transmission accedo perfectamente.

El problema esta en que el servicio Dinamic DNS no esta funcionando correctamente, creo que es problema del RELAY usado (luci-pro-relay), que ya viene instalado por defecto. Relay me esta funcionando bien para poder acceder al router a traves de 192.168.1.x , pero debe haber algun tipo de incompatibilidad por que en la web de NOIP veo que la IP que tiene es 192.168.1.100 en vez de la ip publica del router.

Openwrt lo tengo como cliente wifi del router principal con internet.

¿Por casualidad estás haciendo que mande la IP del "interface" en lugar de comprobar la IP mediante una página web? Tiene toda la pinta...


No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1101 en: 29-10-2014, 14:20 (Miércoles) »
Probe a poner todas las opciones de NETWORK e INTERFACE, y nunca me da la IP publica del router. Como puedo hacerlo?

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1953
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1102 en: 29-10-2014, 14:27 (Miércoles) »
Probe a poner todas las opciones de NETWORK e INTERFACE, y nunca me da la IP publica del router. Como puedo hacerlo?

Haciendo que compruebe la IP mediante una página web.

Aquí hay un ejemplo: https://foro.seguridadwireless.net/openwrt/(tutorial)-configuraciones-basicas-con-openwrt/
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1103 en: 29-10-2014, 15:48 (Miércoles) »
Muchisimas gracias, ha funcionado perfecto

crester

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1104 en: 31-10-2014, 23:42 (Viernes) »
Hola.
¿Sabéis si hay algún plan (no se si se puede) para mejorar el driver y que trabaje en IEEE 802.11n?
El firmware es espectacular y va genial, pero parece que solo trabaja en 802.11g, y sería increíble si pudiese llegar aunque fuese, a 130mbtis

Saludos.

seny

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1105 en: 01-11-2014, 20:32 (Sábado) »
Hola.
¿Sabéis si hay algún plan (no se si se puede) para mejorar el driver y que trabaje en IEEE 802.11n?
El firmware es espectacular y va genial, pero parece que solo trabaja en 802.11g, y sería increíble si pudiese llegar aunque fuese, a 130mbtis

Saludos.
El firmware de este router puede estar compilado con el driver wifi brcmsmac  en lugar del b-43 que será el que tu usas, en condiciones óptimas de recepción y con el driver brcmsmac llega a los 130 mbit/s. saludos.

crester

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1106 en: 01-11-2014, 21:33 (Sábado) »
El firmware de este router puede estar compilado con el driver wifi brcmsmac  en lugar del b-43 que será el que tu usas, en condiciones óptimas de recepción y con el driver brcmsmac llega a los 130 mbit/s. saludos.

uy, que alegría.
¿me puedes dar una pista de cómo hacerlo?

De los enlaces que hay en el primer post, he instalado el RC3.
Revisando el enlace en mediafire, el que me he bajado, por la ruta, parece que es brcmsmac:
https://www.mediafire.com/folder/8mqa4ksm088do/bb-14.07-rc3#sbs9bm6hb2w1z
"noltari" Shared Files -> bb-14.07-rc3 -> brcm63xx -> generic_brcmsmac

Buscando en el sistema de archivos obtengo esto
Código: [Seleccionar]
root@openwrt:~ find / -name brcms*

/etc/modules.d/brcmsmac
/lib/modules/3.10.49/brcmsmac.ko
/rom/etc/modules.d/brcmsmac
/rom/lib/modules/3.10.49/brcmsmac.ko
/sys/bus/bcma/drivers/brcmsmac
/sys/kernel/debug/brcmsmac
/sys/module/cfg80211/holders/brcmsmac
/sys/module/brcmsmac
/sys/module/brcmutil/holders/brcmsmac
/sys/module/mac80211/holders/brcmsmac
/sys/module/compat/holders/brcmsmac
/sys/module/cordic/holders/brcmsmac

y parece que es el que está cargado
Código: [Seleccionar]
root@openwrt:~# lsmod
(....)
brcmsmac              453689  0

Entonces, quizás sería algo de parámetros:
Esta es la configuración de mi radio0

Código: [Seleccionar]
config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:0'
        option disabled '0'
        option txpower '19'
        option htmode 'HT40'
        option noscan '1'
        option country 'ES'
        option channel '6'

y nada, que no hay manera.
El máximo que alcanzo son 54Mbits, full duplex, con tráfico

Código: [Seleccionar]
[Signal: -50 dBm / Noise: -95 dBm]  [-61 dBm] [-95 dBm] [54.0 Mbit/s] MCS 0, [20MHz] [54.0 Mbit/s], MCS 0, [20MHz]

He intentado algún "hack" como:
- comentar  
   option hwmode '11g'
- añadir un signo + , quedando
    option htmode 'HT40+'
  
Y nada,

¿alguna sugerencia más?
Gracias por todo.
Un saludo
« Última modificación: 01-11-2014, 22:35 (Sábado) por crester »

seny

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1107 en: 01-11-2014, 23:57 (Sábado) »
El firm que hay en el repositorio monta el driver b-43, prueba este que acabo de compilar con brcmsmac
OpenWrt Chaos Calmer r42270 / LuCI Trunk (svn-r10537)
Kernel Version   3.14.16 https://www.mediafire.com/?oxfo82z5fq9c58z
Saludos

crester

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1108 en: 02-11-2014, 02:15 (Domingo) »
El firm que hay en el repositorio monta el driver b-43, prueba este que acabo de compilar con brcmsmac
OpenWrt Chaos Calmer r42270 / LuCI Trunk (svn-r10537)
Kernel Version   3.14.16 https://www.mediafire.com/?oxfo82z5fq9c58z
Saludos

Muchas gracias por las molestias.
Ya lo he puesto, pero sigue igual. No pasa de 54 mbits.

¿no será algo del tipo de cifrado (lo tengo en WPA2 - AES forzado)?
no se me ocurre qué puede ser.

seny

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1109 en: 02-11-2014, 11:23 (Domingo) »
Muchas gracias por las molestias.
Ya lo he puesto, pero sigue igual. No pasa de 54 mbits.

¿no será algo del tipo de cifrado (lo tengo en WPA2 - AES forzado)?
no se me ocurre qué puede ser.
No tiene que ver con el cifrado, si lo pruebas desde luci escaneando redes y metiendo la clave tiene que funcionar en modo n a 20 Mhz, el problema puede estar en el ap wifi que no esté bien configurado, que no sea wifi n o que no sea capaz de emitir a 20 Mhz cuando otro cliente se conecta en modo g, si es esto ultimo prueba a desconectar todos los demas clientes wifi en la prueba.

crester

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1110 en: 02-11-2014, 11:52 (Domingo) »
No tiene que ver con el cifrado, si lo pruebas desde luci escaneando redes y metiendo la clave tiene que funcionar en modo n a 20 Mhz, el problema puede estar en el ap wifi que no esté bien configurado, que no sea wifi n o que no sea capaz de emitir a 20 Mhz cuando otro cliente se conecta en modo g, si es esto ultimo prueba a desconectar todos los demas clientes wifi en la prueba.

Sí señor.
Esa es la clave.
El escenario es este:
el AR-5387un se conecta a un TP-LINK WR-841N que está en modo bridge y tiene 1 radio como AP y otra como cliente del AP principal, otro TP-LINK  TL-WR1043ND con DD-WRT.

El problema era en el principal, que estaba forzado a 40Mhz.
Asi el bridge, como solo tiene una radio, mandaba la primera conexión, la de cliente, y se forzaba a 40Mgz, por lo que la radio de AP era también a 40 Mhz.
En cuanto he cambiado en el principal el forzado a 40, la cosa cambia bastante:

78.0 Mbit/s, MCS 12, 20MHz   115.6 Mbit/s, MCS 13, 20MHz

Muchísimas gracias.
Un saludo.

joselete666

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1111 en: 02-11-2014, 14:06 (Domingo) »
El firm que hay en el repositorio monta el driver b-43, prueba este que acabo de compilar con brcmsmac
OpenWrt Chaos Calmer r42270 / LuCI Trunk (svn-r10537)
Kernel Version   3.14.16 https://www.mediafire.com/?oxfo82z5fq9c58z
Saludos

Buenas seny.
Me instale tu compilación y al instalar algunos paquetes como el transmission por ejemplo me da el error siguiente:

//usr/lib/opkg/info/libpolarssl.postinst: line 4: default_postinst: not found
Configuring libcurl.
//usr/lib/opkg/info/libcurl.postinst: line 4: default_postinst: not found
Configuring libevent2.
//usr/lib/opkg/info/libevent2.postinst: line 4: default_postinst: not found
Configuring transmission-remote.
//usr/lib/opkg/info/transmission-remote.postinst: line 4: default_postinst: not found
Configuring transmission-daemon.
//usr/lib/opkg/info/transmission-daemon.postinst: line 4: default_postinst: not found
Configuring transmission-web.
//usr/lib/opkg/info/transmission-web.postinst: line 4: default_postinst: not found
Collected errors:
 * pkg_run_script: package "libpolarssl" postinst script returned status 127.
 * opkg_configure: libpolarssl.postinst returned 127.
 * pkg_run_script: package "libcurl" postinst script returned status 127.
 * opkg_configure: libcurl.postinst returned 127.
 * pkg_run_script: package "libevent2" postinst script returned status 127.
 * opkg_configure: libevent2.postinst returned 127.
 * pkg_run_script: package "transmission-remote" postinst script returned status 127.
 * opkg_configure: transmission-remote.postinst returned 127.
 * pkg_run_script: package "transmission-daemon" postinst script returned status 127.
 * opkg_configure: transmission-daemon.postinst returned 127.
 * pkg_run_script: package "transmission-web" postinst script returned status 127.
 * opkg_configure: transmission-web.postinst returned 127.

La verdad que no se de que puede ser. He buscado un poco pero no he encontrado gran cosa. Pero bueno es solo para que lo supieras.

Muchas gracias por todo.

seny

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1112 en: 03-11-2014, 00:40 (Lunes) »
joselete, ese firm lo subi para estar seguro que en la prueba del wifi brcmsmac usaba un firm correcto, tiene lo básico para esa prueba.

Pero que me corrijan si me equivoco, creo que transmission como tantos otros no se pueden unstalar desde el router, tiene que estar el firm compilado con ello incluido, animaos a compilar que el amigo jar nos lo puso bastante facil el el hilo con chincheta que lo explica.

Saludos

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1113 en: 03-11-2014, 00:59 (Lunes) »
yo tengo transmission funcionando con el firm del primer mensaje

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1953
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1114 en: 03-11-2014, 08:42 (Lunes) »
El firm que hay en el repositorio monta el driver b-43, prueba este que acabo de compilar con brcmsmac
OpenWrt Chaos Calmer r42270 / LuCI Trunk (svn-r10537)
Kernel Version   3.14.16 https://www.mediafire.com/?oxfo82z5fq9c58z
Saludos

Buenas seny.
Me instale tu compilación y al instalar algunos paquetes como el transmission por ejemplo me da el error siguiente:

//usr/lib/opkg/info/libpolarssl.postinst: line 4: default_postinst: not found
Configuring libcurl.
//usr/lib/opkg/info/libcurl.postinst: line 4: default_postinst: not found
Configuring libevent2.
//usr/lib/opkg/info/libevent2.postinst: line 4: default_postinst: not found
Configuring transmission-remote.
//usr/lib/opkg/info/transmission-remote.postinst: line 4: default_postinst: not found
Configuring transmission-daemon.
//usr/lib/opkg/info/transmission-daemon.postinst: line 4: default_postinst: not found
Configuring transmission-web.
//usr/lib/opkg/info/transmission-web.postinst: line 4: default_postinst: not found
Collected errors:
 * pkg_run_script: package "libpolarssl" postinst script returned status 127.
 * opkg_configure: libpolarssl.postinst returned 127.
 * pkg_run_script: package "libcurl" postinst script returned status 127.
 * opkg_configure: libcurl.postinst returned 127.
 * pkg_run_script: package "libevent2" postinst script returned status 127.
 * opkg_configure: libevent2.postinst returned 127.
 * pkg_run_script: package "transmission-remote" postinst script returned status 127.
 * opkg_configure: transmission-remote.postinst returned 127.
 * pkg_run_script: package "transmission-daemon" postinst script returned status 127.
 * opkg_configure: transmission-daemon.postinst returned 127.
 * pkg_run_script: package "transmission-web" postinst script returned status 127.
 * opkg_configure: transmission-web.postinst returned 127.

La verdad que no se de que puede ser. He buscado un poco pero no he encontrado gran cosa. Pero bueno es solo para que lo supieras.

Muchas gracias por todo.


El problema de las compilaciones personales es que están adaptadas a unas necesidades personales. Si se pretende utilizarlas para luego poner otros paquetes de openwrt seguramente no funcionarán.
O se compila uno todo el repositorio para luego utilizarlo cuando se necesite (cosa que encarecidamente recomiendo a todos), o, si no se quieren tener esta clase de problemas, es mejor instalar las versiones estables de openwrt directamente desde la web, e instalar los paquetes necesarios nosotros mismos.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1115 en: 03-11-2014, 13:38 (Lunes) »
no consigo montar particiones FAT32 en este router con el FIRM del primer mensaje (Barrier Breaker 14.07-rc3)

Tengo un disco duro conectado al router para descargar con transmission. 1 particion con EXT4 (sin problema). Otra particion con FAT32, que no consigo que lo monte bien. Tengo instalado Block-Mount y en el menu de MULTI POINTs en LUCI, me encuentra el DEV/SDA2 que corresponde a la particion fat32, en Filesystem le tengo indicado VFAT y que monte en /mnt/sda2.

El caso es que me reconoce el espacio de esa particion, pero no me lo monta. Esta compilacion es compatible con FAT32?
« Última modificación: 03-11-2014, 13:39 (Lunes) por pikomule »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4585
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1116 en: 03-11-2014, 17:00 (Lunes) »
no consigo montar particiones FAT32 en este router con el FIRM del primer mensaje (Barrier Breaker 14.07-rc3)

Tengo un disco duro conectado al router para descargar con transmission. 1 particion con EXT4 (sin problema). Otra particion con FAT32, que no consigo que lo monte bien. Tengo instalado Block-Mount y en el menu de MULTI POINTs en LUCI, me encuentra el DEV/SDA2 que corresponde a la particion fat32, en Filesystem le tengo indicado VFAT y que monte en /mnt/sda2.

El caso es que me reconoce el espacio de esa particion, pero no me lo monta. Esta compilacion es compatible con FAT32?

Si ejecutas el comando de montaje 'a mano' desde una conexión ssh, te da algún tipo de error ?
Valoraciones positivas en compra/venta:
130 en Htcmania
174 en Har2mano
20 en elchapuzasinformatico
11 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1jkj-kzmCBVkVb3_at6sgKinmE7YdFeRi

pikomule

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1117 en: 03-11-2014, 17:09 (Lunes) »
como monto desde ssh?

mount /dev/sda2/ /mnt/sda2/ ?
mount vfat /dev/sda2/ /mnt/sda2/ ?

lo probe asi y no recuerdo si me dio error o que. Luego pego lo que me salga. Si no se monta asi, dime como es

Sekmeth

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1118 en: 03-11-2014, 22:01 (Lunes) »
Hola

En primer lugar felicitaros a todos por el gran trabajo que hacéis. Es increible la de cosas que se pueden hacer con este pequeño router.
....igualmente increible es lo inepto que puedo llegar a ser para hacer incluso lo más sencillo.  :-\

Una vez flasheado con el último firmware colgado en el primer hilo (hay varios, he escogido el de la carpeta "generic_brcmsmac"), soy incapaz de seguir.
Sólo intento compartir un pendrive (ya formateado en ext2) en red por Samba, para más adelante mirar de instalar programas tipo Transmission, etc.).

Abandonada la idea de poder hacerlo directamente por Luci (he leido el hilo entero, al igual que el tutorial de jar229 sobre el HG553 pero no encuentro los pasos a seguir desde la interfaz web) creo que sólo me queda la opción de hacerlo a través de Putty.

Sigo los pasos para el soporte de Samba pero solo obtengo errores.
Debo haberme equivocado en algo de lo más sencillo, pero estoy tan metido en esto que me es imposible mirarlo de manera objetiva para saber el porqué.


Código: [Seleccionar]
login as: root
root@192.168.1.100's password:


BusyBox v1.22.1 (2014-08-13 14:25:28 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (Barrier Breaker, r42068)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@OpenWrt:~# opkg install luci-app-samba
Package luci-app-samba (git-7a26a77-1) installed in root is up to date.
root@OpenWrt:~# opkg install luci-app-p910nd
Package luci-app-p910nd (git-7a26a77-1) installed in root is up to date.
root@OpenWrt:~# opkg install kmod-usb-printer
Unknown package 'kmod-usb-printer'.
Collected errors:
 * opkg_install_cmd: Cannot install package kmod-usb-printer.
root@OpenWrt:~# opkg install kmod-usb2
Package kmod-usb2 (3.10.49-1) installed in root is up to date.
root@OpenWrt:~# opkg install kmod-usb-core
Package kmod-usb-core (3.10.49-1) installed in root is up to date.
root@OpenWrt:~# opkg install kmod-usb-ohci
Package kmod-usb-ohci (3.10.49-1) installed in root is up to date.
root@OpenWrt:~# opkg install usbutils
Unknown package 'usbutils'.
Collected errors:
 * opkg_install_cmd: Cannot install package usbutils.
root@OpenWrt:~# opkg install kmod-usb-storage e2fsprogs kmod-fs-vfat kmod-nls-cp4
37 kmod-nls-iso8859-1
Package kmod-usb-storage (3.10.49-1) installed in root is up to date.
Unknown package 'e2fsprogs'.
Unknown package 'kmod-fsvfat'.
Package kmod-nls-cp437 (3.10.49-1) installed in root is up to date.
Unknown package 'kmod-nls-iso8859-1'.
Collected errors:
 * opkg_install_cmd: Cannot install package e2fsprogs.
 * opkg_install_cmd: Cannot install package kmod-fs-vfat.
 * opkg_install_cmd: Cannot install package kmod-nls-iso8859-1.
root@OpenWrt:~# opkg install swap-utils
Unknown package 'swap-utils'.
Collected errors:
 * opkg_install_cmd: Cannot install package swap-utils.
root@OpenWrt:~# opkg install ntfs-3g kmod-fs-ext4
Unknown package 'ntfs-3g'.
Package kmod-fs-ext4 (3.10.49-1) installed in root is up to date.
Collected errors:
 * opkg_install_cmd: Cannot install package ntfs-3g.

joselete666

  • Visitante
Re: [Desarrollo] OpenWrt en Comtrend AR-5387un
« Respuesta #1119 en: 03-11-2014, 22:51 (Lunes) »
Buenas Sekmeth
Has hecho primero el opkg update?
Saludos