Autor Tema: Problema. Wifislax 4.12 no detecta clientes  (Leído 22870 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Vacasflacas2017

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #40 en: 16-02-2017, 02:31 (Jueves) »
????



 Perdón x la demora USUARIONUEVO he probado tal como me dijiste, y a pesar de que detecta mi tarjeta etc, sigue estando el inconveniente que no detecta cliente. Debe ser como ud dice, problema del kernel. Lamentablemente. De igual forma me fue didáctico, y me ayuda a comprender como se componen las diferentes áreas de desarrollo en linux y sus distros. Supongo q no vale la pena buscar como hacer un reporte para q lo parchen x tan solo una pc w no lo toma. Intuyo q debe haber muchas mas, pero quizás en las notebooks mas nuevas con Broadcom les funcione. Muchas gracias igualmente x tu ayuda y tu tiempp



Vacasflacas2017

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #41 en: 16-02-2017, 02:36 (Jueves) »
Ah! Una cosa mas. Esto no me pasaste: b43-fwcutter-018-i486-1sw
No tiene nada q ver con lo que nosotros buscamos? Saludos

Vacasflacas2017

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #42 en: 19-02-2017, 05:15 (Domingo) »
 ??? Me queda la duda se q va a suceder de aquí a futuro con respecto al kernel si es eso lo q provoca la falla

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #43 en: 20-02-2017, 04:26 (Lunes) »
seguramente, si ese adaptador es viejo, de los que usan protocolos b/g, quede en el olvido y no lo solucionen.

Si es un N o un AC, posiblemente se solucione, pero de todas formas los Broadcom suelen funcionar mal.


saludos
« Última modificación: 20-02-2017, 04:27 (Lunes) por drvalium »

kidkosmic

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #44 en: 22-02-2017, 14:20 (Miércoles) »
Buenas a todos,

Como veo que este hilo es relativamente nuevo, quería saber si podían ayudarme.

A mi me pasa exactamente lo mismo que a USUARIONUEVO.
Tengo un ordenador portatil con una tarjeta de red wifi incorporada (chipset Atheros), donde he probado tanto la version Wifislax64 como la wifislax 4.12, en modo livecd y liveUSB. La tarjeta se pone en modo monitor sin problemas, y airodump funciona, asi también airmon etc etc.
Cuando quiero usar handshaker, me reconoce la tarjeta wifi, la pone en monitor mon0, ejecuta airodump-ng, y se encuentran redes y clientes reales. Para continuar, doy a ctrl + c y en vez de listar las redes y clientes, me pone el mensaje:

No se encontró ninguna red...saliendo del script...

wifislax Handshaker #

También he probado de utilizar el Linset, selecciona la tarjeta de red, indico que escanee todos los canales, se abre la ventana de "Escaneando Objetivos", nuevamente, la dejo correr durante un tiempo, encuentra varias redes y a su vez abajo varios clientes conectados a dichas redes. Al terminar el proceso para que liste todos ellos, me sale el siguiente error:

#########################################################
#                                                                                                                                          #
#                LINSET 0.14 by vk496                                                                                        #
#       Linset Is Not a Social Enginering Tool                                                                         #
#                                                                                                                                          #
#########################################################


expr: error de sintaxis
                         Listado de APs Objetivo

 #      MAC                      CHAN    SECU     PWR    ESSID

grep: el: No existe el fichero o el directorio
grep: número: No existe el fichero o el directorio
grep: de: No existe el fichero o el directorio
grep: líneas: No existe el fichero o el directorio
grep: no: No existe el fichero o el directorio
grep: es: No existe el fichero o el directorio
grep: válido:: No existe el fichero o el directorio
grep: «/tmp/TMPlinset/dump-01.csv»: No existe el fichero o el directorio
 1)     head: el número de líneas no es válido: «/tmp/TMPlinset/dump-01.csv»                 100%

(*) Red con Clientes

        Selecciona Objetivo               
      #>

Como no quise creer que fuera un problema del ordenador, decidí probar con mi ordenador de sobremesa, me compré el adaptador inalambrico TL-WN722N (chipset AR9271) que figura en la lista de dispositivos compatibles, y cargue tanto en VMWare como en Virtualbox ambas versiones de WifiSlax (64 1.0 y la 4.12). En ambos casos me sucede exactamente lo mismo, y me estoy volviendo loco porque no entiendo que estará sucediendo!.

Ejecutando ls /var/log/packages|grep b43 me sale lo siguiente:

wifislax ~ # ls /var/log/packages|grep b43
b43-firmware-6.30.163.46-fw-1sw
b43-fwcutter-019-i586-1sw
wifislax ~ #

Al ejecutar dmesg|grep -i firmware me sale lo siguiente:

wifislax ~ # dmesg|grep -i firmware
[    2.735476] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[   90.149062] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested

Por último, mi router es un ARRIS, y hay varios dispositivos conectados como clientes a mi red, que los veo en el airodump-ng pero obviamente ni handshaker ni linset parecen correr como se observa en varios videos de youtube.

Por favor les ruego ayuda!!

Desde ya muchas gracias!

tabiritrero

  • Visitante
Re: Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #45 en: 23-02-2017, 14:14 (Jueves) »
Código: [Seleccionar]
dmesg|grep -i firmware
creo que falta el firmware

ejecuta eso en consola y dime.

Ahí va captura



 :-\  a me pasa lo mismo  :-\
¿ qué solución hay?

Enviado desde mi HM NOTE 1LTE mediante Tapatalk


Vacasflacas2017

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #46 en: 23-02-2017, 14:30 (Jueves) »
Que 'lastima' q si ya habia un parche en otras versiones no se lo apliquen a esta... Parece q somos varios los q tenemos problemas... Yo les aconsejo a los dos que prueben otras versiones. Saludos

tabiritrero

  • Visitante
Re: Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #47 en: 23-02-2017, 14:37 (Jueves) »
Que 'lastima' q si ya habia un parche en otras versiones no se lo apliquen a esta... Parece q somos varios los q tenemos problemas... Yo les aconsejo a los dos que prueben otras versiones. Saludos
:( O esperar otra versión..... :D  :D  :D  :D

Enviado desde mi HM NOTE 1LTE mediante Tapatalk


Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #48 en: 23-02-2017, 18:55 (Jueves) »
También he probado de utilizar el Linset, selecciona la tarjeta de red, indico que escanee todos los canales, se abre la ventana de "Escaneando Objetivos", nuevamente, la dejo correr durante un tiempo, encuentra varias redes y a su vez abajo varios clientes conectados a dichas redes. Al terminar el proceso para que liste todos ellos, me sale el siguiente error:

#########################################################
#                                                                                                                                          #
#                LINSET 0.14 by vk496                                                                                        #
#       Linset Is Not a Social Enginering Tool                                                                         #
#                                                                                                                                          #
#########################################################


expr: error de sintaxis
                         Listado de APs Objetivo

 #      MAC                      CHAN    SECU     PWR    ESSID

grep: el: No existe el fichero o el directorio
grep: número: No existe el fichero o el directorio
grep: de: No existe el fichero o el directorio
grep: líneas: No existe el fichero o el directorio
grep: no: No existe el fichero o el directorio
grep: es: No existe el fichero o el directorio
grep: válido:: No existe el fichero o el directorio
grep: «/tmp/TMPlinset/dump-01.csv»: No existe el fichero o el directorio
 1)     head: el número de líneas no es válido: «/tmp/TMPlinset/dump-01.csv»                 100%

(*) Red con Clientes

        Selecciona Objetivo               
      #>

Como no quise creer que fuera un problema del ordenador, decidí probar con mi ordenador de sobremesa, me compré el adaptador inalambrico TL-WN722N (chipset AR9271) que figura en la lista de dispositivos compatibles, y cargue tanto en VMWare como en Virtualbox ambas versiones de WifiSlax (64 1.0 y la 4.12). En ambos casos me sucede exactamente lo mismo, y me estoy volviendo loco porque no entiendo que estará sucediendo!.

Ejecutando ls /var/log/packages|grep b43 me sale lo siguiente:

wifislax ~ # ls /var/log/packages|grep b43
b43-firmware-6.30.163.46-fw-1sw
b43-fwcutter-019-i586-1sw
wifislax ~ #

Al ejecutar dmesg|grep -i firmware me sale lo siguiente:

wifislax ~ # dmesg|grep -i firmware
[    2.735476] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[   90.149062] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested

vuelve a descargar la iso de Wifislax y comprueba el MD5, tu Wifislax esta corrupto, ambos programas funcionan bien en VMware con el adaptador TL-WN722N.

con el broadcom no se si funciona nada, esos chips suelen ir fatal.


saludos


Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #49 en: 23-02-2017, 18:57 (Jueves) »

 :-\  a me pasa lo mismo  :-\
¿ qué solución hay?

Tu adaptador WiFi no está siendo reconocido por Wifislax.

¿que adaptador estas usando?

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14705
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #50 en: 23-02-2017, 22:15 (Jueves) »
estais liando una de raviolli.

1 - no es que haya parches sin aplicar a wifislax... salio un bug hace un tiempo y kernel.org parcheao el driver ralinkl , y probablemente se dejo los broadcom sin parchear , "ni yo ni wifislax ni nadie", se dejo ningun parche de nada , si teneis ese problema, os vais a kernel.org y lo reportais para que parcheen , yo no tengo hay nada que hacer.

2 - cuando se pide de mirar los mensajes de firmware , si no aparece el tipico "no lo encuentro" , es que todo esta ok.

3 - para los broadcom ,ya deje los firmwares, no voy a estar posteandolos 10,000 veces...  ¿seccion modulos para wifislax64?


4 - al usuario que le falla con un atheros es un atheros 10.000  ..del que poco sabemos podria estar fallando cualquier cosa, pero vamos ..en los automatismos, si usara comandos a mano no fallaria nada, estoy seguro.


yo en este hilo no veo ningun problema real..a ninguno , unos por que se empeñan , y otros por que no leen ,el unico el del chipset 10000 pci de atheros, que al ser mas nuevo y poco visto aun , no se que estara pasandole.
« Última modificación: 23-02-2017, 22:43 (Jueves) por USUARIONUEVO »

kidkosmic

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #51 en: 24-02-2017, 01:29 (Viernes) »
Acabo de chequear el MD5 del .ISO que me descargué de la web de wifislax.com y está bien, coindice.

Lo que si pude ver, es que cuando corre el script, se generan los archivos de dump-01.csv y otros archivos, un XML de kismet...
Total, que cuando tengo un buen puñado de redes y clientes chequeados durante el proceso de airdump-ng, al dar ctrl-c se genera un archivo dump-02.csv y otros archivos. Este dump-02.csv es el que tiene la cabecera de "EL NUMERO DE LINEAS NO ES VALIDO".
Por tanto, algo esta pasando, y no soy el único al que le sucede esto.
Por pensar que el LiveCD podía interferir, instalé ambas versiones en dos discos virtuales. Es igual..! el error persiste.

Y a tener en cuenta, también me descargué un KALI, y sucede lo mismo!!!!

Que mas puede ser?



También he probado de utilizar el Linset, selecciona la tarjeta de red, indico que escanee todos los canales, se abre la ventana de "Escaneando Objetivos", nuevamente, la dejo correr durante un tiempo, encuentra varias redes y a su vez abajo varios clientes conectados a dichas redes. Al terminar el proceso para que liste todos ellos, me sale el siguiente error:

#########################################################
#                                                                                                                                          #
#                LINSET 0.14 by vk496                                                                                        #
#       Linset Is Not a Social Enginering Tool                                                                         #
#                                                                                                                                          #
#########################################################


expr: error de sintaxis
                         Listado de APs Objetivo

 #      MAC                      CHAN    SECU     PWR    ESSID

grep: el: No existe el fichero o el directorio
grep: número: No existe el fichero o el directorio
grep: de: No existe el fichero o el directorio
grep: líneas: No existe el fichero o el directorio
grep: no: No existe el fichero o el directorio
grep: es: No existe el fichero o el directorio
grep: válido:: No existe el fichero o el directorio
grep: «/tmp/TMPlinset/dump-01.csv»: No existe el fichero o el directorio
 1)     head: el número de líneas no es válido: «/tmp/TMPlinset/dump-01.csv»                 100%

(*) Red con Clientes

        Selecciona Objetivo              
      #>

Como no quise creer que fuera un problema del ordenador, decidí probar con mi ordenador de sobremesa, me compré el adaptador inalambrico TL-WN722N (chipset AR9271) que figura en la lista de dispositivos compatibles, y cargue tanto en VMWare como en Virtualbox ambas versiones de WifiSlax (64 1.0 y la 4.12). En ambos casos me sucede exactamente lo mismo, y me estoy volviendo loco porque no entiendo que estará sucediendo!.

Ejecutando ls /var/log/packages|grep b43 me sale lo siguiente:

wifislax ~ # ls /var/log/packages|grep b43
b43-firmware-6.30.163.46-fw-1sw
b43-fwcutter-019-i586-1sw
wifislax ~ #

Al ejecutar dmesg|grep -i firmware me sale lo siguiente:

wifislax ~ # dmesg|grep -i firmware
[    2.735476] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[   90.149062] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested

vuelve a descargar la iso de Wifislax y comprueba el MD5, tu Wifislax esta corrupto, ambos programas funcionan bien en VMware con el adaptador TL-WN722N.

con el broadcom no se si funciona nada, esos chips suelen ir fatal.


saludos


« Última modificación: 24-02-2017, 09:09 (Viernes) por drvalium »

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #52 en: 24-02-2017, 09:15 (Viernes) »
en el resultado anterior lo que dice fallar es el dump-01.csv y no el dump-02.csv.

grep: «/tmp/TMPlinset/dump-01.csv»: No existe el fichero o el directorio
 1)     head: el número de líneas no es válido: «/tmp/TMPlinset/dump-01.csv»                 100%

muy posiblemente no estes capturando nada ¿cuanto mide ese archivo? ¿0 Kb?

kidkosmic

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #53 en: 24-02-2017, 13:57 (Viernes) »
Muchas gracias drvalium,

Pues, si esta capturando, tanto el dump-01 como el archivo kismet tienen datos mientras esta capturando perfectamente.
Es cuando termino el proceso de captura donde se generan los archivos dump-02 y clientes.csv y me he fijado que el fichero de clientes se general con el error, y por lo visto el script genera un concatenado de datos para armar el dump-02 y tengo la sensación de que es aquí donde está el problema.

Aquí va el proceso completo en imagenes:

01- Arranca el proceso de captura de clientes


02- Chequeo que el dump-01 se está volcando correctamente.


03- También chequeo que el fichero de Kismet se está volcando correctamente.


04- Al terminar el proceso de captura, se generan los archivos de clientes y dump 2 con el error:


Es raro que a algunos nos esté fallando esto, y no solo con el Linset, en handshaker deberia listar todo también y no me funciona tampoco!!

en el resultado anterior lo que dice fallar es el dump-01.csv y no el dump-02.csv.

grep: «/tmp/TMPlinset/dump-01.csv»: No existe el fichero o el directorio
 1)     head: el número de líneas no es válido: «/tmp/TMPlinset/dump-01.csv»                 100%

muy posiblemente no estes capturando nada ¿cuanto mide ese archivo? ¿0 Kb?

Vacasflacas2017

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #54 en: 24-02-2017, 19:47 (Viernes) »
estais liando una de raviolli.

1 - no es que haya parches sin aplicar a wifislax... salio un bug hace un tiempo y kernel.org parcheao el driver ralinkl , y probablemente se dejo los broadcom sin parchear , "ni yo ni wifislax ni nadie", se dejo ningun parche de nada , si teneis ese problema, os vais a kernel.org y lo reportais para que parcheen , yo no tengo hay nada que hacer.


Claro, no lo decía por wifislax, sino por el kernel q es una lastima q no lo hayan parcheado a las broadcom y por eso consultaba si era en vano reportarlo, además en mi calidad de usuario pocas explicaciones podria darles. Quizás uds recolectando mas personas q les suceda lo mismo podrían reportarlo así tiene mas peso. Digo... quizás no les importa tanto que pierda compatibilidad sino que siga funcionando con algunas tarjetas especificas... Igualmente todo esto suponiendo de que sea el bug que genera el kernel.
Ya voy a ver qie hago
 Gracias x tu sugerencia.

samsung

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #55 en: 24-02-2017, 21:57 (Viernes) »
a mi me dio los firmware automaticos por updates

Ermete

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #56 en: 25-02-2017, 10:07 (Sábado) »
estais liando una de raviolli.

1 - no es que haya parches sin aplicar a wifislax... salio un bug hace un tiempo y kernel.org parcheao el driver ralinkl , y probablemente se dejo los broadcom sin parchear , "ni yo ni wifislax ni nadie", se dejo ningun parche de nada , si teneis ese problema, os vais a kernel.org y lo reportais para que parcheen , yo no tengo hay nada que hacer.


Claro, no lo decía por wifislax, sino por el kernel q es una lastima q no lo hayan parcheado a las broadcom y por eso consultaba si era en vano reportarlo, además en mi calidad de usuario pocas explicaciones podria darles. Quizás uds recolectando mas personas q les suceda lo mismo podrían reportarlo así tiene mas peso. Digo... quizás no les importa tanto que pierda compatibilidad sino que siga funcionando con algunas tarjetas especificas... Igualmente todo esto suponiendo de que sea el bug que genera el kernel.
Ya voy a ver qie hago
 Gracias x tu sugerencia.

Si encuentra una solución al kernel que me haga saber, yo estoy en la misma situación que dos años, he recompilado el kernel de una docena de veces sin éxito, funciona hasta 2.26 (Wifislax 4.11), la actualización de Wifislax 4.11 kernel ya no funciona, I 5 Broadcom
« Última modificación: 25-02-2017, 11:05 (Sábado) por Ermete »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14705
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #57 en: 25-02-2017, 20:23 (Sábado) »
para que funciona añadir los firmwares.

otra cosa es lo de detectar cleintes en modo monitor ,son dos cosas distintas.

kidkosmic

  • Visitante
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #58 en: 26-02-2017, 18:04 (Domingo) »
RESUELTO!!!
No se como...
En realidad me puse a mirar ls -l linset para ver cuales son los permisos que tenía.
En principio estaba todo bien, habia una letra mas, una t al final.
Como ya había probado ejecutando chmod +x linset y no me funcionó, pues probé con chmod 777 linset.

Luego de eso lo probé, me funcionó una vez y luego ya no...
Y como me parecía extramadamente raro, probé nuevamente de todo!

Al final, me lista todas las redes únicamente si especifico 1 solo canal, de forma que primero abro un airdump para ver todas las redes disponibles, luego se cual es el canal del cliente al que atacar, indico exclusivamente ese canal en linset y listo!

Igual no me sirvió de nada, porque por mas WPS que le active a mi router (o no lo haga), no he conseguido na de naaaa!!

Gracias igual a todos!!!

Muchas gracias drvalium,

Pues, si esta capturando, tanto el dump-01 como el archivo kismet tienen datos mientras esta capturando perfectamente.
Es cuando termino el proceso de captura donde se generan los archivos dump-02 y clientes.csv y me he fijado que el fichero de clientes se general con el error, y por lo visto el script genera un concatenado de datos para armar el dump-02 y tengo la sensación de que es aquí donde está el problema.

Aquí va el proceso completo en imagenes:

01- Arranca el proceso de captura de clientes


02- Chequeo que el dump-01 se está volcando correctamente.


03- También chequeo que el fichero de Kismet se está volcando correctamente.


04- Al terminar el proceso de captura, se generan los archivos de clientes y dump 2 con el error:


Es raro que a algunos nos esté fallando esto, y no solo con el Linset, en handshaker deberia listar todo también y no me funciona tampoco!!

en el resultado anterior lo que dice fallar es el dump-01.csv y no el dump-02.csv.

grep: «/tmp/TMPlinset/dump-01.csv»: No existe el fichero o el directorio
 1)     head: el número de líneas no es válido: «/tmp/TMPlinset/dump-01.csv»                 100%

muy posiblemente no estes capturando nada ¿cuanto mide ese archivo? ¿0 Kb?

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17387
  • Misántropo
Re: Problema. Wifislax 4.12 no detecta clientes
« Respuesta #59 en: 26-02-2017, 19:20 (Domingo) »
hi

gracias por compartir la solución ;)

para WPS, mejor usa Geminis Auditor.


saludos

//FINAL Y MÁS DOS RESPUESTAS