Autor Tema: Problema de audio en hdmi a tv con wifislax  (Leído 5831 veces)

0 Usuarios y 1 Visitante están viendo este tema.

andreiya

  • Visitante
Problema de audio en hdmi a tv con wifislax
« en: 28-08-2013, 14:43 (Miércoles) »
Hola gente,con el buscador no he encontrado nada así que me decido a crear tema.

Tengo un portátil con una gforce 9200 y 4gb de ram.Lo he conectado por HDMI al TV.

Desde windows me ha costado,pero al final tocando configuraciones he logrado ver y oír una película Blueray que tengo en el disco duro del portátil.
El problema es que va a saltos y salen cuadrados verdes de vez en cuando.Será por memoria o por consumo de recursos de windows,así que se me ocurrió probar con wifislax 4.3,que es el que uso y el problema de fluidez se me ha solucionado.

Me surje el problema más importante y que llevo toda la mañana intentando solucionar.¡No tengo audio!
En windows es tan fácil como seleccionar la salida de audio el HDMI,pero desde wifislax no tengo ni idea de cómo hacerlo y eso que he movido todos los ajustes de audio que he visto.

Agradezco cualquier idea que me podais dar.Saludos




Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14453
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #1 en: 29-08-2013, 01:56 (Jueves) »
bajate este fichero , ponlo en la carpeta modules ...e inicia la live  a ver si ahora si va el hdmi.


recuerda ... arranca con el fichero nuevo ya colocado en modules.


si lo tienes instalado en disco duro ...pues click derecho sobre el fichero ..autoinstalar ..y reinicias.


http://www.multiupload.nl/GC8CK75GJY

andreiya

  • Visitante
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #2 en: 29-08-2013, 17:56 (Jueves) »
bajate este fichero , ponlo en la carpeta modules ...e inicia la live  a ver si ahora si va el hdmi.


recuerda ... arranca con el fichero nuevo ya colocado en modules.


si lo tienes instalado en disco duro ...pues click derecho sobre el fichero ..autoinstalar ..y reinicias.


http://www.multiupload.nl/GC8CK75GJY

Gracias USUARIONUEVO ,crucé los dedos al probar el módulo pero...no funcionó.

Lo dejo por imposible/falta de conocimientos,he buscado lo impensable en wifislax y no veo el porqué no funciona mi audio.Un apunte es que si NO entro a wifislax con la configuración NVIDIA no me va el vídeo tampoco.


Como solución intenté desde live wifislax 4.6 y ahí ni siquiera me sale el vídeo en pantalla  ???
También lo intenté con el mint,por probar,y más de lo mismo.

He lanzado el comando aplay -l y si que se supone que está correcto el audio por HDMI.

Veo que a mucha gente le pasa lo mismo en los foros con linux ,parece mentira que sea tan complejo algo que debe de ser más asequible.No sé qué más intentar así que lo dejo.
Saludos


alist3r

  • Visitante
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #3 en: 29-08-2013, 18:12 (Jueves) »
Veo que a mucha gente le pasa lo mismo en los foros con linux ,parece mentira que sea tan complejo algo que debe de ser más asequible.No sé qué más intentar así que lo dejo.
Saludos

porque linux no se hace solo. además de usuarios dispuestos a colaborar e intentarlo, como tú, hacen falta muchos más desarrolladores, con conocimientos muy profundos de hardware, en muchas más áreas.
Por no hablar de que los fabricantes no siempre colaboran con la información que se necesita.

Por cierto, que yo sepa, la 9200 no ofrece apoyo para audio a través de HDMI  O era sólo la version Mobile? En todo caso, tienes un portatil, por lo que no tienes una 9200 sino una 9200M, que en caso de que yo recuerde bien, no tiene apoyo para sonido HDMI.

Y tambien deberias verifcar si el cable puede manejar ese ancho de banda. No todo los HDMI son iguales.

Si ya dices que no te va bien en windows... lo menos lógico es acusar a linux.
« Última modificación: 29-08-2013, 18:20 (Jueves) por alister »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14453
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #4 en: 29-08-2013, 18:59 (Jueves) »
También puede ser que el sistema pille por defecto la primera que detecta ( sonido integrado )


en la categoría multimedia , hay una herramienta de selección de tarjeta predefinida.


arranca , del desplegable selecciona la que ponga hdmi ...y dale a crear  ..eso creara un xzm en la ruta

/tmp

lo copias a modules o si esta instalado autoinstalar y reinicias.

alist3r

  • Visitante
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #5 en: 29-08-2013, 19:06 (Jueves) »
También puede ser que el sistema pille por defecto la primera que detecta ( sonido integrado )

eso, siempre.

alsa nunca usará salidas HDMI by default habiendo integradas.

y cuando no haya integradas, creará y usará una dummy, antes que usar hdmi.

hay que indicárselo de forma específica porque el sonido hdmi se presupone puede desaparecer en cualquier momento y por tanto se trata como si fuera un dispositivo extraible.

andreiya

  • Visitante
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #6 en: 31-08-2013, 01:45 (Sábado) »

porque linux no se hace solo. además de usuarios dispuestos a colaborar e intentarlo, como tú, hacen falta muchos más desarrolladores, con conocimientos muy profundos de hardware, en muchas más áreas.
Por no hablar de que los fabricantes no siempre colaboran con la información que se necesita.

Por cierto, que yo sepa, la 9200 no ofrece apoyo para audio a través de HDMI  O era sólo la version Mobile? En todo caso, tienes un portatil, por lo que no tienes una 9200 sino una 9200M, que en caso de que yo recuerde bien, no tiene apoyo para sonido HDMI.

Y tambien deberias verifcar si el cable puede manejar ese ancho de banda. No todo los HDMI son iguales.

Si ya dices que no te va bien en windows... lo menos lógico es acusar a linux.

Ante todo gracias a los dos por las molestias y ayuda.Por cierto linux me encanta y no tengo palabras para agradecer el esfuerzo de la gente para  siga adelante y no tener el monopolio windows.

-El tema del cable queda descartado(Probé 2 diferentes uno de ellos de los "caros").Creo que la fluidez se ve afectada por el propio windows,ojalá me equivoque,porque al poner la película en linux fluye perfecto.

-Efectivamente mi tarjeta es:

Procesador GPU:GeForce 9200M GS
Versión del controlador:   311.00
Soporte de DirectX:   10
Núcleos de CUDA:   8
Reloj del núcleo:   529 MHz
Reloj de sombreado:   1300 MHz
Velocidad de datos de la memoria:   800 MHz
Memoria total disponible para gráficos:   1790 MB
Memoria de vídeo dedicada:   512 MB DDR2
Memoria de vídeo del sistema:   0 MB
Memoria compartida del sistema:   1278 MB
Bus:         PCI Express x16

-Haré un último esfuerzo en encontrar una posible solución y postearé el resultado por si sirve de ayuda.
Saludos

hashing

  • Visitante
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #7 en: 31-08-2013, 12:02 (Sábado) »
 Hola andreiya. En las televisiones modernas suele haber una entrada HDMI que esta vinculada con una entrada de audio analogica(jack o RCA) para que los ordenadores con salida DVI(o los que tienen problemas con el audio del hdmi,como es tu caso) puedan mandarle el audio a la television atraves de la salida de auriculares del portatil.
 Deberias comprobar si mientras ves en la television el blu-ray tienes audio en la salida de auriculares del portatil, si es asi solo tienes que hacerte conel cable correspondiente:jack-jack o rca-jack.
 Se que es un parche pero igual te soluciona el problema mientras averiguas lo del audio en el hdmi.

alist3r

  • Visitante
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #8 en: 31-08-2013, 13:06 (Sábado) »
ademas de que lo que comenta hashing es ideal para este caso, tambien hay informes de gente que ha tenido que dejar a un lado los drivers compatibles con cuda, y usar los nouveau, que son los drivers nvidia de código abierto desarrollados por la comunidad.

si para ti es una prioridad el uso del hdmi, quizas esta pueda ser una de tus últimas opciones.

existe un grupo de desarrolladores de una distribución linux orientada a media centers, que aseguran haber resuelto el problema en algunos casis, retrocediendo la version del driver hasta la 173 (si no recuerdo mal) , prescindiendo de PUlseAudio (esto no afecta a usuarios de Wifislax) y realizando unos ajustes avanzados en alsa.

Lamentablemente no recuerdo dónde leí eso exactamente.

Colaborador2016

  • Visitante
Re: Problema de audio en hdmi a tv con wifislax
« Respuesta #9 en: 23-07-2016, 21:10 (Sábado) »
Una ves que estes en wifislax reproduce él vídeo para que él sonido salga por la TV fíjate bien en él reproductor arriba donde dice subtitulos justo debajo de las letras aparece una figura de un destornillador presiona y fíjate donde dice driver de salida y presiona a su derecha y selecciona donde dice alsa (0.3 - HDMA intel PCH) por lo menos a mi me sale a si luego abajo presiona aceptar y él sonido saldrá por la TV