Autor Tema: Paquetes importantes a instalar (apt install)  (Leído 493 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Paquetes importantes a instalar (apt install)
« en: 01-09-2020, 03:48 (Martes) »
Lo primero siempre

Código: [Seleccionar]
apt update
Para compilar crunch
https://sourceforge.net/projects/crunch-wordlist/files/latest/download


no era necesario, ya tenemos

Código: [Seleccionar]
apt-get install crunch
Código: [Seleccionar]
apt install build-essential sudo  --yes

corregido code, las gcc obvio ya vienen dentro de las essential xd

Código: [Seleccionar]
apt install -y  build-essential libpcap-dev aircrack-ng pixiewps git
Código: [Seleccionar]
apt install ettercap-text-only  ettercap-dbg ettercap-common

si quieres modo grafico

Código: [Seleccionar]
apt install ettercap-graphical

pero son incompatibles uno con otro. dejamos el modo texto que somos espartanos jaja


« Última modificación: 02-09-2020, 11:08 (Miércoles) por Hwagm »


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #1 en: 01-09-2020, 03:54 (Martes) »
Instalando  Bully y Mdk3

Código: [Seleccionar]
apt install libpcap-dev libssl-dev --yes
wget https://github.com/aanarchyy/bully/archive/master.zip && unzip master.zip
cd bully*/
cd src/
make
make install 

Código: [Seleccionar]
apt install mdk3 
Y de esta forma, ya tenemos,

¿cual es tu top 5 aplicaciones wireless?

1 - suite aircrack
2 - reaver
3 - bully
4 - ettercap
5 - crunch


Y algunas tambien de : las app de linux, post pegados  como por ejemplo nmap

Código: [Seleccionar]
apt install nmap

wireshark sigo teniendo dudas, pero va  ser que no que son 126Megas xd

Wicd ya venia por defecto en la base de slax, asi que una mas que tenemos, y por ende, no instalamos el NetworkManager, que curiosamente el lanzandor en el desktop y el menu de fluxbox de la nueva live, viene como NM, pero lo que realmente lanza es el Wicd

Reprobare todo de nuevo, quizas, deje una script para generarlo , o quizas, si pesa poco, lo añada todo a un modulo nuevo, ya veremos
« Última modificación: 02-09-2020, 11:10 (Miércoles) por Hwagm »


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #2 en: 02-09-2020, 11:01 (Miércoles) »
porque no Wireshark

Código: [Seleccionar]
apt install wireshark

Código: [Seleccionar]
The following additional packages will be installed:
  libc-ares2 libcap2-bin libdouble-conversion1 liblua5.2-0 libmaxminddb0
  libnl-route-3-200 libpcre16-3 libproxy1v5 libqt5core5a libqt5dbus5
  libqt5gui5 libqt5multimedia5 libqt5network5 libqt5printsupport5
  libqt5widgets5 libsbc1 libsmi2ldbl libspandsp2 libwireshark-data
  libwireshark11 libwiretap8 libwscodecs2 libwsutil9 libxcb-icccm4
  libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0
  libxcb-xinerama0 libxcb-xkb1 libxkbcommon-x11-0 wireshark-common
  wireshark-qt
Suggested packages:
  mmdb-bin qt5-image-formats-plugins qtwayland5 snmp-mibs-downloader
  wireshark-doc
Recommended packages:
  libpam-cap qttranslations5-l10n libqt5svg5 mesa-utils qt5-gtk-platformtheme
  libqt5multimedia5-plugins
The following NEW packages will be installed:
  libc-ares2 libcap2-bin libdouble-conversion1 liblua5.2-0 libmaxminddb0
  libnl-route-3-200 libpcre16-3 libproxy1v5 libqt5core5a libqt5dbus5
  libqt5gui5 libqt5multimedia5 libqt5network5 libqt5printsupport5
  libqt5widgets5 libsbc1 libsmi2ldbl libspandsp2 libwireshark-data
  libwireshark11 libwiretap8 libwscodecs2 libwsutil9 libxcb-icccm4
  libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0
  libxcb-xinerama0 libxcb-xkb1 libxkbcommon-x11-0 wireshark wireshark-common
  wireshark-qt
0 upgraded, 34 newly installed, 0 to remove and 70 not upgraded.
Need to get 29.7 MB of archives.
After this operation, 126 MB of additional disk space will be used.
Do you want to continue? [Y/n]
« Última modificación: 02-09-2020, 11:09 (Miércoles) por Hwagm »


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #3 en: 02-09-2020, 11:07 (Miércoles) »
Seguimos añadiendo paquetes de la Zona GNU / LInux


Código: [Seleccionar]
apt install macchanger nmap

« Última modificación: 02-09-2020, 11:10 (Miércoles) por Hwagm »


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #4 en: 02-09-2020, 11:13 (Miércoles) »
La verdad es un lio tantas versiones de reaver, que si el normal, que si el Reaver modificado para Pixie Dust, que ademas necesita pixie, un lio total xd

https://foro.seguridadwireless.net/zona-linux/reaver-wps/

Reaver modificado para Pixie Dust

Dependencias basados en debian

Código: [Seleccionar]
apt install -y  build-essential libpcap-dev aircrack-ng pixiewps git
Código: [Seleccionar]
git clone https://github.com/t6x/reaver-wps-fork-t6x
Código: [Seleccionar]
cd reaver-wps-fork-t6x*/
cd src/
./configure
make
make install

Para realizar ataques pixie es necesario instalar pixiewps.


Código: [Seleccionar]
apt install -y  build-essential libpcap-dev aircrack-ng pixiewps git
Si bien aircrack-ng ya esta en la base y git tambien, las build-essential no, pero como ya estamos en desarrollo y ya hemos instalado cosas. pues nos vale con

Código: [Seleccionar]
apt install -y  libpcap-dev  pixiewps
Tampoco pasa nada por repetir, ya te informa...

Código: [Seleccionar]
aircrack-ng is already the newest version (1:1.2-0~rc4-2).
build-essential is already the newest version (12.3).
git is already the newest version (1:2.11.0-3+deb9u7).
libpcap-dev is already the newest version (1.8.1-3).

segun donde esteis, pues os avisara o no de lo tenemos.
« Última modificación: 02-09-2020, 11:28 (Miércoles) por Hwagm »


Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15155
Re:Paquetes importantes a instalar (apt install)
« Respuesta #5 en: 02-09-2020, 12:07 (Miércoles) »
no se que base usas , pero los repos son del paleolitico xd

aircrack/ng 1.2-0~rc4

van por la 1.6

y lo de wireshark , ves lo que pasa ?
pues eso no es nada  ;D

3 apps tontas y se te van 250 megas ...como el fern-wifi-cracker  que necesita qt5 y pyqt5 ...ademas de las dependencias de esos..

se te olvida rfkill , ese ocupa poco , crda para configurar canales ..
« Última modificación: 02-09-2020, 12:11 (Miércoles) por USUARIONUEVO »

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #6 en: 02-09-2020, 12:48 (Miércoles) »
no se que base usas , pero los repos son del paleolitico xd

aircrack/ng 1.2-0~rc4

van por la 1.6

jajaaj si lo acabo de ver cd

y lo de wireshark , ves lo que pasa ?
pues eso no es nada  ;D

o por ejemplo tshark 76 megas, o por ejemplo hashcat 240 megas



3 apps tontas y se te van 250 megas ...como el fern-wifi-cracker  que necesita qt5 y pyqt5 ...ademas de las dependencias de esos..

pues pasando xd, quien lo quiera usar que lo bahe e instalar pyhton3

se te olvida rfkill , ese ocupa poco , crda para configurar canales ..

oido cocina


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #7 en: 02-09-2020, 12:49 (Miércoles) »
rfkill, ya lo tenia

Código: [Seleccionar]
root@wifiway:~/airgeddon# apt install rfkill
Reading package lists... Done
Building dependency tree       
Reading state information... Done
rfkill is already the newest version (0.5-1+b1).
0 upgraded, 0 newly installed, 0 to remove and 68 not upgraded.


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #8 en: 02-09-2020, 13:02 (Miércoles) »
Código: [Seleccionar]
apt install  lynis

para instalar wpscan

se necesita para compilar 18 megas xd

gem  bundler    rake

mas  6megas del ruby-dev

pero si o si quiero el wpscan


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #9 en: 02-09-2020, 13:05 (Miércoles) »
Código: [Seleccionar]
apt install build-essential autoconf automake libtool pkg-config libnl-3-dev libssl-dev libpcre3-dev
Código: [Seleccionar]
git clone https://github.com/aircrack-ng/aircrack-ng
cd aircrack-ng
autoreconf -i
./configure --with-experimental
make
make install
ldconfig
« Última modificación: 02-09-2020, 13:09 (Miércoles) por Hwagm »


Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #10 en: 02-09-2020, 13:07 (Miércoles) »
me faltaban

Código: [Seleccionar]
autoconf automake autotools-dev libnl-3-dev libpcre16-3 libpcre3-dev
  libpcre32-3 libpcrecpp0v5 libsigsegv2 libtool m4 pkg-config

jajaj 4 megas mas xd

Código: [Seleccionar]
sudo apt-get install libnl-genl-3-dev
« Última modificación: 02-09-2020, 13:19 (Miércoles) por Hwagm »


Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15155
Re:Paquetes importantes a instalar (apt install)
« Respuesta #11 en: 02-09-2020, 13:35 (Miércoles) »
he visto hay arriba airgeddon , ese te pide hashcat php , hostapd ...  ;D ;D ;D

Desconectado Hwagm

  • Administrador
  • *
  • Mensajes: 18112
    • GNU/Linux Wifislax
Re:Paquetes importantes a instalar (apt install)
« Respuesta #12 en: 02-09-2020, 14:30 (Miércoles) »
Jajaj si un motón. Tanto que he apagado el equipo para reempezar de cero xd nuevamente el último módulo swireless.sb

Por eso estaba en esa ruta esta instalando todo lo que podía jajajaj más los que me dijiste de rfkill

Pero ya el módulo sb estaba en 200 megas. Así que erase full all xd
« Última modificación: 02-09-2020, 14:36 (Miércoles) por Hwagm »