Autor Tema: Actualizadores de Wifislax 2.0 Final que no van bien.  (Leído 4461 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Garcad

  • Visitante
Actualizadores de Wifislax 2.0 Final que no van bien.
« en: 08-02-2019, 08:38 (Viernes) »
Wifislax 2.0 Final

        ******************************
           Actualizador/Instalador   
           Paquete: shellcheck
                                   
           www.seguridadwireless.net 
        ******************************

Version Script: 22/11/2018

La version del sistema es...NO INSTALADA

__________________________________________

La version mas nueva en su pagina web es...shellcheck-0.6.0

Pulsa ENTER si deseas actualizarla


Comprobando dependencias ...

Dependencia ghc NO INSTALADA ...resolviendo.

No se puedo resolver la dependencia ghc.




Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #1 en: 08-02-2019, 08:39 (Viernes) »
kodi 18 leila error no encuentra un parche.

Configurando ...
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naur xbmc-17.1-Krypton.orig/xbmc/filesystem/SMBDirectory.cpp xbmc-17.1-Krypton/xbmc/filesystem/SMBDirectory.cpp
|--- xbmc-17.1-Krypton.orig/xbmc/filesystem/SMBDirectory.cpp    2017-03-20 16:17:49.000000000 +0000
|+++ xbmc-17.1-Krypton/xbmc/filesystem/SMBDirectory.cpp 2017-03-20 23:01:52.444160749 +0000
--------------------------
File to patch:
« Última modificación: 08-02-2019, 09:43 (Viernes) por Garcad »

Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #2 en: 08-02-2019, 08:46 (Viernes) »
        ******************************
           Actualizador/Instalador   
           Paquete: muse
                                   
           www.seguridadwireless.net 
        ******************************

Version Script: 22/11/2018

La version del sistema es...NO INSTALADA

__________________________________________

La version mas nueva en su pagina web es...muse-2.2.1

Pulsa ENTER si deseas actualizarla


Comprobando dependencias ...

Dependencia libffado INSTALADA.
Dependencia celt INSTALADA.
Dependencia jack-audio-connection-kit INSTALADA.
Dependencia ladspa_sdk INSTALADA.
Dependencia liblo NO INSTALADA ...resolviendo.
Dependencia liblo RESUELTA.
Dependencia lash INSTALADA.
Dependencia dssi NO INSTALADA ...resolviendo.

No se puedo resolver la dependencia dssi.

Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #3 en: 08-02-2019, 09:27 (Viernes) »
make[1]: se sale del directorio '/tmp/build/HandBrake/HandBrake-1.2.0/build/gtk'
../gtk/module.rules:31: fallo en las instrucciones para el objetivo 'gtk.build'
make: *** [gtk.build] Error 2

Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #4 en: 08-02-2019, 09:55 (Viernes) »
Modulos Wifislax 2.0 Final.

https://cloud.mail.ru/public/LmJE/8syRvdTUp

winetricks-20181203-x86_64-1wifislax
wine-4.0-x86_64-1wifislax
bleachbit-2.0-x86_64-1_SBo
ttf-mscorefonts-0.1-x86_64-1wifislax
wine-mono-4.7.5-x86_64-1wifislax
wine-gecko-2.47-x86_64-1wifislax
cabextract-1.9-x86_64-1slackbuilds
kodi-18.0-x86_64-1wifislax
flashplayer-plugin-32.0.0.114-x86_64-1wifislax
k3b-2.0.3-x86_64-1wifislax
armitage-150813-noarch-1wifislax
facebook_hack_tool-3.0-x86_64-1wifislax
selenium-3.14.0-x86_64-1slackbuilds
decorator-4.3.2-x86_64-1slackbuilds
networkx-2.0-x86_64-1slackbuilds
simplejson-3.16.1-x86_64-1slackbuilds
lives-2.10.2-x86_64-1wifislax
mechanize-0.2.5-x86_64-1slackbuilds
metasploit-5.0.5-x86_64-1wifislax
matplotlib-2.2.3-x86_64-2slackbuilds
bulk_extractor-1.6.0_215ed3f-x86_64-1wifislax
kiwisolver-1.0.1-x86_64-1slackbuilds
WebSploit-Framework-3.0.0-noarch-1wifislax
web-sorrow-1.5.0-x86_64-1wifislax
perl-lwp-useragent-cached-0.06-x86_64-1slackbuilds
pentbox-1.5-x86_64-1wifislax
subprocess32-3.5.2-x86_64-2slackbuilds
openoffice-4.1.6-x86_64-1wifislax
functools-lru-cache-1.5-x86_64-1slackbuilds
cycler-0.10.0-x86_64-2slackbuilds
python-dateutil-2.7.5-x86_64-1slackbuilds
burpsuite-1.7.36-noarch-1wifislax
muse-2.2.1-x86_64-1wifislax
firefox-65.0-x86_64-1wifislax
libunicap-0.9.12-x86_64-2slackbuilds
audacity-2.3.0-x86_64-1wifislax
dssi-1.1.1-x86_64-1_SBo
slpkg-3.4.2-x86_64-1slackbuilds
qtractor-0.7.1-x86_64-1wifislax
rubberband-1.8.2-x86_64-1slackbuilds
liblo-0.29-x86_64-1slackbuilds
aubio-0.4.7-x86_64-1slackbuilds
avidemux-2.7.1-x86_64-1wifislax
pybluez-0.22-x86_64-1slackbuilds
python-gattlib-0.20150805-x86_64-2slackbuilds
libnfs-3.0.0-x86_64-1slackbuilds
crossguid-20160705-x86_64-1slackbuilds
libmicrohttpd-0.9.55-x86_64-1slackbuilds
edb-debugger-1.0.0-x86_64-1wifislax
xampp-7.3.1-x86_64-1wifislax
libbdplus-0.1.2-x86_64-1slackbuilds
yajl-2.1.0-x86_64-2slackbuilds
tinyxml-2.6.2-x86_64-2slackbuilds
dcadec-0.2.0-x86_64-1slackbuilds
kde-games-4.14.38-x86_64-1wifislax
python3-PyYAML-3.11-x86_64-1slackbuilds
aften-0.0.8-x86_64-1slackbuilds
libcec-4.0.3-x86_64-1slackbuilds
capstone-3.0.5-x86_64-1slackbuilds
platform-2.1.0-x86_64-1slackbuilds
four-in-a-row-3.28.0-x86_64-1wifislax
lockdev-1.0.3-x86_64-1slackbuilds
steam-1.0.0.59-x86_64-1wifislax
libtxc_dxtn-1.0.1-x86_64-1slackbuilds
libreoffice-6.2.0-x86_64-1wifislax
teamviewer-14.1.9025-x86_64-1wifislax
libreoffice-langpack-6.2.0-x86_64-1wifislax
avahi-0.6.32-x86_64-1slackbuilds
libreoffice-helppack-6.2.0-x86_64-1wifislax
frostwire-6.7.7-noarch-1wifislax
libdaemon-0.14-x86_64-1slackbuilds
rtl88XXau-5.2.20_c29acc0-x86_64-1wifislax
google-chrome-72.0.3626.96-x86_64-1wifislax
telegram-1.5.8-x86_64-1slackbuilds
KeeWeb-1.7.6.linux.x64
hosty
python2-pythondialog-3.4.0-x86_64-1_SBo
« Última modificación: 08-02-2019, 12:46 (Viernes) por Garcad »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #5 en: 08-02-2019, 22:15 (Viernes) »
que una dependencia no se resuelva , no quiere decir que el updater falle.

las dependencias son 99% de slackbuilds, asi que lo que falla seguramente es el slackbuild.

para obtener un error o una idea de lo que pasa es tan sencillo como intentar instalarlo con slapt-src -i DEPENDENCIA QUE FALLA.

En el caso de ghc, solo hace falta leer , para imaginarselo , ...  si con mi equipo con 16 gigas de ram y un core i7 6700k  , se pega casi una hora, no quiero imaginarme , en un equipo mas modesto o en vmware o similar, donde algunos indican mas de 1 dia , para compilar ghc.   ;D

Código: [Seleccionar]
You will need 4.3G of free space in /tmp/SBo to build this package.
como lo intentes en modo live , estas jodido  ;D

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #6 en: 08-02-2019, 22:18 (Viernes) »
« Última modificación: 08-02-2019, 22:18 (Viernes) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #7 en: 08-02-2019, 22:24 (Viernes) »
voy a probar handbrake y kodi a ver.


mm , handbrake , ahora no usa gtk2 , usa gtk3 , pero requiere gtk3-3.20 , al tener la 3.18 , no compila.
Hay que fijar la version de handbrake a la 1.1.2

subo el updater.
« Última modificación: 09-02-2019, 01:19 (Sábado) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #8 en: 09-02-2019, 03:49 (Sábado) »
bueno , pues kodi , he tenido que fijar la version a la que esta usando todo el mundo 17.6  , incluso archlinux que son los mas kamikaze estan aun en la 17.6 , asi que toca esperar.

Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #9 en: 09-02-2019, 11:07 (Sábado) »
bueno , pues kodi , he tenido que fijar la version a la que esta usando todo el mundo 17.6  , incluso archlinux que son los mas kamikaze estan aun en la 17.6 , asi que toca esperar.

Gracias, ya lo tengo todo instalado.

Para crear una live, de mi sistema me podrías aconsejar como hacerlo.

Salu2

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #10 en: 09-02-2019, 20:06 (Sábado) »
bueno , pues kodi , he tenido que fijar la version a la que esta usando todo el mundo 17.6  , incluso archlinux que son los mas kamikaze estan aun en la 17.6 , asi que toca esperar.

Gracias, ya lo tengo todo instalado.

Para crear una live, de mi sistema me podrías aconsejar como hacerlo.

Salu2

eso no funciona asi , deberias ir empaquetando todo en xzm , los xzm , se pueden juntar por categorias como hago yo en los de SBo o slackware , para tenerlos en orden.

la idea de crear live de un sistema que esta en el hdd es erronea.

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #11 en: 09-02-2019, 20:12 (Sábado) »
por cierto , esto es una de las cosas que te comente una vez ...

anoche (como casi todos los viernes y si no en sabado) , se hizo un push , en slackbuilds , el cual incluye actualizaciones y reparaciones etc , puede que alguno de tus compilados ya este obsoleto , cada semana hay que revisarlos.  ;)

sbopkg , sync , updates , y cuando tengas la lista , yo suelo pasar a usar slapt-src , por que maneja bien el tema de las dependencias si te falttan.

Por ejemplo algo que interesa , es el driver nvidia que han hecho un push a la rama 418.x

https://git.slackbuilds.org/slackbuilds/commit/?h=14.2

Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #12 en: 09-02-2019, 23:20 (Sábado) »
Mi idea es crear una aplicación para los que quieran tener ciertos módulos en un live usb, y puedan elegir cual poner o cual quitar.

Salu2

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #13 en: 09-02-2019, 23:50 (Sábado) »
Mi idea es crear una aplicación para los que quieran tener ciertos módulos en un live usb, y puedan elegir cual poner o cual quitar.

Salu2

en serio no sabes descomprimir el xzm de turno , y actuar sobre el , y despues click derecho crear xzm otra vez?

removepkg
upgradepkg
installpkg

sabes que es la forma de hacerlo no ?

si vas a actualizar un paquete de slackbuilds que esta en multimedia ...

vas al xzm SBo ,  multimedia , descomprimes , ROOT=descomprimido upgradepkg paquetenuevo

si lo he explicado chorrocientos de veces por el foro ...
« Última modificación: 09-02-2019, 23:50 (Sábado) por USUARIONUEVO »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #14 en: 09-02-2019, 23:53 (Sábado) »
Cada vez que salen cosas de estas , me acuerdo de esos "pobres" , angelitos, que por privado me dicen muchas veces ... SOLO JUNTAS 4 PROGRAMAS Y YA ESTA , ... claro que si guapis , por eso todo el mundo junta 4 programas y hace lives  ;D ;D ;D ;D ;D ;D

la ignorancia es la felicidad ,jajaja



Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #16 en: 10-02-2019, 00:04 (Domingo) »
para comprobar dependencias rotas

Código: [Seleccionar]
slackyd -d

Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #17 en: 10-02-2019, 00:09 (Domingo) »
para comprobar dependencias rotas

Código: [Seleccionar]
slackyd -d

Ya lo se, recuerdo haberlo dicho hace ya unos años ese comando.

Para la mayoría de usuarios es difícil o casi imposible saber como manejarse en linux, por eso creare una aplicación para linux, donde descargara y/o activara los módulos que quiera el usuarios usar.

Salu2

Garcad

  • Visitante
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #18 en: 10-02-2019, 00:11 (Domingo) »
Y con montar una unidad en ext4 para que usarla como changes es suficiente para poder crear cualquier paquete desde la versión live.

ln -s .....
« Última modificación: 10-02-2019, 00:11 (Domingo) por Garcad »

Conectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14708
Re:Actualizadores de Wifislax 2.0 Final que no van bien.
« Respuesta #19 en: 10-02-2019, 00:23 (Domingo) »
linux es muy grande, no es wifislax, ni slackware  , linux es un mundo de distros , diferentes entre ellas, con sus peculiaridades y diferencias , gestores de paquetes distintos, formas de proceder distintas.

por ejemplo en el 99% de distros , los paquetes te los dan ya compilados , de forma que todo el mundo tiene el mismo ,  otras distros prefieren dar un kit basico , con lo mas esencial , y lo amplies a tu gusto , como puede ser slackware , y otras como archlinux que permiten mas flexibilidad.

a lo que voy es que , lo que pretendes, puede que te funcione en wifislax , pero slackware no trabaja igual por ejemplo , ademas lo que tu quieres ya existe y se llama  flatpak , es una especie de gestor "global" , que instala paquetes ya con sus librerias y demas empaquetas en uno.

Hacen un "all-in-one"   , lo empaquetan y luego al usar ese programa el ya sabe que sus librerias estan bajo su misma carpeta.

por ejemplo , /opt/programa

lo que ejecute alli dentro de esa carpeta usara sus librerias desde /opt/programa, e ignorara las del sistema , asegurando asi la funcionalidad.

como no entiendo muy bien que quieres hacer , pues no te puedo decir mas.
« Última modificación: 10-02-2019, 00:24 (Domingo) por USUARIONUEVO »

//FINAL Y MÁS DOS RESPUESTAS