Autor Tema: [POC] UEFI en Wifislax  (Leído 36857 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: [POC] UEFI en Wifislax
« Respuesta #80 en: 21-05-2016, 20:39 (Sábado) »
ningun soft de virtualizacion crea maquinas UEFI por defecto y solo pude probar con vmware workstation player (la version free)

VMware te pregunta que tipo quieres durante la creacion de la máquina virtual, las opciones son BIOS o EFI.



Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #81 en: 21-05-2016, 20:45 (Sábado) »
el bootloader que has puesto funciona bien si intentas hacer booteable una iso desde una de 64 pero desde la 4.11.1 no va,me sale el fallo que he puesto,para hacer booteable desde la 4.11.1 tengo que poner los ejecutables que pusiste ayer en el zip y ejecutar el bootinst.sh que tambien pusiste en el zip.

ya , espera ..que te subo otro test..desde una de 32 me salia tambien un mensaje aunque distinto ...creo que ahora si..


Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #82 en: 21-05-2016, 20:47 (Sábado) »
Para

sol666

http://www.mediafire.com/download/a9fooi916y4u6v9/1-Linux_Wifislax_Boot_Installer.com


@drvalium

igual lo ofrecio en el instalador y no lo vi ...si a posteriori decides cambiar algo , hay un soft para ello ya que algunas opciones no se pueden cambiar desde el gui ..como el tema de la bios.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #83 en: 21-05-2016, 20:48 (Sábado) »
me veo bajando la 4.11.1 ..jajaja por que vaya poltergeist macho ..


por favor, sol666  si puedes probarlo en un momento ...  ;)

asumo que el de windows ya va bien , ya que solo le faltaba el syslinux exe en la carpeta de syslinux del boot.
« Última modificación: 21-05-2016, 20:50 (Sábado) por USUARIONUEVO »

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #84 en: 21-05-2016, 20:52 (Sábado) »
bajala y pruebala 4.11.1,que seguro mas adelante empezara la gente a quejarse de que no puede hacer sus pendrives booteable desde la 4.11.1 y tendran que usar win7.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #85 en: 21-05-2016, 20:55 (Sábado) »
bajala y pruebala 4.11.1,que seguro mas adelante empezara la gente a quejarse de que no puede hacer sus pendrives booteable desde la 4.11.1 y tendran que usar win7.

men , pero si es que la 4.12 esta ya hay hay ..y desde esa me va perfecto ...

el tema es que tu pincho tiene algo distinto ...por que nunca he visto ninguno de los errores que a ti te salen, yo solo he visto uno ..y era distinto al tuyo ..ahora con este ultimo test del fichero ya me va perfcecto en todas...

solo tienes que bajar el fichero que puse (400 kas) ponerlo en la carpeta boot del pincho y ejecutarlo a ver ...


« Última modificación: 21-05-2016, 20:55 (Sábado) por USUARIONUEVO »

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #86 en: 21-05-2016, 21:06 (Sábado) »
es un .bin como lo ejecuto?

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #87 en: 21-05-2016, 21:18 (Sábado) »
es un .bin como lo ejecuto?

es un .com

como siempre..deberia poder ejecutarse con dos clicks...

puede que el navegador le haya cambiado la extension al bajarlo...chrome es muy fan de esas cosas.


abre terminal en la carpeta boot del pincho..


sh ...instalador

pd: acabo de bajarlo y se ha bajado bien..extension  .com   la extension es solo para engañar..sigue siendo un script.
« Última modificación: 21-05-2016, 21:20 (Sábado) por USUARIONUEVO »

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #88 en: 21-05-2016, 21:38 (Sábado) »
con cambiarle la extension a .com sobra,sera por el croome,pero ahora si que me va desde la 4.11.1,no se que has hecho pero has acertado,si tambien funciona desde la de 64 perfecto.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #89 en: 21-05-2016, 21:45 (Sábado) »
con cambiarle la extension a .com sobra,sera por el croome,pero ahora si que me va desde la 4.11.1,no se que has hecho pero has acertado,si tambien funciona desde la de 64 perfecto.

si , de hecho hasta habia montado un pincho con la 4.11.1

asi que "todos contentos ahora" ... ;D


la proxima ya llevara este nuevo  ;)

vk496

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #90 en: 27-05-2016, 19:45 (Viernes) »
Disculpad que no pueda echar una mano ahora mismo, pero estoy de examenes hasta Julio.

Cuando esté libre, voy a echar ojo y seguir por donde me he quedado.

Tengo material para hacer pruebas (antiguo netbook con cargador UEFI x32 y uno con pleno soporte UEFI x64)

Salu2

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #91 en: 27-05-2016, 19:56 (Viernes) »
Disculpad que no pueda echar una mano ahora mismo, pero estoy de examenes hasta Julio.

Cuando esté libre, voy a echar ojo y seguir por donde me he quedado.

Tengo material para hacer pruebas (antiguo netbook con cargador UEFI x32 y uno con pleno soporte UEFI x64)

Salu2

Ya tenemos UEFI , falta adaptar la instalación al hdd, que no se ni por donde empezar.

vk496

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #92 en: 27-05-2016, 20:48 (Viernes) »
Disculpad que no pueda echar una mano ahora mismo, pero estoy de examenes hasta Julio.

Cuando esté libre, voy a echar ojo y seguir por donde me he quedado.

Tengo material para hacer pruebas (antiguo netbook con cargador UEFI x32 y uno con pleno soporte UEFI x64)

Salu2

Ya tenemos UEFI , falta adaptar la instalación al hdd, que no se ni por donde empezar.

Lo mejor de todo sería estudiar el comportamiento de otras distros que tienen instalador UEFI. Otras que no sean Ubuntu, porque esos tienen sus claves firmadas al ser una empresa.

Y el instalador tendrá que buscar la existencia de la partición UEFI o, en su defecto, crear una.

El proceso se simplifica si creamos un cargador firmado por nuestras propias claves. Si queremos la maxima compatibilidad con equipos "especiales" (como tablets que no pueden desactivar el Secure Boot), el proceso se complica, porque hace falta tirar de cargadores de terceros (como el de este POC, Shim)

Salu2

Desconectado drvalium

  • Moderador Global
  • *
  • Mensajes: 17410
  • Misántropo
Re: [POC] UEFI en Wifislax
« Respuesta #93 en: 27-05-2016, 21:42 (Viernes) »
hi

yo he conseguido arrancar dos sistemas con UEFI modificando las opciones del "Secure Boot" en la UEFI de mi portátil, la única pega es que cada vez que arranco me pide un password de cuatro cifras.

En concreto arranco un Windows 10 y un MacOS El Capitán.



saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14471
Re: [POC] UEFI en Wifislax
« Respuesta #94 en: 27-05-2016, 22:12 (Viernes) »
lo del secure boot ya me lo temia, alguien ya reporto , que tenia que desactivarlo.

por lo que leo , los equipos MAC , ya pueden arrancar wifislax sin historias ?


drvalium , lo del password es algo que lleva asi tu equipo , ...imagino al desactivar secure boot,  activa esa otra medida de prevencion.
« Última modificación: 27-05-2016, 22:13 (Viernes) por USUARIONUEVO »

teik

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #95 en: 27-05-2016, 23:05 (Viernes) »
Yo con secure boot desactivado en dos tablets con windows 10 me arrana a la perfeccion, en mac no puedo probar, porque no tengo  ^-^