Autor Tema: [POC] UEFI en Wifislax  (Leído 36866 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #40 en: 18-05-2016, 08:30 (Miércoles) »
no me extraña que acabaras hasta el gorro de uefi ...  lo estoy mirando y llevo 3 días para poca cosa   :-\

no estoy usando nada del poc ... y solo para x64  :(



teik

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #41 en: 18-05-2016, 14:38 (Miércoles) »
Este poc solo sirve para la de 32bits, la de 64 lleva un archivo cambiado rn el arranque que tiene un 2 menos, norecuerdo exactamente como se llamaba y con cambiarlo arranca,prro el problema esta en el reconocimiento de la pantalla.  A mi me arranca pero no reconoce la pantalla ni el tactil, por lo que se queda volteado y es muy incomodo. Normalmente las tablet suelen llevar procesadores intel cherry de esos que son los mas baratos, y hasta el momento se ha conseguido portar en sistemas de linux como ubuntu, pero no se si en slackware han compilado algo para estos procesadores, que es por lo que da ese fallo.
Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #42 en: 18-05-2016, 15:15 (Miércoles) »
me arranca desde usb y maquina virtual..desde cd , parece que esta todo ok, pero se me queda casi siempre en la carga de kde ...(ya me pasaba en la de 32bits)


de todas formas desde cd es un HORROR ... va lentisimo.

para probar efi , he usado 2 pcs y en maquina virtual vmware player , aunque hay que usar una gui no se como se llama "tweak "  ... para activar efi , en la maquina virtual.


todo me funciona..a excepcion de cuando la grabo en cd... que arranca todo , pero no llega  escritorio ,por lo que no es cosa del loader.,.

teik

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #43 en: 18-05-2016, 19:38 (Miércoles) »
si necesitas que haga alguna prueba solo que me lo digas y lo pruebo que yo tengo dos tablets con uefi de 64 bits disponibles.
Saludos

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #44 en: 18-05-2016, 19:40 (Miércoles) »
se esta subiendo la iso ...

hasta las 22:00 no empecéis a bajarla ...
http://www.downloadwireless.net/isos-fase-testing/wifislax64-current/wifislax64-18052016-UEFI.iso

md5 --> 25d5c542d7ef7a426a559f903efea79b
« Última modificación: 18-05-2016, 19:44 (Miércoles) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #45 en: 18-05-2016, 22:27 (Miércoles) »
solo cuando logramos arrancar en modo UEFI/EFI ..el kernel puede generar ficheros en la ruta

/sys/firmware/efi


asi que ..dicen que una imagen vale mas que mil palabras...





aun queda pendiente la instalacion al hdd , pero al menos desde pendrive , se puede arrancar ya, o en maquina virtual,aunque no tiene sentido ya que esta tarde haciendo pruebas, ningun soft de virtualizacion crea maquinas UEFI por defecto y solo pude probar con vmware workstation player (la version free)

teik

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #46 en: 19-05-2016, 10:04 (Jueves) »
Lo acabo de dejar descargando, a la tarde pruebo y te comento como ha ido.  ;)

Por cierto si no recuerdo mal, Hyper-V que se puede activar en windows 10 y windows 8, te da la opción de hacer maquinas virtuales con UEFI. Yo era lo que utilizaba en sus inicios para ir probando, pero no es compatible con otro sistema de virtualizacion, por lo que debes de desinstalar el resto.
Saludos

MODIFICACIÓN
Acabo de meterlo buah; ni que decir del menu que has puesto de inicio, para mi es mejor que el de la de 32 bits. Queda muy elegante y de lujo. Vamos que tienes mi voto para ponerlo así de serie jejeje.
Respecto al arranque ha entrado de momento y me ha reconocido la pantalla y ha girado perfecto. jejej Un diez grande! Con lo que llevaba intentando conseguir que corriera y no había forma.
Muchas gracias por hacer que funcione y por el tiempo que has utilizado, que pocos tenemos UEFI, pero es una alegria que esto sea posible.
No quiero desviar el tema, solo es hacer dos preguntas: ¿como se podría hacer para que funcionar el tactil? y segundo que es menos importante, ¿aun no hay soporte en el kernel para las RTL7823BS?

Saludos y muy contento de que esto funcione jejej. Ya me tienes aqui pegado a cada nueva actualizacion jajaja
« Última modificación: 19-05-2016, 15:28 (Jueves) por teik »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #47 en: 19-05-2016, 16:03 (Jueves) »
Bueno , recuerda que no se puede instalar a hdd ..aunque en  una Tablet queda descartado.  ;) (si se puede instalar como hasta ahora en equipos sin uefi)

Lo del táctil .... supongo será algún driver del kernel .. , igual que el del chip wifi.


pon modelo exacto de Tablet ...a ver que puedo encontrar.
« Última modificación: 19-05-2016, 16:04 (Jueves) por USUARIONUEVO »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #48 en: 19-05-2016, 16:07 (Jueves) »
ok , la versión de desarrollo de 64bits pasa a ser esta ya con el uefi ... ahora a investigar para el hdd.


teik

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #49 en: 19-05-2016, 17:07 (Jueves) »
ok , la versión de desarrollo de 64bits pasa a ser esta ya con el uefi ... ahora a investigar para el hdd.



De lujo jejej.
Pues tengo una chuwi Hi10. y una Teclast x98 Pro. La que he probado por ahora es la chuwi Hi 10, que la otra la tengo abierta para unas modificaciones que le estoy haciendo.
Hay un parche para deb, pero no se si se puede en modo monitor y demas.
https://sourceforge.net/projects/xjubuntu/files/16.04%2064%20bits%20XJUbunTAB%20-%20patched%20kernel/Akmelius%20Atom%20kernel/64%20bits%204.5.1%20with%20Realtek8723bs%20patches/

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #50 en: 19-05-2016, 19:22 (Jueves) »
hola,al intentar hacer booteable la ultima iso me sale esto.

Flushing filesystem buffers, this may take a while...
Setting up MBR on /dev/sdc...
/run/media/root/W6418052016/boot/bootinst.sh: línea 65: /tmp/2541/lilo: cannot execute binary file: Formato de ejecutable incorrecto

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #51 en: 19-05-2016, 19:32 (Jueves) »
hola,al intentar hacer booteable la ultima iso me sale esto.

Flushing filesystem buffers, this may take a while...
Setting up MBR on /dev/sdc...
/run/media/root/W6418052016/boot/bootinst.sh: línea 65: /tmp/2541/lilo: cannot execute binary file: Formato de ejecutable incorrecto

¿Cuál de todas?

la de x64 o cual ?¿

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #52 en: 19-05-2016, 19:33 (Jueves) »
hola,al intentar hacer booteable la ultima iso me sale esto.

Flushing filesystem buffers, this may take a while...
Setting up MBR on /dev/sdc...
/run/media/root/W6418052016/boot/bootinst.sh: línea 65: /tmp/2541/lilo: cannot execute binary file: Formato de ejecutable incorrecto



¿Cuál de todas?

la de x64 o cual ?¿


a ver..si estas en la de 32 bits , no puedes ejecutarlo por que la otra es de 64

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #53 en: 19-05-2016, 20:49 (Jueves) »
la ultima de 64,intento hacer el pen booteable desde la 4.11.1 como con todas.
« Última modificación: 19-05-2016, 20:57 (Jueves) por sol666 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #54 en: 19-05-2016, 22:03 (Jueves) »
la ultima de 64,intento hacer el pen booteable desde la 4.11.1 como con todas.

osea que antes se podia... ya que el de 32 podria ejecutar los binarios sui fuesen de 32 , y todos contentos.

ok , lo miro

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #55 en: 19-05-2016, 22:12 (Jueves) »
miralo,yo no hay manera,desde windows 7 64 tampoco va el instalador (wifislaxbootinstaller) y he probado una cosa,arrancar desde live con la del dia 12 e intentar hacer booteable la del 18 y nanay.
¿y digo yo,como la habeis probado vosotros,desde cd/dvd?
« Última modificación: 19-05-2016, 22:18 (Jueves) por sol666 »

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #56 en: 19-05-2016, 22:19 (Jueves) »
miralo,yo no hay manera,desde windows 7 64 tampoco va el instalador (wifislaxbootinstaller) y he probado una cosa,arrancar desde live con la del dia 12 e intentar hacer booteable la del 18 y nanay.
¿y digo yo,como la habeis probado vosotros,desde cd/dvd?

a mi la de 64 me funciona y el bootloader tambien.

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #57 en: 19-05-2016, 23:18 (Jueves) »
pues a mi no,y he probado con 2 pendrives,desde la 4.11.1 me sale el error antes mencionado al intentar hacer booteable la del 18.

Desconectado USUARIONUEVO

  • Moderador
  • *
  • Mensajes: 14477
Re: [POC] UEFI en Wifislax
« Respuesta #58 en: 19-05-2016, 23:36 (Jueves) »

sol666

  • Visitante
Re: [POC] UEFI en Wifislax
« Respuesta #59 en: 19-05-2016, 23:57 (Jueves) »
                            _.====.._
                           ,:._       ~-_
                               '\        ~-_
                                 \        \.
                               ,/           ~-_
                      -..__..-''   PORTEUS   ~~--..__

==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--==--

Installing Porteus to /dev/sdc1
WARNING: Make sure this is the right partition before proceeding.

Type 'ok' to continue or press Ctrl+c to exit.
ok
Flushing filesystem buffers...

Installation failed with error code '2'.
Please ask for help on the Porteus forum: www.porteus.org/forum
and provide the information from /run/media/root/W6418052016/boot/debug.txt

Exiting now...
cat: /run/media/root/W6418052016/boot/syslinux/lilo.menu: No existe el fichero o el directorio