?>/script>'; } ?> Problema con drivers ipw2200 Widgets Magazine

Autor Tema: Problema con drivers ipw2200  (Leído 4078 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Viper_Scull

  • Visitante
Problema con drivers ipw2200
« en: 12-11-2007, 15:21 (Lunes) »
Buenas. Estoy intentando instalar los drivers de la ipw2200 y parchearla para poder inyectar.
A saber: ieee80211 (1.2.17) + ipw2200 (1.2.1) + patch (para la 1.2.1)

El problema es que cuando intento compilar los ieee80211, me da este error de compilacion:

 En la función ‘ieee80211_classify’:
linea 232- error: ‘struct sk_buff’ no tiene un miembro llamado ‘nh’

Queria saber si coon la nueva version que hay en el proyecto de sourceforge de la ipw2200 que es la 1.2.18 me valdria, ya que el parche creo que solo se realiza sobre el driver en si de la ipw2200.
Comentar que probe con wifislax 3.1 LiveCd, pero solo me deja arrancar si tengo puesto nohotplug, asi que luego no me reconoce las interfaces de red, y ando jodidillo de espacio, asi que quiero probar en Ubuntu y cuando ya compre un HDD externo probare la instalacion completa. Por cierto, que version lleva WifiSlax 3.1 de ieee80211 y del driver????

gracias. Saludos!!

Edito: He intalado la version ieee80211 1.2.18 sin problemas (lei por ai que se arreglaba el fallo del struct sk_buff que me daba problemas). Pero cuando voy a compilar el driver ipw2200 version 1.2.1 me da otro fallo con la structura sk_buff (no encuentra el campo mac).

Estoy sobre Ubuntu 7.10 y empiezo a pensar que sobre el kernel 2.6.22-14 no funcionan estas versiones. He instalado la 1.2.2 y funciona bien, existe el parche para inyectar para la version del driver 1.2.2 de ipw2200???

Si no, tendre que esperar a tener el HDD para poder trastear instalando el  wifislax.

Edito 2ª parte: Bueno perdonan q sea tan brasas pero esto lo mismo ayuda a mas gente en mi caso.
Para el ultimo kernel no vale el codigo que viene aqui por lo ya comentado.

Pero he encontrado los parches para la version 1.2.2. Si se pueden colgar enlances a otros sitios me lo decis y los pongo. Estaria bien que modificarais eso diciendo que para el ultimo kernel no vale y se incluyeran codigo para nuevo driver y nuevo parche.

Bueno el caso que una vez parcheado e instalado hago:
rmmod ipw2200
modprobe ipw2200 rtap_iface=1

 y me crea la interfaz (rtap0) que supuestamente se usara para la inyeccion de trafico. Pero si hago iwconfig, en rtap0 me dice : no wireless extensions.
Voy a seguir probando a ver y sigo contando.

« Última modificación: 12-11-2007, 16:59 (Lunes) por Viper_Scull »