Autor Tema: No puedo poner modo monitor en Ubuntu 7.10!  (Leído 5445 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Hijack

  • Visitante
No puedo poner modo monitor en Ubuntu 7.10!
« en: 03-11-2007, 11:48 (Sábado) »
Hola, pues eso no puedo poner mi tarjeta D-Link g122 con chipset rt73usb en modo monitor y desconozco el porque puesto que en ubuntu 7.04 si podia sin problemas!! En el monitor de red tampoco aparece la "Fuerza de la señal"!!

Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Device or resource busy.

Ya he probado cargado varios modulos pero parece que el suyo es el rt73usb.
Otra cosa que veo rara es que me aparece una admiracion naranja en el monitor de red si no esta asociada a ninguna red este o no conectada a ella... cuando antes siempre estaba sin admiracion, y al conectarse la barra se volvia verde y no como ahora que estoy conectado y la barra esta naranja y al minimo...

Espero que alguien pueda decirme que puede ser porque la he tenido mucho tiempo y veo raro lo que me hace aparte ya del modo monitor.

Un saludo.



berni69

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #1 en: 03-11-2007, 11:52 (Sábado) »
vuelve a compilar los drivers que tenias antes ;), prueba los de la pagina principal www.seguridadwireless.net

pianista

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #2 en: 03-11-2007, 11:56 (Sábado) »
Antes de cargar tu driver, haz...
rmmod rt73usb
rmmod rt2x00lib
rmmod rt2570
rmmod rt2x00usb
Vamos rmmod a todo lo que te salga en: lsmod|grep rt
Saludos

Hijack

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #3 en: 03-11-2007, 11:58 (Sábado) »
Se me olvido comentar que me aparece una interfaz rara...

root@Hijack:~# ifconfig wmaster0
wmaster0  Link encap:UNSPEC  HWaddr 00-XX-XX-XX-XX-XX-E0-E3-00-00-00-00-00-00-00-00 
          UP DIFUSIÓN CORRIENDO MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          colisiones:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0 tiene como HWaddress la mac de mi tarjeta pero con un formato parecido al de modo monitor si no me equivoco, puede que tenga algo que ver???


Hijack

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #4 en: 03-11-2007, 12:24 (Sábado) »
Pianista probe lo que me dijiste y nada... todo igual.

Un saludo.

Hijack

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #5 en: 07-11-2007, 19:04 (Miércoles) »
Alguna idea?  ???

chinotauro

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #6 en: 02-12-2007, 00:47 (Domingo) »
wenas, me está pasando exactamente lo mismo, he probado ya con muchos drivers y pasa igual... he probado ya: rt2570-cvs-20051112, rt2570-k2wrlz-1.6.1 rt2570-k2wrlz-1.3.0,...

$ uname -a
Linux kk 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux


Al compilar la versión 1.3 me da error:

~/wifi/rt2570-k2wrlz-1.3.0/Module$ sudo make
make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-generic'
  CC [M]  /home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module/rtusb_main.o
/home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module/rtusb_main.c: In function ‘usb_rtusb_probe’:
/home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module/rtusb_main.c:1829: error: ‘dev_base’ undeclared (first use in this function)
/home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module/rtusb_main.c:1829: error: (Each undeclared identifier is reported only once
/home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module/rtusb_main.c:1829: error: for each function it appears in.)
/home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module/rtusb_main.c:1829: error: ‘struct net_device’ has no member named ‘next’
make[2]: *** [/home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module/rtusb_main.o] Error 1
make[1]: *** [_module_/home/oracle/wifi/rt2570-k2wrlz-1.3.0/Module] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-generic'
rt2570.ko failed to build!
make: *** [module] Error 1


La versión 1.6 compila bien:

~/wifi/rt2570-k2wrlz-1.6.1/Module$ sudo make
make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-generic'
  Building modules, stage 2.
  MODPOST 1 modules
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-generic'
~/wifi/rt2570-k2wrlz-1.6.1/Module$


~/wifi/rt2570-k2wrlz-1.6.1/Module$ sudo make install
2.6 module install
make -C /lib/modules/2.6.22-14-generic/build SUBDIRS=/home/oracle/wifi/rt2570-k2wrlz-1.6.1/Module  modules_install
make[1]: Entering directory `/usr/src/linux-headers-2.6.22-14-generic'
  INSTALL /home/oracle/wifi/rt2570-k2wrlz-1.6.1/Module/rt2570.ko
  DEPMOD  2.6.22-14-generic
make[1]: Leaving directory `/usr/src/linux-headers-2.6.22-14-generic'
/sbin/depmod -a
~/wifi/rt2570-k2wrlz-1.6.1/Module$

~/wifi/rt2570-k2wrlz-1.6.1/Module$ sudo modprobe rt2570
~/wifi/rt2570-k2wrlz-1.6.1/Module$


$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


$ sudo iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Device or resource


 
« Última modificación: 02-12-2007, 01:10 (Domingo) por chinotauro »

chinotauro

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #7 en: 02-12-2007, 01:27 (Domingo) »
También he instalado los drivers de Serialmonkey y nada...


~/wifi/rt2570-cvs-2007120117/Module$ modinfo rt2570
filename:       /lib/modules/2.6.22-14-generic/extra/rt2570.ko
license:        GPL
author:         http://rt2x00.serialmonkey.com
description:    Ralink RT2570 usb 802.11g WLAN driver 1.0.0 - CVS 2007120117
srcversion:     0EF25C810BFE19498652A85
alias:          usb:v5A57p0260d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0EB0p9020d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v114Bp0110d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0707pEE13d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0681p3C06d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v148Fp9020d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v148Fp2573d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v148Fp2570d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v148Fp1706d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DB0p6869d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DB0p6865d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DB0p6861d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0411p0097d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0411p008Bd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0411p0067d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0411p0066d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v06F8pE000d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1044p8007d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1044p8001d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v2001p3C00d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v14B2p3C02d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13B1p001Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13B1p0011d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13B1p000Dd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp705Ad*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp7051d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp7050d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0B05p1707d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0B05p1706d*dc*dsc*dp*ic*isc*ip*
depends:        usbcore
vermagic:       2.6.22-14-generic SMP mod_unload 586
parm:           debug:Debug mask: n selects filter, 0 for none (int)
parm:           ifname:Network device name (default rausb%d) (charp)


El problema puede venir por aquí?


~/wifi/rt2570-cvs-2007120117/Module$ sudo airmon-ng


Interface       Chipset         Driver

wlan0           Unknown         Unknown (MONITOR MODE NOT SUPPORTED)




« Última modificación: 02-12-2007, 01:34 (Domingo) por chinotauro »

chinotauro

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #8 en: 02-12-2007, 01:42 (Domingo) »
A ver sigo investigando y esto es lo que me pasa...

~/wifi/rt2570-cvs-2007120117/Module$ lsmod | grep rt2570
rt2570                190016  0
usbcore               138632  5 rt73usb,rt2570,rt2x00usb,uhci_hcd

~/wifi/rt2570-cvs-2007120117/Module$ sudo rmmod rt73usb
~/wifi/rt2570-cvs-2007120117/Module$

~/wifi/rt2570-cvs-2007120117/Module$ lsmod | grep rt2570
rt2570                190016  0
usbcore               138632  4 rt2570,rt2x00usb,uhci_hcd

Instalo los drivers...

Hago:

~/wifi/rt2570-cvs-2007120117/Module$ sudo modprobe rt2570
~/wifi/rt2570-cvs-2007120117/Module$

Meto la tarjeta USB y...
~/wifi/rt2570-cvs-2007120117/Module$ lsmod | grep rt2570
rt2570                190016  0
usbcore               138632  5 rt73usb,rt2570,rt2x00usb,uhci_hcd

Vuelto a ver otra vez el "rt73usb" que borré antes! creo que está cogiendo automáticamente mi USB como la rt73 y mi tarjeta es la D-Link DWL-G122 con chipset rt2570, no entiendo nada...  :'(


Una ayudita por favor :D


pd. Acabo de meter la rt73usb en la blacklist y ahora cuando enchufo el USB no me lo detecta.
« Última modificación: 02-12-2007, 01:47 (Domingo) por chinotauro »

chinotauro

  • Visitante
Re: No puedo poner modo monitor en Ubuntu 7.10!
« Respuesta #9 en: 02-12-2007, 02:23 (Domingo) »
Solucionado! al instalar los drivers de la rt73... este post http://foro.elhacker.net/index.php/topic,188836.msg900229/topicseen.html,
 me lió con instalar la rt2570...   :o