Autor Tema: Ettercap no escanea con procesador de 64 bits  (Leído 6890 veces)

0 Usuarios y 1 Visitante están viendo este tema.

luisR2

  • Visitante
Ettercap no escanea con procesador de 64 bits
« en: 28-10-2012, 13:11 (Domingo) »
Hola a toda la comunidad, este es mi primer post en este foro por lo que disculpen si esta no es la seccion adecuada.

He estado utilizando ettercap en una com****dora portatil de 32 bits sin ningun problema, tenia instalado en una particion wifiway 3.4 y en otra particion backtrack 5 ambos funcionaban correctamente, tanto desde live cd como desde hd.

He adquirido un portatil con procesador de 64 bits y he instalado lo mismo en ambas particiones wifiway , backtrak.
Wifiway funciona correctamente la tarjeta se pone en modo monitor y puedo comprobar la seguridad de mi red.
Pero ettercap no consigo que escanee como en 32 bit nada mas que termina el escaneo se cierra.
He provado desde desde live cd versiones para 32 bit y tampoco.
He usado una antena alfa usb como wlan1 y tampoco.
He leido que es debido a incompatibilidad con procesadores de 64 bits, ya que desde el 2006 ettercap dejo de dar soporte a esta aplicacion por lo que se diseño para 32 bits.
He probado a Instalar ettercap al 100% siguiendo un tutorial, pero sin exito.

Existe alguna forma de hacelo correr en 64 bits ? No me gustaria tener que cambiar el pc, ya que es un regalo.

Agradeceria de su ayuda y gracias por su tiempo.




Desconectado drvalium

  • Colaborador
  • *
  • Mensajes: 17378
  • Misántropo
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #1 en: 28-10-2012, 21:41 (Domingo) »
hi

por lo general las aplicaciones 32 bit funcionan en sistemas 64, curioso que esta no lo haga.

prueba con Wireshark, esa si funciona en sistemas 64 bit.


un saludo

Conectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15794
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #2 en: 29-10-2012, 16:51 (Lunes) »
ettercap tiene un bug relacionado con las librerias gtk.

nuestras distros incluso wifislax 4.2 lleva un ettercap con ese problema , ...se cierra al escanear hosts en red.


la solucion pasa por actualizar ettercap a

0.7.4.2

aunque creo que salio la 0.7.5 , pero no fui capaz de compilarla.


Conectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15794
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #3 en: 29-10-2012, 16:55 (Lunes) »
es mas te dire que en casa , todos mis equipos son x64  ^-^


mira este hilo.

https://foro.seguridadwireless.net/live-wifislax/ettercap-se-cierra-al-buscar-un-host/

luisR2

  • Visitante
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #4 en: 30-10-2012, 22:25 (Martes) »
Gracias amigos por ayudarme, esperare que aparezca wifislax 4.3, entretanto intentare actualizar ettercap.

Si soluciono el tema comentare.

Conectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15794
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #5 en: 30-10-2012, 22:46 (Martes) »
Gracias amigos por ayudarme, esperare que aparezca wifislax 4.3, entretanto intentare actualizar ettercap.

Si soluciono el tema comentare.

si se te cierra justo en el momento de lanzar la busqueda de hosts en la red , es cosa del bug.

si se te cierra en algun otro momento , ya no se que decirte.

luisR2

  • Visitante
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #6 en: 02-11-2012, 06:29 (Viernes) »
Disculpa mi tardanza en responder pero tengo poco tiempo, Como dices exacto.  Cierra justo en el momento de lanzar la busqueda de hosts en la red , sera cosa del bug.
Este fin de semana intentare actualizarlo a ettercap 0.7.4.2 haber si lo consigo.

Gracias

luisR2

  • Visitante
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #7 en: 11-11-2012, 20:30 (Domingo) »
Hola de nuevo a todos con un poco de tiempo intentare retomar el tema. consegui hacer funcionar ettercap desde ubuntu 11. pero me gustaria tenerlo funcional desde Backtrak y este es el error que me entrega justo al seleccionar la interfaz y al iniciar el escaneo cerrandose:

root@bt:~# sudo ettercap -G

ettercap 0.7.4.1 copyright 2001-2011 ALoR & NaGA


(<unknown>:2016): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.24.1/gobject/gsignal.c:3079: signal name `depressed' is invalid for instance `0x1ef4340'

(<unknown>:2016): Gtk-WARNING **: Invalid text buffer iterator: either the iterator is uninitialized, or the characters/pixbufs/widgets in the buffer have been modified since the iterator was created.
You must use marks, character numbers, or line numbers to preserve a position across buffer modifications.
You can apply tags and insert marks without invalidating your iterators,
but any mutation that affects 'indexable' buffer contents (contents that can be referred to by character offset)
will invalidate all outstanding iterators
Ooops ! This shouldn't happen...
Segmentation Fault...

Please recompile in debug mode, reproduce the bug and send a bugreport

root@bt:~#

Agradeceria me indicaran que camino seguir para solucionar ( Please recompile in debug mode )

Gracias por su tiempo.


Conectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 15794
Re: Ettercap no escanea con procesador de 64 bits
« Respuesta #8 en: 11-11-2012, 21:47 (Domingo) »
ya te respondi , ...no puedes arreglarlo, solo instalar uno que este fuera de ese bug.


ettercap 0.7.4.1



.y te dije al menos ....0.7.4.2


no puedes arreglarlo , solo tienes 2 opciones ...buscar un paquete mas actualizado , o bien compilartelo e instalartelo tu mismo.


es el bug con referncia a gtk , ..ya te lo dice al inicio.