Autor Tema: ayuda!, problema con grub2 al iniciar windows  (Leído 2721 veces)

0 Usuarios y 1 Visitante están viendo este tema.

alucard joseph

  • Visitante
ayuda!, problema con grub2 al iniciar windows
« en: 18-05-2015, 18:54 (Lunes) »
Hola que tal, gente de la comunidad, tengo un pequeño problema, les platico, despues de haber instalado mi distro de wifislax, la cual se instalo correctamente, incluyendo el Grub2, despues de eso ya saben, es logico reiniciar el ordenador, para poder acceder a la nueva instalacion, y bueno lo raro fue que si pude entrar a la instalacion de linux, pero al querer arrancar la instalacion de Window me aparecio lo siguiente:

https://drive.google.com/file/d/0B5eAT8_zZOV6WWxOaEdoOHNMckpwa2NOcllqWVdMWTBEVzZF/view?usp=sharing

https://drive.google.com/file/d/0B5eAT8_zZOV6UDJMYl82RGxQeTZTb0hDRVpNemxQMktrTGFR/view?pli=1

ya intente solucionarlo con ms-sys pero no puedo hacer que inicie windows, en otro foro me dijeron que hiciera un update-grub pero lo que ocurrio es que ahora no me detecta la particion con windows, ni en el grub, ni como unidad de almacenamiento posterior a eso hice un fdisk -l y esto fue lo que me arrojo:

Código: [Seleccionar]
wifislax ~ # fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, 625142448 sectores en total
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificador del disco: 0xc1b96fcb

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1   *        2048   432185343   216091648    7  HPFS/NTFS/exFAT
/dev/sda2       432187329   516071423    41942047+   f  W95 Ext'd (LBA)
/dev/sda3       516071424   620926975    52427776    7  HPFS/NTFS/exFAT
/dev/sda4       620929024   625123327     2097152    c  W95 FAT32 (LBA)
/dev/sda5       432187392   453156863    10484736   83  Linux
/dev/sda6       453158912   455254015     1047552   82  Linux swap
/dev/sda7       474130432   516071423    20970496    7  HPFS/NTFS/exFAT

no se si me puedan hechar una mano para solucionarlo, se los agradeceria mucho.



Desconectado sanson

  • Colaborador
  • *
  • Mensajes: 8405
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #1 en: 18-05-2015, 20:09 (Lunes) »
Hola

En el menú herramientas de wifislax (lo puedes hacer en modo live, si quieres) tienes un script que se llama recuperar arranque de windows o restaurar MBR .  usalo y con eso restablecerás el arranque de windows y perderás el de wifislax .   

Una vez tengas windows corriendo , vuelve a formatear la partición de linux e instala de nuevo. 

Aseguraré de instalar el grub en sda .

Saludos

alucard joseph

  • Visitante
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #2 en: 18-05-2015, 22:23 (Lunes) »
Saludos Sanson, ya lo he intentado con ms-sys, que es la opcion que me sugieres, yo lo he escrito asi:

Código: [Seleccionar]
ms-sys -n -f /dev/sda1
ms-sys -7 -f /dev/sda1

no se si este mal escrito, pero no me ha dado resultado. por cierto gracias por responder!

Desconectado sanson

  • Colaborador
  • *
  • Mensajes: 8405
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #3 en: 18-05-2015, 22:32 (Lunes) »
Hola

Veo dos errores

Deberías poner sda , sin numero .

Y además esa orden es para w7 la verdad es que para 95 no se cual es .

Te paso un tema donde se trata este asunto , leelo entero por que al principio parece liosos .

https://foro.seguridadwireless.net/live-wifislax/consejos-instalacion-wifislax-4-4-en-disco-duro/


Saludos

5.1

  • Visitante
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #4 en: 18-05-2015, 22:43 (Lunes) »
Antes del update-grub es lo suyo un os-prober ...
Código: [Seleccionar]
os-prober
update-grub

Reinicia ....en teoria eso hara que el grub detecte de nuevo windows

alucard joseph

  • Visitante
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #5 en: 18-05-2015, 23:02 (Lunes) »
hermano gracias por responder, me estas ayudando bastante, si le di una leida al tema del foro, e hice lo que me sugeriste con ayuda del tema y con ayuda de ms-sys --help, llegue a la conclucion de que la orden correcta es:

Código: [Seleccionar]
ms-sys -7 /dev/sda
lo que ocurrio bueno antes tenia W7, y esta vez lo que ocurrio es que me arroja esta screen

https://drive.google.com/file/d/0B5eAT8_zZOV6Rkt0OVd0WEZyU240dnFZYVZVZHlWNDNuN1Rj/view?usp=sharing

y tuve que entrar desde el live, esta vez no me muestra ningun dispositivo de almacenamiento viendo en dolphin, si tecleo fdisk -l me arroja esto:

Código: [Seleccionar]
wifislax ~ # fdisk -l 
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, 625142448 sectores en total
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificador del disco: 0x6e697373 

Esto no parece una tabla de particiones
Probablemente ha seleccionado el dispositivo que no era.
Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sda1   ?  1936269394  3772285809   918008208   4f  QNX4.x tercera parte
/dev/sda2   ?  1917848077  2462285169   272218546+  73  Desconocido
/dev/sda3   ?  1818575915  2362751050   272087568   2b  Desconocido
/dev/sda4   ?  2844524554  2844579527       27487   61  SpeedStor 

Las entradas de la tabla de particiones no están en el orden del disco 

Disco /dev/sdb: 8001 MB, 8001847296 bytes
255 heads, 63 sectors/track, 972 cylinders, 15628608 sectores en total
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificador del disco: 0x00000000 

Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
/dev/sdb1   *        2048    15628287     7813120    b  W95 FAT32

no se pero pienso que despues de eso debere meter un USB boot de win7 verdad o que me sugieres Sanson

Desconectado sanson

  • Colaborador
  • *
  • Mensajes: 8405
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #6 en: 18-05-2015, 23:08 (Lunes) »
Hola

Windows 7 , me pareció leer en el log que tenias w95 ya decía yo que era demasiado viejo.

Pues parece que la cosa va de mal en peor. Si no puedes recuperar el cargador de windows mucho me temo que tengas que reinstalar . 

Es que no se que has hecho y si restaurando el MBR no carga solo se me ocurre que prueves a recuperar el sistema con el cd de instalación de win.


Saludos

alucard joseph

  • Visitante
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #7 en: 18-05-2015, 23:24 (Lunes) »
jejeje  :( ,bueno lo bueno que todo lo tenia respaldado en una particion extra, si perdiera las particiones eso si me daria en la mare.! pero una pregunta, no puedo dar solucion con el comando:

Código: [Seleccionar]
TestDisk
sino, no importa de alguna u otra forma recupero mis datos XD

gracias por su ayuda en verdad

alucard joseph

  • Visitante
Re: ayuda!, problema con grub2 al iniciar windows
« Respuesta #8 en: 27-05-2015, 03:04 (Miércoles) »
hola amigos, gracias por su ayuda, al final solo use el testdisk y le repare el mbr con un disco y listo XD