?>/script>'; } ?> Amago de inyeccion con Ipw3945 Widgets Magazine

Autor Tema: Amago de inyeccion con Ipw3945  (Leído 2138 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Nukem33

  • Visitante
Amago de inyeccion con Ipw3945
« en: 05-02-2009, 14:20 (Jueves) »
Buenas.

Llevo algun tiempo peleandome con dicha tarjeta. Para poder auditar mi ap con ella hago lo siguiente.

rmmod iwl3945
modprobe ipwraw
airmon-ng start wifi0 11

hasta aqui todo de lujo... aparece interface wifi0 centrino abg mode monitor enabled

Entonces lanzo airodump-ng (siguiendo lo que dice la web de aircrack con este adaptador... usar rtap0 para monitorizar y wifi0 para inyectar)

airodump-ng -w pack --ivs --bssid el:mi:ox:xx:xx:xx -c11 rtap0

Perfecto, airodump monitorizando el ap. El pwr muestra lo que quiere... el rxq a 100... y de vez en cuando sube algun data... Nada en especial por ahora.

Abro una nueva shell e intento asociarme.

aireplay-ng -1 30 -a xx:xx:xx:xx:xx:xx -h xx:xx:xx:xx:xx:xx wifi0

Association succesful ;)

No por mucho tiempo... esto sale una y no mas santo tomas... Y ya lo puedes dejar rato que ni caso... Aun asi... lanzo en otra shell...

aireplay-ng -3 -b xx:xx:xx:xx:xx:xx -h xx:xx:xx:xx:xx:xx wifi0

y a esperar...

Nada de nada... En cambio con la zydas 1211rw, mi ap auditado en menos de 2 min... Siguiendo los mismos pasos, excepto el cambio de driver para inyectar.

Reinicio el sistema y pruebo lo siguiente...

Cargo el ipwraw, y lanzo aireplay-ng -9 wifi0

Injection is working... 3% de acierto con mi ap... Si vuelvo a lanzar el mismo comando... 0% en el ap hasta que reinicie el sistema y/o cargue de nuevo el ipwraw.

Con la zydas... Injection is working... una media de 80% en mi ap. Casi 300 paquetes por segundo desde aireplay -3.

Las pruebas que he realizado han sido en backtrack 3, dado que no tengo en casa las lives wifiway y wifislax.

A la hora de instalar drivers, he probado los que Hwagm publico en el apartado Nueva generacion wireless y nada. Tambien los que publican en la web de Aircrack y lo mismo. Con la zydas no he tenido que hacer nada. Lanzo comandos directamente y todo va bien.

Empiezo a pensar, que debe ser una nueva revision de dicho chipset y por eso no funciona correctamente. El portatil que tiene la ipw tiene solo unos meses... En concreto es un HP Compaq 6710b.

La semana que viene, realizare las mismas pruebas con wifislax y con el ultimo wifiway y os comento los resultados en caso de que no se le ocurra nada a nadie.

Gracias por la atencion y perdon por el toston de post.

Saludos.


manel

  • Visitante
Re: Amago de inyeccion con Ipw3945
« Respuesta #1 en: 05-02-2009, 15:12 (Jueves) »
Buenas

Has probado bajando el rate?

#iwconfig [iface] rate 1M

Un saludo


Nukem33

  • Visitante
Re: Amago de inyeccion con Ipw3945
« Respuesta #2 en: 05-02-2009, 15:56 (Jueves) »
buenas

si, eso tambien lo he probado... el caso es que con la zydas no necesito hacerlo...

tambien he probado a ponerme en otra parte de mi casa en vez de estar en la misma sala que el router y nada...

sigo pensando que es la revision del chipset... a todo esto... el controlador en win vista pone que es ipw3945 ABG... y linux tambien lo reconoce como 3945abg... hay alguna forma de saber, si por casualidad el chipset trabaja tambien en N y sea ese el motivo de que no funcione la cosa bien? creo recordar que el estandar N todavia no esta soportado para auditorias... corrijanme si me equivoco...

Gracias de nuevo.

Saludos.


Nukem33

  • Visitante
Re: Amago de inyeccion con Ipw3945
« Respuesta #3 en: 10-02-2009, 10:56 (Martes) »
pensaba que podria ser, que el portatil era demasiado nuevo...

he probado en otro mas antiguo, un asus y mas de lo mismo...

espero probar pronto wifislax/wifiway, porque ninguno de los portatiles que he probado son mios... me los han prestado para tal fin y asi saber como utilizar dicha tarjeta.

Saludos.


Nukem33

  • Visitante
Re: Amago de inyeccion con Ipw3945
« Respuesta #4 en: 26-02-2009, 13:38 (Jueves) »
Buenas, despues de tanto tiempo, he probado con el ultimo wifiway 1.0 final.

Para ahorrarme problemas extras, he cargado el modulo de ipwraw con el lanzador del menu y despues he lanzado airoway... El cual he supuesto que usaria los comandos mejor que yo.

Y nada, mas de lo mismo... No consigo asociarme. He forzado un arp valido conectandome a mi router con la DS y el aireplay empieza a enviar paquetes, pero no captura arps ni suben los data en airodump...

No entiendo porque no funciona este adaptador... Segun lei, esta distro era especifica para la 3945.

En cuanto pueda, lo probare en el asus...

Recuerdo que en wifislax, cuando intentaba asociarme, me salian mensajes del tipo, cambiando paquetes por segundo 200, 180, 160... y asi sucesivamente.

A alguien le ha pasado esto?

Saludos y gracias por la atencion.