Autor Tema: comportamiento extraño de navegadores con portal  (Leído 587 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado dynyly

  • ****
  • Mensajes: 72
comportamiento extraño de navegadores con portal
« en: 14-01-2020, 03:44 (Martes) »
como dice el titulo
esto pasa con los windows pero pasa con todos los navegadores

bueno he jugado con linset hay la prueba y probado con wifislax como victima da alguna opcion hasta que sale la odiada

## #Ahora son necesarias dos interfaces se verfica cuantas hay para continuar si no detiene script y sale
## #Modificadas lineas en la detectecion de interfaces
## #Cambio de modo monitor utilizando iw
## #Vuelve a verificar Hanskake con Aircrack-ng
## #Añadida Verificacion de PMKID
## #Eliminado motor redirecionamiento dns escrito en python
## #Añadido Dnsmasq para redireccion Dns + Dhcpd
## #Añadida creacion de cert autogenerado
## #Reglas en lighttpd para redirect 302
## #Reglas en lighttpd para cert autogenerado
## #Eliminada autoactulizacion del script al estar conectado a internet
## #Opcion de tiempo en verificacion de cambio de canal
## #Cambiadas reglas de iptables
## #Modificada configuracion en Hostpad
-----------------------------------
No todas las interfaces son compatibles con hostapd pero hay un pequeño truco que puede funcionar
por alguna extraña razon hostapd se lleva bien con wlan0 debes renombrar y probar renombrando una como wlan0
hay pequeño script que requiere pequeña modificacion por parte del usuario para renombrar y devolverlas al estado anterior

###################
muestra de fallo con interfaces despues de su uso varias veces

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 10.0.0.1  netmask 255.255.255.0  broadcast 10.0.0.255  <<<### no deberia estar asi
        ether c0:9f:e1:XX:XX:XX  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 10.0.0.1  netmask 255.255.255.0  broadcast 10.0.0.255     <<<### no deberia estar asi
        inet6 fe80::c29f:XXXX:XXXXX:XXXX  prefixlen 64  scopeid 0x20<link>
        ether c0:9f:e1:XX:XX:XX  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 3280 (3.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
       
------
comandos para dejar interfaces bien :
airmon-ng start wlanX
airmon-ng stop wlanXmon
ifconfig wlanX up

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:1b:77:XX:XX:XX  txqueuelen 1000  (Ethernet)     
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 08:86:3b:XX:XX:XX  txqueuelen 1000  (Ethernet)     
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
       
#########
para quitar puertos del ssl en caso de no quererlo falla en android
en pruebas sobre windows 100% hack
en pruebas sobre wifislax da alguna opcion hasta que lo pilla y sale la pantalla odiada de advertencia 
descomentar lineas 1687 ,1688 y 1689 añadiendo delante #
#########
https://mega.nz/#!TNBTFCwL!7mpDqfCLWVSQHciWqxke639HUVyaju8Ini65_oyAcDU





« Última modificación: 19-01-2020, 23:09 (Domingo) por dynyly »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 14555
Re:comportamiento extraño de navegadores con portal
« Respuesta #1 en: 14-01-2020, 23:14 (Martes) »
Hola , solo comentar que certbot, puedes tenerlo mas facil ... en realidad es el paquete letsencrypt

Código: [Seleccionar]
slapt-src -i letsencrypt
Lo complicado ,es que tiene unas cuantas dependencias en python ... pero comentarlo por si te interesaba.

No pesan mucho , voy a meter en desarrollo  ,  nginx , y letsencrypt. ;)

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 14555
Re:comportamiento extraño de navegadores con portal
« Respuesta #2 en: 14-01-2020, 23:17 (Martes) »
node.js , ...es este ?¿?¿

https://slackbuilds.org/repository/14.2/development/nodejs/

y el otro mitmproxy ... necesitas una version concreta =¿?? .... lo pregunto por que con pip install , puedes tenerlo , el problema es que actualiza otros paquetes de python y rompe cosas por el camino y tendria que mirar que version se puede instalar ..sin romper nada.

Desconectado dynyly

  • ****
  • Mensajes: 72
Re:comportamiento extraño de navegadores con portal
« Respuesta #3 en: 15-01-2020, 00:36 (Miércoles) »
salu2
gracias usuario
es que ya ni recuerdo bien antes ya tenia wifislax letsencript anterior version
se agradeciria modulo de mitmproxy   o  node.js
si tienes razon añade python 3  y jode cosas por el camino me ha pasado anteriormente con otras descargas de aplicaciones o scripts
te actualiza python y ahy cosas que dejan de funcionar por eso deberia ser xzm para cuando quiera volver a estado original solo quitar modulos xzm y ya asi es como hago yo cuando me fallan por instalar cosas quito modulo instalado todo vuelve a la normalidad
lo dicho no conocimiento en empaquetado e instalacion
yo cojo el de siempre a ser posible  slakbuilds
descargo ambos pues no siempre es asi
ejemplo con noip de como lo hago yo ;cuando se puede; pues no siempre es asi ¿no?
Código: [Seleccionar]
[tar xvfz noip2.tar.gz                             --- paquete

cp noip2.tar.gz noip-duc-linux.tar.gz noip2/      ----copiar directorio temporal

cd noip2                                          -----situarse en directorio al que se ha copiado

ls

./noip2.SlackBuild                                 ----el que salga de color verde ejecutar instalacion

Una vez terminado el proceso se crea el paquete .tgz en la siguiente ruta: /tmp/

installpkg /tmp/paquete/code]
y despues guardar cambios en xzm pero no tengo ram

da igual version a ser posible actulizada no tengo ram para compilar tengo 3 gb de ram y estoy en live
« Última modificación: 15-01-2020, 00:45 (Miércoles) por dynyly »

Desconectado USUARIONUEVO

  • Colaborador
  • *
  • Mensajes: 14555

Desconectado dynyly

  • ****
  • Mensajes: 72
Re:comportamiento extraño de navegadores con portal
« Respuesta #5 en: 19-01-2020, 02:16 (Domingo) »
gracias me servira
actualizado post principal ....he jugado un poco con linset y bien ...
es que evadir el hsts sin conexion es jodido

« Última modificación: 19-01-2020, 02:57 (Domingo) por dynyly »

//FINAL Y MÁS DOS RESPUESTAS