Autor Tema: problemas con alfa 1w  (Leído 2815 veces)

0 Usuarios y 1 Visitante están viendo este tema.

chewwakka

  • Visitante
problemas con alfa 1w
« en: 31-01-2010, 16:04 (Domingo) »
hola.
recientemente adquiri una alfa 1w pensando que me iba a dar bastante mas alcance que la ipw 5100 que tengo integrada.

parece ser que no es asi, o que no se como sacarle partido al watio que tiene la criatura.
de momento no consigo que me cace mas redes o las mismas pero con mas señal que con la 5100.

he leido buscando donde puede residir el problema y loq ue he econtrado esq se le puede modificar la potencia mediante " iwconfig wlanx txpower xx", pero no noto cambio ninguno al cambniar el txpower. lo cambio asi: sudo iwconfig wlan1 txpower 30 , por ejemplo, cambiando el 30 por otros valores mas altos y mas bajos para intentar notar diferencias, pero ya digo que no noto nada. este comando no me da ninguna salida. solo me devuelve el prompt
segui leyendo sobre el tema y parece ser que hay que "activarlo" o algo asi (lie en ingles y no lo contrlo demasiado) con iwpriv, pero la salida a iwpriv, con el modulo rtl8187 es :

Código: [Seleccionar]
bt ~ $ sudo iwpriv
lo        no private ioctls.

eth0      no private ioctls.

wmaster0  no private ioctls.

wlan0     no private ioctls.

wmaster1  no private ioctls.

wlan1     no private ioctls

por loq ue entiendo que con este modulo cargado no puedo hacer funcionar. este es el modinfo de rtl8187:

Código: [Seleccionar]
filename:       /lib/modules/2.6.29.4/kernel/drivers/net/wireless/rtl818x/rtl8187.ko
license:        GPL
description:    RTL8187/RTL8187B USB wireless driver
author:         Larry Finger <Larry.Finger@lwfinger.net>
author:         Hin-Tak Leung <htl10@users.sourceforge.net>
author:         Herton Ronaldo Krzesinski <herton@mandriva.com.br>
author:         Andrea Merello <andreamrl@tiscali.it>
author:         Michael Wu <flamingice@sourmilk.net>
alias:          usb:v1B75p8187d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v18E8p6232d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v13D1pABE6d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v1371p9401d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v114Bp0150d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p0028d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0DF6p000Dd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v03F0pCA02d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0846p4260d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0846p6A00d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0846p6100d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0789p010Cd*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0769p11F2d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8198d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8197d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8189d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8187d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v050Dp705Ed*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0B05p171Dd*dc*dsc*dp*ic*isc*ip*
depends:        mac80211,eeprom_93cx6,cfg80211
vermagic:       2.6.29.4 SMP mod_unload 686

en cambio, si cambio el modulo rtl8187 por el r8187, las salidas son estas:
Código: [Seleccionar]
bt ~ $ iwpriv
lo        no private ioctls.

eth0      no private ioctls.

wmaster0  no private ioctls.

wlan0     no private ioctls.

wlan1     Available private ioctls :
          fasttx           (8BE0) : set   1 int   & get   0
          highpower        (8BE1) : set   1 int   & get   0
          badcrc           (8BE2) : set   1 int   & get   0
          activescan       (8BE3) : set   1 int   & get   0

bt ~ $ modinfo r8187
filename:       /lib/modules/2.6.29.4/kernel/drivers/net/wireless/rtl8187/r8187.ko
description:    Linux driver for Realtek RTL8187 WiFi cards
author:         Andrea Merello <andreamrl@tiscali.it>
version:        V 1.1
license:        GPL
srcversion:     B47853FE060936B2124EEB3
alias:          usb:v0846p6A00d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0846p6100d*dc*dsc*dp*ic*isc*ip*
alias:          usb:v0BDAp8187d*dc*dsc*dp*ic*isc*ip*
depends:        ieee80211-rtl
vermagic:       2.6.29.4 SMP mod_unload 686
parm:           ifname:charp
parm:           devname: Net interface name, wlan%d=default
parm:           channels: Channel bitmask for specific locales. NYI (int)
el problema viene cuando lo que quiero es navegar, ya que el modulo r8187 no me permite navegar. solo auditar.
tambien he leido que se puede navegar con el r8187, pero no le he dado mucha importancia ya que he encontrada poca informacion al respecto y no demasiado seria, creo.

todo esto me pasa corriendo un ubuntu 8.10 con kernel 2.6.29.4. he probado con un kernel 2.6.30.5, pero por causas ajenas a mi comprension la grafica (ati) no me va ni con sus driver propietarios, asi que me gustaria solucionar el problema desde este kernel, siesq tiene solucion.

espero haberme expresado con claridad y perdon por la ignorancia, siqesq el problema es sencillo. de veras que he leido lo que he encontrado al respecto.

gracias



jumavi-75

  • Visitante
Re: problemas con alfa 1w
« Respuesta #1 en: 13-02-2010, 19:52 (Sábado) »
prueba esto
iwconfig
sale el tx power a 8
iwpriv wlan0 highpower 1
iwconfig wlan0 txpower 30
y otra vez
iwconfig
veras que el tx power sale a 30