Autor Tema: Problemas de conexión con WDS. ¿Posibles enlaces redundantes?  (Leído 3190 veces)

0 Usuarios y 1 Visitante están viendo este tema.

nastyboy

  • Visitante
Hola

tengo en casa una instalación con dos routers comtrend cd536+, uno hace de router principal y el otro de punto de acceso (AP). Se enlazan por WDS y está configurado de modo que sólo del segundo router (AP) acepta conexiones wifi

Desde hace unas semanas sufro extraños cortes de comunicación de modo que por wifi no hay modo de comunicarse, a pesar de que los equipos cliente dicen que hay acceso a internet, que de hecho lo hay. Haciendo comprobaciones constato que desde el router principal NUNCA se pierde la conexión, ni por cable ni por wifi (esto último cambiándole la configuración para que sí acepte conexiones ). Tampoco es un problema de saturación de canales, pues estoy sólo en mi canal, mientras que en uno de los adjunos no hay nadie y en el otro sólo dos vecinos. Tampoco parece deberse a intrusiones, tengo seguridad por MAC, WEP, baliza oculta, protocolos desconectados y os routers no constatan accesos desconocidos.

Lo que me he dado cuenta es que en la información de Bridging hay algo que no logro interpretar, y por eso os escribo.
He leído algo sobre el spanning tree protocol y los enlaces redundantes en instalaciones con WDS y me pregunto si los cortes que sufro y lo que me indican los routers se deben a que sufro de esos bucles.
Os ruego que leáis las fotos que os adjunto y me déis un diagnóstico

Gracias






En esta segunda foto, los datos de la columna 'state', NO los he borrdo yo, es que no los da el router.




« Última modificación: 09-02-2013, 18:35 (Sábado) por nastyboy »

danitool

  • Visitante
Re: Problemas de conexión con WDS. ¿Posibles enlaces redundantes?
« Respuesta #1 en: 09-02-2013, 01:43 (Sábado) »
Y tanto que está rara la cosa.

Primero solo es un enlace WDS de dos routers?, entonces por qué tantas interfaces de red WDS???.

Segundo, no dices que firmwares estás usando, ni donde has configurado el bridging WDS. Es más por la forma de nombrar las interfaces WDS uno de ellos pareciese que usa un kernel 2.4 mientras que el otro un kernel 2.6... Quizás mejor que ambos usasen el mismo firmware ya que on routers idénticos.

wds0.49154 <--- suelen nombrarse así en los kernel 2.4

Si no te supone ningún problema casi que lo mejor sería actualizar el router con el firmware antiguo, y volver ambos a valores de fábrica para meterle una configuración sana.

nastyboy

  • Visitante
Re: Problemas de conexión con WDS. ¿Posibles enlaces redundantes?
« Respuesta #2 en: 09-02-2013, 18:55 (Sábado) »
Y tanto que está rara la cosa.

Primero solo es un enlace WDS de dos routers?, entonces por qué tantas interfaces de red WDS???.

Segundo, no dices que firmwares estás usando, ni donde has configurado el bridging WDS. Es más por la forma de nombrar las interfaces WDS uno de ellos pareciese que usa un kernel 2.4 mientras que el otro un kernel 2.6... Quizás mejor que ambos usasen el mismo firmware ya que on routers idénticos.

wds0.49154 <--- suelen nombrarse así en los kernel 2.4

Si no te supone ningún problema casi que lo mejor sería actualizar el router con el firmware antiguo, y volver ambos a valores de fábrica para meterle una configuración sana.

Hola, gracias por responder.ç
Sí, WDS sólo entre dos routers. Ambos son Comtrend ct536+
El principal (ADSL) lleva firmware: A101-220TLF-C35
El secundario (AP): A101-300NCM-C02

Esto no ocurría antes, este enlace lleva años funcionando bien y es desde hace poco que sufro cortes. Conexión teoricamente hay, eso dicen los clientes, pero en la práctica no se navega, e incluso es dificil entrar al router principal via wifi. Por cable, todo normal.

Hoy mismo lo he sufrido y por suerte lo he solucionado haciendo un reboot de ambos aparatos.
Te pongo las tablas de bridging de hoy mismo del router principal

FIJATE EL GALIMATIAS QUE SALE, y el valor de prioridad negativo. Eso no es normal y coincide con los problemas.




saludos


danitool

  • Visitante
Re: Problemas de conexión con WDS. ¿Posibles enlaces redundantes?
« Respuesta #3 en: 09-02-2013, 23:32 (Sábado) »
Pues ni idea de que van esas tablas que pones, desconozco ese firmware, no sé como lo configuraste tampoco, el wds debieras configurarlo manual en plan poner al uno la mac del otro en la sección del wireless, ambos mismo canal, mismo encriptado wifi. Es más sencillo que un sonajero.

Este comtrend es como el ct-5361

Seguramente el firmware CT-5361T-A111-306FPT-C01_R02 sirva en estos routers, en su día lo usé funciona bien tanto para al ADSL como para WDS.

Te lo indico por si te planteas actualizar el firmware, y empezar con una configuración sana desde 0. Para lo cual tendrás que saber como tienes configurado tú adsl ya que la configuración suele ser específica para cada ISP.

nastyboy

  • Visitante
Re: Problemas de conexión con WDS. ¿Posibles enlaces redundantes?
« Respuesta #4 en: 10-02-2013, 04:19 (Domingo) »
Pues ni idea de que van esas tablas que pones, desconozco ese firmware, no sé como lo configuraste tampoco, el wds debieras configurarlo manual en plan poner al uno la mac del otro en la sección del wireless, ambos mismo canal, mismo encriptado wifi. Es más sencillo que un sonajero.

Este comtrend es como el ct-5361

Seguramente el firmware CT-5361T-A111-306FPT-C01_R02 sirva en estos routers, en su día lo usé funciona bien tanto para al ADSL como para WDS.

Te lo indico por si te planteas actualizar el firmware, y empezar con una configuración sana desde 0. Para lo cual tendrás que saber como tienes configurado tú adsl ya que la configuración suele ser específica para cada ISP.

ee instalación WDS lleva varios años funcionando bien, ahsta uñtimamente. Tal como tu dices, darle a cada uno la MAC del oro, desactivar dhcp, y alguna cosilla menor más.

cohone

  • Visitante
Re: Problemas de conexión con WDS. ¿Posibles enlaces redundantes?
« Respuesta #5 en: 15-02-2013, 18:14 (Viernes) »
Hola

tengo en casa una instalación con dos routers comtrend cd536+, uno hace de router principal y el otro de punto de acceso (AP). Se enlazan por WDS y está configurado de modo que sólo del segundo router (AP) acepta conexiones wifi

Desde hace unas semanas sufro extraños cortes de comunicación de modo que por wifi no hay modo de comunicarse, a pesar de que los equipos cliente dicen que hay acceso a internet, que de hecho lo hay. Haciendo comprobaciones constato que desde el router principal NUNCA se pierde la conexión, ni por cable ni por wifi (esto último cambiándole la configuración para que sí acepte conexiones ). Tampoco es un problema de saturación de canales, pues estoy sólo en mi canal, mientras que en uno de los adjunos no hay nadie y en el otro sólo dos vecinos. Tampoco parece deberse a intrusiones, tengo seguridad por MAC, WEP, baliza oculta, protocolos desconectados y os routers no constatan accesos desconocidos.

Lo que me he dado cuenta es que en la información de Bridging hay algo que no logro interpretar, y por eso os escribo.
He leído algo sobre el spanning tree protocol y los enlaces redundantes en instalaciones con WDS y me pregunto si los cortes que sufro y lo que me indican los routers se deben a que sufro de esos bucles.
Os ruego que leáis las fotos que os adjunto y me déis un diagnóstico

Gracias






En esta segunda foto, los datos de la columna 'state', NO los he borrdo yo, es que no los da el router.




Yo tampoco se interpretar los pantallazos esos que pones, pero, para tener ese tipo de redundancia debes tener más de una ruta, cosa que con un  wds no tienes,  sería algo así como tener conectado por wds y por cable a la vez. ¿O me equivoco? (la verdad es que en este caso hablo sin saber)

y por otro lado, si tienes wep, ni la mac, ni la essid oculta, ni desactivar dhcp, te asegura que no tengas intrusos. Lo único que te lo puede asegurar más o menos es que el router venga con la opción de mostrarte "estaciones asociadas", y aún así no tendrás total seguridad.

Por si las moscas, deberías comprobar directamente con un sniffer wifi si alguien te está mandando paquetes de desasociación o intentando algún tipo de DoS (hace un tiempo me dijeron que había un programa para móvil que era capaz de echar abajo una red, con los síntomas que estás contando, aunque no le he llegado a ver ^-^)

nastyboy

  • Visitante
Re: Problemas de conexión con WDS. ¿Posibles enlaces redundantes?
« Respuesta #6 en: 16-02-2013, 09:30 (Sábado) »
No tengo constancia de que me entre nadie al router. La opcion de estaciones asociadas, las tablas ARP aparecen sólo con mis máquinas.
Evidentemente NO me conecto simultaneamente por cable y wifi con las misma máquina.

¿podría ser que alguien haya clonado alguna MAC mia, la del router punto de acceso, y establezca una WDS con su propio router?, de ahí las redundancias...


¿Conocéis si existe WDS con WPA/WPA2 on algún firmware para esterouter o con algún otro marca/modelo de router?

Por cierto que llevo un par de días sin sufrir de estos cortes.

saludos


//FINAL Y MÁS DOS RESPUESTAS