Autor Tema: ¿Alguien ha realizado jtag con senao eoc 2610?  (Leído 83255 veces)

0 Usuarios y 1 Visitante están viendo este tema.

SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #20 en: 19-06-2010, 16:35 (Sábado) »
bueno yo espero a que tu pruebes(creo que con la flash soldada al pcb), que me animaria mucho mas para no andar soldando y desoldando

ya te digo 3,35v de un transformador chino 3v  4,5v   6v   9v    12v escogiendo 3 v, pero  la flash trabaja entre 2,7 y 3,6 voltios segun datasheet

el backup 15 minutos mas o menos y pesa 8192kb, pero me ha jodido que no lleva ninguna extension asociada, lo he editado y solo veo legible al principio:

AP51-3660

ya tenemos la flash para manejarla a nuestro antojo, pero con cuidado que ahora creo que  viene lo mas dificil ^-^

ahora mismo estoy intentando buscar un editor para .bin para poder ver el contenido de ar cfe.bin y original.bin

saludos y espero tus resultados ;)




ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #21 en: 19-06-2010, 16:56 (Sábado) »
ok. para editar el archivo puedes usar un editor de hexadeximal o mejor aun en este elnace: http://spiflash.org/ en el menu "SPI Flash EEPROM programmer" en "descargas" ese software es para programar memorias seriales por lpt1 diseñado para la board que ves en la pagina, pero te permite cargar el archivo y visualizar su contenido.

« Última modificación: 19-06-2010, 16:59 (Sábado) por ciberpanare »

SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #22 en: 19-06-2010, 16:57 (Sábado) »
pues creo que nosotros solo podemos meterle a la flash archivos con extension .bin, o sea del tema micro-redboot mientras no tengamos redboot nada de nada

no creas que por que el original.bin tenga casi los 8mb no necesita un cfe.bin, puesto que apenas si pesa 300kb

en fin dudas y dudas, por eso digo ahora tenemos que ir despacio y sobre todo yo, que tengo la flash desoldada y no se si funcionaria el spiptgmw con ella soldada

¿una pregunta, algun valiente dispuesto a dumpear su m25p64? ;D >:D

Post Merge: 19-06-2010, 16:27 (Sábado)
metiendole original.bin

C:Documents and SettingsOscarEscritoriospipgm>spipgmw /p original2610.bin

SPI FlashROM Programmer 1.6 (C) 2008-2009 by Martin Rehak; rayer@seznam.cz
Compiled by GCC 3.4.5 (mingw-vista special r3) at 22:49:21, Jan 21 2009
(Win9x/NT/2K/XP compatability)

SPI connected to LPT port at I/O base address: 378h, SCK pulse width: t+0us
FlashROM JEDEC ID, type: 202017h
ST Microelectronic M25P64 (8MB)
Programming page at: 00140A00h (15%)

no va a tardar ni 20 minutos

Post Merge: 19-06-2010, 17:39 (Sábado)
termino pero con un error :(

C:\Documents and Settings\Oscar\Escritorio\spipgm>spipgmw /p original2610.bin

SPI FlashROM Programmer 1.6 (C) 2008-2009 by Martin Rehak; rayer@seznam.cz
Compiled by GCC 3.4.5 (mingw-vista special r3) at 22:49:21, Jan 21 2009
(Win9x/NT/2K/XP compatability)

SPI connected to LPT port at I/O base address: 378h, SCK pulse width: t+0us
FlashROM JEDEC ID, type: 202017h
ST Microelectronic M25P64 (8MB)
ERROR: cannot read page 32512 from file

C:\Documents and Settings\Oscar\Escritorio\spipgm>
« Última modificación: 19-06-2010, 17:39 (Sábado) por seraser »

uNbAs

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #23 en: 19-06-2010, 17:53 (Sábado) »
Aquí os dejo las ROM para los AP48 y AP51 este segundo probablemente es el que necesitéis, como siempre gracias a la peña de DD-WRT

ReadME de la Seccion

Rooms Senao

RedBoot Collection





SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #24 en: 19-06-2010, 18:29 (Sábado) »
ok mil gracias unbas ;)

tambien este link que me has pasado que  tiene el redboot para el eoc2610

http://robin-files.wik.is/EnGenius_EOC-2610_Redboot_fix

y ahora a googlear a ver si spitgmw admite meter  archivos  .rom

Post Merge: 19-06-2010, 18:49 (Sábado)
Le he metido el original.bin y he puesto la flash en la board sin soldar solo muy presionada, hacia buen contacto y TENGO LANNNNNNNNNNNNNNNNNNNN ;D

Ahora toca soldarla y ver que pasa, hay lan pero no hay ip, creo que brick pero redboot tiene que haber ya
« Última modificación: 19-06-2010, 20:02 (Sábado) por seraser »

ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #25 en: 19-06-2010, 20:27 (Sábado) »
ok mil gracias unbas ;)

tambien este link que me has pasado que  tiene el redboot para el eoc2610

http://robin-files.wik.is/EnGenius_EOC-2610_Redboot_fix

y ahora a googlear a ver si spitgmw admite meter  archivos  .rom

Post Merge: 19-06-2010, 18:49 (Sábado)
Le he metido el original.bin y he puesto la flash en la board sin soldar solo muy presionada, hacia buen contacto y TENGO LANNNNNNNNNNNNNNNNNNNN ;D

Ahora toca soldarla y ver que pasa, hay lan pero no hay ip, creo que brick pero redboot tiene que haber ya

Felicidades  >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:( >:(
Ya con LAN, lo de mas es cuento hermano, espero que mantengan este hilo, para ayudar a los demas con el mismo problema.
hasta usando el ap51-flash sin que tengas ip, solucionarias

Al final si estaba en lo cierto de que en el bin original estaba todo?
Cuanto tiempo se llevo cargar el bin original?
Espero tu respuesta.

SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #26 en: 19-06-2010, 21:04 (Sábado) »
poco ciberpanare, 20 minutos, luego hice un backup y lo edite, vi archivos tales como redboot ip y cosas asi y deduci con la ayuda de mi amigo Unbas que debia de haber redboot

te dara error cuando le metas el original.bin, en ultima instancia

voy a soldar otra vez la flash, tiene una patilla medio ida ???  veremos que pasa

espero tengas destreza con el soldador, he visto en foros que mucha gente solo levanta los pines necesarios sin sacar la flash del pcb, extrema la precaucion con el soldador ciberpanare

bueno a ver cuando te atreves tu >:D

ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #27 en: 19-06-2010, 21:37 (Sábado) »
poco ciberpanare, 20 minutos, luego hice un backup y lo edite, vi archivos tales como redboot ip y cosas asi y deduci con la ayuda de mi amigo Unbas que debia de haber redboot

te dara error cuando le metas el original.bin, en ultima instancia

voy a soldar otra vez la flash, tiene una patilla medio ida ???  veremos que pasa

espero tengas destreza con el soldador, he visto en foros que mucha gente solo levanta los pines necesarios sin sacar la flash del pcb, extrema la precaucion con el soldador ciberpanare

bueno a ver cuando te atreves tu >:D

Si, ya lo estoy haciendo, pero en este caso desconecte solo los pines 1 y 2 (hold y Vcc +3v) es mejor porque me ahorro soldar el cable de tierra (gnd) directamente a la memoria, lo puedo tomar de otra parte de la placa.

Necesito que me confirmes por favor como dejaste el WP a tierra o como en el esquema a +vcc.
Estoy esperando para soldar y hacer mi intento. Esten atentos

SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #28 en: 19-06-2010, 21:59 (Sábado) »
todo segun esquema ciberpanare, WP a 3,3V

yo ya dudo que pueda terminar con buen fin :'(, la patilla numero 16  de la flash se ha ido y estoy intentando rescatarla de una miilonesima parte metalica que ha quedado adherida a la flash

en fin todo seria ver si venden la flash y su precio 8), pero no hay mal que por bien no venga, ya esta comprobado que se recupera la Lan con este metodo

saludos

Post Merge: 19-06-2010, 23:00 (Sábado)
en fin todo esta hecho, mi senao ha muerto :'(

tecnicamente ha perdido varios pines donde suelda la flash, ha sido imposible recuperar el pin perdido y al desoldar de nuevo la flash la placa no ha podido mas

aviso a navegantes, mejor levantar las patillas

ciberpanare ya el tema esta en ti ;)
« Última modificación: 19-06-2010, 23:00 (Sábado) por seraser »

ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #29 en: 19-06-2010, 23:16 (Sábado) »
todo segun esquema ciberpanare, WP a 3,3V

yo ya dudo que pueda terminar con buen fin :'(, la patilla numero 16  de la flash se ha ido y estoy intentando rescatarla de una miilonesima parte metalica que ha quedado adherida a la flash

en fin todo seria ver si venden la flash y su precio 8), pero no hay mal que por bien no venga, ya esta comprobado que se recupera la Lan con este metodo

saludos

Post Merge: 19-06-2010, 22:00 (Sábado)
en fin todo esta hecho, mi senao ha muerto :'(

tecnicamente ha perdido varios pines donde suelda la flash, ha sido imposible recuperar el pin perdido y al desoldar de nuevo la flash la placa no ha podido mas

aviso a navegantes, mejor levantar las patillas

ciberpanare ya el tema esta en ti ;)

Lo siento mucho amigo, pero creo que valio la pena intentarlo.
Ya lo logre y le envie el firmware original, solo levante el pin 1, 2 y 9 (hold, vcc y WP respectivamente)  despeues de la grabacion, aun no tengo actividad de lan, esta igual como anteriormente estaba, voy a revisar a ver si no quedaron bien soldados los pines. Por cierto tambien me dio el mismo error que a ti. "ERROR: cannot read page 32512 from file"

Post Merge: 19-06-2010, 23:24 (Sábado)
Me parecio haber visto esa memoria en venta por la pagina de ebay
Por cierto, seraser, cuentame de que pasi eres?
« Última modificación: 19-06-2010, 23:24 (Sábado) por ciberpanare »

SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #30 en: 19-06-2010, 23:26 (Sábado) »
pues es raro que no te funcione la Lan, solo has desoldado tres pines, que pillo eres :D

por sacar lo positivo, ya no tengo eoc pero si una planar de 10dbi ;D

pues para que quiero la flash si ya no tengo donde soldarla :'(

soy de España

saludos

Post Merge: 19-06-2010, 22:44 (Sábado)
ciberpanare, si me pudieras hacer un favor:

yo he perdido los pines de soldadura en placa 9, 11 y 14 y en uso de estos tres solo esta el 9 que corresponde a WP, si pudieras decirme un punto digamos gemelo con un comprobador seria estupendo y veria la opcion de la memoria por ebay por que no sale cara

http://shop.ebay.de/?_from=R40&_trksid=p3907.m570.l1313&_nkw=m25p64&_sacat=See-All-Categories

saludos
« Última modificación: 20-06-2010, 00:05 (Domingo) por seraser »

ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #31 en: 20-06-2010, 00:14 (Domingo) »
Claro amigo, pero antes te digo que ya tengo un problema parecido al tuyo, en este caso con el mismo pin 9, al despegarlo por primera vez le hice fuerza antes de que se deritiera bie la soldadura, ello causo que se despegara la pista.
He realizado varias pruebas, he comprobado que ese pin va conectado al vcc o a la msima alimentacion de la placa, tal como aparece tambien en el diagrama que usamos. Pero como en mi caso es la pista mas no el pin, probe conectandolo por un puente hace le diodo que esta al lado que entrega 3.3v pero aun no logro actividad de LAN.

Ahora voy a seguirle la pista pero tengo que despegar la antena integrada, pues he visto que dicha pista daba a un puente que va a la otra cara de la placa.

Post Merge: 20-06-2010, 00:43 (Domingo)
:'( Lamento informarles que el pin 9 acaba de fallecer, no dio mas entre tanto movimiento.

Seraser, no he logrado saber con determinacion hacia donde va la pista, se que llega a un punte (tipo orificio) que pasa hacia la otra cara de la pcb, pero al buscarlo en la otra cara, solo hay un punto mas nada, no se ve pista ni nada
« Última modificación: 20-06-2010, 00:43 (Domingo) por ciberpanare »

corwar

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #32 en: 20-06-2010, 00:49 (Domingo) »
Valiente de raviolli el intentar soldar y desoldar ese chip con un soldador normal.

Pillate una memoria, y prueba otra vez, y referente a soldarlo en la placa, igual te sale mejor comprar cable de modding(este que es muy fino) y sacar las conexiones fuera.

Este es el cable que te digo, yo compre 5m y es realmente fino
http://cgi.ebay.es/5M-BLUE-KYNAR-WIRE-XBOX-PS2-WII-MOD-5-Metre-for-Modding-/220387455709?cmd=ViewItem&pt=UK_BOI_Electrical_Components_Supplies_ET&hash=item33501db2dd

A ver si te sirve de algo. Puedes poner una foto de donde va soldao el chip?

saludos

ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #33 en: 20-06-2010, 01:14 (Domingo) »
Creo que la pista del pin 9 no solo iba hacia afuera, sino hacia dentro, pasando por debajo de la memoria.
Seraser, como tu si desoldaste la memoria mepodrias confirmar la ruta de la pista? si es posible coloca una foto.

He logrado soldar un cable al punto de cobre que quedo del pin 9, pero estoy esperando por ti seraser a saber si esa pisto no solo iba para afuera sino que pasa por debajo de la memoria hacia otro punto, no lo se porque yo nunca desolde la mia.


Post Merge: 20-06-2010, 02:47 (Domingo)
pues es raro que no te funcione la Lan, solo has desoldado tres pines, que pillo eres :D

por sacar lo positivo, ya no tengo eoc pero si una planar de 10dbi ;D

pues para que quiero la flash si ya no tengo donde soldarla :'(

soy de España

saludos

Post Merge: 19-06-2010, 22:44 (Sábado)
ciberpanare, si me pudieras hacer un favor:

yo he perdido los pines de soldadura en placa 9, 11 y 14 y en uso de estos tres solo esta el 9 que corresponde a WP, si pudieras decirme un punto digamos gemelo con un comprobador seria estupendo y veria la opcion de la memoria por ebay por que no sale cara

http://shop.ebay.de/?_from=R40&_trksid=p3907.m570.l1313&_nkw=m25p64&_sacat=See-All-Categories

saludos

Amigo, aun no comprendo, se te dañaron los pines de la memoria o las pistas de soldadura de la pcb?
Estoy seguro que el pin 9 de la placa esta conectado al punto positivo vcc, pero pareciera esa pista tambien va hacia otro lado, pasando por debajo de la memoria.
(he tardado con las respuestas porque mi internet el dia de hoy ha estado muy inestable, va y viene.
« Última modificación: 20-06-2010, 02:47 (Domingo) por ciberpanare »

corwar

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #34 en: 20-06-2010, 10:05 (Domingo) »
Se le partieron los pines del chip

SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #35 en: 20-06-2010, 10:40 (Domingo) »
 :-*hola, que tal corwar, como ves aqui haciendo destrozos >:D

para ser exactos parti el pin 16 del chip de la flash
y en el pcb perdi los puntos de soldadura 9, 11, y 14, de los cuales solo vale el punto 9

y efectivamente el punto 9 se mete en un orifico que pega al punto de soldadura, sin mas no tiene otro recorrido, pues ahi se podria soldar creo yo, y es normal que no haya continuidad con vcc, asi el hardware puede gestionar mediante un switch cuando mete tension o no y por lo tanto cuando se puede escribir en la flash o no

tengo una duda ciberpanare, si me la pudieras aclarar haria que me decantara o no por pedir un m25p64 en ebay por 5€, en el grupo de 4 resistencias que pegan a esa misma cara del pin 9 ¿te dan continuidad tres de ellas o me las he cepillado con la calor(casi seguro)?

si pudiera volver a empezar no desoldaria nada, todo segun esta en el pcb, cawuenlaputa haber visto esa lan funcionando y no haber podido rematar :-\

cualquier cosa dime ciberpanare
« Última modificación: 20-06-2010, 13:29 (Domingo) por seraser »

corwar

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #36 en: 20-06-2010, 11:10 (Domingo) »
Usa el orificio, que pasara a la otra cara de la placa, pero te sirve igualmente.


ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #37 en: 20-06-2010, 13:59 (Domingo) »
:-*hola, que tal corwar, como ves aqui haciendo destrozos >:D

para ser exactos parti el pin 16 del chip de la flash
y en el pcb perdi los puntos de soldadura 9, 11, y 14, de los cuales solo vale el punto 9

y efectivamente el punto 9 se mete en un orifico que pega al punto de soldadura, sin mas no tiene otro recorrido, pues ahi se podria soldar creo yo, y es normal que no haya continuidad con vcc, asi el hardware puede gestionar mediante un switch cuando mete tension o no y por lo tanto cuando se puede escribir en la flash o no

tengo una duda ciberpanare, si me la pudieras aclarar haria que me decantara o no por pedir un m25p64 en ebay por 5€, en el grupo de 4 resistencias que pegan a esa misma cara del pin 9 ¿te dan continuidad tres de ellas o me las he cepillado con la calor(casi seguro)?

si pudiera volver a empezar no desoldaria nada, todo segun esta en el pcb, cawuenlaputa haber visto esa lan funcionando y no haber podido rematar :-

cualquier cosa dime ciberpanare

Amigo, el pin 9 no tiene reistencias alrededor.
Vamos a tener que buscar la forma de trabajar con imagenes para no confundirnos.

Post Merge: 20-06-2010, 14:10 (Domingo)
Amigos, acabo de hacerle seguimiento al orificio al cual llegaba la pista, y efectivamente, llega hasta el par de diodos que estan de cara a los pines 1,2,3,4. ya lo verifique y existe contiuidad ente el orificio y los diodos. Lo cual quiere decir que el WP en la board siempre esta el nivel 1 (VCC).

Lo que aun no comprendo es porque si ya hice el puente entre el pin 9 y el diodo, porque aun no tengo lan.

Estas seguro de que la pista del pin que solo va al orificio, no será que hay otra ruta a la que no se le esta haciendo contacto?
Habras hecho algo adicional a grabar el bin original Seraser?
« Última modificación: 20-06-2010, 14:10 (Domingo) por ciberpanare »

SERASER

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #38 en: 20-06-2010, 14:24 (Domingo) »
ciberpanare me referia a r129 r130 r133 r158 que forman una bateria de 4 resistencias proximas al pin 9

en cuanto a como flashee yo te lo indico, obviamente tu has de hacerlo con los comandos y parametros necesarios que sabes de sobra

primero la identifique

luego la desbloquee

luego la borre

luego la programe

luego hice un backup

edite dicho backup con word pad y tras ver que habia datos al final del mismo sobre el redboot me anime a probar con la flash adherida manualmente

y tuve lan

y no una vez si no dos veces

animo!!
« Última modificación: 20-06-2010, 14:28 (Domingo) por seraser »

ciberpanare

  • Visitante
Re: ¿Alguien ha realizado jtag con senao eoc 2610?
« Respuesta #39 en: 20-06-2010, 14:38 (Domingo) »
Bueno, de todos esos pasos, me falto borrar.
AHora me da miedo volver  a soltar los pines para hacer el borrado y nuevamente grabar.
Si lo voy intentar, sino lo hago no valdra la pena tanto esfuerzo.
Estoy seguro de que con esto estamos ayudando a otros con el mismo problema y ellos lo haran mejor.

« Última modificación: 20-06-2010, 14:41 (Domingo) por ciberpanare »

//FINAL Y MÁS DOS RESPUESTAS