Autor Tema: WDS con HW HG556a  (Leído 14753 veces)

0 Usuarios y 1 Visitante están viendo este tema.

SirLouen

  • Visitante
WDS con HW HG556a
« en: 10-01-2013, 11:35 (Jueves) »
He visto que hay varios tutoriales en este foro para hacer diversas configuraciones con OpenWRT para hacer wireless clients y bridges con relayd (un problema especificamente cuando utilizamos DLNA entre equipos de diferentes redes por ejemplo).

Pero me gustaría dar el paso mas alla y probar a configurar mi router principal HG556a en modo WDS ¿Es posible? En el otro punto tengo un TP-Link WR1043ND (Chip Atheros) con DD-WRT (tampoco se si se podría hacer un WDS entre distintas plataformas)



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: WDS con HW HG556a
« Respuesta #1 en: 10-01-2013, 11:55 (Jueves) »
Yo tengo enlazados 2 hg556a con WDS y el enlace/transferencia funciona estupendamente  >:(

Eso sí, ambos con OpenWrt.

Prueba y nos comentas  ;)

P.D.: Si el hg556a que tienes, lleva el firmware de vodafone (como pones que lo tienes como router principal ...) , olvídate del WDS.

SirLouen

  • Visitante
Re: WDS con HW HG556a
« Respuesta #2 en: 10-01-2013, 12:31 (Jueves) »
Hola jar
En realidad me referia poniendo HG556a con OpenWRT (quitando firm de vodafone), y el TP-Link dejarlo con DD-WRT
Puedes ponerme las configs WDS de tu HG556a? Es que no he encontrado un tutorial decente y la ultima experiencia que tuve con OpenWRT fue un poco dramatica, tuve que volver a DD-WRT por que no conseguia hacerlo funcionar.

Entiendo que en etc-config-wireless podría configurar el 556a:


config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'channel' '8'
        option 'disabled' '0'

config 'wifi-iface'
        option 'device' 'wifi0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'mi_red_wifi'
        option 'hidden' '0'
        option 'encryption' 'psk2'
        option 'key' 'mi_clave_wifi'

config 'wifi-iface'
        option 'device' 'wifi0'
        option 'network' 'lan'
        option 'ssid' 'mi_red_wifi'
        option 'bssid' 'mac_del_tplink'
        option 'encryption' 'psk2'
        option 'key' 'mi_clave_wifi'
        option 'mode' 'wds'
        option 'hidden' '0'

Y el TP-Link:

config 'wifi-device' 'wifi0'
        option 'type' 'atheros'
        option 'disabled' '0'
        option 'diversity' '0'
        option 'channel' '8'

config 'wifi-iface'
        option 'device' 'wifi0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'mi_red_wifi'
        option 'hidden' '0'
        option 'encryption' 'psk2'
        option 'key' 'mi_clave_wifi'
        option 'wds' '1'
        option 'bssid' 'mac_de_huawei'
« Última modificación: 10-01-2013, 12:32 (Jueves) por SirLouen »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: WDS con HW HG556a
« Respuesta #3 en: 10-01-2013, 13:36 (Jueves) »
hg556a en modo AP WDS

Código: [Seleccionar]
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'pci0000:00/0000:00:01.0'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option channel '1'
option htmode 'HT40+'
option country 'ES'
option txpower '19'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'otra_wifi_mas_2'
option wds '1'
option encryption 'psk'
option key 'xxxxxxx'

hg556a en modo Cliente WDS


Código: [Seleccionar]
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'pci0000:00/0000:00:01.0'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '0'
option channel '1'
option txpower '19'
option htmode 'HT40+'
option country 'ES'

config wifi-iface
option ssid 'otra_wifi_mas_2'
option encryption 'psk'
option device 'radio0'
option mode 'sta'
option bssid 'F4:C7:xx:xx:xx'
option key 'xxxxxxx'
option wds '1'
option network 'lan'

Tal y como yo los tengo, el que están modo cliente sólo enlaza, no 'repite' la señal. Si necesitas que lo haga, tendrás que añadirle un nuevo interface en modo AP WDS.

Ya dirás ...  ;)

hermesreg

  • Visitante
Re: WDS con HW HG556a
« Respuesta #4 en: 10-01-2013, 13:50 (Jueves) »
Muy buenas,,, yo tambien quiero hacer eso, es decir hacer wds con una HG556z, pero necesito empezar por el principio...


algún tutorial, para instalar el firmware open... y configurar para que se enganche al WRT54GL....

Gracias, y siento mucho ser tan newbie,,, pero tengo ganas de aprender...


SirLouen

  • Visitante
Re: WDS con HW HG556a
« Respuesta #5 en: 10-01-2013, 14:29 (Jueves) »
Hola jar

Para la parte de

config wifi-device 'radio0'

Entiendo que estos parametros:

   option hwmode '11ng'
   option path 'pci0000:00/0000:00:01.0'
   list ht_capab 'SHORT-GI-40'
   list ht_capab 'TX-STBC'
   list ht_capab 'RX-STBC1'
   list ht_capab 'DSSS_CCK-40'
   option channel '1'
   option htmode 'HT40+'
   option country 'ES'
   option txpower '19'

No son necesarios para una configuración mínima, ¿Cierto?
Mas especificamente por el hecho que en caso de un TP-Link WR1043ND no tengo claro que todos fueran a concordar bien, ni siquiera tengo claro si en
   option type 'mac80211'

Seria mas conveniente poner "atheros"

Todavia estoy muy iniciado en este sistema.

Por cierto, uno de los grandes problemas que he encontrado cuando te pones a cacharrear con esto y que mas aversión me produce, es que cuando no va, la perdida es que te quedas sin internet, al quedarte sin internet, no hay manera de buscar una solucion googleando, y en consecuencia, estas como quien dice, "en tierra de nadie" y a ver como sacas la papeleta :) (mas considerando que todo esto es para una red casera)

Saludos
« Última modificación: 10-01-2013, 14:31 (Jueves) por SirLouen »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: WDS con HW HG556a
« Respuesta #6 en: 10-01-2013, 18:05 (Jueves) »
Supongo que sin esos parámetros también debiera funcionar, pero ... hasta que no lo pruebes no lo sabremos  >:D

SirLouen

  • Visitante
Re: WDS con HW HG556a
« Respuesta #7 en: 10-01-2013, 18:34 (Jueves) »
Por curiosidad
Nada mas le meta el firm al HG556 va a funcionar la ADSL (VF) conectando un PC al puerto LAN sin mas? Es para saber tener donde agarrarme antes de lanzarme a la piscina :)
¿O hace falta alguna configuracion?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: WDS con HW HG556a
« Respuesta #8 en: 10-01-2013, 18:41 (Jueves) »
https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg227088/#msg227088

Citar
Recordad que al instalar el firmware perderéis la función de modem ADSL.

SirLouen

  • Visitante
Re: WDS con HW HG556a
« Respuesta #9 en: 10-01-2013, 18:44 (Jueves) »
Cuando hablas de perder, te refieres a perder en el sentido "de hace falta configurar" o de "perder la funcionalidad" literalmente?

Noltari

  • Visitante
Re: WDS con HW HG556a
« Respuesta #10 en: 10-01-2013, 18:57 (Jueves) »
Cuando hablas de perder, te refieres a perder en el sentido "de hace falta configurar" o de "perder la funcionalidad" literalmente?
No hay driver ADSL.

"Perder" no se pierde nada. Simplemente deja de estar disponible mientras usas OpenWrt. Si luego flasheas el firmware oficial está disponible de nuevo.

El problema se da en routers de los que no se dispone del firmware oficial. Obviamente, una vez en OpenWrt te has quedado sin ADSL porque no puedes volver al firmware oficial.

Saludos.

Elnef

  • Visitante
Re: WDS con HW HG556a
« Respuesta #11 en: 17-01-2013, 10:58 (Jueves) »
Ayer configuré 2 atheros en WDS y quiero añadir un par de detalles importantes que pueden ayudar a otros usuarios y en este hilo se dan por sabidos.

1- Los dos routers deben tener la IP de la lan en el mismo marco de direcciones. Por ejemplo:
 Router principal -> 192.168.1.2
 Router remoto -> 192.168.1.3
 Si la máscara de red es del tipo 255.255.255.0

2- El router remoto tiene que tener desactivado el DHCP.

3- A la hora de configurar el router remoto la conexión wifi del cliente debe estar asociada a la interface "LAN" y no a la "WWAN" que es la que el router pone por defecto desde LuCI al seleccionar la opción de explorar redes para conectarse.

Esto lo hice ayer porque antes tenía el router remoto como repetidor con relayd y aunque desactivé firewall y probé mil combinaciones no conseguía usar el DLNA desde un MiniPc Android conectado al Remoto, respecto a mi Pc conectado al principal. Al conectarlos por WDS se solucionó el problema y ya va perfecto el DLNA.
« Última modificación: 17-01-2013, 11:01 (Jueves) por Elnef »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: WDS con HW HG556a
« Respuesta #12 en: 17-01-2013, 11:31 (Jueves) »
Muy bien explicado, Elnef  >:(

A veces, damos cosas por supuestas y luego llegan los problemas  ;D

Bastinazo

  • Visitante
Re: WDS con HW HG556a
« Respuesta #13 en: 09-02-2013, 14:36 (Sábado) »
No sois capaz de hacer andar un linksys 160NL (atheros) con DDWRT y el HG556a (atheros) con Openwrt en WDS.

Linksys 160NL DDWRT
Seccion WDS  con la MAC del HG556a


HG556a con opewrt
Network-> Interfaces


Network-> wifi



Configuración /etc/config/wifi en HG556a
Citar

config wifi-device 'radio0'
   option type 'mac80211'
   option hwmode '11ng'
   option path 'pci0000:00/0000:00:01.0'
   option htmode 'HT40+'
   list ht_capab 'SHORT-GI-40'
   list ht_capab 'TX-STBC'
   list ht_capab 'RX-STBC1'
   list ht_capab 'DSSS_CCK-40'
   option disabled '0'
   option txpower '19'
   option country 'JP'
   option distance '100'
   option channel '13'

config wifi-iface
   option ssid 'wireless'
   option encryption 'psk2'
   option device 'radio0'
   option mode 'sta'
   option bssid '00:03:XX:XX:XX:XX'
   option key 'mi_clave_WPA2'
   option wds '1'
   option network 'lan
'

/etc/confgi/network/ HG556a
Citar
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config interface 'lan'
   option ifname 'eth0.1'
   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.1.2'
   option gateway '192.168.1.1'
   option dns '192.168.1.1'

config switch
   option name 'eth0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth0'
   option vlan '1'
   option ports '0 1 2 3 4 5t
'


DHCP en Opewrt desactivado:
IP Router DDWRT        192.168.1.1
IP HG556a OpenWRT  192.168.1.2
mascara 255.255.255.0


Parace que hay enlace, pero no tengo ni conexion a internet ni responde al ping el router principal.


¿qué se me escapa?

Gracias máquinas
« Última modificación: 09-02-2013, 15:57 (Sábado) por Bastinazo »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Re: WDS con HW HG556a
« Respuesta #14 en: 09-02-2013, 14:58 (Sábado) »
Habría que ver los ficheros de configuración de DD-WRT.
El hg556a tiene WiFi atheros ?

Enviado desde mi Infected V3.0 usando Tapatalk 2

Bastinazo

  • Visitante
Re: WDS con HW HG556a
« Respuesta #15 en: 09-02-2013, 15:57 (Sábado) »
Si el HG556a es atheros.

En cuanto al los ficheros de configuración en DDWRT no sé donde están, creo que estos iban en nvram en DDWRT.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: WDS con HW HG556a
« Respuesta #16 en: 09-02-2013, 16:40 (Sábado) »
Y la IP del router principal (la del que te da acceso a internet) ?
Si está en otra subred, es posible que ahí esté el problema.
Si no es eso ... ^-^ ... la verdad es que DD-WRT no lo conozco demasiado (y no tengo ningún router con él).

Bastinazo

  • Visitante
Re: WDS con HW HG556a
« Respuesta #17 en: 09-02-2013, 17:19 (Sábado) »
La puerta de enlace del Router Principal  es 192.168.1.1
EL linksys (router principal) está conectado a un router de ono en modo cable modem puro, para que el linksys gestione las conexiones, cuya puerta de enlace es, asu vez 192.168.100.1

Aqui el apartado de configuracion IP del linksys



Al HG556a le puse la ip 192.168.1.2
y puerta de enlace 192.168.1.1 (Ip router principal). Igual que como hago con todas las maquinas de mi red a la que le quiero asignar una ip fija.


¿¿??

« Última modificación: 09-02-2013, 17:20 (Sábado) por Bastinazo »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Re: WDS con HW HG556a
« Respuesta #18 en: 09-02-2013, 17:47 (Sábado) »
Pues parece estar todo correcto.
Igual hay pequeñas diferencias en la implementación del WDS entre ambos firmware ...:-\

Has desactivado el firewall en OpenWrt ?

Enviado desde mi Infected V3.0 usando Tapatalk 2

Bastinazo

  • Visitante
Re: WDS con HW HG556a
« Respuesta #19 en: 10-02-2013, 22:10 (Domingo) »
Nada, ni desactivando el el firewall.

Hay ping desde los distintos aparatos de la red. Pero si hago ping fuera de la LAN como por ej google, nada de nada. ???