Autor Tema: Velocidad lenta USB, ExFat en OpenWrt  (Leído 4545 veces)

0 Usuarios y 1 Visitante están viendo este tema.

caracol32

  • Visitante
Velocidad lenta USB, ExFat en OpenWrt
« en: 15-06-2015, 05:04 (Lunes) »
Hola, buenas a todos!

Quería haceros un pregunta, resulta que hace un tiempo que estoy metido en esto de OpenWrt. Hace poco me compré el Router "MyNet 750 Western Digital" ya que leí en este foro que era un buen router para OpenWrt. Bueno mi objetivo era crear una red para compartir mis discos duros usb desde un servidor "Samba".

Coseguí compartir mis discos duros "NTFS" después de mucho invertigar, pero como siempre hay un problema... y quizás en único para mí importante de OpenWrt "la velocidad es penosa!, malísima tanto lectura como escritura!".
Según leí resulta que el problema es "NTFS" y su paquete "NTFS-3g" que va mal por que OpenWrt es Linux.
Tambien he visto un nuevo paquete llamado "Exfat" y mi pregunta es: es posible montar dicho sistema de archivos o aún esta muy verde? se puede desde "Block-Mount"? la velocidad aumentaría?

Bueno ante todo mucha gracias a quien responda y ojala sea "jar229" que según leo por aquí sus post es un maquina en este tema.
Un saludo a todos chicos!

PD: Mi OpenWRT en dicho router es "Chacos Calmer RC1"


« Última modificación: 15-06-2015, 05:21 (Lunes) por caracol32 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4592
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #1 en: 15-06-2015, 09:43 (Lunes) »
Como has podido comprobar, el rendimiento con NTFS es muy malo. Ya se avisa de ello en varios sitios (entre ellos, en las FAQ).

Nunca he usado extFAT, pero puedo asegurarte que con formatos linux; ext2, ext3 o ext4, el rendimiento es muy bueno. Lógicamente ext4 es el más recomendable.

Si te animas a probar extFAT, ya nos contarás  ;)

P.D.: Yo tengo dos WD MyNet 750 y estoy encantado con ellos  >:(
« Última modificación: 15-06-2015, 09:44 (Lunes) por jar229 »
Valoraciones positivas en compra/venta:
152 en Htcmania
200 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

caracol32

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #2 en: 15-06-2015, 11:13 (Lunes) »
Bueno ante todo gracias por responder Jar229!!

Me alegro mucho de hablar contigo, entonces "Exfat" no se podría poner? es q me da cosa cambiar a ext4 Windows no lo detectaría y todo lo q tengo es windows no Linux  :-\.
Crees que algún dia habrá cambios en ntfs y estará a la altura del resto de sistemas de archivos? estoy dispuesto a experimentar con "Exfat" pero si no va a funcionar... también el factor velocidad, si ganaría o quedaría igual que con NTFS Jejejejeje.

Bueno de todas maneras ya tengo un motivo para hablar contigo  >:(
« Última modificación: 15-06-2015, 11:22 (Lunes) por caracol32 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4592
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #3 en: 15-06-2015, 11:38 (Lunes) »
Bueno ante todo gracias por responder Jar229!!

Me alegro mucho de hablar contigo, entonces "Exfat" no se podría poner? es q me da cosa cambiar a ext4 Windows no lo detectaría y todo lo q tengo es windows no Linux  :-\.
Crees que algún dia habrá cambios en ntfs y estará a la altura del resto de sistemas de archivos? estoy dispuesto a experimentar con "Exfat" pero si no va a funcionar... también el factor velocidad, si ganaría o quedaría igual que con NTFS Jejejejeje.

Bueno de todas maneras ya tengo un motivo para hablar contigo  >:(

Según he leído, es posible instalar exfat pero el rendimiento también es muy malo (https://forum.openwrt.org/viewtopic.php?id=40722).

En cuanto a usar un sistema de ficheros de linux, a no ser que pretendas conectar y desconectar el disco del router (cosa no muy recomendable), podrás acceder a el desde cualquier equipo (con windows o linux) usando los servicios de samba o ftp.

Saludos  ;)
Valoraciones positivas en compra/venta:
152 en Htcmania
200 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

caracol32

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #4 en: 15-06-2015, 12:01 (Lunes) »
Gracias de nuevo tio x responder, no me canso de decirlo.
Cuando salgo fuera me lo suelo llevar el disco duro, pero no lo detectaría ext4 nativamente Windows no? tendría q instalar algo en windows?.
Puff lastima q la velocidad sea mala! tenia esperanza  ;D.
Gracias por la info tío! recuerdo q cuando el router estaba con su firm original cogía entre 10-15 MB de velocidad desde Wifi 5Gz! ahora máximo coge 2MB de escritura y 5MB de lectura.
X cierto este router con DD-WRT iría mejor en ese aspecto?

Bueno gracias por escribirme tio de debo una!!!  >:(
« Última modificación: 15-06-2015, 12:03 (Lunes) por caracol32 »

vk496

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #5 en: 16-06-2015, 00:09 (Martes) »
Hola. Tengo el mismo router que vostros dos (lamento no haber comprado uno más cuando tuve la ocasión).

Si usas samba, windows no distingue que sistema de archivos tiene el hdd, te funcionará igual. El problema es cuando quieres conectar ext4 a windows por cable USB.

No se cómo está la cosa ahora, pero me acuerdo que en su momento se podía instalar los drivers de ext3 y usarlo sin problemas (no sé si ya se puede para ext4)

Si tienes pensado conectar y desconectar el disco duro (cosa no recomendable, como ya indicó @jar229) deberías darle la función de montar/desmontar el hdd a la tecla wps y los leds para el estado de ese hdd.

Así podrias quitar y poner el hdd de una forma más segura y sin tener que estar abriendo el terminal todo el rato.

Salu2

caracol32

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #6 en: 16-06-2015, 06:54 (Martes) »
Buenas Chicos!!!
Interesante que samba no distinga si es otro sistema de archivos. Bueno y yo he pensado es posible que con la salida de este nuevo windows ósea "Windows 10" coja ex4 nativamente?, lo habéis pensado? ojalá sea así, ya q en un futuro tengo pensado ponerlo en el pc sobremesa y tablet hibrida.

Me alegro mucho de haber escrito en el foro y de hablar con vosotro! Voy a ponerme al lio y probar la velocidad de ext4 desde un pendrive deberia cogerlo facilmente desde "Block-Mount" no?

Saludo!!! y que tengais un buen día!

PD: Al entrar a una particion ext4 desde Samba encontre unas carpetas raras y no me deja leer ni escribir en la unidad, es posible q no se haya formateado bien? se necesita el paquete libext2fs?
« Última modificación: 16-06-2015, 08:38 (Martes) por caracol32 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4592
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #7 en: 16-06-2015, 08:50 (Martes) »
Buenas Chicos!!!
Interesante que samba no distinga si es otro sistema de archivos. Bueno y yo he pensado es posible que con la salida de este nuevo windows ósea "Windows 10" coja ex4 nativamente?, lo habéis pensado? ojalá sea así, ya q en un futuro tengo pensado ponerlo en el pc sobremesa y tablet hibrida.

Me alegro mucho de haber escrito en el foro y de hablar con vosotro! Voy a ponerme al lio y probar la velocidad de ext4 desde un pendrive deberia cogerlo facilmente desde "Block-Mount" no?

Saludo!!! y que tengais un buen día!

PD: Al entrar a una particion ext4 desde Samba encontre unas carpetas raras y no me deja leer ni escribir en la unidad, es posible q no se haya formateado bien? se necesita el paquete libext2fs?

Windows 10 no dará soporte directo a ningún formato de ficheros de linux, te lo aseguro  ;D

El tema de las 'carpetas raras' tienes que ser más explícito. Y en cuanto a que no te deja escribir en la unidad, casi seguro que es un problema de permisos.

Para solucionar el problema de los permisos, desde una conexión ssh, escribe en el terminal

Código: [Seleccionar]
chmod 777 /mnt/disco_duro
disco_duro se ha de substituir por el nombre de la carpeta en la que montes el pendrive. Te aconsejo que te mires [Tutorial] HG553: LuCi Samba FTP MLDonkey Transmission Wifi rtorrent, etc. para ver cómo se configura y funciona samba.
Valoraciones positivas en compra/venta:
152 en Htcmania
200 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

caracol32

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #8 en: 16-06-2015, 09:40 (Martes) »
Buenas de nuevo jar!!
Sé que se necesitan permiso 777 pero lo activé tanto en "Samba" desde luci como desde SSH desde el comando q me dijistes pero nada me sale el mensaje "se necesitan permisos", no me acepta Samba ext4.

ahora q tenia ganas de probar ext4...  ;D

Gracias nuevamente tio!

PD: Aquí te dejo unas imagenes xk yo creo q esta todo bien y nada no deja

Puntos Montados:
http://subefotos.com/ver/?d59b6bb9884020cf51228f13ac434681o.jpg

Samba:
http://subefotos.com/ver/?141793d53ab7d6dd9c42fb618a2ec11co.jpg


PD IMPORTANTE: Cuidado con actualizar a la versión "Chaos Calmer RC.2" esta corrupta o algo q no deja entrar al router despues de grabar el firmware.Lo digo xk me ha pasado y ha tocado entrar al modo recovery  para volver a RC.1 :-X (el firm ocupa menos de lo normal)
Tambien he notado que al instalar los paquetes salen errores, quizas por eso no me coja ext4 (el paquete da error en la instalacion)

« Última modificación: 16-06-2015, 11:53 (Martes) por caracol32 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4592
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #9 en: 16-06-2015, 11:49 (Martes) »
En samba has creado el usuario y le has puesto password ?

Podría ser que algún paquete no se haya instalado bien ...  ^-^
Valoraciones positivas en compra/venta:
152 en Htcmania
200 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

caracol32

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #10 en: 16-06-2015, 11:58 (Martes) »
Jar ostía menos mal que has llegado tiaco!
Sí sí, yo lo hago así como invitado en Samba ya q no quiero Usuario/contraseña y me ha funcionado siempre bien en "NTFS", siempre lo he hecho todo desde "LUCI".

Pero bueno a lo q iba, esta pasando algo que no me deja instalar ni un paquete. Ahora no deja instalar nada! salen muchos errores y despues ni me aparecen en "paquetes instalados".
Jajajaja Madre mia que lio, me he quedado sin servidor samba y sin ningun paquete! quise actualizar para ver si con la RC.2 conseguia que me funcionase Ext4.
Pero me ha tocao volver a RC.1 desde "Recovery" y al querer instalar paquetes me dice q nanai, jajajaj >:( has probado la versión RC.2? (no lo hagas  ;D)

PD: Solucionados errores de algunos paquetes (era por tema de la configuracion, al configurar todo manualmente se instalaron bien).
Pense que como decia "vk496" ext4 funcionaria en samba pero parece que no!
que velocidades conseguis vosotros?
« Última modificación: 16-06-2015, 14:08 (Martes) por caracol32 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4592
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #11 en: 16-06-2015, 14:32 (Martes) »
Samba tiene que funcionar con ext4, sí o sí  ;D
Valoraciones positivas en compra/venta:
152 en Htcmania
200 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

caracol32

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #12 en: 16-06-2015, 15:00 (Martes) »
Buenas de nuevo Jar229!

Entonces eso como es? los permisos estan bien de eso estoy seguro ya q cuando uso "ntfs" funciona sin problemas y con "ex4" nada de nada. Hasta he probado con "Ext2 y Ext3". Tambien decir q los paquetes instalados que tengo son los mismo q comentas en tu tutorial. Si te fijas en las fotos q te mande veras que hasta sale montado el pendrive. Quizás sea muy pequeño el pen? es de 1GB.

Gracias y perdón por todo el tocho q he escrito en el post, ya no molesto más tío, me da ya hasta fatiga!!  :-X

PD: aquí te dejo los pasos q hago, lo saque de la web de OpenWrt.
http://translate.google.es/translate?hl=es&sl=en&u=http://wiki.openwrt.org/doc/recipes/usb-storage-samba-webinterface&prev=search

PD. Bueno ya lo he conseguido era por culpa del pendrive q la particion necesitaba estar en primaria y activa  >:( Gracias x vuestra ayuda os estoy eternamente agradecido.
« Última modificación: 16-06-2015, 16:42 (Martes) por caracol32 »

Joseba30

  • Visitante
Re: Velocidad lenta USB, ExFat en OpenWrt
« Respuesta #13 en: 16-06-2015, 18:20 (Martes) »
primero exfat funciona perfectamente, y me gustaria matizar eso de ntfs va mal por que openwrt es linux, no, va mal por que es una **** mierda de sistema de archivos y va mal en linux por que esta pesimamente documentado.

Segundo, veo que a pesar de  marcar el punto de montaje bien en la parte superior de la captura que mandas, en la parte baja cuando señala el uuid del dispositivo marca un ?.

Diria que tienes algun error en el fstab, revisa /etc/config/fstab (te bajas una copia de la configuracion y alli lo tendras) apostaria un euro a que tienes duplicado el montaje, una vez con dispositivo (/dev/sda1) otra con uuid o algo asi (o con etiqueta, label)

//FINAL Y MÁS DOS RESPUESTAS