Autor Tema: Pyload en HG556a  (Leído 17660 veces)

0 Usuarios y 1 Visitante están viendo este tema.

frankcis81

  • Visitante
Pyload en HG556a
« en: 28-06-2013, 11:04 (Viernes) »
Hola a todos

Hace unos meses conseguí un HG556a de un amigo que se dio de baja en vodafone, hasta ahora lo he tenido en un cajón abandonado, pero ahora me he metido con el tema del Openwrt y la verdad es que estoy muy pez en el asunto.

El tema es que la unica funcion que me interesa por ahora de este aparato seria la de poder utilizarlo como gestor de descargas con el pyload, pero tengo el problema que cuando me pongo a instalarlo me quedo sin espacio antes de poder instalar todas la dependencias.

¿alguien me podía orientar un poquito?

Gracias y un saludo


« Última modificación: 03-02-2014, 14:33 (Lunes) por frankcis81 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #1 en: 28-06-2013, 11:11 (Viernes) »
Pyload es un script en python. Este y sus dependencias, como bien dices, ocupan mucho.
Así que su instalación, pasaría por usar previamente extroot: http://wiki.openwrt.org/doc/howto/extroot

Tienes el proceso explicado en este tutorial: https://foro.seguridadwireless.net/openwrt/instalacion-de-openwrt-y-mas-en-wrt160nl/

De todas formas, ya te anticipo, que tendrás problemas con algunos de los servidores de descarga directa. Los plugins de pyload no se actualizan tan rápido como los de jdownloader.
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

frankcis81

  • Visitante
Re: Pyload en HG556a
« Respuesta #2 en: 28-06-2013, 16:04 (Viernes) »
Gracias!!, no habia dado con esta informacion.

Me voy a poner a ello,

Gracias otra vez  :D

frankcis81

  • Visitante
Re: Pyload en HG556a
« Respuesta #3 en: 10-07-2013, 09:53 (Miércoles) »
Bueno despues de mucho pelear con el tema, ya tengo corriendo el OpenWRT 12.09 con todo instalado.  >:(

El problema que tengo ahora es que cuando intento arrancar pyload (lo he probado a lanzarlo desde el putty), me da el siguiente error.  :(

------------------------------------------------------
Traceback (most recent call last):
  File "/usr/bin/pyload", line 55, in <module>
    from module.database import DatabaseBackend, FileHandler
  File "/usr/share/python/pyload/module/database/__init__.py", line 1, in <module>
    from DatabaseBackend import DatabaseBackend
  File "/usr/share/python/pyload/module/database/DatabaseBackend.py", line 33, in <module>
    import sqlite3
  File "/usr/lib/python2.7/sqlite3/__init__.py", line 24, in <module>
    from dbapi2 import *
  File "/usr/lib/python2.7/sqlite3/dbapi2.py", line 27, in <module>
    from _sqlite3 import *
ImportError: No module named _sqlite3
------------------------------------------------------------------
estoy un poco perdido, si alguien me pudiera orientar.  >:D

Y otra pregunta. ¿existe algun otro gestor de descargas directas aparte de este?

Gracias!!!
« Última modificación: 10-07-2013, 10:00 (Miércoles) por frankcis81 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #4 en: 10-07-2013, 10:14 (Miércoles) »
Uf, hace mucho que no instalo pyload ...  ^-^

El primer arranque es recomendable hacerlo con el comando:

Código: [Seleccionar]
pyLoadCore -s
Así se supone, lo iniciamos en modo setup (configuración).

De todas formas, que sepas que la versión disponible en el repositorio de openwrt es la 0.48 y actualmente están en la 0.49.

Por el error que da ... seguro que has instalado sqlite3 y python-sqlite3 ?

Si consigo sacar tiempo (no prometo nada) intento instalarlo en alguno de mis routers ...  >:D
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

frankcis81

  • Visitante
Re: Pyload en HG556a
« Respuesta #5 en: 10-07-2013, 11:47 (Miércoles) »
Lo he arrancado asi la primera vez y es cuando me ha dado ese error. Los paquetes creo que los tengo todos. te pego un listado de los paquetes instalados por si me faltase algo.

Muchas gracias por tu tiempo

-------------------------------
base-files - 117-r36422
blkid - 2.21.2-1
block-mount - 0.2.0-9
busybox - 1.19.4-6
ddns-scripts - 1.0.0-21
dnsmasq - 2.62-2
dropbear - 2011.54-2
etherwake - 1.09-3
firewall - 2-55.1
freeswitch - 1.0.7-2
freeswitch-mod-cdr-sqlite - 1.0.7-2
giflib - 4.1.6-1
hotplug2 - 1.0-beta-4
iptables - 1.4.10-4
iw - 3.6-1
iwinfo - 36
js - 1.6.20070208-2
jshn - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
kernel - 3.3.8-1-3e727c51e42e8034f8ada81e0e9fe681
kmod-ath - 3.3.8+2012-09-07-3
kmod-ath9k - 3.3.8+2012-09-07-3
kmod-ath9k-common - 3.3.8+2012-09-07-3
kmod-button-hotplug - 3.3.8-3
kmod-cfg80211 - 3.3.8+2012-09-07-3
kmod-crypto-aes - 3.3.8-1
kmod-crypto-arc4 - 3.3.8-1
kmod-crypto-core - 3.3.8-1
kmod-eeprom-93cx6 - 3.3.8-1
kmod-fs-ext4 - 3.3.8-1
kmod-fs-ntfs - 3.3.8-1
kmod-fs-vfat - 3.3.8-1
kmod-fuse - 3.3.8-1
kmod-input-core - 3.3.8-1
kmod-input-gpio-keys-polled - 3.3.8-1
kmod-input-polldev - 3.3.8-1
kmod-ipt-conntrack - 3.3.8-1
kmod-ipt-core - 3.3.8-1
kmod-ipt-nat - 3.3.8-1
kmod-ipt-nathelper - 3.3.8-1
kmod-lib-crc-ccitt - 3.3.8-1
kmod-lib-crc-itu-t - 3.3.8-1
kmod-lib-crc16 - 3.3.8-1
kmod-mac80211 - 3.3.8+2012-09-07-3
kmod-nls-base - 3.3.8-1
kmod-nls-cp437 - 3.3.8-1
kmod-nls-iso8859-1 - 3.3.8-1
kmod-nls-utf8 - 3.3.8-1
kmod-ppp - 3.3.8-1
kmod-rt2800-lib - 3.3.8+2012-09-07-3
kmod-rt2800-pci - 3.3.8+2012-09-07-3
kmod-rt2x00-lib - 3.3.8+2012-09-07-3
kmod-rt2x00-pci - 3.3.8+2012-09-07-3
kmod-scsi-core - 3.3.8-1
kmod-switch - 3.3.8-5
kmod-usb-core - 3.3.8-1
kmod-usb-ohci - 3.3.8-1
kmod-usb-storage - 3.3.8-1
kmod-usb-uhci - 3.3.8-1
kmod-usb2 - 3.3.8-1
libblkid - 2.21.2-1
libblobmsg-json - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
libbz2 - 1.0.6-1
libc - 0.9.33.2-1
libcurl - 7.29.0-1
libexpat - 2.0.1-1
libffi - 3.0.10-1
libfreetype - 2.4.8-1
libgcc - 4.6-linaro-1
libgmp - 4.3.1-2
libip4tc - 1.4.10-4
libiwinfo - 36
libiwinfo-lua - 36
libjpeg - 6b-1
libjs - 1.6.20070208-2
libjson - 0.9-2
libleptonica - 1.68-1
liblua - 5.1.4-8
libmount - 2.21.2-1
libncurses - 5.7-5
libnl-tiny - 0.1-3
libopenssl - 1.0.1e-1
libpcre - 8.11-2
libpng - 1.2.46-2
libpq - 9.0.1-3
libpthread - 0.9.33.2-1
libreadline - 5.2-2
librt - 0.9.33.2-1
libsqlite3 - 3071201-1
libstdcpp - 4.6-linaro-1
libtiff - 4.0.3-1
libubox - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
libubus - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
libubus-lua - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
libuci - 2013-01-04.1-1
libuci-lua - 2013-01-04.1-1
libusb-1.0 - 1.0.9-1
libuuid - 2.21.2-1
libxml2 - 2.7.8-2
libxtables - 1.4.10-4
lsqlite3 - 7-2
lua - 5.1.4-8
luasql-sqlite3 - 2.1.1-1
luci - 0.11.1-1
luci-app-commands - 0.11.1-1
luci-app-ddns - 0.11.1-1
luci-app-firewall - 0.11.1-1
luci-app-wol - 0.11.1-1
luci-i18n-english - 0.11.1-1
luci-i18n-spanish - 0.11.1-1
luci-lib-core - 0.11.1-1
luci-lib-ipkg - 0.11.1-1
luci-lib-nixio - 0.11.1-1
luci-lib-sys - 0.11.1-1
luci-lib-web - 0.11.1-1
luci-mod-admin-core - 0.11.1-1
luci-mod-admin-full - 0.11.1-1
luci-proto-core - 0.11.1-1
luci-proto-ppp - 0.11.1-1
luci-sgi-cgi - 0.11.1-1
luci-theme-base - 0.11.1-1
luci-theme-bootstrap - 0.11.1-1
luci-theme-openwrt - 0.11.1-1
mount-utils - 2.21.2-1
mtd - 18.1
nano - 2.2.6-1
netifd - 2013-01-29.2-4bb99d4eb462776336928392010b372236ac3c93
ntfs-3g - 2011.4.12-1-fuseint
opkg - 618-3
php5 - 5.4.5-3
php5-mod-sqlite3 - 5.4.5-3
ppp - 2.4.5-8
pyload - 0.4.8-1
pyopenssl - 0.10-1
python - 2.7.3-1
python-crypto - 2.0.1-1
python-curl - 7.19.0-1
python-django - 1.3.1-1
python-expat - 2.7.3-1
python-imaging-library - 1.1.7-2
python-mini - 2.7.3-1
python-sqlite3 - 2.7.3-1
robocfg - 0.01-1
shadow-common - 4.1.5.1-1
shadow-su - 4.1.5.1-1
sqlite3-cli - 3071201-1
swap-utils - 2.21.2-1
terminfo - 5.7-5
tesseract - 3.01-1
ubus - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
ubusd - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
uci - 2013-01-04.1-1
uclibcxx - 0.2.4-1
uhttpd - 2012-10-30-e57bf6d8bfa465a50eea2c30269acdfe751a46fd
unrar - 4.0.7-1
usbreset - 2
usbutils - 005-1
vsftpd - 3.0.2-1
wireless-tools - 29-5
wpad-mini - 20120910-1
zlib - 1.2.7-1


Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #6 en: 10-07-2013, 13:05 (Miércoles) »
Según he leído por ahí, es posible que sea un problema de la versión de python que se usa.
Estás trabajando con una versión 'antigua' de pyload y con una 'moderna' de python: http://forum.qnap.com/viewtopic.php?p=186361

Se me ocurre que intentes probar con la nueva (sin desinstalar, de momento) la antigua.

A ver si puedo indicarte de forma correcta el proceso ...

Conexión ssh desde putty.

Si no tienes instalado wget y unzip, instálalos con:

Código: [Seleccionar]
opkg update
opkg install wget unzip

Te posicionas donde tienes montado el pendrive o disco duro, bajas pyload 0.49 y lo descomprimes:

Código: [Seleccionar]
cd /mnt/disco_duro
wget http://download.pyload.org/pyload-src-v0.4.9.zip
unzip pyload-src-v0.4.9.zip

Ahora lo lanzas con el siguiente comando:

Código: [Seleccionar]
/mnt/disco_duro/pyload/pyLoadCore -s
"disco_duro" debes cambiarlo por el nombre con el que montes tu disco  ;)

Ya me dirás ...  ;)
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

frankcis81

  • Visitante
Re: Pyload en HG556a
« Respuesta #7 en: 10-07-2013, 14:10 (Miércoles) »
Buenas

He seguido las instrucciones que me has dado y el error que de devuelve es el mismo.  :-[

Creo que me voy a quedar con las ganas, jejeje.  >:D

Gracias de verdad por tu tiempo.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #8 en: 11-07-2013, 09:25 (Jueves) »
Otro intento.

Desinstala sqlite3-cli y python-mini

Código: [Seleccionar]
opkg remove sqlite3-cli python-mini
Instalas los mismos paquetes, pero de la versión trunk:

Código: [Seleccionar]
opkg update
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/sqlite3-cli_3071201-1_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-mini_2.7.3-2_brcm63xx.ipk

Y vuelves a probar.

Si no te funciona ejecuta:

Código: [Seleccionar]
python systemCheck.py
Y postea por aquí el resultado.
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #9 en: 11-07-2013, 10:28 (Jueves) »
Ignora mi mensaje anterior.

Fuerza la instalación de las versiones más nueva de python-sqlite3 y python-mini. Con eso debería funcionar.

Código: [Seleccionar]
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-mini_2.7.3-2_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-sqlite3_2.7.3-2_brcm63xx.ipk

Si quieres usar la última versión de pyload, recuerda que debes arrancarlo con desde la ruta en que lo instalaste 'manualmente'.

Ya me contarás ...

Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #10 en: 11-07-2013, 12:22 (Jueves) »
Le he puesto un par de enlaces (de putlocker y uploaded ) y parece que funciona ....  >:(

He localizado un webui más 'decente' que el que incluye por defecto.

Versión windows: http://spambri.de/pyloadgui/pyloadgui-0.1.7z
Versiones varias: http://spambri.de/pyloadgui/
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

frankcis81

  • Visitante
Re: Pyload en HG556a
« Respuesta #11 en: 11-07-2013, 13:27 (Jueves) »
Bueno pues despues de mucha pelea ya esta funcionando!  >:( >:( >:( >:(



Te vuelvo a repetir lo mismo, muchas gracias por tu tiempo y por tu inestimable ayuda, con personas como tu da gusto pedir un poco de ayuda cuando te quedas "atascado".

Ahora voy a ver si configuro un par de cosas mas (Vsftpd ddns, y la funcion de convertirlo en AP del otro router de Vodafone) y ya tengo lo que necesito.  ;D

A punto estuve ayer por dejarlo por imposible y haberme comprado una raspberry pi para lo mismo, jejeje.

Un Saludo y gracias 1000

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #12 en: 11-07-2013, 13:44 (Jueves) »
Voy a tenerlo en 'observación' un par de semanas a ver si los enlaces (testearé varios servers) siguen bajando.

Si es estable y se siguen actualizando los plugins, igual escribo un pequeño tutorial para la instalación/configuración  ;)

Bueno pues despues de mucha pelea ya esta funcionando!  >:( >:( >:( >:(

Te vuelvo a repetir lo mismo, muchas gracias por tu tiempo y por tu inestimable ayuda, con personas como tu da gusto pedir un poco de ayuda cuando te quedas "atascado".

Ahora voy a ver si configuro un par de cosas mas (Vsftpd ddns, y la funcion de convertirlo en AP del otro router de Vodafone) y ya tengo lo que necesito.  ;D

A punto estuve ayer por dejarlo por imposible y haberme comprado una raspberry pi para lo mismo, jejeje.

Un Saludo y gracias 1000

Un placer, haberte podido ayudar. Para eso estamos por aquí  ;)

Rendirse ... ?

Eso nunca  8)
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

hloro7

  • Visitante
Re: Pyload en HG556a
« Respuesta #13 en: 03-02-2014, 12:01 (Lunes) »
Hola

edito: para añadir que lo tengo con extroot en un disco usb
Quiero usar este router con openwrt para descargar con transmission y pyload, y compartirlo con samba, no necesito wifi. Tengo todo funcionando, pero no puedo hacer que pyload funcione, ademas de que no he sido capaz de encontrar un manual para instalar pyload en openwrt, puede que solo necesite eso.

No me importaria que me guiaseis desde el principio y volver a instalar firmware limpio y documentar la instalacion de pyload para que sea util para otros users.

He probado con varios firmwares del hilo oficial del 556a y deduciendo los paquetes para instalar pyload de este mismo hilo. Pero al intentar hacer hacer la instalacion con pyloadCore.py -s obtengo el error:
Traceback (most recent call last):
  File "./pyLoadCore.py", line 30, in <module>
    import logging
  File "/usr/lib/python2.7/logging/__init__.py", line 94, in <module>
    _startTime = time.time()
IOError: [Errno 11] Resource temporarily unavailable


Los paquetes que tengo instalados son los siguientes:
6relayd - 2013-10-21-ad00c3dd9ee42f172870708724858ab502b3a689
aircrack-ng - 1.1-3
aircrack-ptw - 1.0.0-1

base-files - 149-r39139
blinkled - 0.0.1-1
blkid - 2.21.2-2
block-mount - 2013-12-09-0c6d5bd1fc1fd28c71290610faeee11b399c869a
bonniexx - 1.96-1
bully - 1.0-22
busybox - 1.19.4-7
bwping - 1.4-1
chat - 2.4.5-10
cifsmount - 5.4-1
comgt - 0.32-21
crda - 1.1.2-1
ddns-scripts - 1.0.0-22
dhcp6-server - 1.0-1
dnsmasq - 2.66-5
dnsmasq-dhcpv6 - 2.66-5
dropbear - 2013.59-1
dsniff - 2.4b1-3
e2fsprogs - 1.42.4-1
etherwake - 1.09-3
ethtool - 3.7-1
fdisk - 2.21.2-2
firewall - 2013-12-17
giflib - 4.1.6-1
glib2 - 2.37.7-1
hd-idle - 1.04-1
hdparm - 9.39-1
hostapd-common - 20131120-1
hostapd-utils - 20131120-1
httping - 1.5.2-1
imapfilter - 2.2.2-1
ip - 3.11.0-1
ip6tables - 1.4.20-1
iptables - 1.4.20-1
iptables-mod-conntrack-extra - 1.4.20-1
iptables-mod-ipopt - 1.4.20-1
iw - 3.10-1
js - 1.6.20070208-2
jshn - 2013-12-02-318d682d29a8974aa53bd7dc523f1514eb0eddb9
kernel - 3.10.24-1-df54115339cbceb6622ff9680b7233a2
kmod-ath - 3.10.24+2013-11-05-5
kmod-ath9k - 3.10.24+2013-11-05-5
kmod-ath9k-common - 3.10.24+2013-11-05-5
kmod-button-hotplug - 3.10.24-3
kmod-cfg80211 - 3.10.24+2013-11-05-5
kmod-crypto-aes - 3.10.24-1
kmod-crypto-arc4 - 3.10.24-1
kmod-crypto-core - 3.10.24-1
kmod-crypto-des - 3.10.24-1
kmod-crypto-ecb - 3.10.24-1
kmod-crypto-hash - 3.10.24-1
kmod-crypto-hmac - 3.10.24-1
kmod-crypto-manager - 3.10.24-1
kmod-crypto-md4 - 3.10.24-1
kmod-crypto-md5 - 3.10.24-1
kmod-crypto-pcompress - 3.10.24-1
kmod-crypto-sha256 - 3.10.24-1
kmod-eeprom-93cx6 - 3.10.24-1
kmod-fs-cifs - 3.10.24-1
kmod-fs-ext4 - 3.10.24-1
kmod-fs-isofs - 3.10.24-1
kmod-fs-udf - 3.10.24-1
kmod-fs-vfat - 3.10.24-1
kmod-input-core - 3.10.24-1
kmod-input-gpio-keys-polled - 3.10.24-1
kmod-input-polldev - 3.10.24-1
kmod-ip6tables - 3.10.24-1
kmod-ipt-conntrack - 3.10.24-1
kmod-ipt-conntrack-extra - 3.10.24-1
kmod-ipt-core - 3.10.24-1
kmod-ipt-ipopt - 3.10.24-1
kmod-ipt-nat - 3.10.24-1
kmod-ipt-nathelper - 3.10.24-1
kmod-ipv6 - 3.10.24-1
kmod-leds-gpio - 3.10.24-1
kmod-ledtrig-default-on - 3.10.24-1
kmod-ledtrig-gpio - 3.10.24-1
kmod-ledtrig-netdev - 3.10.24-1
kmod-ledtrig-usbdev - 3.10.24-1
kmod-lib-crc-ccitt - 3.10.24-1
kmod-lib-crc-itu-t - 3.10.24-1
kmod-lib-crc16 - 3.10.24-1
kmod-lib-zlib - 3.10.24-1
kmod-lib80211 - 3.10.24+2013-11-05-5
kmod-libertas-usb - 3.10.24+2013-11-05-5
kmod-loop - 3.10.24-1
kmod-mac80211 - 3.10.24+2013-11-05-5
kmod-nls-base - 3.10.24-1
kmod-p54-common - 3.10.24+2013-11-05-5
kmod-p54-usb - 3.10.24+2013-11-05-5
kmod-ppp - 3.10.24-1
kmod-pppoe - 3.10.24-1
kmod-pppox - 3.10.24-1
kmod-rt2500-usb - 3.10.24+2013-11-05-5
kmod-rt2800-lib - 3.10.24+2013-11-05-5
kmod-rt2800-mmio - 3.10.24+2013-11-05-5
kmod-rt2800-pci - 3.10.24+2013-11-05-5
kmod-rt2800-usb - 3.10.24+2013-11-05-5
kmod-rt2x00-lib - 3.10.24+2013-11-05-5
kmod-rt2x00-mmio - 3.10.24+2013-11-05-5
kmod-rt2x00-pci - 3.10.24+2013-11-05-5
kmod-rt2x00-usb - 3.10.24+2013-11-05-5
kmod-rt73-usb - 3.10.24+2013-11-05-5
kmod-rtl8192c-common - 3.10.24+2013-11-05-5
kmod-rtl8192cu - 3.10.24+2013-11-05-5
kmod-rtlwifi - 3.10.24+2013-11-05-5
kmod-rtlwifi-usb - 3.10.24+2013-11-05-5
kmod-scsi-core - 3.10.24-1
kmod-scsi-generic - 3.10.24-1
kmod-slhc - 3.10.24-1
kmod-tun - 3.10.24-1
kmod-usb-core - 3.10.24-1
kmod-usb-ohci - 3.10.24-1
kmod-usb-storage - 3.10.24-1
kmod-usb-storage-extras - 3.10.24-1
kmod-usb2 - 3.10.24-1
kmod-zd1211rw - 3.10.24+2013-11-05-5
libblkid - 2.21.2-2
libblobmsg-json - 2013-12-02-318d682d29a8974aa53bd7dc523f1514eb0eddb9
libbz2 - 1.0.6-1
libc - 0.9.33.2-1
libcurl - 7.33.0-4
libcyassl - 2.8.0-1
libdaemon - 0.14-2
libelf1 - 0.155-1
libevent2 - 2.0.21-1
libexpat - 2.0.1-1
libext2fs - 1.42.4-1
libffi - 3.0.11-1
libfreetype - 2.4.8-1
libgcc - 4.6-linaro-1
libgdbm - 1.10-1
libgmp - 5.1.0-1
libintl-full - 0.18.2.1-1
libip4tc - 1.4.20-1
libip6tc - 1.4.20-1
libiwinfo - 47
libiwinfo-lua - 47
libjpeg - 6b-1
libjs - 1.6.20070208-2
libjson-c - 0.11-2
libjson-script - 2013-12-02-318d682d29a8974aa53bd7dc523f1514eb0eddb9
libleptonica - 1.68-1
liblua - 5.1.5-1
liblzo - 2.06-1
libminiupnpc - 1.8-1
libncurses - 5.9-1
libnet0 - 1.0.2a-8
libnet1 - 1.1.6-1
libnfnetlink - 1.0.1-1
libnids - 1.24-1
libnl-tiny - 0.1-3
libopenssl - 1.0.1e-2
libpcap - 1.3.0-1
libpcre - 8.11-2
libpng - 1.2.50-1
libpolarssl - 1.2.9-1
libpthread - 0.9.33.2-1
libreadline - 6.2-1
librpc - 0.9.32-rc2-0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
librt - 0.9.33.2-1
libsqlite3 - 3071201-1
libstdcpp - 4.6-linaro-1
libtiff - 4.0.3-1
libubox - 2013-12-02-318d682d29a8974aa53bd7dc523f1514eb0eddb9
libubus - 2013-11-07-8ea96670367e5dd23988b51ee4f0f790393effaf
libubus-lua - 2013-11-07-8ea96670367e5dd23988b51ee4f0f790393effaf
libuci - 2013-12-02.1-1
libuci-lua - 2013-12-02.1-1
libusb-1.0 - 1.0.9-1
libustream-cyassl - 2013-10-30-1dc753d6438121ef4cc57b185ea340c082d362c6
libuuid - 2.21.2-2
libxtables - 1.4.20-1
lmbench - 3.0-a9-1
lmbench-bw-file-rd - 3.0-a9-1
lmbench-bw-mem - 3.0-a9-1
lmbench-bw-tcp - 3.0-a9-1
lmbench-cache - 3.0-a9-1
lmbench-disk - 3.0-a9-1
lmbench-lat-dram-page - 3.0-a9-1
lmbench-lat-http - 3.0-a9-1
lmbench-lat-mem-rd - 3.0-a9-1
lmbench-lat-mmap - 3.0-a9-1
lmbench-lat-udp - 3.0-a9-1
lmbench-memsize - 3.0-a9-1
lmbench-mhz - 3.0-a9-1
lmbench-tlb - 3.0-a9-1
lua - 5.1.5-1
luci - svn-r9945-1
luci-app-ddns - svn-r9945-1
luci-app-diag-core - svn-r9945-1
luci-app-diag-devinfo - svn-r9945-1
luci-app-firewall - svn-r9945-1
luci-app-hd-idle - svn-r9945-1
luci-app-multiwan - svn-r9945-1
luci-app-ntpc - svn-r9945-1
luci-app-radvd - svn-r9945-1
luci-app-upnp - svn-r9945-1
luci-app-wol - svn-r9945-1
luci-i18n-english - svn-r9945-1
luci-i18n-spanish - svn-r9945-1
luci-lib-core - svn-r9945-1
luci-lib-ipkg - svn-r9945-1
luci-lib-nixio - svn-r9945-1
luci-lib-sys - svn-r9945-1
luci-lib-web - svn-r9945-1
luci-mod-admin-core - svn-r9945-1
luci-mod-admin-full - svn-r9945-1
luci-proto-3g - svn-r9945-1
luci-proto-core - svn-r9945-1
luci-proto-ppp - svn-r9945-1
luci-proto-relay - svn-r9945-1
luci-sgi-cgi - svn-r9945-1
luci-sgi-uhttpd - svn-r9945-1
luci-ssl - svn-r9945-1
luci-theme-base - svn-r9945-1
luci-theme-bootstrap - svn-r9945-1
mac-to-devinfo - 1.0.0-2
macchanger - 1.5.0-1
mc - 4.8.10-1
miniupnpd - 1.8.20130426-1
msmtp - 1.4.27-1
mtd - 20
multiwan - 1.0.22-2
nbtscan - 1.5.1
netdiscover - 0.3-beta6-3
netdiscover-to-devinfo - 1.0.0-2
netifd - 2013-12-16-1a770b186b4bc9e714dbdd30d0c41ea471fa8245
ntpclient - 2007_365-4
odhcp6c - 2013-12-15-be05c0ded0257cbb82857f6d01226ef6de28befe
openvpn-openssl - 2.3.2-3
opkg - 618-6
pciutils - 3.2.0-1
ppp - 2.4.5-10
ppp-mod-pppoe - 2.4.5-10
procd - 2013-12-18-2dc572df0e3002263c0a49ebbc329ed1b6c42a01
procps - 3.2.8-1
procps-pkill - 3.2.8-1
pure-ftpd - 1.0.36-1
px5g - 1
pyopenssl - 0.10-1
python - 2.7.3-2
python-crypto - 2.6-1
python-curl - 7.19.0-1
python-django - 1.3.1-1
python-expat - 2.7.3-2
python-imaging-library - 1.1.7-2
python-mini - 2.7.3-2
python-openssl - 2.7.3-2
python-sqlite3 - 2.7.3-2
radvd - 1.9.1-2
relayd - 2011-10-24-4e8f1fa4ca2b176500362843a9e57ea5abd4b7a3
rt-speedtest - 6
samba36-server - 3.6.11-2
screen - 4.0.3-3
sdparm - 1.04-1
smap - 0.6.0-2
smap-to-devinfo - 1.0.0-2
sqlite3-cli - 3071201-1
swap-utils - 2.21.2-2
swconfig - 10
tcpdump - 4.2.1-3
terminfo - 5.9-1
tesseract - 3.01-1
traceroute6 - 1.0.2-1
transmission-daemon - 2.82-1
transmission-remote - 2.82-1
transmission-web - 2.82-1
ubox - 2013-12-09-0c6d5bd1fc1fd28c71290610faeee11b399c869a
ubus - 2013-11-07-8ea96670367e5dd23988b51ee4f0f790393effaf
ubusd - 2013-11-07-8ea96670367e5dd23988b51ee4f0f790393effaf
uci - 2013-12-02.1-1
uclibcxx - 0.2.4-1
udev - 173-1
uhttpd - 2013-11-21-cd66639800ee2882a0867ec54868502eb9b893d8
uhttpd-mod-lua - 2013-11-21-cd66639800ee2882a0867ec54868502eb9b893d8
uhttpd-mod-ubus - 2013-11-21-cd66639800ee2882a0867ec54868502eb9b893d8
unrar - 4.0.7-1
unzip - 5.52-1
usbutils - 007-1
wavemon - 0.7.5-1
wget - 1.14-1
wireless-tools - 29-5
wpad-mini - 20131120-1
zlib - 1.2.8-1


Por otro lado, despues de instalar los ultimos paquetes de python, al ejecutar "opkg update", obtengo el error, error que no se producia antes de instalar los paquetes para pyload
opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/Packages.gz.
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/Packages.gz, wget returned 4.


gracias por adelantado y por vuestro tiempo
« Última modificación: 03-02-2014, 12:03 (Lunes) por hloro7 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #14 en: 03-02-2014, 12:38 (Lunes) »
Lo curioso es que en la relación de paquetes instalados no tienes pyload  ???

Actualmente, la versión 0.50 está en desarrollo. Si algún día terminan con ella, prometo un tutorial para su instalación paso a paso.

Por otro lado, yo te recomendaría usar rtorrent + rutorrent en lugar de transmission  ;)
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

hloro7

  • Visitante
Re: Pyload en HG556a
« Respuesta #15 en: 03-02-2014, 13:30 (Lunes) »
Lo curioso es que en la relación de paquetes instalados no tienes pyload  ???
-Baje la version 0.50, descomprimi y ejecute directamente, ..... creo que volvere a instalar el firmware y probare con la version estable

Actualmente, la versión 0.50 está en desarrollo. Si algún día terminan con ella, prometo un tutorial para su instalación paso a paso.

Por otro lado, yo te recomendaría usar rtorrent + rutorrent en lugar de transmission  ;)
si, ya lei que era mas ligero, en cuanto tenga funcionando pyload, creo que cambiare, gracias


Contesto en negrita,
en cuanto al manual para instalar, ¿simplemente seria opkg install pyload, se instalarian automaticamente los paquetes necesarios o tendria que instalar alguno a mano?.... es que como comento no encuentro ningun manual para openwrt y pyload.....
gracias

frankcis81

  • Visitante
Re: Pyload en HG556a
« Respuesta #16 en: 03-02-2014, 14:32 (Lunes) »
Si te sirve de ayuda, lo que tengo montado yo en mi HG556a es,

- Como base el firmare 12.09 que esta en la pagina oficial de OpenWrt (https://files.myopera.com/danitool/linux/hg556a/hg556a_backport_12.09-luci.zip)

- Exroot y todo lo que necesites a tu gusto siguiendo el tutorial que me facilito jar229 (https://foro.seguridadwireless.net/openwrt/instalacion-de-openwrt-y-mas-en-wrt160nl/)

- Instalacion de python-sqlite3 y python-mini

opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-mini_2.7.3-2_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-sqlite3_2.7.3-2_brcm63xx.ipk

- La ultima version stable de Pyload (http://download.pyload.org/pyload-src-v0.4.9.zip), configurandola para que se arrancara al iniciar el sistema.

Siguiendo estos pasos y con la ayuda que me brindo Jar229 no tuve problemas a la hora de ponerlo en marcha.

« Última modificación: 03-02-2014, 14:35 (Lunes) por frankcis81 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: Pyload en HG556a
« Respuesta #17 en: 04-02-2014, 12:15 (Martes) »
Acabo de repetir el proceso (con el fin de más adelante testear la versión 0.50) y he tenido que forzar la instalación de libcurl: http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/libcurl_7.35.0-1_brcm63xx.ipk

De lo contrario, obtenía el siguiente error:

Código: [Seleccionar]
root@vr3025un:~# pyload
Fatal Python error: pycurl: libcurl link-time version is older than compile-time version
Aborted
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

hloro7

  • Visitante
Re: Pyload en HG556a
« Respuesta #18 en: 05-02-2014, 16:57 (Miércoles) »
Si te sirve de ayuda, lo que tengo montado yo en mi HG556a es,

- Como base el firmare 12.09 que esta en la pagina oficial de OpenWrt (https://files.myopera.com/danitool/linux/hg556a/hg556a_backport_12.09-luci.zip)

- Exroot y todo lo que necesites a tu gusto siguiendo el tutorial que me facilito jar229 (https://foro.seguridadwireless.net/openwrt/instalacion-de-openwrt-y-mas-en-wrt160nl/)

- Instalacion de python-sqlite3 y python-mini

opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-mini_2.7.3-2_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-sqlite3_2.7.3-2_brcm63xx.ipk

- La ultima version stable de Pyload (http://download.pyload.org/pyload-src-v0.4.9.zip), configurandola para que se arrancara al iniciar el sistema.

Siguiendo estos pasos y con la ayuda que me brindo Jar229 no tuve problemas a la hora de ponerlo en marcha.


Claro que me ayuda!! gracias frankcis81
 ;)

hloro7

  • Visitante
Re: Pyload en HG556a
« Respuesta #19 en: 05-02-2014, 17:06 (Miércoles) »
Ahora escribo como lo he conseguido yo. BASADO en las instrucciones de frankcis81

- Como base el firmare 12.09 que esta en la pagina oficial de OpenWrt (https://files.myopera.com/danitool/linux/hg556a/hg556a_backport_12.09-luci.zip)

- Exroot y todo lo que necesites a tu gusto siguiendo el tutorial que me facilito jar229 (https://foro.seguridadwireless.net/openwrt/instalacion-de-openwrt-y-mas-en-wrt160nl/)


- Instalacion de python y dependencias varias.

opkg update   para asegurar de que todo esta actualizado.

opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-mini_2.7.3-2_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/libsqlite3_3071201-1_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/libffi_3.0.11-1_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python_2.7.3-2_brcm63xx.ipk
opkg install http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/python-sqlite3_2.7.3-2_brcm63xx.ipk


opkg install pyload (se instalara la version 0.4.8.1) y bastantes modulos que necesita

Descargo la ultima version estable de Pyload (http://download.pyload.org/pyload-src-v0.4.9.zip)
Descomprimo y ejecuto el fichero descomprimido con "-s" para la configuracion inicial.
Un sintoma de que "funciona" correctamente es que en la primera ejecucion, comienza a actualizar los plugin de los servidores: rapidsahre, uploade, etc nunca lo habia conseguido

Gracias por la ayuda

PD: ¿como configurar pyload 0.4.9 para que arranque al inicio del sistema? pues, ahora mismo lo ejecuto en un terminal a mano

//FINAL Y MÁS DOS RESPUESTAS