Autor Tema: Problema netgear R8000  (Leído 1899 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Next13

  • Visitante
Problema netgear R8000
« en: 13-06-2017, 16:07 (Martes) »
Buenas tardes, este mi primero post,muchas gracias por vuestro trabajo, antes de hacer la consulta he estado mirando google y probado modo failsafe……..  tengo un router netgear R8000 que instalé por error la imagen trunk openwrt-bcm53xx-netgear-r8000-squashfs  en lugar de la imagen openwrt-15.05.1-bcm53xx-netgear-r8000-squashfs , he utilizado el software putty y winscp.
Accedí por winscp a la carperta /tmp y coloque el firmware original para instalar desde putty
ejecute
cd /tmp
mtd -r write /tmp/netgear-r8000.bin firmware

Empezo a hacer instalación, pero no terminó, el led de encendido queda intermitente y solo puedo acceder a través del puerto seríe, donde no me deja hacer nada solo carga parte y termina con este mensaje:
FE for Foxconn Router R8000 version: v1.0.8
Build Date: Fri May 30 15:03:06 CST 2014
Init Arena
Init Devs.
Boot up from NAND flash...
Bootcode Boot partition size = 524288(0x80000)
DDR Clock: 800 MHz
Info: DDR frequency set from clkfreq=1000,*800*
et2: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.43.2 (r474543)
CPU type 0x0: 1000MHz
Tot mem: 262144 KBytes

Device eth0:  hwaddr 00-00-00-00-00-00, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Checking crc...Boot program checksum is invalid
Device eth0 has been deactivated.
Device eth0:  hwaddr 00-00-00-00-00, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Start TFTP server
Reading ::

Alguien me puede ayudar.
Muchas gracias

Un saludo



Next13

  • Visitante
Re: Problema netgear R8000
« Respuesta #1 en: 13-06-2017, 21:38 (Martes) »
Buenas, he solucionado el problema, desde consola cmd Windows, ya tenía activado cliente TFTP
Creé carpeta temp en C:\
Guarde firmware openwrt con luci: openwrt-15.05.1-bcm53xx-netgear-r8000-squashfs
Desenchufe router de la corriente unos segundos.
Asigne al PC una IP ej: 192.168.1.100, máscara 255.255.255.0
Abrí una consola cmd como administrador  ping continuo: ping -t 192.168.1.1
Segunda consola cmd para ejecutar comando
tftp -i 192.168.1.1 put openwrt-15.05.1-bcm53xx-netgear-r8000-squashfs.
Cuando se ejecuta ping continuo nos aparecen primeras líneas son resultado de enviar ping al router estando éste apagado o reiniciándose. Las 3 siguientes, que llevan el TTL=100 son resultado de arrancar el router en modo debug, aceptando por tanto cualquier actualización de firmware. Las 3 últimas (TTL=64) ya indican que ese modo ya ha sido deshabilitado y por tanto comienza el arranque normal. Por tanto, el objetivo es ejecutar la orden tftp cuando el punto de acceso esté respondiendo pings con TTL=100.

C:\temp>
C:\temp>tftp -i 192.168.1.1 put openwrt-15.05.1-bcm53xx-netgear-r8000-squashfs.chk
Transferencia correcta: 7733306 bytes en 7 segundo(s), 1104758 bytes/s

Despues se reinicia router y accedí a la interfaz luci......

Saludos

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2075
Re: Problema netgear R8000
« Respuesta #2 en: 14-06-2017, 09:28 (Miércoles) »
Buenas, he solucionado el problema, desde consola cmd Windows, ya tenía activado cliente TFTP
Creé carpeta temp en C:\
Guarde firmware openwrt con luci: openwrt-15.05.1-bcm53xx-netgear-r8000-squashfs
Desenchufe router de la corriente unos segundos.
Asigne al PC una IP ej: 192.168.1.100, máscara 255.255.255.0
Abrí una consola cmd como administrador  ping continuo: ping -t 192.168.1.1
Segunda consola cmd para ejecutar comando
tftp -i 192.168.1.1 put openwrt-15.05.1-bcm53xx-netgear-r8000-squashfs.
Cuando se ejecuta ping continuo nos aparecen primeras líneas son resultado de enviar ping al router estando éste apagado o reiniciándose. Las 3 siguientes, que llevan el TTL=100 son resultado de arrancar el router en modo debug, aceptando por tanto cualquier actualización de firmware. Las 3 últimas (TTL=64) ya indican que ese modo ya ha sido deshabilitado y por tanto comienza el arranque normal. Por tanto, el objetivo es ejecutar la orden tftp cuando el punto de acceso esté respondiendo pings con TTL=100.

C:\temp>
C:\temp>tftp -i 192.168.1.1 put openwrt-15.05.1-bcm53xx-netgear-r8000-squashfs.chk
Transferencia correcta: 7733306 bytes en 7 segundo(s), 1104758 bytes/s

Despues se reinicia router y accedí a la interfaz luci......

Saludos


Gracias por el aporte. Seguro que a más de uno le sirven los pasos que has seguido para recuperar el router.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

//FINAL Y MÁS DOS RESPUESTAS