Autor Tema: Problema modo repetidor AR5387un  (Leído 3939 veces)

0 Usuarios y 1 Visitante están viendo este tema.

~mary~

  • Visitante
Problema modo repetidor AR5387un
« en: 24-01-2015, 11:10 (Sábado) »
Hola, estoy intentando usar este router como repetidor de otro router que no tiene openwrt.

El router principal esta en: 192.168.0.1
El AR5387un: 192.168.10.1

wireless:
Código: [Seleccionar]
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11ng'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0/bcma0:0'
option htmode 'HT20'
list ht_capab 'GF'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
option channel '2'
option txpower '19'
option country '00'

config wifi-iface
option network 'wwan'
option ssid 'RED_WIFI_ROUTER_NEUTRO'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid 'AQUI_MAC'
option key 'AQUI_PASS'

config wifi-iface
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
option network 'lan'
option disabled '1'

Como se puede apreciar la red openwrt la tengo desactivada, de esta forma el router y los pcs conectados mediante cable tienen internet. Pero en el momento que borro esa linea y reinicio, no puedo conectarme a la nueva red(openwrt) un dmesg sobre el equipo cliente me muestra:

[ 3857.310078] wlan0: send auth to MAC (try 1/3)
[ 3857.333513] wlan0: send auth to MAC (try 2/3)
[ 3857.362990] wlan0: send auth to MAC (try 3/3)
[ 3857.388027] wlan0: authentication with MAC timed out

Si pruebo a conectarme por cable al AR5387 con ip estática me conecto y puedo ver que en luci ambas redes me las muestra como master, y si me intento conectar con DHCP se queda en obteniendo IP.


network
Código: [Seleccionar]
config interface 'loopback'
    option ifname 'lo'
        option proto 'static'
            option ipaddr '127.0.0.1'
                option netmask '255.0.0.0'
               
                config interface 'lan'
                    option ifname 'eth0'
                        option type 'bridge'
                            option proto 'static'
                                option ipaddr '192.168.10.1'
                                    option gateway '192.168.0.1'   # Your main router's IP
                                        option netmask '255.255.255.0'
                                            option dns     '192.168.0.1'
                                           
                                            config interface 'wwan'
                                                option proto 'static'
                                                    option ipaddr '192.168.0.254' #match you main router network 192.168.x.254
                                                        option netmask '255.255.255.0'
                                                            option gateway '192.168.0.1'   #your main router's IP
                                                           
                                                            config 'interface' 'stabridge'
                                                                option 'proto' 'relay'
                                                                    option 'network' 'lan wwan'
                                                                        option ipaddr '192.168.0.254' #Same IP as in WWAN

Dhcp:
Código: [Seleccionar]
config dhcp lan
    option interface    lan
    option start     100
    option limit    150
    option leasetime    12h
    option force    1
                   
config dhcp wan
    option interface    wan
    option ignore    1

Alguna idea? Gracias



popeye7

  • Visitante
Re: Problema modo repetidor AR5387un
« Respuesta #1 en: 24-01-2015, 12:18 (Sábado) »
Hola , el rango de ip del AR5387un tiene que ser distinto del router principal ,por ejemplo 192.168.3.1.

Te voy  a dar unas directrices de como yo lo conseguí( apto solo para novatos como yo) :

- te hace falta un adaptador usb , en mi caso utilicé uno con chip atheros ar9271

- una vez instalado el firmware


https://mega.co.nz/#!PlBUDbiS!VaslB1PrOEHGsri2RfUtABI7w4fBJEl4zARmcuz6ZKk


abrimos luci , nos vamos a  networt -interfaces y cambiamos la ip por 192.168.3.1 ( si aplicas y guardas debes saber que tendrás que

modificar  en las propiedades ethernet  el protocolo de internet versión 4 (TCP/IPv4) en ese rango el:192.168.3.2.

- Una vez conectado el adaptador , en networkt wifi ,en radio 0 escanemos y nos unimos a la red ,ponemos contraseña guardar y aplicar.

Nos vamos de nuevo a wifi , le damos a add en radio 1 , le ponemos la clave ,encriptación y nombre que queramos , activamos la casilla lan y

tiene que estar en el modo acces point ,guardar y aplicar
 
-Ya deberia aparecer tu nueva red  .

Suerte

~mary~

  • Visitante
Re: Problema modo repetidor AR5387un
« Respuesta #2 en: 24-01-2015, 15:26 (Sábado) »
Hola,

el AR5387un ya está en otra subred 192.168.10.X

Me gustaría poder hacerlo sin un adaptador de red ya que el USB del router lo tengo ocupado y no me gustaría tener que gastar unos de los adaptadores para esto cuando se supone que sin él debería de funcionar.

Gracias de todas formas.

ruloalg

  • Visitante
Re: Problema modo repetidor AR5387un
« Respuesta #3 en: 24-01-2015, 15:32 (Sábado) »
Este router lleva broadcom, sin otro adaptador usb (o otro router) no se puede poner en repetidor

~mary~

  • Visitante
Re: Problema modo repetidor AR5387un
« Respuesta #4 en: 25-01-2015, 11:57 (Domingo) »
Hola, acabo de ver en:
http://wiki.openwrt.org/doc/recipes/guest-wlan

Note: Your hardware may not be capable of this. For example, the open source b43 driver for Broadcom hardware cannot have multiple SSIDs. You need to use the proprietary wl driver by Broadcom (with 2.6 kernel) - currently, you need to build the images yourself. — sup 2012/05/12 20:22. Worked with AR71xx + AR9280, Barrier Breaker r41336 (Kernel 3.10.36)

Y si compilo con el driver propietario si que podré no?

EDITO: no, no puedo. ya lo he probado.

esto probando lo que dice popeye7 pero con una imagen compilada por mi, consigo que se conecte a mi router principal, que me detecte el usb, pero:

si ejecuto un ifconfig no veo el nuevo wlan. mientras que si hago iwconfig si que lo veo mostrándome:

wlan1     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off

Pero no permite usarlo desde luci, alguna idea?
« Última modificación: 25-01-2015, 12:38 (Domingo) por ~mary~ »

Noltari

  • Visitante
Re: Problema modo repetidor AR5387un
« Respuesta #5 en: 25-01-2015, 13:36 (Domingo) »
El driver propietario no funciona nada bien en las últimas versiones de OpenWrt por lo obsoleto que está. Además, precisamente porque es una versión muy antigua no funciona con dispositivos bcm63xx que utilizan BCMA (BCM6328) en lugar de SSB, como es el caso del AR-5387un.

El mejor driver ahora mismo para este router es brcmsmac, ya que por lo menos funciona el modo N, no como b43.
Así que la única opción si quieres utilizar este router para tal propósito sería utilizar un WiFi USB (preferiblemente ath9k) junto con un HUB USB si tienes el USB ocupado.

También existe la alternativa de buscar otro router OpenWrt que lleve WiFi atheros.

Saludos.

~mary~

  • Visitante
Re: Problema modo repetidor AR5387un
« Respuesta #6 en: 25-01-2015, 15:23 (Domingo) »
El driver propietario no funciona nada bien en las últimas versiones de OpenWrt por lo obsoleto que está. Además, precisamente porque es una versión muy antigua no funciona con dispositivos bcm63xx que utilizan BCMA (BCM6328) en lugar de SSB, como es el caso del AR-5387un.

El mejor driver ahora mismo para este router es brcmsmac, ya que por lo menos funciona el modo N, no como b43.
Así que la única opción si quieres utilizar este router para tal propósito sería utilizar un WiFi USB (preferiblemente ath9k) junto con un HUB USB si tienes el USB ocupado.

También existe la alternativa de buscar otro router OpenWrt que lleve WiFi atheros.

Saludos.

He eliminado el dispositivo usb que tenía para intentar conectar un adaptador de red por usb en concreto uno que lleva el chip: rtl8192cu

Pero sigo sin conseguir que me lo reconozca como Wireless Controller, de hecho la interfaz wlan1 tengo que levantarla yo a mano cada vez que reinicio.

¿Sabes si es problema de este chipset o es que se necesita alguna configuración especial?

Muchas gracias.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4590
Re:
« Respuesta #7 en: 25-01-2015, 16:38 (Domingo) »
Lee las FAQ, está explicado como añadir un pincho WiFi USB.
De todas formas no tengo nada claro que ese chipset esté soportado en OpenWrt.

Enviado desde uno de mis 'cacharros' usando Tapatalk

Valoraciones positivas en compra/venta:
147 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1999
Re:
« Respuesta #8 en: 26-01-2015, 11:09 (Lunes) »
Lee las FAQ, está explicado como añadir un pincho WiFi USB.
De todas formas no tengo nada claro que ese chipset esté soportado en OpenWrt.

Enviado desde uno de mis 'cacharros' usando Tapatalk



El rtl8192cu, soportado está. Yo tengo pinchos con ese chipset y los reconoce y funciona, pero probarlos lo que se dice probarlos a fondo no lo he hecho.

@ ~mary~
Si dices que antes de borrarlo te funcionaba, supongo que tendrás los drivers para que lo reconozca. De todas formas mira si tienes instalado el módulo: kmod-rtl8192cu
Mira también en el log del sistema si te da algún error al pinchar el wifi con logread
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

//FINAL Y MÁS DOS RESPUESTAS