Autor Tema: Problema con TP-Link WR841N v:11.1  (Leído 3664 veces)

0 Usuarios y 1 Visitante están viendo este tema.

maikx

  • Visitante
Problema con TP-Link WR841N v:11.1
« en: 09-12-2016, 20:33 (Viernes) »
Hola buenas,
Adquirí este modelo de router y le instalé la version Trunk de Openwrt para esta versión y modelo de producto. Tras andar investigando y ver que no podia instalar Luci decidi volver el router a su firmware original y lo conseguí, instalando la última versión de firmware descargada de la página de Tp-link  apropiada para la versión del hardware del router, osea la v: 11. y hasta aqui todo bien , en principio.
El problema viene ahora cuando de nuevo quiero instalar Openwrt y parece que el router con su firmware original me está aplicando algun tipo de cortesía para que no pueda volver a cambiarlo, devolviéndome -> "Error Code : 18005 Upgrade unsuccessfully because de version of de upgraded file was incorrect. Please check the file name" . Y otras veces, aun habiendo elegido el archivo .bin correcto para el flasheo, simplemente me dice que no he elegido el archivo o no es valido .
Alguna pista ?
Soy algo nuevo en todo esto y espero no estar preguntando ninguna obviedad.
Un cordial saludo y gracias
   



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2075
Re: Problema con TP-Link WR841N v:11.1
« Respuesta #1 en: 10-12-2016, 07:44 (Sábado) »
Hola buenas,
Adquirí este modelo de router y le instalé la version Trunk de Openwrt para esta versión y modelo de producto. Tras andar investigando y ver que no podia instalar Luci decidi volver el router a su firmware original y lo conseguí, instalando la última versión de firmware descargada de la página de Tp-link  apropiada para la versión del hardware del router, osea la v: 11. y hasta aqui todo bien , en principio.
El problema viene ahora cuando de nuevo quiero instalar Openwrt y parece que el router con su firmware original me está aplicando algun tipo de cortesía para que no pueda volver a cambiarlo, devolviéndome -> "Error Code : 18005 Upgrade unsuccessfully because de version of de upgraded file was incorrect. Please check the file name" . Y otras veces, aun habiendo elegido el archivo .bin correcto para el flasheo, simplemente me dice que no he elegido el archivo o no es valido .
Alguna pista ?
Soy algo nuevo en todo esto y espero no estar preguntando ninguna obviedad.
Un cordial saludo y gracias
   


Mira la página oficial de openwrt, a ver si te aclara algo: https://wiki.openwrt.org/toh/tp-link/tl-wr841nd
Parece que el flasheo lo hace con TFTP y renombrando el fichero a flashear. ¿Es lo que has hecho tú?
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

maikx

  • Visitante
Re: Problema con TP-Link WR841N v:11.1
« Respuesta #2 en: 10-12-2016, 12:19 (Sábado) »
Hola y gracias por la respuesta Tki2000,
 te cuento que la primera vez cuando lo compré que lo flasheé, fue vía web server del propio router, instalándole el Openwrt como una actualización .
Ahora me he descargado el Tftd a  ver ...
Ya te voy contando, a ver si me aclaro...
Gracias de nuevo por el interés y un saludo
 

maikx

  • Visitante
Re: Problema con TP-Link WR841N v:11.1
« Respuesta #3 en: 10-12-2016, 13:34 (Sábado) »
Arreglado !!!!
Seguí los pasos de la página como me indicaste y a la primera !!!
Gracias

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2075
Re: Problema con TP-Link WR841N v:11.1
« Respuesta #4 en: 10-12-2016, 14:11 (Sábado) »
Arreglado !!!!
Seguí los pasos de la página como me indicaste y a la primera !!!
Gracias


 >:( >:( >:(
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

DarkD3v1L

  • Visitante
Re: Problema con TP-Link WR841N v:11.1
« Respuesta #5 en: 21-12-2016, 15:54 (Miércoles) »
Una simple pregunta.

Yo tengo este modelo de router tambien (V 11.1), en la pagina web de openwrt pone esto "You can use 15.05 images for v10 with sysupgrade -F, overriding the hardware check. "

Esto que quiere decir, que puedo meter la imagen de la version v10 tal cual? es que no entiendo a que se refiere con el comando sysupgrade -F.

Me gustaria tener openwrt con Luci a ser posible.

Gracias :D

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2075
Re: Problema con TP-Link WR841N v:11.1
« Respuesta #6 en: 22-12-2016, 08:45 (Jueves) »
Una simple pregunta.

Yo tengo este modelo de router tambien (V 11.1), en la pagina web de openwrt pone esto "You can use 15.05 images for v10 with sysupgrade -F, overriding the hardware check. "

Esto que quiere decir, que puedo meter la imagen de la version v10 tal cual? es que no entiendo a que se refiere con el comando sysupgrade -F.

Me gustaria tener openwrt con Luci a ser posible.

Gracias :D

La -F es para forzar. Si lo haces sin forzar, ya que la imagen es para la versión 10, te dirá que no es apta para ese router. Dado que ambos routers tienen el mismo hardware, y son compatibles, podemos forzar la instalación, obviando la comprobación de versión.
Para añadirle el parámetro -F tendrás que hacer el sysupgrade por consola SSH.
Pasa la imagen por SCP al directorio /tmp del router, abre una consola SSH, y después haz el sysupgrade desde la consola con el fichero que acabas de subir al router.

Para el SCP utiliza WinSCP.
Para la consola SSH, utiliza PuTTy.
Para el upgrade haz
Código: [Seleccionar]
sysupgrade -F /tmp/nombre_del_fichero_openwrt.bin
Arrebusca en el baúl de los recuerd..., digo busca con Google cómo se usan esos programas con openwrt, si no sabes cómo...  ;)

Si tienes alguna duda, pregunta por aquí...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

DarkD3v1L

  • Visitante
Re: Problema con TP-Link WR841N v:11.1
« Respuesta #7 en: 22-12-2016, 08:55 (Jueves) »
Una simple pregunta.

Yo tengo este modelo de router tambien (V 11.1), en la pagina web de openwrt pone esto "You can use 15.05 images for v10 with sysupgrade -F, overriding the hardware check. "

Esto que quiere decir, que puedo meter la imagen de la version v10 tal cual? es que no entiendo a que se refiere con el comando sysupgrade -F.

Me gustaria tener openwrt con Luci a ser posible.

Gracias :D

La -F es para forzar. Si lo haces sin forzar, ya que la imagen es para la versión 10, te dirá que no es apta para ese router. Dado que ambos routers tienen el mismo hardware, y son compatibles, podemos forzar la instalación, obviando la comprobación de versión.
Para añadirle el parámetro -F tendrás que hacer el sysupgrade por consola SSH.
Pasa la imagen por SCP al directorio /tmp del router, abre una consola SSH, y después haz el sysupgrade desde la consola con el fichero que acabas de subir al router.

Para el SCP utiliza WinSCP.
Para la consola SSH, utiliza PuTTy.
Para el upgrade haz
Código: [Seleccionar]
sysupgrade -F /tmp/nombre_del_fichero_openwrt.bin
Arrebusca en el baúl de los recuerd..., digo busca con Google cómo se usan esos programas con openwrt, si no sabes cómo...  ;)

Si tienes alguna duda, pregunta por aquí...

Muchas gracias, probare esta tarde a meterlo.

//FINAL Y MÁS DOS RESPUESTAS