Autor Tema: Problema con tarjeta de Audio USB  (Leído 5190 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ivallesp

  • Visitante
Problema con tarjeta de Audio USB
« en: 07-06-2014, 13:50 (Sábado) »
Hola gente,

Estoy peleándome con una tarjeta de Audio que he comprado por eBay. Es esta:

El caso es que tengo todas las dependencias instaladas pero no me aparece el dispositivo en /dev y al lanzar el comando lsusb me devuelve lo siguiente:

Código: [Seleccionar]
root@OpenWrt:~# lsusb
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 14cd:6116 Super Top M6116 SATA Bridge
Bus 001 Device 004: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
Bus 001 Device 006: ID 04f9:01a8 Brother Industries, Ltd DCP-130C
Bus 001 Device 007: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller

Osea que como veis lo detecta. Es el último (CM108).

Si lanzo ls /dev me devuelve esto:
Código: [Seleccionar]
root@OpenWrt:~# ls /dev
bus                        mtd2                mtdblock4           sda1
console                  mtd2ro              mtdblock5           sda2
cpu_dma_latency   mtd3                network_latency     sdb
full                        mtd3ro              network_throughput  shm
fuse                mtd4                null                tty
kmsg                mtd4ro              port                ttyS0
log                 mtd5                ppp                 urandom
mem                 mtd5ro              ptmx                usb
mtd0                mtdblock0           pts                 watchdog
mtd0ro              mtdblock1           random              zero
mtd1                mtdblock2           root
mtd1ro              mtdblock3           sda

Y como veis no aparece el dispositivo. Lo tengo conectado al Hub (Alimentado a 2A), donde tengo también el disco duro y la impresora funcionando. He probado a desconectar la impresora, por si el problema era que no tenía suficiente corriente pero no lo detecta. Los paquetes que he instalado son: kmod-usb-audio, kmod-sound-core, usbutils, mpd, madplay, kmod-sound-soc-core.

Mi versión de firmware es Barrier breaker r40396, y el router en cuestión es el Comtrend AR5387un (Gracias Noltari)

A ver si alguien puede ayudarme, ya no sé qué hacer.

gracias. ???


« Última modificación: 07-06-2014, 16:45 (Sábado) por ivallesp »

Noltari

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #1 en: 07-06-2014, 14:19 (Sábado) »
Te falta un detalle bastante importante: el router en el que te está dando problemas...

ivallesp

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #2 en: 07-06-2014, 16:54 (Sábado) »
editado :D Gracias Noltari.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1993
Re: Problema con tarjeta de Audio USB
« Respuesta #3 en: 07-06-2014, 18:16 (Sábado) »
¿Tienes activado el soporte ALSA en el kernel?
Si no me equivoco es necesario tener el soporte ALSA activado y los drivers ALSA cargados.

http://wiki.openwrt.org/doc/howto/usb.audio
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

ivallesp

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #4 en: 07-06-2014, 19:05 (Sábado) »
Pues me parece que sí, he instalado todas las dependencias que se comentan en el link que añades. Si ejecuto la orden alsa init me lanza lo siguiente:

Código: [Seleccionar]
root@OpenWrt:~# alsactl init
alsactl: init:1758: No soundcards found...

Os pego también lo que me devuelve al lanzar el comando dmesg:


Código: [Seleccionar]
root@OpenWrt:~# dmesg|tail
[   32.664000] device eth0.1 entered promiscuous mode
[   32.668000] device eth0 entered promiscuous mode
[   32.692000] br-lan: port 1(eth0.1) entered forwarding state
[   32.696000] br-lan: port 1(eth0.1) entered forwarding state
[   33.632000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   34.700000] br-lan: port 1(eth0.1) entered forwarding state
[ 6110.812000] usb 1-1.4.1: USB disconnect, device number 5
[ 6117.156000] usb 1-1.4.4: new full-speed USB device number 7 using ehci-platform
[24908.320000] usb 1-1.4.4: USB disconnect, device number 7
[24915.176000] usb 1-1.4.1: new full-speed USB device number 8 using ehci-platform

Como veis, lo he desconectado y conectado 2 veces.

Por si es de ayuda, también os paso el lsmod:
http://pastebin.com/Hyy999av

Gracias por vuestra ayuda.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1993
Re: Problema con tarjeta de Audio USB
« Respuesta #5 en: 07-06-2014, 19:55 (Sábado) »
Pues me parece que sí, he instalado todas las dependencias que se comentan en el link que añades. Si ejecuto la orden alsa init me lanza lo siguiente:

Código: [Seleccionar]
root@OpenWrt:~# alsactl init
alsactl: init:1758: No soundcards found...

Os pego también lo que me devuelve al lanzar el comando dmesg:


Código: [Seleccionar]
root@OpenWrt:~# dmesg|tail
[   32.664000] device eth0.1 entered promiscuous mode
[   32.668000] device eth0 entered promiscuous mode
[   32.692000] br-lan: port 1(eth0.1) entered forwarding state
[   32.696000] br-lan: port 1(eth0.1) entered forwarding state
[   33.632000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   34.700000] br-lan: port 1(eth0.1) entered forwarding state
[ 6110.812000] usb 1-1.4.1: USB disconnect, device number 5
[ 6117.156000] usb 1-1.4.4: new full-speed USB device number 7 using ehci-platform
[24908.320000] usb 1-1.4.4: USB disconnect, device number 7
[24915.176000] usb 1-1.4.1: new full-speed USB device number 8 using ehci-platform

Como veis, lo he desconectado y conectado 2 veces.

Por si es de ayuda, también os paso el lsmod:
http://pastebin.com/Hyy999av

Gracias por vuestra ayuda.

Esto..... ¿tienes cargado el kmod-usb-audio?
Al ponerlo ha salido andando mi SoundBlaster MP3+....  ^-^
Código: [Seleccionar]
root@OpenWrt:/# lsusb
Bus 001 Device 002: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 041e:3010 Creative Technology, Ltd SoundBlaster MP3+
root@OpenWrt:/# alsactl init
Found hardware: "USB-Audio" "USB Mixer" "USB041e:3010" "" ""
Hardware is initialized using a generic method
« Última modificación: 07-06-2014, 19:57 (Sábado) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4590
Re: Problema con tarjeta de Audio USB
« Respuesta #6 en: 07-06-2014, 20:02 (Sábado) »
Y los paquetes dependientes del kernel, los has cargado correctamente o forzando las dependencias ?
Valoraciones positivas en compra/venta:
147 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1993
Re: Problema con tarjeta de Audio USB
« Respuesta #7 en: 07-06-2014, 20:17 (Sábado) »
Y los paquetes dependientes del kernel, los has cargado correctamente o forzando las dependencias ?

Si me preguntas a mí, los he cargado correctamente. Tengo todo el repositorio compilado.  ;D
Con respecto a los que tengan que forzar dependencias, pues seguramente no les funcione, a no ser que las versiones de kernel les coincidan con las del paquete que estén instalando.
De lo que no estoy seguro es de si cambiando el módulo de sitio una vez instalado forzando las dependencias, podría servir para que funcionara.
Los módulos dependientes del kernel se instalan en el directorio /lib/modules/<version kernel>/
Si forzamos la instalación de un módulo para el kernel 3.12.34, por ejemplo, en nuestro kernel 3.12.20, los nombres de los directorios no serán los mismos y seguramente el kernel no encuentre el paquete recién instalado y forzado.
Si copiáramos el módulo de un directorio a otro, haríamos que el kernel lo encontrara, pero las posibilidades de que funcione o no son aleatorias, dependiendo de si el módulo mantiene compatibilidad con las llamadas a funciones del kernel antiguo o no. Y por supuesto corriendo el riesgo de provocar un kernel panic...  :-\
En fin, que si no tienes todo el repositorio, como ya dije, es una lotería que funcionen las cosas...
« Última modificación: 07-06-2014, 20:18 (Sábado) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

ivallesp

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #8 en: 09-06-2014, 13:07 (Lunes) »
Gracias por vuestras respuestas. No he forzado las dependencias de los paquetes, jar229.

Tki2000, si te refieres a si tengo instalado el paquete kmod-usb-audio, sí, lo tengo. Si hay que cargarlo de alguna forma lo desconozco. ¿Basta con instalarlo?

Gracias.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1993
Re: Problema con tarjeta de Audio USB
« Respuesta #9 en: 09-06-2014, 13:24 (Lunes) »
Gracias por vuestras respuestas. No he forzado las dependencias de los paquetes, jar229.

Tki2000, si te refieres a si tengo instalado el paquete kmod-usb-audio, sí, lo tengo. Si hay que cargarlo de alguna forma lo desconozco. ¿Basta con instalarlo?

Gracias.

En mi caso sí bastó sólo con eso.
¿Podrías poner el contenido de /lib/modules/<version kernel> que tengas?
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

ivallesp

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #10 en: 11-06-2014, 11:55 (Miércoles) »
Código: [Seleccionar]
root@OpenWrt:~# ls /lib/modules/3.10.34/
arc4.ko                 iptable_nat.ko          rtl_usb.ko
ath.ko                  iptable_raw.ko          rtlwifi.ko
ath9k_common.ko         ipv6.ko                 scsi_mod.ko
ath9k_htc.ko            jbd2.ko                 sd_mod.ko
ath9k_hw.ko             lib80211.ko             slhc.ko
brcmfmac.ko             lib80211_crypt_ccmp.ko  snd-ac97-codec.ko
brcmsmac.ko             lib80211_crypt_tkip.ko  snd-compress.ko
brcmutil.ko             lib80211_crypt_wep.ko   snd-cs5535audio.ko
button-hotplug.ko       libertas.ko             snd-hwdep.ko
carl9170.ko             mac80211.ko             snd-intel8x0.ko
cfg80211.ko             mbcache.ko              snd-mixer-oss.ko
compat.ko               nf_conntrack.ko         snd-page-alloc.ko
cordic.ko               nf_conntrack_ftp.ko     snd-pcm-oss.ko
crc-ccitt.ko            nf_conntrack_ipv4.ko    snd-pcm.ko
crc-itu-t.ko            nf_conntrack_ipv6.ko    snd-rawmidi.ko
crc16.ko                nf_conntrack_irc.ko     snd-seq-device.ko
crc8.ko                 nf_defrag_ipv4.ko       snd-soc-core.ko
crypto_blkcipher.ko     nf_defrag_ipv6.ko       snd-timer.ko
crypto_hash.ko          nf_nat.ko               snd-usb-audio.ko
eeprom_93cx6.ko         nf_nat_ftp.ko           snd-usbmidi-lib.ko
ext4.ko                 nf_nat_ipv4.ko          snd.ko
fat.ko                  nf_nat_irc.ko           usb-storage.ko
fuse.ko                 nls_base.ko             usb8xxx.ko
gpio_keys_polled.ko     nls_cp437.ko            usblp.ko
input-core.ko           nls_cp850.ko            vfat.ko
input-polldev.ko        nls_cp852.ko            x_tables.ko
ip6_tables.ko           nls_iso8859-15.ko       xt_CT.ko
ip6t_REJECT.ko          nls_utf8.ko             xt_LOG.ko
ip6t_ah.ko              p54common.ko            xt_REDIRECT.ko
ip6t_eui64.ko           p54usb.ko               xt_TCPMSS.ko
ip6t_frag.ko            ppp_async.ko            xt_comment.ko
ip6t_hbh.ko             ppp_generic.ko          xt_conntrack.ko
ip6t_ipv6header.ko      pppoe.ko                xt_limit.ko
ip6t_mh.ko              pppox.ko                xt_mac.ko
ip6t_rt.ko              rt2500usb.ko            xt_mark.ko
ip6table_filter.ko      rt2800lib.ko            xt_multiport.ko
ip6table_mangle.ko      rt2800usb.ko            xt_nat.ko
ip6table_raw.ko         rt2x00lib.ko            xt_state.ko
ip_tables.ko            rt2x00usb.ko            xt_tcpudp.ko
ipt_MASQUERADE.ko       rt73usb.ko              xt_time.ko
ipt_REJECT.ko           rtl8187.ko              zd1201.ko
iptable_filter.ko       rtl8192c-common.ko      zd1211rw.ko
iptable_mangle.ko       rtl8192cu.ko

Es este.

raphik

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #11 en: 11-06-2014, 16:47 (Miércoles) »
Tengo un pincho USB similar al tuyo. Mi router lo reconoce como dispositivo OHCI.

Código: [Seleccionar]
[  111.932000] usb 2-1: USB disconnect, device number 2
[  113.972000] usb 2-1: new full-speed USB device number 3 using bcm63xx_ohci
[  114.324000] input: C-Media USB Headphone Set   as /devices/platform/bcm63xx_ohci.0/usb2/2-1/2-1:1.3/input/input1
[  114.332000] generic-usb 0003:0D8C:000C.0002: input: USB HID v1.00 Device [C-Media USB Headphone Set  ] on usb-bcm63xx-1/input3

Parece que tu router no tiene instalado el módulo que da soporte a la interfaz OHCI. Prueba
opkg update
opkg install kmod-usb-ohci

¡Suerte!

ivallesp

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #12 en: 11-06-2014, 18:10 (Miércoles) »
Tengo un pincho USB similar al tuyo. Mi router lo reconoce como dispositivo OHCI.

Código: [Seleccionar]
[  111.932000] usb 2-1: USB disconnect, device number 2
[  113.972000] usb 2-1: new full-speed USB device number 3 using bcm63xx_ohci
[  114.324000] input: C-Media USB Headphone Set   as /devices/platform/bcm63xx_ohci.0/usb2/2-1/2-1:1.3/input/input1
[  114.332000] generic-usb 0003:0D8C:000C.0002: input: USB HID v1.00 Device [C-Media USB Headphone Set  ] on usb-bcm63xx-1/input3

Parece que tu router no tiene instalado el módulo que da soporte a la interfaz OHCI. Prueba
opkg update
opkg install kmod-usb-ohci

¡Suerte!

Hola raphik,

Primero que nada, gracias por tu respuesta. Ahora está instalado ése módulo, pero parece que todo sigue igual... ¿Alguna otra idea?

ivallesp

  • Visitante
Re: Problema con tarjeta de Audio USB
« Respuesta #13 en: 11-06-2014, 18:27 (Miércoles) »
He dado con la solución...

La cosa va por lo que comenta Tki2000, cambiar de directorio los módulos del kernel. Lo que he hecho ha sido instalar todas las dependencias que dicen en la wiki (http://wiki.openwrt.org/doc/howto/usb.audio) + la que comenta raphik kmod-usb-ohci. Todo forzando dependencias. También he instalado los paquetes del protocolo i2c forzados. Por último, copiamos los módulos de la carpeta /lib/modules/<kernel_forzado> a la carpeta /lib/modules/<tu_kernel>. Reiniciamos y voila!, encuentra el dispositivo /dev/audio y funciona. Al menos a mi me ha funcionado.

Gracias a todos por vuestra ayuda :D

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1993
Re: Problema con tarjeta de Audio USB
« Respuesta #14 en: 11-06-2014, 19:15 (Miércoles) »
He dado con la solución...

La cosa va por lo que comenta Tki2000, cambiar de directorio los módulos del kernel. Lo que he hecho ha sido instalar todas las dependencias que dicen en la wiki (http://wiki.openwrt.org/doc/howto/usb.audio) + la que comenta raphik kmod-usb-ohci. Todo forzando dependencias. También he instalado los paquetes del protocolo i2c forzados. Por último, copiamos los módulos de la carpeta /lib/modules/<kernel_forzado> a la carpeta /lib/modules/<tu_kernel>. Reiniciamos y voila!, encuentra el dispositivo /dev/audio y funciona. Al menos a mi me ha funcionado.

Gracias a todos por vuestra ayuda :D

¡¡¡Me alegro!!!  ;D ;D ;D
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

//FINAL Y MÁS DOS RESPUESTAS