Autor Tema: Problema al abrir puertos en Huawei HG556a con modem 3G  (Leído 2197 veces)

0 Usuarios y 1 Visitante están viendo este tema.

chamus92

  • Visitante
Problema al abrir puertos en Huawei HG556a con modem 3G
« en: 07-07-2016, 19:25 (Jueves) »
Buenas tardes a todos, he estado buscando por foros a ver si alguien tenía un problema parecido al mío y no he encontrado nada, primero muchas gracias de antemano, llevo muchísimo tiempo con esto, tanto aprendiendo de redes como de programación de Arduino, mi problema es el siguiente, tengo una especie de servidor web instalado en un arduino que controla diferentes sensores y actuadores desde una web, todo funciona perfectamente en la red de casa o con mi router de casa, pero no es ahí donde lo quiero poner, solo tengo acceso a internet a través de 3G, tengo un pincho 3g conectado a un router huawei hg556a con Openwrt y funciona correctamente pero cuando redirijo los puertos no me deja entrar desde el exterior, unicamente desde mi movil conectado a 3g, mi movil y el pincho son de masmovil. ¿Es posible que el propio pincho tenga su firewall y no acepte conexiones exteriores? ¿o al conectarlo a mi router es solo el router el que controla el cortafuegos?, cuando abro los puertos utilizando el mismo router en mi red de casa funciona todo como debería, no entiendo cual puede ser el problema después de probar tanto.
Un saludo y muchas gracias otra vez!



Ficht

  • Visitante
Re: Problema al abrir puertos en Huawei HG556a con modem 3G
« Respuesta #1 en: 07-07-2016, 22:30 (Jueves) »
Buenas tardes a todos, he estado buscando por foros a ver si alguien tenía un problema parecido al mío y no he encontrado nada, primero muchas gracias de antemano, llevo muchísimo tiempo con esto, tanto aprendiendo de redes como de programación de Arduino, mi problema es el siguiente, tengo una especie de servidor web instalado en un arduino que controla diferentes sensores y actuadores desde una web, todo funciona perfectamente en la red de casa o con mi router de casa, pero no es ahí donde lo quiero poner, solo tengo acceso a internet a través de 3G, tengo un pincho 3g conectado a un router huawei hg556a con Openwrt y funciona correctamente pero cuando redirijo los puertos no me deja entrar desde el exterior, unicamente desde mi movil conectado a 3g, mi movil y el pincho son de masmovil. ¿Es posible que el propio pincho tenga su firewall y no acepte conexiones exteriores? ¿o al conectarlo a mi router es solo el router el que controla el cortafuegos?, cuando abro los puertos utilizando el mismo router en mi red de casa funciona todo como debería, no entiendo cual puede ser el problema después de probar tanto.
Un saludo y muchas gracias otra vez!

Hola, prueba preguntarle a masmovil (o alguien que lo sepa) como es la configuración del pincho para tener IP publica, según que compañía y como se configure, la conexión pasa por un proxy, con lo que no podrás acceder desde fuera.

chamus92

  • Visitante
Re: Problema al abrir puertos en Huawei HG556a con modem 3G
« Respuesta #2 en: 07-07-2016, 22:33 (Jueves) »
IP pública si que me aparece, ya que desde otro movil si puedo acceder... pero es posible que sea tema de la compañia... lo había pensado

Ficht

  • Visitante
Re: Problema al abrir puertos en Huawei HG556a con modem 3G
« Respuesta #3 en: 07-07-2016, 23:03 (Jueves) »
IP pública si que me aparece, ya que desde otro movil si puedo acceder... pero es posible que sea tema de la compañia... lo había pensado

Por eso creo que será una IP privada, porque el móvil es probable que esté en el mismo rango que el router...

No se, postea los datos de configuración que tienes...


Compara que ip detecta por ejemplo el router y que ip detectan los servicios web tipo check IP

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 1977
Re: Problema al abrir puertos en Huawei HG556a con modem 3G
« Respuesta #4 en: 07-07-2016, 23:39 (Jueves) »
La mayoría de compañías tienen proxies para conectar con 3G, con lo que no vas a poder conectar. Tan sólo con Vodafone en tu casa y las 50GB he conseguido IP pública y poder acceder desde fuera, y sólo si uso un módem serie, con un hilink no funciona porque lleva firewall incorporado, que no puedo desactivar (por ahora).
Pregunta a tu compañía si te pueden dar IP pública, y utiliza un módem serie.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

Ficht

  • Visitante
Re: Problema al abrir puertos en Huawei HG556a con modem 3G
« Respuesta #5 en: 08-07-2016, 00:06 (Viernes) »
La mayoría de compañías tienen proxies para conectar con 3G, con lo que no vas a poder conectar. Tan sólo con Vodafone en tu casa y las 50GB he conseguido IP pública y poder acceder desde fuera, y sólo si uso un módem serie, con un hilink no funciona porque lleva firewall incorporado, que no puedo desactivar (por ahora).
Pregunta a tu compañía si te pueden dar IP pública, y utiliza un módem serie.

En el caso de movistar también funciona, en dependencia de la configuración de APN telefonica.es o movistar.es

chamus92

  • Visitante
Re: Problema al abrir puertos en Huawei HG556a con modem 3G
« Respuesta #6 en: 08-07-2016, 10:57 (Viernes) »
Caguenn... jajaj, si ya les llamé para ver si me podían dar IP fija pero Mas Movil no ofrece ese servicio, tendré que buscar otro método...

seny

  • Visitante
Re: Problema al abrir puertos en Huawei HG556a con modem 3G
« Respuesta #7 en: 13-07-2016, 00:17 (Miércoles) »
Hola, yo me encontré con el mismo problema usando una sim 3g de las que proporciona jazztel duplicada de la línea de movil, solo para datos..

La única solución que he encontrado ha sido mediante una vpn, estableciendo un tunel desde el router con el piganillo 3g en modo cliente a otro router que tengo en casa como servidor vpn.

Lo que no he conseguido es darle internet al cliente desde el servidor, si lo intento se corta el tunel.. ???

Pero estoy bastante contento con lo que voy consiguiendo, tengo montadas una serie de órdenes desde el luci app commands usando sshpass con las que puedes hacer de todo: accionar relés, hacer fotos, bajarlas al server, reiniciar el cliente, entre kas que ya he probado.

Saludos

//FINAL Y MÁS DOS RESPUESTAS