Autor Tema: Pinchos USB Wifi que funcionan correctamente (añade el tuyo)  (Leído 1997 veces)

0 Usuarios y 1 Visitante están viendo este tema.

peperfus

  • Visitante
Hola.
Con el fin de facilitar la instalación adicional de wifi en nuestro router openwrt (/lede), propongo crear este hilo a modo de lista para que cada uno que haya probado un determinado pincho wifi, lo publique aquí, junto con su valoración y si el pincho va bien, regular o mal...; así cuando alguien quiera comprar uno, no tener que marearse mucho preguntando y rebuscando que si este chip, o tal otro, esta revisión, drivers.... y tener cierta tranquilidad al saber que está comprobado que alguno funciona (al menos en alguna versión de openwrt)

No debe ser necesario compilar drivers ni nada por el estilo; sino que, al estar este hilo orientado a novatos ( ^-^), sólo pondremos los que funcionan directamente, si bien sea necesario instalar algún paquete (opkg ...) y alguna pequeña configuración.

Para no hacer demasiado favor comercial, evitar mencionar nombres de tiendas.
Hay que poner:
  • Marca y modelo del router
  • Versión de openwrt (o lede)
  • Marca y modelo del pincho wifi usb
  • Observaciones o comentarios...
  • Positivo
  • Negativo
  • Nota

Esta lista está basada en la filosofía "a mí me va"; pero obviamente, no hay ninguna garantía ni compromiso de ningún tipo.

El que quiera colaborar, adelante.
También se puede poner pinchos que no van; indicándolo claramente para que no haya confusión.

EDITO:
OJO. IMPORTANTE: Como ha compartido el compañero Pteridium en este hilo, los pinchos wifi no van bien en los routers con chip broadcom (bcm63xx). Tened esto en cuenta antes de comprar un nuevo pincho; mirad si el router lleva ese chip.


« Última modificación: 11-05-2017, 11:42 (Jueves) por peperfus »

peperfus

  • Visitante
Re: Pinchos USB Wifi que funcionan correctamente (añade el tuyo)
« Respuesta #1 en: 11-05-2017, 01:38 (Jueves) »
Empiezo:

  • Marca y modelo del router: Astoria Networks ARV7519RW22-A-LT (Livebox 2.1 de Orange) (Chip Lantiq)
  • Versión de openwrt (o lede):LEDE 17.01.2
  • Marca y modelo del pincho wifi usb: TP-LINK TL-WN722N
  • Observaciones o comentarios: Para instalarlo, usar el driver: kmod-ath9k-htc. Sólo me deja cambiar nombre de la wifi y cifrado. Si cambio canal o potencia de transmisión, se pierde la señal de la wifi y no puedo conectar*. Al reiniciar el router no se activa automáticamente. El único workaround para que se me active automáticamente que me ha funcionado es poner el comando "wifi" en el archivo /etc/rc.local
  • Positivo: Antena extraíble. Parece que tiene bastante potencia. Aún no lo he probado de rendimiento. La relación calidad/precio parece buena. Incluye alargador usb, que se agradece.
  • Negativo: Bastante pejiguero para configurarlo. El tamaño es un poco grande.
  • Nota: ....

YA FUNCIONA PERFECTAMENTE. VER ACTUALIZACIÓN MÁS ABAJO. No hace falta hacer nada de esto. Ir directamente a la actualización del post, abajo del todo. Sólo instalar driver y hostapd.

* Ahora acabo de descubrir que sí se puede cambiar el canal (excepto a auto) y la potencia de transmisión:
desde consola:
ifconfig wlan0 down
wifi down (no sé cuál de los dos comandos es necesario)
editar /etc/config/wireless y poner canal y potencia deseada
wifi reload
wifi

En cambio, si cambio esos parámetros desde luci, la señal wifi se pierde.
Re-edito: Cosa rara: ahora sí que me deja cambiar el canal desde luci. En fin. Un comportamiento raro.

Re-Re-edito: Este pincho a veces da problemas. Creo que es por tema del driver. A veces el dmesg me muestra el error del firmware download failed (refiriéndose al driver del pincho) y otras, simplemente funciona. Aún no tengo claro qué causa el error para intentar reproducirlo y buscar una solución o workaround.

Creo que he descubierto el causante del problema..
Resulta que suelo cargar el móvil con el usb del router. Es más lento que el cargador del móvil, pero al tenerlo al lado del ordenador y siempre disponible, para mí es más práctico. Pues bien; al desconectar el móvil, el pincho ha vuelto a funcionar con normalidad. Ya carga el firmware bien y la wifi funciona. No sé porqué, pero puede que al haber algún otro cacharro conectado al otro usb al mismo tiempo que el pincho wifi, dé problemas.

Requete reedito: Olvidadlo. Me sigue dando problemas otra vez, sin el móvil conectado. Otra vez download failed.  Esto es cada vez más rallante.

Archivo firmware: http://linuxwireless.org/download/htc_fw/1.3/htc_9271.fw



-----------------------------
Actualización, 15/08/2017
Ya funciona perfectamente.
Con la última versión de LEDE: (17.01.2 a día de hoy). Simplemente instalar el driver (ath9k-htc) y hostapd para cifrado wpa, configurar la wifi y reiniciar y ya está funcionando. Si no sale el apartado wireless en el menú interfaces, Ir a alguna opción del menú cualquiera para que se refresque y ya debería aparecer. Por fin  :D
« Última modificación: 15-08-2017, 23:22 (Martes) por peperfus »

peperfus

  • Visitante
Re: Pinchos USB Wifi que funcionan correctamente (añade el tuyo)
« Respuesta #2 en: 11-05-2017, 23:07 (Jueves) »
Otro:

  • Marca y modelo del router: Astoria Networks ARV7519RW22-A-LT (Livebox 2.1 de Orange) (Chip Lantiq)
  • Versión de openwrt (o lede): OpenWrt Chaos Calmer 15.05.1 / LuCI 15.05-149-g0d8bbd2 Release (git-15.363.78009-956be55)
  • Marca y modelo del pincho wifi usb: Sagem XG-760N
  • Observaciones o comentarios: Para instalarlo, usar el driver: kmod-zd1211rw.
  • Positivo: Buen tamaño.
  • Negativo: No tiene antena externa.
  • Nota:

Aún lo estoy probando; lo acabo de instalar.
« Última modificación: 11-05-2017, 23:09 (Jueves) por peperfus »

//FINAL Y MÁS DOS RESPUESTAS