Autor Tema: OpenWrt y Wake on Lan  (Leído 2948 veces)

0 Usuarios y 1 Visitante están viendo este tema.

korso

  • Visitante
OpenWrt y Wake on Lan
« en: 29-01-2013, 21:54 (Martes) »
Hola a todos!!!

Tengo un problema rarísimo con openwrt en un CT536+ y el WOL (bueno, mas que wake on lan, sería wake on wan). Os pongo al día:

Tengo un router barricade 2 (SMC7904BRA2) ADSL2+ que no permite modificación de la tabla ARP ni usar ips de broadcast en la configuración de NAT con lo que no puedo hacer wake on wan de ninguna de las maneras. Para poder solventarlo, instalé openwrt en el router comtrend y lo conecté al SMC. Esta es la configuración a grandes rasgos:

SMC --> IP: 192.168.2.1. DDNS con No-Ip.

NAT: hacia 192.168.2.100 -> Puerto 443 (servidor ssh en el pc)
NAT: hacia 192.168.2.190 -> Puerto 22 (servidor ssh del comtrend)

Comtrend -> IP: 192.168.2.190 , configuración por defecto con luci.

Bueno, pues aquí viene lo extraño. Si tengo el PC encendido, puedo conectarme desde fuera de la red local (desde el trabajo en concreto) sin ningún problema. PERO, si el PC no está encendido (ojo, sólo el PC, el SMC y el Comtrend si lo están), dejo inmediatamente de poder conectarme al servidor SSH del comtrend... con lo que el invento se me va al garete.

Le he buscado mil vueltas pero no le encuentro ningún tipo de explicación lógica. Desde mi casa, por contra, he probado a conectarme a un PC remoto (en otra ciudad), desde ese mismo PC entrar por ssh al comtrend (con el PC de mi casa apagado)... y funciona!!! Con lo que todavía me parece más raro....

Resumiendo por si no me he explicado bien: Si tengo el PC de mi casa encendido, puedo entrar en el comtrend por ssh desde el trabajo. En cuanto apago el PC de casa, pierdo el acceso, tanto al PC (obviamente) como al router comtrend.


A ver si alguien puede arrojarme un poco de luz ya que se me han secado las ideas :( (o si alguien ha conseguido rular el Wake on Wan con el barricade).

Mil gracias por adelantado!!!!



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: OpenWrt y Wake on Lan
« Respuesta #1 en: 30-01-2013, 08:19 (Miércoles) »
Has probado cambiado el puerto para SSH en el Comtrend ?

La verdad es que es algo raro el asunto ...  ^-^
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

brunorro

  • Visitante
Re: OpenWrt y Wake on Lan
« Respuesta #2 en: 11-02-2013, 14:45 (Lunes) »
Una tontería ultra chorra, pero que es lo único que se me ocurre...

Podría ser que tengas activado el upnp y te la esté jugando ?