Autor Tema: OpenWRT deja de tener conexión a Internet  (Leído 3189 veces)

0 Usuarios y 1 Visitante están viendo este tema.

vk496

  • Visitante
OpenWRT deja de tener conexión a Internet
« en: 25-11-2014, 16:34 (Martes) »
Pues eso, de la noche a la mañana deja de tener Internet. Lo tengo (mas bien tenía) como BridgeAP.

OpenWRT: 192.168.1.5
Router Principal: 192.168.1.1

Están conectados por Ethernet. Hoy por la mañana tenia problemas para conectarme al WiFi desde el móvil. Revisé y me di cuenta que que OpenWRT no era capaz de hacer ping a ningún host, pero si que se podía navegar desde cualquier otro dispositivo (sea ethernet o WiFI).

Alguien ha tenido alguna experiencia parecida?

Nota: Parece ser que es problema de los DNS. Indico el DNS en /etc/config/network pero no lo coge.

Salu2



mekkon

  • Visitante
Re: OpenWRT deja de tener conexión a Internet
« Respuesta #1 en: 25-11-2014, 17:34 (Martes) »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re:
« Respuesta #2 en: 25-11-2014, 18:36 (Martes) »
Has probado a reiniciar el router ?

Enviado desde uno de mis 'cacharros' usando Tapatalk
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vk496

  • Visitante
Re: Re: OpenWRT deja de tener conexión a Internet
« Respuesta #3 en: 25-11-2014, 19:26 (Martes) »
Claro que lo he reiniciado... Y a saber cuantas veces xD

Lo que sucede es que no quiere aplicar la config de los DNS, por lo que me encuentro en un entorno en el que cualquier cliente puede recibir el DNS del router principal excepto OpenWRT, ya que este es capaz de hacer ping en la subred y a los DNS de google, pero no puede resolver ningún host.

Lo gracioso es que esto pasa de la noche a la mañana. Manda huev.os

Salu2

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2038
Re: Re: OpenWRT deja de tener conexión a Internet
« Respuesta #4 en: 27-11-2014, 17:38 (Jueves) »
Claro que lo he reiniciado... Y a saber cuantas veces xD

Lo que sucede es que no quiere aplicar la config de los DNS, por lo que me encuentro en un entorno en el que cualquier cliente puede recibir el DNS del router principal excepto OpenWRT, ya que este es capaz de hacer ping en la subred y a los DNS de google, pero no puede resolver ningún host.

Lo gracioso es que esto pasa de la noche a la mañana. Manda huev.os

Salu2

Los DNS se resuelven por el puerto 53. ¿Has comprobado si por casualidad está habilitado para recibir tráfico en ese puerto, o se te ha borrado la regla del firewall?
Llámese Expediente X...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

vk496

  • Visitante
Re: Re: Re: Re: OpenWRT deja de tener conexión a Internet
« Respuesta #5 en: 27-11-2014, 17:45 (Jueves) »
Claro que lo he reiniciado... Y a saber cuantas veces xD

Lo que sucede es que no quiere aplicar la config de los DNS, por lo que me encuentro en un entorno en el que cualquier cliente puede recibir el DNS del router principal excepto OpenWRT, ya que este es capaz de hacer ping en la subred y a los DNS de google, pero no puede resolver ningún host.

Lo gracioso es que esto pasa de la noche a la mañana. Manda huev.os

Salu2

Los DNS se resuelven por el puerto 53. ¿Has comprobado si por casualidad está habilitado para recibir tráfico en ese puerto, o se te ha borrado la regla del firewall?
Llámese Expediente X...
Tengo el firewall deshabilitado.

El lunes cuando lo tenga otra vez a mano, me pondré a hacer backups y restaurar archivos por defecto para ver dónde está el problema...

Para que luego me digan que soy yo el que busco los problemas...

Salu2

mekkon

  • Visitante
Re: OpenWRT deja de tener conexión a Internet
« Respuesta #6 en: 01-12-2014, 18:06 (Lunes) »
Quizás no sea cosa de IPV4 sino de IPV6 que no esta resolviendo bien las DNS, y sea IPV6 que tenga preferencia sobre IPV4, esto me recuerda un poco cuando estaba probando DNSCrypt, prueba quizás desactivando IPV6 en el pc para acotar un poco el problema.

un saludo.

vk496

  • Visitante
Re: Re: OpenWRT deja de tener conexión a Internet
« Respuesta #7 en: 09-12-2014, 14:59 (Martes) »
Ok, misterio resuelto.

La culpa es de DNS-CRYPT. Todavía no tengo claro por qué deja de funcionar así de repente. Lo desactivé y todo funciona correctamente

Salu2

//FINAL Y MÁS DOS RESPUESTAS