Autor Tema: Ayuda con antena USB en openwrt  (Leído 8298 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sankosme

  • Visitante
Ayuda con antena USB en openwrt
« en: 22-02-2014, 15:35 (Sábado) »
Hola, en luci al acceder al apartado wifi solo veo el adaptador interno, no veo mi ubiquiti.

dmesg :

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS=64 #Cfgs=  1
P:  Vendor=0cf3 ProdID=b003 Rev= 1.08
S:  Manufacturer=UBIQUITI
S:  Product=WifiStationEXT
S:  SerialNumber=11112
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 6 Cls=ff(vend.) Sub=00 Prot=00 Driver=ath9k_htc
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=  64 Ivl=125us
E:  Ad=04(O) Atr=03(Int.) MxPS=  64 Ivl=125us
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=06(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

cat /sys/kernel/debug/usb/devices

[  180.870000] ath9k_htc 1-1:1.0: no of_node; not parsing pinctrl DT
[  180.870000] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
[  181.170000] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[  181.410000] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits


wifi detect > /etc/config/wireless y luego reinicio el router pero sigue sin aparecer, solo está 'radio0'. El fichero /etc/config/wireless:


config wifi-device 'radio0'
   option type 'mac80211'
   option channel '11'
   option hwmode '11ng'
   option path '10180000.wmac'
   list ht_capab 'GF'
   list ht_capab 'SHORT-GI-20'
   list ht_capab 'SHORT-GI-40'
   list ht_capab 'TX-STBC'
   list ht_capab 'RX-STBC12'
   option htmode 'HT20'

config wifi-iface
   option device 'radio0'
   option network 'lan'
   option mode 'ap'
   option ssid 'OpenWrt'
   option encryption 'none'


¿Alguien sabe porque no me aparece la antena usb??

Saludos¡¡¡¡



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Ayuda con antena USB en openwrt
« Respuesta #1 en: 22-02-2014, 20:16 (Sábado) »
Qué router y qué compilación estás usando ?
Has instalado el driver correspondiente ?

sankosme

  • Visitante
Re: Re: Ayuda con antena USB en openwrt
« Respuesta #2 en: 22-02-2014, 22:26 (Sábado) »
Router de telefonica homestation,el firm lo compile yo añadiendo el driver de la ubiquiti ya que no me dejaba instalarlo.segui el post de este foro de compilar openwrt al gusto.

Enviado desde mi Nexus One usando Tapatalk 2

wolf_rider

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #3 en: 22-02-2014, 23:18 (Sábado) »
Uf tio otro con el mismo problema Yo Ya me canse del Atheros lo estoy intentando desde mas de dos meses. y Al final lo he conseguido como tu. Me reconoce la tarjeta pero no funciona mas de una hora conectada. Mi recomendación es no utilizar Atheros o vas a morirte en el intento. Suerte

sankosme

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #4 en: 23-02-2014, 01:26 (Domingo) »
Pues pensé que al haber drivers no habría problemas, la ubiquiti es una gran antena, adaptada para exteriores y muy estable, enlaza con tan solo una raya de señal. Las alfa por lo que leí igual, estabilidad cero en openwrt. Entonces tendré que cambiar la ubiquiti...vaya ****da.

Saludos¡¡¡

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Re: Ayuda con antena USB en openwrt
« Respuesta #5 en: 23-02-2014, 10:49 (Domingo) »
No te dice nada 'raro' en la salida del comando dmseg ?

Yo tengo una WiFi USB con chipset atheros que uso sin problemas.

Enviado desde mi CUBOT GT99

sankosme

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #6 en: 23-02-2014, 11:20 (Domingo) »
Pongo la salida completa:  

Código: [Seleccionar]
root@OpenWrt:~# dmesg
[    0.000000] Linux version 3.10.28 (mlago@ubuntuvirtual) (gcc version 4.6.4 (OpenWrt/Linaro
GCC 4.6-2013.05 r39605) ) #1 Thu Feb 20 06:54:05 PST 2014
[    0.000000] SoC Type: Ralink RT3052 id:1 rev:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0001964c (MIPS 24KEc)
[    0.000000] MIPS: machine is Alpha ASL26555
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] On node 0 totalpages: 8192
[    0.000000] free_area_init_node: node 0, pgdat 80288990, node_mem_map 81004080
[    0.000000]   Normal zone: 64 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 8192 pages, LIFO batch:0
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 16kB, 4-way, VIPT, no aliases, linesize 32 bytes
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line: console=ttyS0,57600 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=0005f8a8
[    0.000000] Readback ErrCtl register=0005f8a8
[    0.000000] Memory: 29352k/32768k available (2130k kernel code, 3416k reserved, 532k
data, 216k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:128
[    0.000000] CPU Clock: 384MHz
[    0.070000] Calibrating delay loop... 255.59 BogoMIPS (lpj=1277952)
[    0.070000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] pinctrl core: initialized pinctrl subsystem
[    0.100000] NET: Registered protocol family 16
[    0.120000] rt2880-pinmux pinctrl.1: try to register 52 pins ...
[    0.120000] pinctrl core: registered pin 0 (io0) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 1 (io1) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 2 (io2) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 3 (io3) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 4 (io4) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 5 (io5) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 6 (io6) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 7 (io7) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 8 (io8) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 9 (io9) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 10 (io10) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 11 (io11) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 12 (io12) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 13 (io13) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 14 (io14) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 15 (io15) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 16 (io16) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 17 (io17) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 18 (io18) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 19 (io19) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 20 (io20) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 21 (io21) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 22 (io22) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 23 (io23) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 24 (io24) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 25 (io25) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 26 (io26) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 27 (io27) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 28 (io28) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 29 (io29) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 30 (io30) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 31 (io31) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 32 (io32) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 33 (io33) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 34 (io34) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 35 (io35) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 36 (io36) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 37 (io37) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 38 (io38) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 39 (io39) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 40 (io40) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 41 (io41) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 42 (io42) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 43 (io43) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 44 (io44) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 45 (io45) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 46 (io46) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 47 (io47) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 48 (io48) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 49 (io49) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 50 (io50) on rt2880-pinmux
[    0.120000] pinctrl core: registered pin 51 (io51) on rt2880-pinmux
[    0.120000] pinctrl core: add 6 pinmux maps
[    0.120000] rt2880-pinmux pinctrl.1: found group selector 7 for sdram
[    0.120000] rt2880-pinmux pinctrl.1: found group selector 0 for i2c
[    0.120000] rt2880-pinmux pinctrl.1: found group selector 4 for jtag
[    0.120000] rt2880-pinmux pinctrl.1: found group selector 6 for rgmii
[    0.120000] rt2880-pinmux pinctrl.1: found group selector 5 for mdio
[    0.120000] rt2880-pinmux pinctrl.1: found group selector 2 for uartf
[    0.120000] rt2880-pinmux pinctrl.1: request pin 24 (io24) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 25 (io25) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 26 (io26) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 27 (io27) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 28 (io28) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 29 (io29) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 30 (io30) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 31 (io31) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 32 (io32) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 33 (io33) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 34 (io34) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 35 (io35) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 36 (io36) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 37 (io37) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 38 (io38) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 39 (io39) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 1 (io1) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 2 (io2) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 17 (io17) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 18 (io18) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 19 (io19) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 20 (io20) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 21 (io21) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 40 (io40) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 41 (io41) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 42 (io42) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 43 (io43) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 44 (io44) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 45 (io45) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 46 (io46) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 47 (io47) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 48 (io48) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 49 (io49) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 50 (io50) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 51 (io51) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 22 (io22) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 23 (io23) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 7 (io7) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 8 (io8) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 9 (io9) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 10 (io10) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 11 (io11) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 12 (io12) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 13 (io13) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: request pin 14 (io14) for pinctrl.1
[    0.120000] rt2880-pinmux pinctrl.1: failed to lookup the sleep state
[    0.140000] bio: create slab <bio-0> at 0
[    0.150000] rt2880_gpio 10000600.gpio: registering 24 gpios
[    0.160000] rt2880_gpio 10000600.gpio: registering 24 irq handlers
[    0.170000] Switching to clocksource MIPS
[    0.180000] NET: Registered protocol family 2
[    0.190000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.210000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.220000] TCP: Hash tables configured (established 512 bind 512)
[    0.230000] TCP: reno registered
[    0.240000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.250000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.260000] NET: Registered protocol family 1
[    0.270000] rt-timer 10000100.timer: maximum frequncy is 7812Hz
[    0.290000] alarmtimer alarmtimer: no of_node; not parsing pinctrl DT
[    0.320000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.330000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORIT Y)
(c) 2001-2006 Red Hat, Inc.
[    0.350000] msgmni has been set to 57
[    0.360000] io scheduler noop registered
[    0.370000] io scheduler deadline registered (default)
[    0.380000] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    0.390000] serial8250 serial8250: no of_node; not parsing pinctrl DT
[    0.400000] pinctrl core: add 1 pinmux maps
[    0.400000] rt2880-pinmux pinctrl.1: found group selector 3 for uartlite
[    0.400000] rt2880-pinmux pinctrl.1: request pin 15 (io15) for 10000c00.uartlite
[    0.400000] rt2880-pinmux pinctrl.1: request pin 16 (io16) for 10000c00.uartlite
[    0.400000] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 20) is a 16550A
[    0.410000] console [ttyS0] enabled, bootconsole disabled
[    0.440000] pinctrl core: add 1 pinmux maps
[    0.440000] rt2880-pinmux pinctrl.1: found group selector 1 for spi
[    0.440000] rt2880-pinmux pinctrl.1: request pin 3 (io3) for 10000b00.spi
[    0.440000] rt2880-pinmux pinctrl.1: request pin 4 (io4) for 10000b00.spi
[    0.440000] rt2880-pinmux pinctrl.1: request pin 5 (io5) for 10000b00.spi
[    0.440000] rt2880-pinmux pinctrl.1: request pin 6 (io6) for 10000b00.spi
[    0.440000] m25p80 spi32766.0: s25sl12801 (16384 Kbytes)
[    0.450000] 7 ofpart partitions found on MTD device spi32766.0
[    0.460000] Creating 7 MTD partitions on "spi32766.0":
[    0.470000] 0x000000000000-0x000000030000 : "uboot"
[    0.490000] 0x000000030000-0x000000040000 : "uboot-env"
[    0.500000] 0x000000040000-0x000000050000 : "factory"
[    0.520000] 0x000000050000-0x000000fd0000 : "firmware"
[    0.530000] 0x00000013da38-0x000000fd0000 : "rootfs"
[    0.540000] mtd: partition "rootfs" must either start or end on erase block boundary or
be smaller than an erase block -- forcing read-only
[    0.570000] mtd: device 4 (rootfs) set to be root filesystem
[    0.580000] mtd: partition "rootfs_data" created automatically, ofs=0x530000,len=0xaa0000
[    0.600000] 0x000000530000-0x000000fd0000 : "rootfs_data"
[    0.610000] 0x000000fd0000-0x000000fe0000 : "cert"
[    0.620000] 0x000000fe0000-0x000000ff0000 : "langpack"
[    0.640000] 0x000000ff0000-0x000001000000 : "devdata"
[    0.660000] eth0: done loading
[    0.670000] rt2880_wdt 10000120.watchdog: Initialized
[    0.680000] TCP: cubic registered
[    0.690000] NET: Registered protocol family 17
[    0.700000] 8021q: 802.1Q VLAN Support v1.8
[    0.730000] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.740000] Freeing unused kernel memory: 216K (8029a000 - 802d0000)
[   10.040000] usbcore: registered new interface driver usbfs
[   10.050000] usbcore: registered new interface driver hub
[   10.060000] usbcore: registered new device driver usb
[   10.130000] rt2880-pinmux pinctrl.1: request pin 10 (io10) for pio:10
[   10.130000] rt2880-pinmux pinctrl.1: request pin 12 (io12) for pio:12
[   10.150000] SCSI subsystem initialized
[   10.170000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   10.180000] ehci-platform: EHCI generic platform driver
[   10.200000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   10.220000] dwc_otg: version 2.72a 24-JUN-2008
[   10.230000] dwc_otg: Core Release: 2.66a
[   10.440000] dwc_otg: Periodic Transfer Interrupt Enhancement - disabled
[   10.450000] dwc_otg: Multiprocessor Interrupt Enhancement - disabled
[   10.460000] dwc_otg: Using DMA mode
[   10.470000] dwc_otg: Device using Buffer DMA mode
[   10.480000] dwc_otg 101c0000.otg: DWC OTG Controller
[   10.490000] dwc_otg 101c0000.otg: new USB bus registered, assigned bus number 1
[   10.500000] dwc_otg 101c0000.otg: irq 26, io mem 0x101c0000
[   10.520000] dwc_otg: Init: Port Power? op_state=1
[   10.530000] dwc_otg: Init: Power Port (0)
[   10.540000] usb usb1: no of_node; not parsing pinctrl DT
[   10.540000] hub 1-0:1.0: no of_node; not parsing pinctrl DT
[   10.540000] hub 1-0:1.0: USB hub found
[   10.540000] hub 1-0:1.0: 1 port detected
[   10.560000] leds-gpio gpio-leds.4: pins are not configured from the driver
[   10.570000] rt2880-pinmux pinctrl.1: request pin 0 (io0) for pio:0
[   10.570000] rt2880-pinmux pinctrl.1: request pin 1 (io1) for pio:1
[   10.570000] rt2880-pinmux pinctrl.1: request pin 2 (io2) for pio:2
[   10.570000] rt2880-pinmux pinctrl.1: request pin 7 (io7) for pio:7
[   10.570000] rt2880-pinmux pinctrl.1: request pin 8 (io8) for pio:8
[   10.570000] rt2880-pinmux pinctrl.1: request pin 9 (io9) for pio:9
[   10.570000] rt2880-pinmux pinctrl.1: request pin 14 (io14) for pio:14
[   10.580000] rt2880-pinmux pinctrl.1: request pin 17 (io17) for pio:17
[   10.580000] usbcore: registered new interface driver usb-storage
[   12.540000] jffs2: notice: (325) jffs2_build_xattr_subsystem: complete building xattr
subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 16 of xref (0 dead, 2 orphan) found.
[   12.870000] jffs2: notice: (322) jffs2_build_xattr_subsystem: complete building xattr
subsystem, 1 of xdatum (0 unchecked, 0 orphan) and 16 of xref (0 dead, 2 orphan) found.
[   17.260000] NET: Registered protocol family 10
[   17.300000] NTFS driver 2.1.30 [Flags: R/O MODULE].
[   17.340000] nf_conntrack version 0.5.0 (462 buckets, 1848 max)
[   17.360000] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   17.410000] fuse init (API version 7.22)
[   17.430000] Loading modules backported from Linux version master-2014-01-23-0-g62c147d
[   17.440000] Backport generated by backports.git backports-20140124-0-g1256d3e
[   17.470000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   17.520000] usbcore: registered new interface driver usblp
[   17.590000] xt_time: kernel timezone is -0000
[   17.700000] cfg80211: Calling CRDA to update world regulatory domain
[   17.720000] cfg80211: World regulatory domain updated:
[   17.730000] cfg80211:  DFS Master region: unset
[   17.730000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   17.750000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   17.770000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   17.780000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   17.800000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (300 mBi, 2000 mBm)
[   17.810000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (300 mBi, 2000 mBm)
[   17.830000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0mBm)
[   17.880000] PPP generic driver version 2.4.2
[   17.900000] NET: Registered protocol family 24
[   17.940000] usbcore: registered new interface driver rt73usb
[   17.970000] usbcore: registered new interface driver rtl8187
[   18.040000] usbcore: registered new interface driver rt2500usb
[   18.080000] rt2800_wmac 10180000.wmac: failed to load eeprom property
[   18.090000] ieee80211 phy0: rt2x00lib_request_eeprom_file: Info -
Loading EEPROM data from 'soc_wmac.eeprom'.
[   18.120000] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 2872, rev 0200 detected
[   18.130000] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 0008 detected
[   18.150000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   18.170000] usbcore: registered new interface driver rt2800usb
[   18.210000] usbcore: registered new interface driver ath9k_htc
[   26.590000] device eth0.1 entered promiscuous mode
[   26.600000] device eth0 entered promiscuous mode
[   26.610000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   26.640000] br-lan: port 1(eth0.1) entered forwarding state
[   26.650000] br-lan: port 1(eth0.1) entered forwarding state
[   28.650000] br-lan: port 1(eth0.1) entered forwarding state
[   31.230000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   31.260000] device wlan0 entered promiscuous mode
[   32.500000] br-lan: port 2(wlan0) entered forwarding state
[   32.510000] br-lan: port 2(wlan0) entered forwarding state
[   32.520000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   34.510000] br-lan: port 2(wlan0) entered forwarding state
[  189.380000] usb 1-1: new high-speed USB device number 2 using dwc_otg
[  189.620000] usb 1-1: no of_node; not parsing pinctrl DT
[  189.620000] ath9k_htc 1-1:1.0: no of_node; not parsing pinctrl DT
[  189.620000] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
[  190.110000] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[  190.350000] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
[  284.910000] rt305x-esw 10110000.esw: link changed 0x10

El modelo del router exacto es ASL-265555 y la compilación  OpenWrt Barrier Breaker r39605 | Load: 1.93 0.67 0.24

A lo mejor pruebo la antena en un HG553 por si es de la compilación.

Saludos¡¡
« Última modificación: 27-11-2015, 11:20 (Viernes) por Pteridium »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Re: Ayuda con antena USB en openwrt
« Respuesta #7 en: 23-02-2014, 12:31 (Domingo) »
La verdad es que leer el log desde el móvil es complicado. No veo nada raro ... :D

Enviado desde mi CUBOT GT99

sankosme

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #8 en: 23-02-2014, 19:37 (Domingo) »
Acabo de probar con una alfa 1w. La detecta pero no asociada a nada ni a tiros, incluso teniendo casi un 90% de señal. Tengo una signalking china con chip ralink 3070, esta sí funciona perfecta, detecta y asocia muy bien. Me jode que la ubiquiti que es una buena antena no funcione en openwrt y la signalking que es china de 12 euros vaya perfecta...en fin..

Saludos¡¡¡

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: Ayuda con antena USB en openwrt
« Respuesta #9 en: 23-02-2014, 20:51 (Domingo) »
Podría ser un problema similar al de este post: https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg270003/#msg270003

Pero la verdad, no lo tengo claro. A ver si danitool se pasa por aquí y te aclara algo más  ^-^

gasalb

  • Visitante
Re: Re: Re: Ayuda con antena USB en openwrt
« Respuesta #10 en: 23-02-2014, 21:59 (Domingo) »
Uf tio otro con el mismo problema Yo Ya me canse del Atheros lo estoy intentando desde mas de dos meses. y Al final lo he conseguido como tu. Me reconoce la tarjeta pero no funciona mas de una hora conectada. Mi recomendación es no utilizar Atheros o vas a morirte en el intento. Suerte
Yo tambien tuve problemas cin la atheros 9271 alfa NHA.Lo que tu dices,despues de una hora se apagaba.Probada en un tplink wr1043 y en hg556.La solucion, compre un hub usb que trae alimentacion aparte y un cable doble usb(se enchufan 2 usb en el hub y de los dos,sale el cable para el adaptor alfa) y desde que tengo el hub,unos 3 meses,se me paro dos veces.Tampoco le doy mucho uso,a ese ruter va la tele y una tablet.

Enviado desde mi GT-I8260 mediante Tapatalk

sankosme

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #11 en: 23-02-2014, 23:22 (Domingo) »
Tiene toda la pinta de que el problema es el mismo, carga el driver pero no aparece. El id y fabricante coinciden

{ USB_DEVICE(0x0cf3, 0xb003) }, /* Ubiquiti WifiStation Ext */

Lo que no tengo claro es como se parchea y si me vale el parche de
Citar
danitool
ya que es para un Huawei HG556a.

Saludos¡¡

sankosme

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #12 en: 28-02-2014, 11:37 (Viernes) »
Sigo en las mismas, resulta que he mirado el archivo del driver y sí tiene el ID de la antena. Me parece que voy pillarme una ralink porque no veo mucha solución.

Saludos¡¡

GLaDOS

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #13 en: 28-02-2014, 11:52 (Viernes) »
No se si puedo aportar algo, pero bueno, ha sido mi experiencia:

Agarré de la red un sinfín de tutoriales, que si WDS que si relayd... A día de hoy todavía no tengo muy claro lo que viene siendo.

Configuré la interfaz LAN en el rango 192.168.2.x, me peleé MUCHÍSIMO para que LuCI reconociera el Adaptador Wireless USB y una vez conseguido (danitool, Noltari, espeltron y alguno más puede dar fe de lo que les dí la vara) tras un Escaneo pude asociar asociar el AR9271 (Alfa Negra) a la red objetivo (Abierta, no os asustéis con lo de objetivo), creando la interfaz WAN.

Asombrosamente, desde la LAN se podía acceder sin problemas a Internet.

El único problema que tengo es la inestabilidad. Al principio, sufría caídas cada 20-30 min lo cual era una jodienda porque no podía acabar de ver ni un capítulo entero dese pelisalacarta en la RPi. Tras pruebas con la localización de la antena la cosa mejoró, con conexiones estables de hasta 50 min de duración.

Tras cada caída hay que acceder al Router y Re-Conectar la interfaz WAN.

Las caídas entiendo que se deben a la naturaleza intrínseca del Wireless. Como yo digo, cuando estás lanzando Bits al aire, alguno se te pierde por el camino.

Me planteé que fuese cuestión de las cesiones DHCP, así que intenté configurar la WAN con IP Fija pero esto me imposibilitaba el reenvio de DNS a la interfaz WAN, así abandoné esa opción y por otro lado también me di cuenta de que no podía ser cuestión de cesiones DHCP TAN sumamente cortas.

Dado que supongo que la cosa es del Wireless, una mejora de Antena debería mejorar esto, teniendo en cuenta que ahora estamos tirando con la Alfa Negra pegadita con su ventosa a la ventana y una Antena Omni de 8-9 dbi's.

Con una antena direccional (no sé si sectorial, planar o parabólica, creo que lo más adecuado para este caso sería planar, por favor, si alguien puede darme una pequeña directriz a pesar de que entiendo que no sea el tema adecuado lo agradecería mucho) debería mejorar bastante la cosa.

A pesar de eso, no creo que eso resolviera el tema al 100%, un camión pasando por la calle (estamos hablando de pueblo de casa baja) podría provocar una caída. Por otro lado, a pesar de las caídas, la navegación es PERFECTA, os confirmo que los streamings en la RPi han ido de lujo - hasta que se cae y te jodes, claro :-\ - .

Es por eso que razono que no debería ser muy complicado hacer un pequeño script que cada... 5-10 segundos compruebe que la interfaz WAN esté conectada y en el momento que la detecte caída, la vuelva a levantar.

Ya os digo que no me tiene pinta de ser algo muy complicado, pero es que no tengo ni idea de como programar eso, ni de donde se 'mete' ese script en OpenWRT y os JURO, que buscando en toda la red, en el foro, en otros foros (soy un poco promiscua  >:D ) e incluso tanto en cristiano como en inglés, no  he encontrado a NADIE hablando sobre re-conexión de la interfaz WAN en OpenWRT.

Tampoco sé si na configuración óptima solucionaría esto, quizás vosotros que tenéis más experiencia podáis alumbrarme.

Así que si alguien tiene alguna pista... Vendría como agua de mayo. ;) ;)

Hablando de las NHA. Tengo el mismo problema, caída cada 50 min. ¿Vosotros confirmáis que es cosa del modelo? Hasta ahora me lo había planteado pero claro, no tenía con qué comparar.

wolf_rider

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #14 en: 28-02-2014, 18:47 (Viernes) »
No se si puedo aportar algo, pero bueno, ha sido mi experiencia:

Agarré de la red un sinfín de tutoriales, que si WDS que si relayd... A día de hoy todavía no tengo muy claro lo que viene siendo.

Configuré la interfaz LAN en el rango 192.168.2.x, me peleé MUCHÍSIMO para que LuCI reconociera el Adaptador Wireless USB y una vez conseguido (danitool, Noltari, espeltron y alguno más puede dar fe de lo que les dí la vara) tras un Escaneo pude asociar asociar el AR9271 (Alfa Negra) a la red objetivo (Abierta, no os asustéis con lo de objetivo), creando la interfaz WAN.

Asombrosamente, desde la LAN se podía acceder sin problemas a Internet.

El único problema que tengo es la inestabilidad. Al principio, sufría caídas cada 20-30 min lo cual era una jodienda porque no podía acabar de ver ni un capítulo entero dese pelisalacarta en la RPi. Tras pruebas con la localización de la antena la cosa mejoró, con conexiones estables de hasta 50 min de duración.

Tras cada caída hay que acceder al Router y Re-Conectar la interfaz WAN.

Las caídas entiendo que se deben a la naturaleza intrínseca del Wireless. Como yo digo, cuando estás lanzando Bits al aire, alguno se te pierde por el camino.

Me planteé que fuese cuestión de las cesiones DHCP, así que intenté configurar la WAN con IP Fija pero esto me imposibilitaba el reenvio de DNS a la interfaz WAN, así abandoné esa opción y por otro lado también me di cuenta de que no podía ser cuestión de cesiones DHCP TAN sumamente cortas.

Dado que supongo que la cosa es del Wireless, una mejora de Antena debería mejorar esto, teniendo en cuenta que ahora estamos tirando con la Alfa Negra pegadita con su ventosa a la ventana y una Antena Omni de 8-9 dbi's.

Con una antena direccional (no sé si sectorial, planar o parabólica, creo que lo más adecuado para este caso sería planar, por favor, si alguien puede darme una pequeña directriz a pesar de que entiendo que no sea el tema adecuado lo agradecería mucho) debería mejorar bastante la cosa.

A pesar de eso, no creo que eso resolviera el tema al 100%, un camión pasando por la calle (estamos hablando de pueblo de casa baja) podría provocar una caída. Por otro lado, a pesar de las caídas, la navegación es PERFECTA, os confirmo que los streamings en la RPi han ido de lujo - hasta que se cae y te jodes, claro :-\ - .

Es por eso que razono que no debería ser muy complicado hacer un pequeño script que cada... 5-10 segundos compruebe que la interfaz WAN esté conectada y en el momento que la detecte caída, la vuelva a levantar.

Ya os digo que no me tiene pinta de ser algo muy complicado, pero es que no tengo ni idea de como programar eso, ni de donde se 'mete' ese script en OpenWRT y os JURO, que buscando en toda la red, en el foro, en otros foros (soy un poco promiscua  >:D ) e incluso tanto en cristiano como en inglés, no  he encontrado a NADIE hablando sobre re-conexión de la interfaz WAN en OpenWRT.

Tampoco sé si na configuración óptima solucionaría esto, quizás vosotros que tenéis más experiencia podáis alumbrarme.

Así que si alguien tiene alguna pista... Vendría como agua de mayo. ;) ;)

Hablando de las NHA. Tengo el mismo problema, caída cada 50 min. ¿Vosotros confirmáis que es cosa del modelo? Hasta ahora me lo había planteado pero claro, no tenía con qué comparar.
hola mira no soy experto ni mucho menos, pero esto de la alfa negra lo tengo mas que probado.
1: La Alfa en <Win> es una maravilla probablemente la mejor es capaz de enganchar se en una red con una "raya" pero va a seguir. La única pega es que de vez en cuando cuando enciendes el PC no la reconoce o no se arranca, le sueltas el usb y vuelvas a lanchar la y ya esta a volar.
2: En Linux <Wifislax> audita bastante bien, pero conectar no tanto. Yo creo que todo esto es por los drivers que hay por que supongo que el  wifislax utiliza los de compat-wire.... como el openwrt y si no me equivoco todos los demás.
En openwrt conectada me dura 1 hora como mucho, Conectada también en wifislax igual en ubuntu igual.
Por eso hay que tener por lo menos dos tarjetas dependiendo de que uso le vas a dar, Para mi Atheros=estabilidad y sordera. Ralink=menos estabilidad pero mas potente. Esto mas o menos es como jugar al Diablo 3 si tienes muchos puntos en el daño matas rápido,, pero no tendrás mucha vida y mueres rápido, o lo contrario. Equilibrio hay que tener. Ala hasta aquí que ya me he perdido en mis pensamientos. xexexexexex

GLaDOS

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #15 en: 01-03-2014, 14:01 (Sábado) »
El caso es que mi cuñado (que es el que funciona con ese setup) en Win tenía estabilidad total, ahora funciona a través de OpenWRT- Commtrend VR-3025u y conexiones de 50 min.

Voy a rebuscar el post gracias al que pude programar un Script que re-conecta la interfaz WAN al caerse.

alfonsom

  • Visitante
Re: Ayuda con antena USB en openwrt
« Respuesta #16 en: 26-11-2015, 08:49 (Jueves) »
Acabo de probar con una alfa 1w. La detecta pero no asociada a nada ni a tiros, incluso teniendo casi un 90% de señal. Tengo una signalking china con chip ralink 3070, esta sí funciona perfecta, detecta y asocia muy bien. Me jode que la ubiquiti que es una buena antena no funcione en openwrt y la signalking que es china de 12 euros vaya perfecta...en fin..

Saludos¡¡¡
Hola me puede decir que router tienes y la version de openwrt que usas con la antena signalking, es la misma que tengo y yo no consigo que la reconozca.

Saludos

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2192
Re: Ayuda con antena USB en openwrt
« Respuesta #17 en: 26-11-2015, 11:26 (Jueves) »
Acabo de probar con una alfa 1w. La detecta pero no asociada a nada ni a tiros, incluso teniendo casi un 90% de señal. Tengo una signalking china con chip ralink 3070, esta sí funciona perfecta, detecta y asocia muy bien. Me jode que la ubiquiti que es una buena antena no funcione en openwrt y la signalking que es china de 12 euros vaya perfecta...en fin..

Saludos¡¡¡
Hola me puede decir que router tienes y la version de openwrt que usas con la antena signalking, es la misma que tengo y yo no consigo que la reconozca.

Saludos

Mira a ver si esto te puede solucionar algo: https://foro.seguridadwireless.net/openwrt/antenas-usb-rt3572-y-openwrt/
Recuerda que tienes que instalarle los drivers del chipset wifi para que te reconozca la antena.