Autor Tema: noip openwrt  (Leído 7246 veces)

0 Usuarios y 1 Visitante están viendo este tema.

faio86

  • Visitante
noip openwrt
« en: 28-01-2014, 21:41 (Martes) »
Buenas, me gustaría tener acceso desde Internet (fuera de mi red) a las descargas (panel de control) de transmission.

El primer paso que ha sido abrir una cuenta en no-ip y configurar el apartado de luci-Dynamic DNS, similar a esto

Para ver que no es problema de los firewall, desactivo el firewall del router principal y el firewall de openwrt

Código: [Seleccionar]
el de openwrt lo desactivo
asi /etc/init.d/firewall stop

El problema es al entrar a la dirección de noip entra al Router principal donde pone usuario y contraseña.

pongo un dmesg por si os ayuda.
Código: [Seleccionar]
[    0.000000] Linux version 3.3.8 (marco@homer) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #9 Wed Sep 12 18:05:29 CEST 2012
[    0.000000] Detected Broadcom 0x6358 CPU revision a1
[    0.000000] CPU frequency is 300 MHz
[    0.000000] 64MB of RAM installed
[    0.000000] registering 40 GPIOs
[    0.000000] gpiochip_add: registered GPIOs 0 to 39 on device: bcm63xx-gpio
[    0.000000] board_bcm963xx: Boot address 0xbe000000
[    0.000000] board_bcm963xx: CFE version: 100.48.56-48.46
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 0002a010 (Broadcom BMIPS4350)
[    0.000000] board_bcm963xx: board name: HW553
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00004000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00004000
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 802a5c30, node_mem_map 81000000
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16256 pages, LIFO batch:3
[    0.000000] Reserving 0MB of memory at 0MB for crashkernel
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line:  root=/dev/mtdblock2 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
[    0.000000] Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] Memory: 61848k/65536k available (2244k kernel code, 3688k reserved, 404k data, 196k init, 0k highmem)
[    0.000000] NR_IRQS:128
[    0.000000] Calibrating delay loop... 299.26 BogoMIPS (lpj=598528)
[    0.036000] pid_max: default: 32768 minimum: 301
[    0.040000] Mount-cache hash table entries: 512
[    0.052000] NET: Registered protocol family 16
[    0.068000] registering PCI controller with io_map_base unset
[    0.088000] bio: create slab <bio-0> at 0
[    0.096000] PCI host bridge to bus 0000:00
[    0.100000] pci_bus 0000:00: root bus resource [mem 0x30000000-0x37ffffff]
[    0.104000] pci_bus 0000:00: root bus resource [io  0x8000000-0x800ffff]
[    0.108000] pci 0000:00:01.0: [14e4:4318] type 0 class 0x000280
[    0.108000] pci 0000:00:01.0: reg 10: [mem 0x00000000-0x00001fff]
[    0.120000] pci 0000:00:01.0: BAR 0: assigned [mem 0x30000000-0x30001fff]
[    0.124000] Switching to clocksource MIPS
[    0.136000] PCI: Enabling device 0000:00:01.0 (0000 -> 0002)
[    0.144000] b43-pci-bridge 0000:00:01.0: setting latency timer to 64
[    0.164000] ssb: Found chip with id 0x4318, rev 0x02 and package 0x00
[    0.172000] ssb: Core 0 found: ChipCommon (cc 0x800, rev 0x0D, vendor 0x4243)
[    0.172000] ssb: Core 1 found: IEEE 802.11 (cc 0x812, rev 0x09, vendor 0x4243)
[    0.172000] ssb: Core 2 found: PCI (cc 0x804, rev 0x0C, vendor 0x4243)
[    0.172000] ssb: Core 3 found: PCMCIA (cc 0x80D, rev 0x07, vendor 0x4243)
[    0.212000] ssb: Sonics Silicon Backplane found on PCI device 0000:00:01.0
[    0.220000] NET: Registered protocol family 2
[    0.228000] IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.236000] TCP established hash table entries: 2048 (order: 2, 16384 bytes)
[    0.240000] TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
[    0.248000] TCP: Hash tables configured (established 2048 bind 2048)
[    0.256000] TCP reno registered
[    0.260000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.264000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.272000] NET: Registered protocol family 1
[    0.276000] PCI: CLS 0 bytes, default 16
[    0.280000] audit: initializing netlink socket (disabled)
[    0.288000] type=2000 audit(0.288:1): initialized
[    0.292000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.300000] JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.308000] msgmni has been set to 120
[    0.312000] io scheduler noop registered
[    0.316000] io scheduler deadline registered (default)
[    0.324000] bcm63xx_uart.0: ttyS0 at MMIO 0xfffe0100 (irq = 10) is a bcm63xx_uart
[    0.332000] console [ttyS0] enabled, bootconsole disabled
[    0.352000] physmap platform flash device: 02000000 at 1e000000
[    0.356000] physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank. Manufacturer ID 0x000001 Chip ID 0x002101
[    0.368000] physmap-flash.0: Found an alias at 0x1000000 for the chip at 0x0
[    0.368000] Amd/Fujitsu Extended Query Table at 0x0040
[    0.372000]   Amd/Fujitsu Extended Query version 1.3.
[    0.380000] number of CFI chips: 1
[    0.384000] bcm63xxpart: CFE boot tag found with version 7 and board type HW553
[    0.392000] bcm63xxpart: Partition 0 is CFE offset 0 and length 20000
[    0.396000] bcm63xxpart: Partition 1 is kernel offset 20100 and length fff00
[    0.404000] bcm63xxpart: Partition 2 is rootfs offset 120000 and length ec0000
[    0.412000] bcm63xxpart: Partition 3 is nvram offset fe0000 and length 20000
[    0.420000] bcm63xxpart: Partition 4 is linux offset 20000 and length fc0000
[    0.428000] bcm63xxpart: Spare partition is offset a40004 and length 59fffc
[    0.432000] 5 bcm63xxpart partitions found on MTD device physmap-flash.0
[    0.440000] Creating 5 MTD partitions on "physmap-flash.0":
[    0.448000] 0x000000000000-0x000000020000 : "CFE"
[    0.456000] 0x000000020100-0x000000120000 : "kernel"
[    0.460000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.476000] 0x000000120000-0x000000fe0000 : "rootfs"
[    0.488000] mtd: partition "rootfs" set to be root filesystem
[    0.492000] mtd: partition "rootfs_data" created automatically, ofs=A40000, len=5A0000
[    0.500000] 0x000000a40000-0x000000fe0000 : "rootfs_data"
[    0.512000] 0x000000fe0000-0x000001000000 : "nvram"
[    0.520000] 0x000000020000-0x000000fe0000 : "linux"
[    0.540000] bcm63xx_enet MII bus: probed
[    0.544000] bcm63xx_enet bcm63xx_enet.0: attached PHY at address 1 [Generic PHY]
[    0.556000] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    0.564000] Registered led device: HW553:red:lan
[    0.568000] Registered led device: HW553:blue:lan
[    0.568000] Registered led device: HW553:red:adsl
[    0.568000] Registered led device: HW553:blue:adsl
[    0.568000] Registered led device: HW553:red:power
[    0.568000] Registered led device: HW553:blue:power
[    0.572000] Registered led device: HW553:red:wifi
[    0.572000] Registered led device: HW553:red:internetkey
[    0.572000] Registered led device: HW553:blue:internetkey
[    0.572000] TCP cubic registered
[    0.576000] NET: Registered protocol family 17
[    0.584000] 8021q: 802.1Q VLAN Support v1.8
[    0.596000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    0.604000] Freeing unused kernel memory: 196k freed
[    4.236000] eth1: link forced UP - 100/full - flow control off/off
[    4.436000] roboswitch: Probing device eth0: Failed to enable switch
[    4.444000] roboswitch: Probing device eth1: found a 5325! It's a 5350.
[   10.648000] JFFS2 notice: (371) jffs2_build_xattr_subsystem: complete building xattr subsystem, 1 of xdatum (1 unchecked, 0 orphan) and 11 of xref (0 dead, 0 orphan) found.
[   12.100000] SCSI subsystem initialized
[   12.424000] usbcore: registered new interface driver usbfs
[   12.432000] usbcore: registered new interface driver hub
[   12.440000] usbcore: registered new device driver usb
[   13.304000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[   13.416000] bcm63xx_ehci bcm63xx_ehci.0: BCM63XX integrated EHCI controller
[   13.420000] bcm63xx_ehci bcm63xx_ehci.0: new USB bus registered, assigned bus number 1
[   13.456000] bcm63xx_ehci bcm63xx_ehci.0: irq 18, io mem 0xfffe1300
[   13.472000] bcm63xx_ehci bcm63xx_ehci.0: USB 2.0 started, EHCI 1.00, overcurrent ignored
[   13.480000] hub 1-0:1.0: USB hub found
[   13.484000] hub 1-0:1.0: 2 ports detected
[   13.516000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[   13.624000] bcm63xx_ohci bcm63xx_ohci.0: BCM63XX integrated OHCI controller
[   13.628000] bcm63xx_ohci bcm63xx_ohci.0: new USB bus registered, assigned bus number 2
[   13.636000] bcm63xx_ohci bcm63xx_ohci.0: irq 13, io mem 0xfffe1400
[   13.704000] hub 2-0:1.0: USB hub found
[   13.708000] hub 2-0:1.0: 1 port detected
[   13.824000] uhci_hcd: USB Universal Host Controller Interface driver
[   13.860000] Initializing USB Mass Storage driver...
[   13.868000] usbcore: registered new interface driver usb-storage
[   13.872000] USB Mass Storage support registered.
[   38.452000] Compat-drivers backport release: compat-drivers-2012-09-04-2-gddac993
[   38.460000] Backport based on wireless-testing.git master-2012-09-07
[   38.464000] compat.git: wireless-testing.git
[   38.536000] cfg80211: Calling CRDA to update world regulatory domain
[   38.540000] cfg80211: World regulatory domain updated:
[   38.548000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   38.556000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   38.564000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   38.572000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   38.580000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   38.588000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   39.456000] cfg80211: World regulatory domain updated:
[   39.460000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   39.468000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   39.476000] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   39.484000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[   39.492000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   39.500000] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[   40.584000] usbcore: registered new interface driver rtl8187
[   40.628000] usbcore: registered new interface driver rt2800usb
[   40.748000] NET: Registered protocol family 8
[   40.756000] NET: Registered protocol family 20
[   42.364000] wl: module license 'unspecified' taints kernel.
[   42.372000] Disabling lock debugging due to kernel taint
[   42.472000] SSB/BCMA glue driver successfully attached
[   42.492000] Got version 2 SPROM from SSB
[   42.504000] wl0: Broadcom BCM4318 802.11 Wireless Controller 5.10.56.27
[   42.548000] Button Hotplug driver version 0.4.1
[   43.636000] PPP generic driver version 2.4.2
[   44.364000] tun: Universal TUN/TAP device driver, 1.6
[   44.368000] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[   44.788000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   45.256000] NET: Registered protocol family 24
[   45.516000] nf_conntrack version 0.5.0 (969 buckets, 3876 max)
[   46.472000] usbcore: registered new interface driver usbserial
[   46.476000] USB Serial support registered for generic
[   46.484000] usbcore: registered new interface driver usbserial_generic
[   46.488000] usbserial: USB Serial Driver core
[   46.860000] USB Serial support registered for GSM modem (1-port)
[   46.868000] usbcore: registered new interface driver option
[   46.872000] option: v0.7.2:USB Driver for GSM modems
[   53.132000] eth1: link forced UP - 100/full - flow control off/off
[   53.148000] device eth1 entered promiscuous mode
[   53.156000] br-lan: port 1(eth1) entered forwarding state
[   53.160000] br-lan: port 1(eth1) entered forwarding state
[   55.164000] br-lan: port 1(eth1) entered forwarding state

Como debo configurarlo para ver trasnmission???.

Gracias de antemano. >:D >:D




« Última modificación: 28-01-2014, 22:42 (Martes) por faio86 »

Pteridium

  • Visitante
Re: noip openwrt
« Respuesta #1 en: 28-01-2014, 21:55 (Martes) »
¿Podrías aclarar lo de tener acceso externo?

Por lo que comentas, y por la experiencia que tengo con esto, por defecto te va a conectar al router en el que tengas configurado no-ip, así que toca redirigir o abrir puertos en el firewall.

faio86

  • Visitante
Re: noip openwrt
« Respuesta #2 en: 28-01-2014, 22:30 (Martes) »
Aclaro ip externa me refiero a conectarme a transmission desde mi movil por 3g o una conexion fuera de mi red y ver como van mis descargas y tal.

noip lo tengo en el router de openwrt.

(solo me actualiza la ip en no-ip manualmente).

(en otras pruebas me pillaba la ip pero era al conectarme a noip por web  :-X sorry)

 ahora lo he comprobado desde el router-openwrt y no pilla.


Tengo el router-openwrt conectado por cable al router principal y el interfaz wifi desactivado por si influye.

¿¿En caso de redirigir puertos que puertos seria el 9091???
¿¿Como debo configurarlo para que pille la ip 'Url' 'interfaz eth1' 'wan'???

Gracias.. ;D
« Última modificación: 28-01-2014, 22:39 (Martes) por faio86 »

Pteridium

  • Visitante
Re: noip openwrt
« Respuesta #3 en: 28-01-2014, 22:55 (Martes) »
Yo tengo el router con openwrt conectado a un modem, con lo que no tengo ni idea de cómo hacer que te dé no-ip cuando estás detrás de otro router.
Esto es un trozo de /etc/config/firewall con el que accedía en remoto por ssh a un router con el que estaba cacharreando:
Código: [Seleccionar]
config redirect
option target 'DNAT'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '22'
option dest_ip '192.168.1.2'
option dest_port '22'
option name 'ssh_tests'

Y ésta es la redirección para acceder al router principal por ssh:
Código: [Seleccionar]
config rule
option src 'wan'
option proto 'tcp'
option dest_port '2222'
option target 'ACCEPT'
option name 'ssh_wan'
Puse el puerto ssh en 2222 porque al dejarlo en 22 en el log del sistema me aparecían un montón de intentos de acceso desde ip's chinas.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: noip openwrt
« Respuesta #4 en: 29-01-2014, 08:53 (Miércoles) »
En el router principal, debes redirigir/abrir el puerto 9091 hacia la IP del router con OpenWrt.
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

faio86

  • Visitante
Re: noip openwrt
« Respuesta #5 en: 29-01-2014, 16:07 (Miércoles) »
Hola buenas, en el routeropenwrt he puesto
Código: [Seleccionar]
config redirect
option target 'DNAT'
option src 'wan'
option dest 'lan'
option proto 'tcp'
option src_dport '9091'
option dest_ip '192.168.1.2'// la ip de mi router principal el que da acceso a internet
option dest_port 9091'
option name 'ssh_tests'

ip openwrt 192.168.1.98
ip router principal 192.168.1.2

y el router principal



el router tiene el firmware poligon

meto mi ip publica ejemplo xx.xx.xxx.xxx:9091 y no consigo acceder.
al meter mi ip publica xx.xx.xxx.xxx sale la configuracion del router principal


network
Código: [Seleccionar]
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.98'
option gateway '192.168.1.2'
option dns '8.8.8.8'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'


Muchísimas gracias por vuestra colaboración >:( >:D 8).
« Última modificación: 29-01-2014, 16:11 (Miércoles) por faio86 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4593
Re: noip openwrt
« Respuesta #6 en: 29-01-2014, 19:32 (Miércoles) »
Como el router con OpenWrt está funcionando como un simple cliente cableado de la red, lo mejor es que deshabilites el firewall:

Código: [Seleccionar]
/etc/init.d/firewall disable
/etc/init.d/firewall stop
Valoraciones positivas en compra/venta:
155 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

faio86

  • Visitante
Re: noip openwrt
« Respuesta #7 en: 30-01-2014, 15:43 (Jueves) »
Buenas.

No lo consigo, he pensado que cambiando el firmware del router principal puede que funcione.
Actualmente tengo un cifrado wpa2-psk y no se si ese cifrado lo admitirá este firm

bitswitcher, parece muy interesante ¿¿alguien lo tiene???

Edito:
Acabo de instalar este firm con la misma configuración wifi que tenia antes (wpa-psk+wpa-psk/tkip), y va bastante bien.

Proximamente probare a abrir los puertos y tal, y os comento.

Dejo un enlace para descargar este firm traducido en español
Bitswitcher
Espero sea de utilidad a algien ???

Yo lo he probado en hg536+ ,  creo que funciona en todos los Broadcom 6348 ??? :-X.

Muchas Gracias ;)
« Última modificación: 30-01-2014, 21:48 (Jueves) por faio86 »

faio86

  • Visitante
Re: noip openwrt
« Respuesta #8 en: 05-02-2014, 17:48 (Miércoles) »
Bueno al final volví a instalar el firm poligon .
El wifi de bitswitcher era muy inestable, con constantes caidas.

No consigo ver el puerto 9091 aun abriendo puertos en el router principal y el de openwrt sin firewall como dijisteis.

Gracias por vuestra colaboración.
« Última modificación: 15-02-2014, 23:26 (Sábado) por faio86 »

eucota

  • Visitante
Re: noip openwrt
« Respuesta #9 en: 01-12-2015, 09:48 (Martes) »
Muy buenas,

Aunque este hilo esta más que pasao aclarar que creo que la solución la tienes en el hilo "configuraciones básicas openwrt" concretamente en el apartado de "route" modificando el archivo con vi tal y como se explica. Si no hago ese paso me pasa lo que describes, al hacerlo se accede sin problema. También puedes probar haciendo en el router principal DMZ a la IP del openwrt.

Saludos.

//FINAL Y MÁS DOS RESPUESTAS