Autor Tema: Incapaz de conectar router neutro con OpenWRT a cablemodem  (Leído 2894 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jfromeo

  • Visitante
Incapaz de conectar router neutro con OpenWRT a cablemodem
« en: 27-05-2014, 02:17 (Martes) »
Buenas a todos.

Dispongo de los siguientes equipos:

  • Router cable Netgear CG3100Dv3 con firmware 1.05.05
  • Router neutro Comtrend 5813N con firmware OpenWRT r37180

Pretendo pasar el router cable a modo bridge (cablemodem) y conectarle el router neutro para gestionar la LAN y el WiFi desde éste último.

He seguido los siguientes pasos:

En el router cable Netgear CG3100Dv3:

  • Deshabilitar WiFi
  • Deshabilitar DHCP
  • Deshabilitar Firewall
  • Cambiar la IP de la puerta de enlace a 192.168.0.1
  • Habilitar DMZ en 192.168.0.2

En el router neutro Comtrend 5813N:

Eliminar todas las interfaces
Crear una interfaz LAN, tipo VLAN sobre eth0 -eth0.1-, asignándole los puertos "Port 0" a "Port 3" (puertos 1-4 físicos en el router neutro)
Editar la interfaz LAN en "Static IP Address", asignándole la IP 192.168.1.1
Crear una interfaz WAN, tipo VLAN sobre eth0 -eth0.2-, asignándole el puerto Port 4 (puerto WAN físico en el router neutro)
Editar la interfaz WAN en "Static IP Address", asignándole la IP 192.168.0.2 (DMZ), puerta de enlace 192.168.0.1 (cablemodem Netgear)
Habilitar DHCP desde 192.168.1.100 a 192.168.1.254

Pues bien, si me conecto físicamente al cablemodem, funciona todo perfectamente. Pero en cuanto pongo el neutro detrás (y me conecto a él), nada funciona.

Os adjunto unas capturas de las partes más "delicadas" de la configuración:

VLANs creadas


Interfaces creadas


Configuración interfaz LAN




Configuración interfaz WAN




Pienso que el problema puede venir de la configuración manual de la WAN, ya que el router neutro no parece conectarse al cablemodem (el LAN y el WiFi funciona perfectamente, pero sin salida a internet).

Muchas gracias por adelantado.
Un saludo.



Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2080
Re: Incapaz de conectar router neutro con OpenWRT a cablemodem
« Respuesta #1 en: 27-05-2014, 08:20 (Martes) »
Poner un router en modo DMZ (De-Militarized Zone) no lo pone en modo bridge.
En modo bridge el router copia todo lo que entra a la salida sin interpretar datos. Por eso al router neutro que esté detrás le asignará la IP pública, ya que él mismo es como si no existiera.
Con la zona DMZ, lo que hacemos es "redirigir" lo que entra a otra IP, con lo que perdemos la IP original. Vamos, que lo que hacemos es un ruteo de datos, pero todos a la misma IP.
Para poner el router Netgear en modo bridge, mira a ver si te sirve esto: http://wiki.bandaancha.st/Netgear_CG3100D_opciones_avanzadas/ocultas
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Lighter

  • Visitante
Re: Incapaz de conectar router neutro con OpenWRT a cablemodem
« Respuesta #2 en: 29-05-2014, 19:46 (Jueves) »
Me rompí la cabeza una tarde para resolver el mismo problema, el modem lo puse en bridge y la interfaz WAN con cliente pppoe, pones usuario y password y listo, averigua cómo poner tu modem en modo bridge.
« Última modificación: 29-05-2014, 19:49 (Jueves) por Lighter »

jfromeo

  • Visitante
Re: Incapaz de conectar router neutro con OpenWRT a cablemodem
« Respuesta #3 en: 13-06-2014, 10:24 (Viernes) »
Poner un router en modo DMZ (De-Militarized Zone) no lo pone en modo bridge.
En modo bridge el router copia todo lo que entra a la salida sin interpretar datos. Por eso al router neutro que esté detrás le asignará la IP pública, ya que él mismo es como si no existiera.
Con la zona DMZ, lo que hacemos es "redirigir" lo que entra a otra IP, con lo que perdemos la IP original. Vamos, que lo que hacemos es un ruteo de datos, pero todos a la misma IP.
Para poner el router Netgear en modo bridge, mira a ver si te sirve esto: http://wiki.bandaancha.st/Netgear_CG3100D_opciones_avanzadas/ocultas


Gracias, desde la 1.05.05 se puede desactivar el NAT directamente sin tener que hacer telnet.

Estoy por cable ethernet, interfaz 10/100/1000.

Antes tenía 100MB/10MB. He hecho la prueba de conectarme directamente al CG3100Dv3 y pasar el speedtest y da 100MB/10MB, pero cuando pongo el Comtrend delante, me baja a 25MB/10MB. Creo que puedo descartar entonces que sea algo del firewall del router en modo bridge. Probaré a leer sobre el OpenWRT.
« Última modificación: 13-06-2014, 12:25 (Viernes) por jfromeo »

//FINAL Y MÁS DOS RESPUESTAS