Autor Tema: Imposible overlay en OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530  (Leído 2407 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ATAGA

  • Visitante
Estoy intentando hacer overlay en una de las tres particiones que tengo en un disco duro de 1,8´´:

   /dev/sda1: UUID="55e7486d-6035-4410-9c96-cb426f4e1af6" LABEL="SWAP" VERSION="2" TYPE="swap"
   /dev/sda2: UUID="47ae9452-b20b-4bb4-8749-f18a37dddb4a" LABEL="SYSTEM" NAME="EXT_JOURNAL" VERSION="1.0" TYPE="ext4"
   /dev/sda3: UUID="68d5bf9b-fbe0-4bb2-af60-b4a9d20566b9" LABEL="DATA" NAME="EXT_JOURNAL" VERSION="1.0" TYPE="ext4"

Cualquier intento por montar la particion sda2 en /overlay se la pasa por el forro....ya sea desde LuCI o editando el archivo fstab manualmente desde SSH. La unica manera de poder hacerlo es montandola directamente con el comando:

mount -t ext4 /dev/sda2 /overlay -o rw,sync

Y ESTO FUNCIONA, pero al reiniciar el router no se automonta la particion por lo que tengo que volver a montarla en cada reinicio  ¿hay alguna manera de automontarla en el arranque?



Ficht

  • Visitante
Estoy intentando hacer overlay en una de las tres particiones que tengo en un disco duro de 1,8´´:

   /dev/sda1: UUID="55e7486d-6035-4410-9c96-cb426f4e1af6" LABEL="SWAP" VERSION="2" TYPE="swap"
   /dev/sda2: UUID="47ae9452-b20b-4bb4-8749-f18a37dddb4a" LABEL="SYSTEM" NAME="EXT_JOURNAL" VERSION="1.0" TYPE="ext4"
   /dev/sda3: UUID="68d5bf9b-fbe0-4bb2-af60-b4a9d20566b9" LABEL="DATA" NAME="EXT_JOURNAL" VERSION="1.0" TYPE="ext4"

Cualquier intento por montar la particion sda2 en /overlay se la pasa por el forro....ya sea desde LuCI o editando el archivo fstab manualmente desde SSH. La unica manera de poder hacerlo es montandola directamente con el comando:

mount -t ext4 /dev/sda2 /overlay -o rw,sync

Y ESTO FUNCIONA, pero al reiniciar el router no se automonta la particion por lo que tengo que volver a montarla en cada reinicio  ¿hay alguna manera de automontarla en el arranque?
Hola
Asegurate de que la edicion de archivo fstab es el que esta en el arranque del router y no en una copia creada en la partición  a montar...
Revisa el hilo de extroot (hilos relevantes) que hay comandos útiles, ademas de mirar en openwrt.org.

Enviado desde mi LG-D390n mediante Tapatalk


ATAGA

  • Visitante
No se si sera porque no puedo instalar los paquetes "block-hotplug" y "block-extroot" que no existen para esta compilacion. Ademas lo mas asombroso es que si lo configuras desde LuCI aun activando la opcion "Usar como raíz del sistema de ficheros" o diciendole expresamente que te lo monte en "/overlay" te lo monta si o si en "mnt/sda2" (el numero es de  la particion que tu hayas elegido).

Si te metes dentro del sistema y editas por vi la tabla de particiones (fstab) y fuerzas a que la monte en /overlay misteriosamente nunca se llega a montar la particion ya puede estar el fstab en el directorio /etc o en el /etc/config o en ambos sitios a la vez que no hay manera....

Si la montas tu mismo "mount -t ext4 /dev/sda2 /overlay -o rw,sync" entonces si esponde y la unica manera de automontarla es escribiendo este mismo codigo en "sistema > Arrranque > Arranque local"

mount -t ext4 /dev/sda2 /overlay -o rw,sync
exit 0


Ficht

  • Visitante
No se si sera porque no puedo instalar los paquetes "block-hotplug" y "block-extroot" que no existen para esta compilacion. Ademas lo mas asombroso es que si lo configuras desde LuCI aun activando la opcion "Usar como raíz del sistema de ficheros" o diciendole expresamente que te lo monte en "/overlay" te lo monta si o si en "mnt/sda2" (el numero es de  la particion que tu hayas elegido).

Si te metes dentro del sistema y editas por vi la tabla de particiones (fstab) y fuerzas a que la monte en /overlay misteriosamente nunca se llega a montar la particion ya puede estar el fstab en el directorio /etc o en el /etc/config o en ambos sitios a la vez que no hay manera....

Si la montas tu mismo "mount -t ext4 /dev/sda2 /overlay -o rw,sync" entonces si esponde y la unica manera de automontarla es escribiendo este mismo codigo en "sistema > Arrranque > Arranque local"

mount -t ext4 /dev/sda2 /overlay -o rw,sync
exit 0
Te respondo luego desde un pc

Enviado desde mi LG-D390n mediante Tapatalk


Ficht

  • Visitante
No se si sera porque no puedo instalar los paquetes "block-hotplug" y "block-extroot" que no existen para esta compilacion. Ademas lo mas asombroso es que si lo configuras desde LuCI aun activando la opcion "Usar como raíz del sistema de ficheros" o diciendole expresamente que te lo monte en "/overlay" te lo monta si o si en "mnt/sda2" (el numero es de  la particion que tu hayas elegido).

Si te metes dentro del sistema y editas por vi la tabla de particiones (fstab) y fuerzas a que la monte en /overlay misteriosamente nunca se llega a montar la particion ya puede estar el fstab en el directorio /etc o en el /etc/config o en ambos sitios a la vez que no hay manera....

Si la montas tu mismo "mount -t ext4 /dev/sda2 /overlay -o rw,sync" entonces si esponde y la unica manera de automontarla es escribiendo este mismo codigo en "sistema > Arrranque > Arranque local"

mount -t ext4 /dev/sda2 /overlay -o rw,sync
exit 0



Hola.
Si se monta manualmente, entonces no tendría que haber problemas para que se monte en el arranque de manera automática.

Ejecutas así?  para fstab

Código: [Seleccionar]
block detect > /etc/config/fstab
edita las opciones de montaje

Código: [Seleccionar]
vi /etc/config/fstab
https://foro.seguridadwireless.net/openwrt/ejecutando-openwrt-desde-una-memoria-o-disco-usb-(extroot)/

Revisa aquí también.

https://wiki.openwrt.org/doc/howto/extroot

ATAGA

  • Visitante
El archivo fstab lo tengo tal que asi:

config global
   option anon_swap '0'
   option anon_mount '0'
   option auto_swap '1'
   option auto_mount '1'
   option delay_root '10'
   option check_fs '0'

config swap
   option enabled '1'
   option device '/dev/sda1'

config mount
        option device '/dev/sda2'
        option target '/overlay'
   option enabled '1'
   option fstype 'ext4'
   option is_rootfs '1'

config mount
   option enabled '1'
   option device '/dev/sda3'
   option target '/data'
   option fstype 'ext4'
   option options 'rw,sync'

Si quito el autoarranque "mount -t ext4 /dev/sda2 /overlay -o rw,sync" y reinico desaparece el montaje, de hecho, si escribo en ssh el comando mount no aparece montado. Tambien pense hacer el montaje manual y luego meterle "block detect > /etc/config/fstab"  para haber si se guardaba la configuracion con los cambios, pero al abrir fstab me pone forzosamente "mnt/sda2"  y lo mas curioso es que crea automaticamente el directorio "mnt/sda2" y luego lo monta alli por narices...

Este tutorial tambien lo he probado y sigo igual
https://foro.seguridadwireless.net/openwrt/ejecutando-openwrt-desde-una-memoria-o-disco-usb-(extroot)/

La unica diferencia es que a mi el overlay me lo monta por defecto en  "/dev/ubi0_1" que no se puede desmontar y si lo intentas se desmonta la "mnt/sda2" , ademas si monto "mnt/sda2"  en overlay aparecen  "/dev/ubi0_1"  y  "/dev/sda2" montadas en overlay a la vez.

Ficht

  • Visitante
El archivo fstab lo tengo tal que asi:

config global
   option anon_swap '0'
   option anon_mount '0'
   option auto_swap '1'
   option auto_mount '1'
   option delay_root '10'
   option check_fs '0'

config swap
   option enabled '1'
   option device '/dev/sda1'

config mount
        option device '/dev/sda2'
        option target '/overlay'
   option enabled '1'
   option fstype 'ext4'
   option is_rootfs '1'

config mount
   option enabled '1'
   option device '/dev/sda3'
   option target '/data'
   option fstype 'ext4'
   option options 'rw,sync'

Si quito el autoarranque "mount -t ext4 /dev/sda2 /overlay -o rw,sync" y reinico desaparece el montaje, de hecho, si escribo en ssh el comando mount no aparece montado. Tambien pense hacer el montaje manual y luego meterle "block detect > /etc/config/fstab"  para haber si se guardaba la configuracion con los cambios, pero al abrir fstab me pone forzosamente "mnt/sda2"  y lo mas curioso es que crea automaticamente el directorio "mnt/sda2" y luego lo monta alli por narices...

Este tutorial tambien lo he probado y sigo igual
https://foro.seguridadwireless.net/openwrt/ejecutando-openwrt-desde-una-memoria-o-disco-usb-(extroot)/

La unica diferencia es que a mi el overlay me lo monta por defecto en  "/dev/ubi0_1" que no se puede desmontar y si lo intentas se desmonta la "mnt/sda2" , ademas si monto "mnt/sda2"  en overlay aparecen  "/dev/ubi0_1"  y  "/dev/sda2" montadas en overlay a la vez.

Aquí está el modo correcto de hacerlo en Barrier Breaker
https://wiki.openwrt.org/doc/howto/extroot.old#barrier_breaker

fíjate bien...  el orden en el que haces los pasos... luego las opciones de montaje.

Si desde la pantalla de luci - programas o software no salen los megas que corresponde al disco, no está montado correctamente.
« Última modificación: 29-12-2015, 18:39 (Martes) por Ficht »

ATAGA

  • Visitante
Re: Imposible overlay en OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530
« Respuesta #7 en: 30-12-2015, 11:42 (Miércoles) »
Solucionado >:(, me he leido mas detenidamente el ultimo enlace que me has dejado y el problema era que en la opcion:

option target '/overlay'

hay que escribirla asi:

option target 'overlay'

,es decir, sin la barrita. Menos mal que este problema estaba comentado en la wiki... porque yo seria incapaz de llegar a esa conclusion tan disparatada.

Gracias por todo

//FINAL Y MÁS DOS RESPUESTAS