Autor Tema: Configurar Wifi para invitados (y limitar su velocidad)  (Leído 22933 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Elnef

  • Visitante
Configurar Wifi para invitados (y limitar su velocidad)
« en: 19-11-2013, 13:31 (Martes) »
Tengo un HG556a Atheros con dos señales wifi. Ambas como puntos de acceso con distintos SSID y password.

Y me gustaría limitar la velocidad de la conexión de una de las dos, para que los usuarios de la otra tengan "preferencia". He estado mirando los hilos que habland el QOS, pero sólo veo su aplicación para IPs concretas. No veo forma de indicar preferencia en función de la Wii.

Lo ideal sería que una de ellas sólo usar 512 kbs de velocidad mientras los usuarios de la otra dispongan del resto del ancho de banda.

¿Es posible?


« Última modificación: 21-11-2013, 12:13 (Jueves) por jar229 »

Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #1 en: 20-11-2013, 13:49 (Miércoles) »
Tengo un HG556a Atheros con dos señales wifi. Ambas como puntos de acceso con distintos SSID y password.

Y me gustaría limitar la velocidad de la conexión de una de las dos, para que los usuarios de la otra tengan "preferencia". He estado mirando los hilos que habland el QOS, pero sólo veo su aplicación para IPs concretas. No veo forma de indicar preferencia en función de la Wii.

Lo ideal sería que una de ellas sólo usar 512 kbs de velocidad mientras los usuarios de la otra dispongan del resto del ancho de banda.

¿Es posible?

Tras invertigar más, veo que mi solución no pasa por QOS, sino por generar dos interfaces lan y asignar una a cada red wifi. Luego con el wshaper puedo limitar la conexión de una de ellas.

El problema que tengo es que cuando genero la segunda interfaz no consigo que tenga acceso a internet.

Para clarificar el tema:
- Tengo un modem router que controla el aceso a internet, la nat, el DHCP etc. con al IP 192.168.1.1

- Por cable de red tengo un HG556a atheros con ip 192.168.1.2 con una sola interface LAN sin DHCP y con conexión Wifi.

Y quiero hacer una segunda interface que se comunique con la primera con ip 10.0.0.1 con DHCP. Y consu propia wifi

Lo consigo. Y los equipos conectados a esa red cogen la ip del tipo 10.0.0.0/24, pueden hacer ping a la 192.168.1.2, pero no a la 192.168.1.1 y no tienen acceso a internet.

He seguido este tuto:
http://wiki.openwrt.org/doc/recipes/guest-wlan

peluzza

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #2 en: 20-11-2013, 15:08 (Miércoles) »
Tengo un HG556a Atheros con dos señales wifi. Ambas como puntos de acceso con distintos SSID y password.

Y me gustaría limitar la velocidad de la conexión de una de las dos, para que los usuarios de la otra tengan "preferencia". He estado mirando los hilos que habland el QOS, pero sólo veo su aplicación para IPs concretas. No veo forma de indicar preferencia en función de la Wii.

Lo ideal sería que una de ellas sólo usar 512 kbs de velocidad mientras los usuarios de la otra dispongan del resto del ancho de banda.

¿Es posible?

Tras invertigar más, veo que mi solución no pasa por QOS, sino por generar dos interfaces lan y asignar una a cada red wifi. Luego con el wshaper puedo limitar la conexión de una de ellas.

El problema que tengo es que cuando genero la segunda interfaz no consigo que tenga acceso a internet.

Para clarificar el tema:
- Tengo un modem router que controla el aceso a internet, la nat, el DHCP etc. con al IP 192.168.1.1

- Por cable de red tengo un HG556a atheros con ip 192.168.1.2 con una sola interface LAN sin DHCP y con conexión Wifi.

Y quiero hacer una segunda interface que se comunique con la primera con ip 10.0.0.1 con DHCP. Y consu propia wifi

Lo consigo. Y los equipos conectados a esa red cogen la ip del tipo 10.0.0.0/24, pueden hacer ping a la 192.168.1.2, pero no a la 192.168.1.1 y no tienen acceso a internet.

He seguido este tuto:
http://wiki.openwrt.org/doc/recipes/guest-wlan


Por aclararlo definitivamente ¿Cuantas interfaces físicas utilizas? ¿se pasa lo mismo cuando virtualizas ifaces que cuando las conectas por usb?

Pega aquí tu salida del uci para los siguientes comandos: uci show, uci get network.CADA_UNO_DE_TUS_IFACES

o tambien puedes mostrar tu etc config network

Elnef

  • Visitante
Re: [Desarrollo] OpenWrt en Huawei HG556a
« Respuesta #3 en: 21-11-2013, 11:48 (Jueves) »
Estoy siguiendo estos tutoriales y nada.

http://wiki.openwrt.org/doc/recipes/guest-wlan
http://wiki.openwrt.org/doc/recipes/guest-wlan-webinterface

Y creo que mi problema es que aquí parten de que hay una Wan en el router. Y yo me conecto por la LAN, dejando toda la funcionalidad de modem, nat, etc al router principal de Movistar.

Aquí va mi configuración.

Network:
Código: [Seleccionar]
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd95:97ef:9ae7::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4 5t'

config interface 'guest'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option dns '8.8.8.8 8.8.4.4'


DHCP
Código: [Seleccionar]
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        list 'interface' 'lan'
        list 'interface' 'guest'

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config dhcp
        option start '100'
        option limit '150'
        option interface 'guest'
        option leasetime '1h'


Firewall
Código: [Seleccionar]
config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option network 'lan'
        option forward 'REJECT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
               option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'guest'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'guest'
        option input 'REJECT'

config rule
        option target 'ACCEPT'
        option proto 'tcp udp'
        option dest_port '53'
        option name 'Guest DNS'
        option src 'guest'

config rule
        option enabled '1'
        option target 'ACCEPT'
        option proto 'udp'
        option dest_port '67-68'
        option name 'Guest DHCP'
         option name 'Guest DHCP'
        option src 'guest'

config forwarding
        option dest 'wan'
        option src 'guest'



Wireless
Código: [Seleccionar]
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11ng'
        option path 'pci0000:00/0000:00:01.0'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'TX-STBC'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '19'
        option country 'US'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'GUEST'
        option encryption 'psk2+ccmp'
        option key 'GUESTpass'
        option network 'guest'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'MAINWIFI'
        option encryption 'psk2+ccmp'
        option key 'MAINWIFIpass'
        option network 'lan'

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #4 en: 21-11-2013, 12:16 (Jueves) »
El tema es interesante, así que lo he 'separado' del hilo principal del hg556a  ;)
Citar
Código: [Seleccionar]
config interface 'guest'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option dns '8.8.8.8 8.8.4.4'

Aquí te faltaría option gateway '10.0.0.1'

Yo pienso que es un tema del firewall ...  ^-^
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Elnef

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #5 en: 21-11-2013, 12:48 (Jueves) »
¿El mismo Gateway y ipadrr?

Elnef

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #6 en: 21-11-2013, 12:54 (Jueves) »
He probado lo del Gateway y sigue igual.

Un cosa que estoy viendo es que al conectarme al wifi de invitado me asigna una ip del tipo 10.0.0.1/24 pero no puedo hacer ping al 10.0.0.1

Yo también creo que los tiros van por la configuración del Firewall.

Elnef

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #7 en: 21-11-2013, 13:24 (Jueves) »
Si cambio en el firewall

Código: [Seleccionar]
config zone
        option name 'guest'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'guest'
        option input 'REJECT'

Por:
Código: [Seleccionar]
config zone
        option name 'guest'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'guest'
        option input 'ACCEPT'

Ya puedo hacer ping al 10.0.0.1 y al 192.168.1.2, pero no al 192.168.1.1 y sigo sin acceso a internet.

peluzza

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #8 en: 21-11-2013, 15:43 (Jueves) »
Es normal que no llegues a uno de los dos routers, eso es porque lo tienes en modo brigde, si sales a internet ves el router de internet, y si desconectas el cable de red y renuevas la conexion, vuelves a ver el router con owrt.

Como solución rápida, sin entrar en el fondo del asunto, yo pondría la wifi del homestation como principal y habilitaría una sola interfaz web en el segundo router como invitado, te evitas estos temas.

Si insistes en seguir ofreciendo dos wifis en un router, creo que deberías cambiar las interfaces virtuales a radio0.1 y radio0.2, ya que están las dos en radio0 y da conflicto.

En este aspecto, tambien da problemas el cambio de rango, quizá si una fuera 192.168.1.X y la otra fuera 192.168.2.X ...

Otra solución, cuesta menos de cuatro euros : http://dx.com/es/p/ultra-mini-nano-usb-2-0-802-11n-b-g-150mbps-wi-fi-wlan-wireless-network-adapter-black-71905
« Última modificación: 21-11-2013, 15:46 (Jueves) por peluzza »

vk496

  • Visitante
Re: Re: Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #9 en: 21-11-2013, 16:16 (Jueves) »
Es normal que no llegues a uno de los dos routers, eso es porque lo tienes en modo brigde, si sales a internet ves el router de internet, y si desconectas el cable de red y renuevas la conexion, vuelves a ver el router con owrt.

Como solución rápida, sin entrar en el fondo del asunto, yo pondría la wifi del homestation como principal y habilitaría una sola interfaz web en el segundo router como invitado, te evitas estos temas.

Si insistes en seguir ofreciendo dos wifis en un router, creo que deberías cambiar las interfaces virtuales a radio0.1 y radio0.2, ya que están las dos en radio0 y da conflicto.

En este aspecto, tambien da problemas el cambio de rango, quizá si una fuera 192.168.1.X y la otra fuera 192.168.2.X ...

Otra solución, cuesta menos de cuatro euros : http://dx.com/es/p/ultra-mini-nano-usb-2-0-802-11n-b-g-150mbps-wi-fi-wlan-wireless-network-adapter-black-71905
No lo exageran un poco?

Citar
- Potencia de transmisión: 20 dBm
- Distancia real de trabajo: 100 metros más lejos en interiores y 300 metros más lejos al aire libre (varía de acuerdo al medio ambiente)

Salu2

Enviado desde mi GT-I9505

Elnef

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #10 en: 22-11-2013, 07:43 (Viernes) »
Es normal que no llegues a uno de los dos routers, eso es porque lo tienes en modo brigde, si sales a internet ves el router de internet, y si desconectas el cable de red y renuevas la conexion, vuelves a ver el router con owrt.

Como solución rápida, sin entrar en el fondo del asunto, yo pondría la wifi del homestation como principal y habilitaría una sola interfaz web en el segundo router como invitado, te evitas estos temas.

Si insistes en seguir ofreciendo dos wifis en un router, creo que deberías cambiar las interfaces virtuales a radio0.1 y radio0.2, ya que están las dos en radio0 y da conflicto.

En este aspecto, tambien da problemas el cambio de rango, quizá si una fuera 192.168.1.X y la otra fuera 192.168.2.X ...

Otra solución, cuesta menos de cuatro euros : http://dx.com/es/p/ultra-mini-nano-usb-2-0-802-11n-b-g-150mbps-wi-fi-wlan-wireless-network-adapter-black-71905

No puedo hacer eso porque se trata de un punto de acceso en una oficina. Así que el router principal está en el cuarto de servidores a bastante distancia y su wifi no se pilla en toda la oficina. Por eso cojo una toma de red y conector el otro router con Openwrt para generar la señal wifi.

Respecto a lo de crear dos redes en el mismo radio, funciona muy bien si direcciono las dos al mismo interface lan. Pero entonces es tontería tener una wifi abierta y otra con seguridad, si al final ambas acceden a la misma red a la misma velocidad.

De todas formas si al final no consigo hacerlo con el mismo radio, tengo por aquí un módulo wifi usb que ya he usado previamente en algún experimento con OpenWRT. Pero ya digo que lo ideal sería hacerlo de este modo.

Otra alternativa que nunca he usado. Podría ser crear una interface WAN como interface principal de internet y direccionar la LAN y la GUEST a esa como hacen en el ejemplo del enlace. Pero desconozco como configurar un router con en esa configuración.

Supongo que habría que crear una WAN type DHCP, que coja la ip que le asigne el router principal y luego hacer una LAN en otra red con su propio DHCP. Pero creo que esto haría que no  pudierámos acceder al router principal.

ESto he visto ejemplos de como hacerlo en routers neutros que tienen un puerto WAN, pero no tengo ni idea de como hacerlo con un HG556a que usa como WAN los propios puertos lan.

¿Alguien se animaría a hacer un tutorial de la configuración de switch del openwrt de Luci? Porque yo me pierdo en los conceptos de Vlan, tagged, etc
« Última modificación: 22-11-2013, 07:46 (Viernes) por Elnef »

Elnef

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #11 en: 27-11-2013, 14:13 (Miércoles) »
Conseguido.

He tenido que cambiar mi punto de partida y sólo usar los tutoriales como consejos. Y ya está funcionando. Hoy no tengo tiempo pero durante esta semana abriré un hilo nuevo con un tutorial para quien lo quiera hacer.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #12 en: 28-11-2013, 09:12 (Jueves) »
Conseguido.

He tenido que cambiar mi punto de partida y sólo usar los tutoriales como consejos. Y ya está funcionando. Hoy no tengo tiempo pero durante esta semana abriré un hilo nuevo con un tutorial para quien lo quiera hacer.

Estupendo  ;)
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

espinete2004

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #13 en: 02-12-2013, 17:10 (Lunes) »
Hola Elnef....

estoy en tu mismo caso. Cuando configuro las interfaces con su correspondientes wifis dejo de tener acceso al router y la wifi invitados asigna ip pero no sale a internet.

¿Lo has conseguido hacer sin una wifi usb pinchada al router?

Un saludín.

jrierab

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #14 en: 06-12-2013, 20:47 (Viernes) »
Yo estoy igual, con un WDR3600. La red de invitados funciona correctamente, asigna IP e incluso puedo hacer ping al router sin problemas. Pero no sale a internet   :(

Creo que tiene que ser algo de las VLANs. Estoy ahora con fibra óptica, pero antes, con ADSL normal y un 1043ND, esta misma configuración funcionaba sin problemas. O eso, o la versión del Openwrt (antes 1.4.7, ahora 1.5.11).

En fin, si a alguien se le ocurre algo, que lo comente.

Edito:

Bueno, en mi caso era una tontería. En la configuración de la zona guest en el firewall, no había puesto:
        option network 'guest'

¡Ahora funcionando correctamente!
« Última modificación: 06-12-2013, 23:50 (Viernes) por jrierab »

espinete2004

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #15 en: 24-12-2013, 10:14 (Martes) »
Hola Elnef...

comenta porfa como lo has conseguido. Estoy en un camino sin salida a falta de alguna indicación de como hacerlo sin wifi usb extra.

Un saludo y felices fiestas a todos.

naghtan

  • Visitante
Re: Configurar Wifi para invitados (y limitar su velocidad)
« Respuesta #16 en: 05-04-2014, 00:11 (Sábado) »
Buenas, ¿Al final hiciste el tutorial?

saludos.