Autor Tema: Configurar hg556a en modo repetidor para conectarse a wifisfera  (Leído 22943 veces)

0 Usuarios y 1 Visitante están viendo este tema.

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #20 en: 27-03-2015, 14:50 (Viernes) »
Nada he probado otra vez poniendo las lineas bien y sin exito jar229, no se que podrá ser, quedan las dos en cliente no sé porque!!! Le falta el paso de la que repite, ponerla en master y ya digo es a raiz de instalar el wpad, me imagino que el cifrado y demás de la conexión a la que me conecto esté bien, puesto que queda en cliente y ya he probado el router y coge conexión pero cuando creo la otra para repetir nada esta deja de coger conexión y ambas quedan en cliente aunque la repetida sin conectar y aunque la active no activa.


« Última modificación: 27-03-2015, 15:38 (Viernes) por vwmk216v »

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #21 en: 27-03-2015, 15:40 (Viernes) »
Hay algun firm que pueda instalar al router que traiga el wpad instalado y que se haya probado en modo repetidor? De ser así lo cargo y pruebo.
Podrá ser este el problema?

Enterprise WPA is not supported by the wpad-mini access point software on OpenWRT so you will need to remove that and install the full version of hostapd:

opkg update opkg
remove wpad-mini
opkg install hostapd

Next, you can modify your /etc/config/wireless file to support WPA Enterprise authentication. Specifically you will need to create a wifi-iface with the encryption option set to wpa2, a server address, and a key
« Última modificación: 27-03-2015, 18:32 (Viernes) por vwmk216v »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #22 en: 27-03-2015, 19:22 (Viernes) »
En un rato (cundo termine la máquina), cuelgo una compilación con wpad (en lugar de wpad-mini).
Eso sí, como no tengo ningún router con wifi atheros no podré probarla  ^-^
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #23 en: 27-03-2015, 20:04 (Viernes) »
Aquí está la compilación. Para saber cual de los dos firmwares has de usar, mira la wiki: http://wiki.openwrt.org/toh/huawei/hg556a

r45066
« Última modificación: 31-03-2015, 09:57 (Martes) por jar229 »
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #24 en: 27-03-2015, 21:14 (Viernes) »
Muchas gracias jar229 en cuanto lo pruebe os comento resultado aunque probare a instalar el hostpad en vez de wpad como explican en la pagina de openwrt, a ver si hay suerte. Un saludo

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #25 en: 29-03-2015, 15:46 (Domingo) »
He probado la nueva compilación y no hubo exito, ahora hace bien el puente, la conexión a la que conecta queda en cliente y la repetida en master, pero cuando creo la conexión repetida pierde la señal el router, es decir primero conecto a wifisfera y tiene internet y justo cuando creo el puente pierde la conexión, decir que no he probado a instalar el hostpad.
« Última modificación: 29-03-2015, 19:25 (Domingo) por vwmk216v »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #26 en: 29-03-2015, 21:01 (Domingo) »
He probado la nueva compilación y no hubo exito, ahora hace bien el puente, la conexión a la que conecta queda en cliente y la repetida en master, pero cuando creo la conexión repetida pierde la señal el router, es decir primero conecto a wifisfera y tiene internet y justo cuando creo el puente pierde la conexión, decir que no he probado a instalar el hostpad.

Prueba a instalar hostapd, pero me da a mi, que vas a seguir con el mismo problema.

Prueba a ejecutar este comando desde una conexión ssh, a ver si 'levanta' correctamente las interfaces

Código: [Seleccionar]
/etc/init.d/network restart
Si no te funciona, postea por aquí el resultado a ver si vemos algún mensaje de error que pueda darnos una pista.
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #27 en: 30-03-2015, 21:32 (Lunes) »
Bueno despues de varias pruebas sigo sin éxito, como era de esperar instale el hostpad y tampoco iba, probe a ejecutar ese comando jar229 y no reportó ningún error desde ssh. Lo único que he visto es lo siguiente que dejando el router en cliente sin hacer el puente se conecta pone un 45% mas o menos pero al rato pierde y queda a 0% y asi sucesivamente. En la ocasión en la que me pone un 45% pruebo a hacer un ping y no tengo conexión en el router, y el último dato es que he llamado al soporte técnico (que no saben si se puede hacer) y me dicen que en modo debe de aparecer infraestructura y no cliente como tengo puesto. Tengo la sensación que va ser una red que por algo no se puede repetir. Vosotros direis!!

seny

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #28 en: 30-03-2015, 23:05 (Lunes) »
Bueno despues de varias pruebas sigo sin éxito, como era de esperar instale el hostpad y tampoco iba, probe a ejecutar ese comando jar229 y no reportó ningún error desde ssh. Lo único que he visto es lo siguiente que dejando el router en cliente sin hacer el puente se conecta pone un 45% mas o menos pero al rato pierde y queda a 0% y asi sucesivamente. En la ocasión en la que me pone un 45% pruebo a hacer un ping y no tengo conexión en el router, y el último dato es que he llamado al soporte técnico (que no saben si se puede hacer) y me dicen que en modo debe de aparecer infraestructura y no cliente como tengo puesto. Tengo la sensación que va ser una red que por algo no se puede repetir. Vosotros direis!!
Supongo que la interfaz Lan del router sigue con la IP 192.168.1.1 prueba cambiarla a por ejemplo 192.168.3.1

Eso mismo me sucede conectando a la wifi que genera mi htc con android, si mantengo la IP dendro del rango 192.168.1.x, no funciona, puede que sea el mismo problema.

xexudj89

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #29 en: 30-03-2015, 23:54 (Lunes) »
Aquí está la compilación. Para saber cual de los dos firmwares has de usar, mira la wiki: http://wiki.openwrt.org/toh/huawei/hg556a

r45066

He probado esta compilacion en mi router y se me renicia cada pocos minutos.... problema del firm o problema de alguna configuracion de openwrt?

He probado este firm en otro router HG556a (hg56BZRB VER..A) y no en ninguna de las dos compilaciones funciona el wifi, el firmware si no me he equivoco es el b.

Un saludo a todos
« Última modificación: 31-03-2015, 00:20 (Martes) por Nexus89 »

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #30 en: 31-03-2015, 00:52 (Martes) »
Gracias Seny probaré a cambiar la ip del router porque la tengo 192.168.1.1, siempre la dejo así porque le cuesta mucho al router cambiar la ip, igual es que lo hago mal. En cuanto a esa compilación nexus89 a mi también se me reiniciaba siempre era encender y reiniciarse y así constantemente, pero pero justo cuando creaba el puente para repetir la conexión, pensé que era un problema de la configuración que había hecho.

xexudj89

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #31 en: 31-03-2015, 01:09 (Martes) »
Gracias Seny probaré a cambiar la ip del router porque la tengo 192.168.1.1, siempre la dejo así porque le cuesta mucho al router cambiar la ip, igual es que lo hago mal. En cuanto a esa compilación nexus89 a mi también se me reiniciaba siempre era encender y reiniciarse y así constantemente, pero pero justo cuando creaba el puente para repetir la conexión, pensé que era un problema de la configuración que había hecho.

Pues a mi me pasa lo mismo.. se renicia cada poco tiempo..... haber si jar229 lo lee a lo mejor es el firm que esta mal configurado o algo.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4594
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #32 en: 31-03-2015, 09:53 (Martes) »
Como ya dije, no puedo testear esa compilación, ya que no tengo ningún hg556a con wifi atheros  ^-^

Yo he compilado como siempre, pero es posible, que algo vaya mal. Dejad de usarla.

Borro el enlace para que no haya más problemas.
« Última modificación: 01-04-2015, 11:38 (Miércoles) por jar229 »
Valoraciones positivas en compra/venta:
153 en Htcmania
203 en Har2mano
22 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

seny

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #33 en: 01-04-2015, 11:27 (Miércoles) »
Gracias Seny probaré a cambiar la ip del router porque la tengo 192.168.1.1, siempre la dejo así porque le cuesta mucho al router cambiar la ip, igual es que lo hago mal. En cuanto a esa compilación nexus89 a mi también se me reiniciaba siempre era encender y reiniciarse y así constantemente, pero pero justo cuando creaba el puente para repetir la conexión, pensé que era un problema de la configuración que había hecho.

Ahora no confundamos los reinicios de un firm concreto con los reinicios de la conexión que tenias antes con un firm contrastado, me ha parecido entender que incluso sin intentar repetir la conexión ya se reiniciaba conectando desde OpenWRT.


vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #34 en: 03-04-2015, 19:22 (Viernes) »
He sido incapaz de cambiar la ip del router, incluyo leyendo el tutorial de Noltari, pongo pasos que he seguido por si he hecho algo mal.
Cargo el firm, pongo contraseña y abro ventana en ssh, ejecuto mtd erase -r rootfs_data, espero a que reinicie. Una vez reiniciado el router vuelvo a poner contraseña desde luci, me voy a lan, pongo la nueva dirección de ip, pongo guardar y aplicar y nada, se queda como colgado el router con los mismos led encendidos y la ventana de luci queda como colgada también. Quito corriente al router y vuelvo a encender y no puedo acceder ni con la nueva dirección de ip ni con la vieja. He probado con estos comandos desde ssh

uci set network.lan.ipaddr=192.168.2.1
uci commit
reboot

y tampoco cuando reinicia el router la dirección de ip sigue siendo 192.168.1.1

seny

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #35 en: 03-04-2015, 22:40 (Viernes) »
Puede que no sea ese el problema pero se debería poder cambiar la ip..

Si lo haces desde windows es muy engorroso, lo mejor es reiniciar el adaptador y esperar a que el entramado windows/cortafuegos/antivirus te pregunte si la nueva red es pública o privada.., o incluso reiniciar el sistema, eso depende de lo depurado que sea el antivirus.. el router en principio no es necesario reiniciarlo despues de cambiar la ip..

Comenta si era ese el problema.
« Última modificación: 03-04-2015, 22:41 (Viernes) por seny »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2038
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #36 en: 04-04-2015, 12:13 (Sábado) »
He sido incapaz de cambiar la ip del router, incluyo leyendo el tutorial de Noltari, pongo pasos que he seguido por si he hecho algo mal.
Cargo el firm, pongo contraseña y abro ventana en ssh, ejecuto mtd erase -r rootfs_data, espero a que reinicie. Una vez reiniciado el router vuelvo a poner contraseña desde luci, me voy a lan, pongo la nueva dirección de ip, pongo guardar y aplicar y nada, se queda como colgado el router con los mismos led encendidos y la ventana de luci queda como colgada también. Quito corriente al router y vuelvo a encender y no puedo acceder ni con la nueva dirección de ip ni con la vieja. He probado con estos comandos desde ssh

uci set network.lan.ipaddr=192.168.2.1
uci commit
reboot

y tampoco cuando reinicia el router la dirección de ip sigue siendo 192.168.1.1


Si te PC tiene una IP en el rango 192.168.1.x, podrás acceder a los dispositivos en ese rango, pero no a los del rango 192.168.2.x.
Al cambiar la IP del router de 192.168.1.1 a 192.168.2.1, estás cambiando el rango de IP del router. Por eso parece que se queda colgado, porque tu PC seguirá estando en el rango 192.168.1.x y estarás intentando acceder al rango 192.168.2.x. Para acceder, tendrás que cambiar la IP al PC (a la 192.168.2.2, por ejemplo), y luego acceder al router con la nueva IP (192.168.2.1). Como dice seny, es engorroso, pero si sabemos lo que hacemos, parece más fácil.

Si lo anterior no te está funcionando, debe haber otro problema, como por ejemplo, que te hayas quedado sin espacio en la flash para grabar los cambios. Cuando entres por SSH, pon df, y mira si la partición rootfs está al 100%. Si lo está, tendrás que borrar algo para poder grabar los cambios. Comprueba también si al teclear dmesg y logread, hay líneas donde te indique si hay algún error en el arranque con respecto a la flash o sistema de archivos jffs2.

Si el cambio de IP lo haces desde SSH, tendrás que reiniciar los servicios que dependan de la red. Si el cambio de IP lo haces desde luci, los cambios se harán automáticamente y no habrá necesidad de reinciar el router para acceder, sólo cambiar el rango de IP del PC. Por simplicidad, te aconsejo que el cambio de IP lo hagas desde luci, cambies la IP del PC, y accedas al router con la nueva IP.

No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #37 en: 04-04-2015, 14:29 (Sábado) »
Gracias por responder, ya está, no me había dado cuenta que tenia ip fija en la tarjeta de red, fue ponerla en automático y para acceder a luci ya tuve que poner 192.168.2.1.
Ahora al cambiar la ip del router probaré a ver si con la conexión de wifisfera me hace el puente bien, no se si será importante, pero que en modo tenga que aparecer infraestructura en vez de cliente me parece extraño, pero bueno seguiré haciendo pruebas y os comento.

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #38 en: 05-04-2015, 22:08 (Domingo) »
Despues de cambiar la ip al router, nada sigue sin repetir la señal de wifisfera, el router lo conecto pero al repetir la conexión queda sin red, no se que podrá ser, a ver si a alguien se le ocurre algo.

seny

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #39 en: 05-04-2015, 22:39 (Domingo) »
Prueba con este que compilé ayer para wifi atheros y con wpad.

//FINAL Y MÁS DOS RESPUESTAS