Autor Tema: Configurar hg556a en modo repetidor para conectarse a wifisfera  (Leído 23225 veces)

0 Usuarios y 1 Visitante están viendo este tema.

vwmk216v

  • Visitante
Configurar hg556a en modo repetidor para conectarse a wifisfera
« en: 25-03-2015, 15:33 (Miércoles) »
Hola, quería plantear algo que realmente no se si se puede hacer con este router. Lo he planteado al servicio técnico de la compañia y no me saben decir, yo vivo en asturias y aqui con la compañia telecable pues hay wifi en muchas zonas de la provincia y que con una contraseña que ellos te dan pues te conectas sin problemas, pero unicamente ordenadores, tablets, telefonos etc.... bajo una aplicación o configurando el ordenador, yo lo que quería hacer es conectar el hg556a a esa red llamada wifisfera y repetir la señal en mi domicilio, desde la compañia creen que si se puede hacer pero no saben como, solo me dijeron que el cifrado de la contraseña es wpa2 enterprise, adjunto un enlace en el que el servicio técnico explica como hacer la configuración desde linux, por ver si con esos pasos se podría hacer algo bajo luci "http://www.telecable.es/wifisfera/linux/Manual%20wifisfera_Linux.pdf". Además para poder conectarse es necesario insertar un nombre de usuario y contraseña. Un saludo y muchas gracias!!!!



Pteridium

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #1 en: 25-03-2015, 15:46 (Miércoles) »
Por defecto openwrt no soporta WPA-enterprise. Para que lo haga hay que cambiar wpad-mini por wpad.
Lo mejor es que compiles un firm y hagas el cambio mencionado.
Lo que no sé es si hay que añadir algo más a la compilación.  ???

Si lo consigues, ¿serías tan amable de indicar cómo lo has configurado?
« Última modificación: 25-03-2015, 15:47 (Miércoles) por Pteridium »

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #2 en: 25-03-2015, 22:54 (Miércoles) »
Si lo consigo claro que lo cuelgo, pero no se si lo conseguiré, yo utilizo el router en modo repetidor unicamente, vamos k nunca hice ninguna compilación, pero por la información que pones para el cifrado wpa enterprise eso creo que va ser fundamental.

Por lo que veo aqui "http://wiki.openwrt.org/doc/uci/wireless" creo que la clave está ne crear un cliente wpa enterprise, y luego ya se deben poder poner los datos que facilita la compañia.

A ver si alguien nos ilumina y no puede decir como crear un cliente wpa enterprise.
Decir que tengo en el router el firm r39304usb.
« Última modificación: 25-03-2015, 23:08 (Miércoles) por vwmk216v »

dolfet15

  • Visitante
Re:
« Respuesta #3 en: 26-03-2015, 08:05 (Jueves) »
Si para conectarte a ese WiFi solo es necesario introducir un usuario y contraseña (wpa enterpise) y nada de usar aplicaciones raras si que puedes.

A ver primero es necesario que añadas soporte para contraseñas wpa-enterprise , creo que el paquete se llama "wpad" .
Y luego desde luci te vas a la configuración del WiFi , escaneas redes , la seleccionas y pones los datos y listo. Hay muchos tutoriales de como hacer esto

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #4 en: 26-03-2015, 10:25 (Jueves) »
Gracias por responder dolfet15, me podrías o pasar un enlace para cargar el paquete wpad? Un saludo!!

mitsurugi

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #5 en: 26-03-2015, 12:55 (Jueves) »
Debes entrar en la config del router, por lua supongo que entraras.
Luego vas a sistema, software, update list, pones en filtro: wpad
Te aparecera el wpadmini instalado, pues pinchas en desinstalar y luego pinchas en availe packages y das a instalar en wpad
Creo que con eso valdria, si tienes alguna duda, comentanos.

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #6 en: 26-03-2015, 14:26 (Jueves) »
Ok, muchisimas gracias, en cuanto lo pruebe os comento.

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #7 en: 26-03-2015, 20:22 (Jueves) »
Me he puesto con el tema, he desinstalado el wpad-mini pero no me encuentra ningún paquete, he modificado la ruta en el apartado configuración pero a la hora de buscar paquetes desde luci no me pone el nombre del paquete sino unicamente instalar. Esto es lo que tengo en configuación:

src/gz barrier_breaker http://downloads.openwrt.org/barrier_breaker/14.07-rc3/brcm63xx/generic/packages/
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

Si trato de instalarlo por ssh de todos los paquetes me pone arquitectura no valida y tampoco puedo instalarlo, y desde luci aparecen pero sin nombre solo queda activado el icono instalar sin saber que paquete es. Un saludo
« Última modificación: 26-03-2015, 20:53 (Jueves) por vwmk216v »

mitsurugi

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #8 en: 26-03-2015, 21:18 (Jueves) »
Hostias que raro. ¿Te conecta con el exterior? puedes probar a hacer lo siguiente conectado al router por ssh.-
ping www.google.es

Haber si es que no te conecta y por eso no te muestra los paquetes al dar update.

¿Al actualizar la lista de paquetes te tira algun error?

Tambien puedes buscar los paquetes por la inicial, en este caso por w

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #9 en: 26-03-2015, 21:32 (Jueves) »
Por ssh accedi tambien poniendo opkg update y aparecen todos los paquetes pero no me deja instalarlos pone arquitectura no valida. He visto que hay forma de instalarlo desde un usb pero la verda que no me aclaro como hacerlo. He de decir que el router tiene conexión puesto que yo navego sin problemas y cuando actualizo la lista de paquetes salen muchisimos pero ninguno pone nombre. El router actualmente está como repetidor y es versión C tarjeta atheros

Tendré que poner estas lineas antes de la configuración?

arch all 100
arch brcm4716 200
arch brcm47xx 300

Algo similar a esto pero poniendo brcm63xx ?
« Última modificación: 26-03-2015, 22:20 (Jueves) por vwmk216v »

seny

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #10 en: 26-03-2015, 23:09 (Jueves) »
Hola, no se si tienes en cuenta que a este router cuando no guarda ña configuracion hay que ejecutar desde ssh:

mtd erase -r rootfs_data

Quizas sea ese el problema, si no compruenba si realmente tienes instalada la versión barrier breaker 14.07-rc3

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #11 en: 26-03-2015, 23:14 (Jueves) »
ese comando lo ejecute y ahora guarda cambios, en cuanto a la versión que tengo instalada es la mas actual que esta en la pagina uno del foro la r39304usb

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #12 en: 27-03-2015, 09:01 (Viernes) »
ese comando lo ejecute y ahora guarda cambios, en cuanto a la versión que tengo instalada es la mas actual que esta en la pagina uno del foro la r39304usb

Esa no es la versión más actual. Pero vamos, que el problema debe ser otro.

Es rarísimo eso de que te diga que es arquitectura no valida, cuando la configuración es la correcta.

Haz un copy paste del resultado de ejecutar estos comandos.

Código: [Seleccionar]
ping www.google.es
Código: [Seleccionar]
opkg update
« Última modificación: 27-03-2015, 09:08 (Viernes) por jar229 »
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #13 en: 27-03-2015, 10:37 (Viernes) »
root@OpenWrt:~# ping www.google.es
PING www.google.es (74.125.206.94): 56 data bytes
64 bytes from 74.125.206.94: seq=0 ttl=45 time=71.893 ms
64 bytes from 74.125.206.94: seq=1 ttl=45 time=68.687 ms
64 bytes from 74.125.206.94: seq=2 ttl=45 time=69.930 ms
64 bytes from 74.125.206.94: seq=3 ttl=45 time=68.478 ms
64 bytes from 74.125.206.94: seq=4 ttl=45 time=70.869 ms
64 bytes from 74.125.206.94: seq=5 ttl=45 time=69.218 ms
64 bytes from 74.125.206.94: seq=6 ttl=45 time=68.785 ms
64 bytes from 74.125.206.94: seq=7 ttl=45 time=69.832 ms
64 bytes from 74.125.206.94: seq=8 ttl=45 time=69.442 ms
64 bytes from 74.125.206.94: seq=9 ttl=45 time=68.822 ms
64 bytes from 74.125.206.94: seq=10 ttl=45 time=70.170 ms
64 bytes from 74.125.206.94: seq=11 ttl=45 time=87.290 ms
^C
--- www.google.es ping statistics ---
12 packets transmitted, 12 packets received, 0% packet loss
round-trip min/avg/max = 68.478/71.118/87.290 ms


root@OpenWrt:~# opkg update
Package agetty version 2.24.1-1 has no valid architecture, ignoring.
Package arptables version 0.0.4-1 has no valid architecture, ignoring.
Package atm-aread version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmaddr version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmdiag version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmdump version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmloop version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmsigd version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmswitch version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmtcp version 2.5.2-5 has no valid architecture, ignoring.
Package atm-awrite version 2.5.2-5 has no valid architecture, ignoring.
Package atm-bus version 2.5.2-5 has no valid architecture, ignoring.
Package atm-debug-tools version 2.5.2-5 has no valid architecture, ignoring.
Package atm-diagnostics version 2.5.2-5 has no valid architecture, ignoring.
Package atm-esi version 2.5.2-5 has no valid architecture, ignoring.
Package atm-ilmid version 2.5.2-5 has no valid architecture, ignoring.
Package atm-ilmidiag version 2.5.2-5 has no valid architecture, ignoring.
Package atm-lecs version 2.5.2-5 has no valid architecture, ignoring.
Package atm-les version 2.5.2-5 has no valid architecture, ignoring.
Package atm-mpcd version 2.5.2-5 has no valid architecture, ignoring.
Package atm-saaldump version 2.5.2-5 has no valid architecture, ignoring.
Package atm-sonetdiag version 2.5.2-5 has no valid architecture, ignoring.
Package atm-svc_recv version 2.5.2-5 has no valid architecture, ignoring.
Package atm-svc_send version 2.5.2-5 has no valid architecture, ignoring.
Package atm-tools version 2.5.2-5 has no valid architecture, ignoring.
Package atm-ttcp_atm version 2.5.2-5 has no valid architecture, ignoring.
Package atm-zeppelin version 2.5.2-5 has no valid architecture, ignoring.
Package authsae version 2014-04-19-295164a83717ce59ca280468fc2f7edcea6b3cbf has no valid architecture, ignoring.
Package badblocks version 1.42.4-1 has no valid architecture, ignoring.
Package base-files version 155-r42056 has no valid architecture, ignoring.
Package binutils version 2.24-1 has no valid architecture, ignoring.
Package blkid version 2.24.1-1 has no valid architecture, ignoring.
Package block-mount version 2014-06-22-e0430f5c62f367e5a8e02755412977b02c3fc45e has no valid architecture, ignoring.
Package br2684ctl version 2.5.2-5 has no valid architecture, ignoring.
Package busybox version 1.22.1-2 has no valid architecture, ignoring.
Package ca-certificates version 20140325 has no valid architecture, ignoring.
Package cal version 2.24.1-1 has no valid architecture, ignoring.
 

Y así todos los paquetes

Haciendo ping a downloads.openwrt.org

root@OpenWrt:~# ping downloads.openwrt.org
PING downloads.openwrt.org (78.24.191.177): 56 data bytes
64 bytes from 78.24.191.177: seq=0 ttl=50 time=104.377 ms
64 bytes from 78.24.191.177: seq=1 ttl=50 time=98.967 ms
64 bytes from 78.24.191.177: seq=2 ttl=50 time=99.865 ms
64 bytes from 78.24.191.177: seq=3 ttl=50 time=101.358 ms
64 bytes from 78.24.191.177: seq=4 ttl=50 time=100.554 ms
64 bytes from 78.24.191.177: seq=5 ttl=50 time=100.721 ms
64 bytes from 78.24.191.177: seq=6 ttl=50 time=101.943 ms
^C
--- downloads.openwrt.org ping statistics ---
7 packets transmitted, 7 packets received, 0% packet loss
round-trip min/avg/max = 98.967/101.112/104.377 ms



« Última modificación: 27-03-2015, 10:59 (Viernes) por vwmk216v »

Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 2113
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #14 en: 27-03-2015, 11:09 (Viernes) »
root@OpenWrt:~# opkg update
Package agetty version 2.24.1-1 has no valid architecture, ignoring.
Package arptables version 0.0.4-1 has no valid architecture, ignoring.
Package atm-aread version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmaddr version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmdiag version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmdump version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmloop version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmsigd version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmswitch version 2.5.2-5 has no valid architecture, ignoring.
Package atm-atmtcp version 2.5.2-5 has no valid architecture, ignoring.
Package atm-awrite version 2.5.2-5 has no valid architecture, ignoring.
Package atm-bus version 2.5.2-5 has no valid architecture, ignoring.
Package atm-debug-tools version 2.5.2-5 has no valid architecture, ignoring.
Package atm-diagnostics version 2.5.2-5 has no valid architecture, ignoring.
Package atm-esi version 2.5.2-5 has no valid architecture, ignoring.
Package atm-ilmid version 2.5.2-5 has no valid architecture, ignoring.
Package atm-ilmidiag version 2.5.2-5 has no valid architecture, ignoring.
Package atm-lecs version 2.5.2-5 has no valid architecture, ignoring.
Package atm-les version 2.5.2-5 has no valid architecture, ignoring.
Package atm-mpcd version 2.5.2-5 has no valid architecture, ignoring.
Package atm-saaldump version 2.5.2-5 has no valid architecture, ignoring.
Package atm-sonetdiag version 2.5.2-5 has no valid architecture, ignoring.
Package atm-svc_recv version 2.5.2-5 has no valid architecture, ignoring.
Package atm-svc_send version 2.5.2-5 has no valid architecture, ignoring.
Package atm-tools version 2.5.2-5 has no valid architecture, ignoring.
Package atm-ttcp_atm version 2.5.2-5 has no valid architecture, ignoring.
Package atm-zeppelin version 2.5.2-5 has no valid architecture, ignoring.
Package authsae version 2014-04-19-295164a83717ce59ca280468fc2f7edcea6b3cbf has no valid architecture, ignoring.
Package badblocks version 1.42.4-1 has no valid architecture, ignoring.
Package base-files version 155-r42056 has no valid architecture, ignoring.
Package binutils version 2.24-1 has no valid architecture, ignoring.
Package blkid version 2.24.1-1 has no valid architecture, ignoring.
Package block-mount version 2014-06-22-e0430f5c62f367e5a8e02755412977b02c3fc45e has no valid architecture, ignoring.
Package br2684ctl version 2.5.2-5 has no valid architecture, ignoring.
Package busybox version 1.22.1-2 has no valid architecture, ignoring.
Package ca-certificates version 20140325 has no valid architecture, ignoring.
Package cal version 2.24.1-1 has no valid architecture, ignoring.
 

Y así todos los paquetes

¿Podrías pegar el resultado de?
Código: [Seleccionar]
cat /etc/opkg.conf
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #15 en: 27-03-2015, 11:17 (Viernes) »
Bufff gracias igual por la ayuda prestada, pero después de leer por este foro he añadido por ssh estas dos lineas y solucionado el wpad está instalado.

#/etc/init.d/uhttpd enable      
#/etc/init.d/uhttpd reload

Ahora a ver si soy capaz de configurar con las claves de wifisfera para conectarlo. Ya os comentaro avances. Un saludo

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #16 en: 27-03-2015, 12:48 (Viernes) »
He avanzado algo, he conseguido conectar el router a wifisfera, pero os explico el problema porque he vuelto a cargar el firm al router un par de veces, desde que desinstalo el wpad-mini y instalo el wpad, no me hace la función de repetidor, osea la conexión primaria queda en cliente y la que repite en cliente, es decir no pasa a master, no se porque. Si desisntalo la que yo creo para repetir, el router vuelve a conectarse, algo hay que me hace el puente mal. Pero es mas para que vuelva a repetirme mi conexión es imposible siempre que instalo el wpad no me cambia a master la conexión repetida, con lo cual vuelvo a cargar el firm y otra vez lo hace bien. A ver si me podeis ayudar. Un saludo!!

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #17 en: 27-03-2015, 13:10 (Viernes) »
Por probar, mira de hacer lo siguiente después de instalar wpad:

Borrar el fichero wireless

Código: [Seleccionar]
rm /etc/config/wireless
Crearlo de nuevo, detectando la wifi

Código: [Seleccionar]
wifi detect > /etc/config/wireless
Reiniciar el router y probar.
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vwmk216v

  • Visitante
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #18 en: 27-03-2015, 13:47 (Viernes) »
Me ha puesto esto

root@OpenWrt:~# rm /etc/config/wireles
rm: can't remove '/etc/config/wireles': No such file or directory
root@OpenWrt:~# wifi detect > /etc/config/wireless
root@OpenWrt:~#

A traves de luci ahora en red interfaces la wwan me pone instalar extensiones de protocolo
Nada sin exito jar229, me sigue haciendo el puente mal
« Última modificación: 27-03-2015, 14:21 (Viernes) por vwmk216v »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4599
Re: Configurar hg556a en modo repetidor para conectarse a wifisfera
« Respuesta #19 en: 27-03-2015, 14:07 (Viernes) »
Me ha puesto esto

root@OpenWrt:~# rm /etc/config/wireles
rm: can't remove '/etc/config/wireles': No such file or directory

Te faltaba una s

Has puesto rm /etc/config/wireles
Y debería ser rm /etc/config/wireless
Valoraciones positivas en compra/venta:
162 en Htcmania
215 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka