Autor Tema: Configuración samba share  (Leído 162 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado cbx200

  • **
  • Mensajes: 7
Configuración samba share
« en: 14-11-2018, 13:59 (Miércoles) »
Buenas tardes


Me he comprado el router GL-AR750S. He conseguido instalar el openwrt, cosa no muy dificil ya que venia practicamente preinstalado. He podido configurar OpenVPN con y sin un proveedor de VPN. Me puedo conectar al terminal con putty.

La siguiente cosa que queria hacer es usar un disco duro conectado al puerto USB del router como unidad multimedia para la casa.
Siguiendo las instrucciones que he encontrado, he instalado un monton de paquetes y  he conseguido montar el disco duro, creo que correctamente ya que puedo acceder al contenido del disco duro via ssh:
Esto es lo que aparece en Luci en Mounted file systems

/dev/sda1/mnt/sda1       5.09 GB / 465.76 GB        99% (460.67 GB)

Sin embargo ni el router, ni el disco duro, me aparecen en los diferentes file explorers que he probado  en red local. Ni en windows ni en ipads/iphones etc.
He leido que habria que configurar el archivo de config de samba, lo he intentado a traves de luci en la pestaña de network shares, edit template, he escrito lo siguiente (copiado de una pagina web>):

config 'sambashare'
        option 'name' 'Shares'
        option 'path' '/mnt/sda1'
        option 'users' 'root'
        option 'guest_ok' 'yes'
        option 'create_mask' '0700'
        option 'dir_mask' '0700'
       

Sin embargo no hay manera el router sigue sin aparecer en ningun file explorer.
He intentado mapear el drive ia la dirreccion ip del router  pero no hay manera no entra o no lo reconoce.
Tambien he intentado conectarme via VLC , pero sin exito.

Es esta configuración correcta?
Salu2



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4579
Valoraciones positivas en compra/venta:
114 en Htcmania
104 en Har2mano
16 en elchapuzasinformatico
7 en gsmspain
4 en foro2mano
 .... :)
 
Mis portátiles en venta: https://drive.google.com/open?id=1DjTt6LiqDWzlRayB4KFhFSKc9ZQ-1mjf

Desconectado cbx200

  • **
  • Mensajes: 7
Re:Configuración samba share
« Respuesta #2 en: 16-11-2018, 21:06 (Viernes) »
gracias

el problema que tengo es que no inicia samba, y no se porque
me dicen que los ficheros estos smdb.xxx.core  que se encuentran en tmp indican que samba no arranca, no se que hacer

salu2
root@GL-AR750S:/tmp# ls
TZ                            lib                           resolv.conf.auto              smbd.1542302881.15825.6.core
api.socket-0                  lock                          run                           smbd.1542302882.15920.6.core
dhcp.leases                   log                           shm                           smbd.1542318584.22105.6.core
dnsmasq.d                     luci-indexcache               smbd.1542299981.1956.6.core   state
etc                           luci-modulecache              smbd.1542299986.2371.6.core   sysinfo
extroot                       nmbd                          smbd.1542299989.2469.6.core   tmp
hosts                         overlay                       smbd.1542299991.2765.6.core   wpa_ctrl_2666-1
html.socket-0                 resolv.conf                   smbd.1542301878.7020.6.core
root@GL-AR750S:/tmp#
« Última modificación: 16-11-2018, 21:07 (Viernes) por cbx200 »

Desconectado eduperez

  • **
  • Mensajes: 19
Re:Configuración samba share
« Respuesta #3 en: 17-11-2018, 12:55 (Sábado) »
Creo que ya te he respondido en el foro de OpenWrt, pero que no se diga...

El problema es que uno de los programas de SAMBA (el smbd para ser exactos) da error al arrancar. Y no es que haya un problema en la configuración, o que no encuentre el disco, o algo parecido, es que simplemente no funciona. Pero, como ya te han dicho en el otro foro, tú no estás usando OpenWrt, estás usando un software modificado por el fabricante de tu router a partir de OpenWrt, y no hay manera de saber exactamente qué han modificado, ni qué es lo que está pasando en tu dispositivo.

Si puedes, instala el OpenWrt original, y a partir de ahí volvemos a retomar el asunto; si no, tendrás que contactar con el fabricante, y explicarles que su software no funciona en su dispositivo.