Autor Tema: Informacion para instalar paquete de idiomas en OpenWrt  (Leído 10369 veces)

0 Usuarios y 1 Visitante están viendo este tema.

coe

  • Visitante
Informacion para instalar paquete de idiomas en OpenWrt
« en: 15-12-2014, 21:21 (Lunes) »
  Desde hace un par de meses tengo un router ar-5387un al que le puse la compilación Barrier Breaker 14.07-rc3{Con LuCI} siguiendo uno de vuestros tutoriales y me funciona bien, salvo que un par de móviles con android se desconectan continuamente y que ya he visto que le ocurre a alguien mas, pero no es el motivo de la consulta, si no que quisiera poder instalar en el router el idioma español ( luci-i18n-español ) y no se como hacerlo, he visto todos los mensajes de OpenWrt y no me aclaro, sobre todo porque no soy usuario de Linux y sobre el uso de comandos no se nada, por eso desearía que alguien me lo pudiera explicar paso a paso, si se puede desde LuCi y como o si es necesario desde cmd y que sintaxis debo emplear.

 



vk496

  • Visitante
Re: Informacion para instalar paquete de idiomas en OpenWrt
« Respuesta #1 en: 15-12-2014, 21:44 (Lunes) »
opkg update
opkg install NombreDelPaquete

Salu2

coe

  • Visitante
Re: Informacion para instalar paquete de idiomas en OpenWrt
« Respuesta #2 en: 15-12-2014, 21:56 (Lunes) »
  Muchas gracias por la respuesta vk 496

 ¿En donde debo de escribir esa sintaxis en la consola o desde LuCi?
 Como he explicado en mi primer mensaje no se como hacerlo y necesito que alguien me lo explique tipo "tutorial"
 Conseguí instalar OpenWrt en el router gracias al magnifico tutorial que esta en esta web y al estar guiado a cada paso fue fácil, pero no he encontrado la manera de instalar el idioma español y es porque carezco de los conocimientos suficientes, por eso solicito que la explicación sea mas detalladas y sencillas para que alguien sin conocimientos pueda llevarla a cabo.

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2047
Re: Informacion para instalar paquete de idiomas en OpenWrt
« Respuesta #3 en: 16-12-2014, 08:57 (Martes) »
LuCi:
Vete a System -> Software
Dale al botón "Update lists"
Debes tener conexión a internet para que la lista de paquetes se actualice. Una vez actualizada:
Pincha en "Available packages"
Escribe en el cuadro Filter: luci-i18n y pincha en el botón "Find package" para buscar.
Te aparecerá el listado de todos los paquetes de idioma para luci. Selecciona el que quieras y pincha en él. El paquete se instalará directamente.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

coe

  • Visitante
Re: Informacion para instalar paquete de idiomas en OpenWrt
« Respuesta #4 en: 16-12-2014, 22:07 (Martes) »
  Tki2000 Muchisimas gracias.

 Con tu explicación paso a paso y detallada he conseguido descargar el paquete de idiomas e instalarlo.

 Voy a describir el proceso siguiendo los pasos indicados por Tki2000, porque a algún usuario con pocos conocimientos le puede ocurrir y así ya sabe como solucionarlo, en mi caso, sin la ayuda de Tki2000 me habría sido muy difícil, por no decir imposible, el haber instalado el idioma español.

 Para poner el idioma español necesitamos tener conexión a internet en este router, entramos a la configuración por la puerta de enlace, nos logeamos en LuCi y vamos a System->Software,  pinchamos en Update lists y te puede ocurrir que te salga este error.



 
 No se ha descargado, entonces en esa misma pantalla pinchamos en Configuration y en la ultima linea donde dice:

src/gz barrier_breaker http://downloads.openwrt.org/snapshots/trunk/brcm63xx/packages/Packages.gz  

 quitamos    Packages.gz     y ponemos     luci/        vamos abajo a la derecha y pinchamos en Submit luego pinchamos en Actions y posteriormente en  Update lists ahora ya si se descarga el paquete de idiomas, pinchamos en Available packages y en el cuadro Filter escribimos luci-i18n spanish pinchamos en Find package y en la parte baja de la pantalla nos aparece el archivo, solo queda pinchar en install y se instalara el archivo de idioma español, una vez que ha terminado pinchamos en Logout para salir del router, lo apagamos y encendemos para que se haga el cambio, nos volvemos a conectar por la puerta de enlace y nos aparecera la pantalla para logearse ya en español.



 A los usuarios avanzados o acostumbrados a manejarse con estos temas le resultara muy fácil hacer estos cambios, pero a los que como yo apenas contamos con conocimientos necesitamos que alguien nos oriente con detalle para poder hacerlo y no quedarnos atascados en algún lugar.

 Nuevamente muchisimas gracias Tki2000 por tu ayuda.
« Última modificación: 17-12-2014, 18:55 (Miércoles) por coe »

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2047
Re: Informacion para instalar paquete de idiomas en OpenWrt
« Respuesta #5 en: 17-12-2014, 09:28 (Miércoles) »
Lo de no encontrar la actualización pasa por no tener una versión estable de OpenWrt, sino una trunk (FAQ : "Sobre las compilaciones personalizadas basadas en la rama 'trunk' en desarrollo)". Dado que las últimas versiones de trunk han cambiado, la forma de acceso a los paquetes de descarga da el error que te ha dado porque la localización de paquetes en la web ha cambiado.

Puedes ver más detalles en las FAQ, en la sección "No se actualiza la lista de paquetes por internet."

Muchas gracias a tí, por comentar gráficamente.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

coe

  • Visitante
Re: Informacion para instalar paquete de idiomas en OpenWrt
« Respuesta #6 en: 17-12-2014, 19:26 (Miércoles) »
  Leí por el foro algo sobre versiones "trunk" y las digamos "definitivas" y pensé que la mas adecuada era la Barrier Breaker 14.07-rc3 {Con LuCI}, de las tres que vi en la primera pagina de  https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5387un/ (por cierto, desde hace unos días da error) y también me descargue para otro AR-5387un que tengo desde un enlace que pone Jar229  https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5387un/1043/  por si en la del otro router hubiera hecho algo mal y no podía poner el idioma español, pero me ocurrió lo mismo.


 
 
 

Desconectado Tki2000

  • Moderador
  • *
  • Mensajes: 2047
Re: Informacion para instalar paquete de idiomas en OpenWrt
« Respuesta #7 en: 18-12-2014, 08:49 (Jueves) »
  Leí por el foro algo sobre versiones "trunk" y las digamos "definitivas" y pensé que la mas adecuada era la Barrier Breaker 14.07-rc3 {Con LuCI}, de las tres que vi en la primera pagina de  https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5387un/ (por cierto, desde hace unos días da error) y también me descargue para otro AR-5387un que tengo desde un enlace que pone Jar229  https://foro.seguridadwireless.net/openwrt/openwrt-en-comtrend-ar5387un/1043/  por si en la del otro router hubiera hecho algo mal y no podía poner el idioma español, pero me ocurrió lo mismo.


Hay un poco de confusión en ese sentido en el foro. La 14.07-rc3 de este foro está adaptada para hacer funcionar la wifi de ciertos routers que no estaban soportados en la rama oficial en ese momento. Después de esa adaptación, sacaron la rc3 oficial (que tampoco le da wifi a esos routers en cuestión), y la mezcla de los nombres puede llevar a confusión. O sea, que por un lado tenemos la rc3 de este foro en la que se le da wifi y se hace funcionar ciertos routers (entre ellos el ar5387un), y por otro lado está la rc3 oficial. El problema está en que la rc3 de este foro apunta a la lista de paquetes de la rama trunk de la página oficial, y esa rama trunk es la que ha cambiado, provocando los fallos de actualización en los paquetes (por no encontrar la ruta y por no coincidir las versiones del kernel)...
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Solo a un mandril epiléptico se le podría haber ocurrido diseñar la cinta de menú de M$.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.

//FINAL Y MÁS DOS RESPUESTAS