Autor Tema: Ayuda configurar dos router openwrt para compartir internet  (Leído 1323 veces)

0 Usuarios y 1 Visitante están viendo este tema.

p500hev

  • Visitante
Buenas tardes, espero alguien me pueda ayudar/orientar, actualmente tengo la red en mi casa de esta forma:

Router tplink con Openwrt 18.06 en el recibo internet por la interfaz wan del mismo y reparto el servicio

Segmento principal
172.16.10.0/24
Segmento secundario
192.168.1.0/24

En el segmento principal (172.16.10.0/24)tengo dos AP
Wifi_Principal de 5 Ghz
Wifi_Principal de 2.4 Ghz
1 puerto para NAS
1 puerto para PC de escritorio

Y en el segmento secundario (192.168.1.1/24) tengo un AP
Wifi_Secundario en 2.4Ghz
1 Puerto configurado sin uso

El segmento secundario es para invitados y alguno que otro vecino que de repente me pide internet, por lo cual lo tengo restringido con SQM Qos para que no abusen esta red funciona al 100%.

Mi problema va que hay una parte de la casa que literalmente no llega la señal por lo que compre otro tp-link exactamente igual para repartir wifi en esa zona que no tengo cobertura ya puse la canaleta que lleva el cable del router principal a donde colocare el segundo router pero ahora me encuentro con el problema de que no se como configurar el router secundario para que me mantenga esos tres AP como en el primero y la conectividad transparante.

Lo que se me ocurrio pero siento que es la peor solucion es copiar la configuracion del primero en el segundo pero estaria haciendo un doble NAT y aparte tendria que configurar el firewall y ya no podria utilizar en este segundo router el SQM Qos ya que la velocidad seria la de la lan y no la de internet y me pegaria en un NAS que tengo conectado en el router principal en el segmento 172.16.10.0/24.

Ya busque por internet pero no encuentro informacion que yo pueda entender para hacer lo que quiero si hay alguien en el foro que me pueda ayudar se lo agradeceria mucho.



Desconectado eduperez

  • **
  • Mensajes: 42
Re:Ayuda configurar dos router openwrt para compartir internet
« Respuesta #1 en: 02-10-2018, 18:40 (Martes) »
En el fondo, lo que tienes que hacer es llevar dos conexiones desde el router principal al secundario, una para cada segmento de red, pero sobre un único cable ethernet, ¿no?. Luego sólo tendrías que configurar el router secundario como punto de acceso tonto, pero con dos redes distintas independientes. Lo de llevar dos conexiones de un router al otro se llama trunking: básicamente, tienes que reservar un puerto en el router principal, y conectar ahí las dos redes, pero cada una en una VLAN diferente, marcando los paquetes a la salida (tagging) para que no se mezclen; y en el router secundario haces lo mismo, en el puerto donde conectes el cable.

p500hev

  • Visitante
Re:Ayuda configurar dos router openwrt para compartir internet
« Respuesta #2 en: 04-10-2018, 00:40 (Jueves) »
En el fondo, lo que tienes que hacer es llevar dos conexiones desde el router principal al secundario, una para cada segmento de red, pero sobre un único cable ethernet, ¿no?. Luego sólo tendrías que configurar el router secundario como punto de acceso tonto, pero con dos redes distintas independientes. Lo de llevar dos conexiones de un router al otro se llama trunking: básicamente, tienes que reservar un puerto en el router principal, y conectar ahí las dos redes, pero cada una en una VLAN diferente, marcando los paquetes a la salida (tagging) para que no se mezclen; y en el router secundario haces lo mismo, en el puerto donde conectes el cable.

Ya habia leido algo pero no me quedaba claro y lo había hecho antes de postear solo que al momento de conectarme via wifi a la red del router 2 me desconectaba y de repente aun conectado a la red no tenia Internet entonces pensaba que estaba haciendo algo mal, después de que me escribiste y que me quedo claro que si estaba bien decidi hacer lo mismo pero reservando un puerto para cada vlan en el router 2 y me conecte via cable. Resultado todo funcionaba sin problemas en cada puerto una vlan distinta así que me di cuenta que el problema es del router en parte inalambrica, ya hice pruebas y solo me funciona en modo b/g, pero al momento de seleccionar en modo N empieza el show de desconeccion y demas cosas raras ??? ??? ??? ya revise la hoja de datos en openwrt y lo unico que mencionan es que el firmware no funciona en modo de 5GHz pero eso no me afecta en nada lo que no entiendo es por que no funciona en modo N, ya volvi a cargar el firmware 2 veces mas volvi a configurar todo y nada.

Con el firmware original del TP-Link funciona todo sin problemas, el detalle es que no puedo tener dos vlans con el firm original

El router es el C20 AC750

https://www.tp-link.com/in/products/details/cat-9_Archer-C20.html

https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c20_ac750_v4

Alguna idea de que este pasando???