Autor Tema: Ayuda con OpenWrt No scanea redes  (Leído 2196 veces)

0 Usuarios y 1 Visitante están viendo este tema.

fran1992

  • Visitante
Ayuda con OpenWrt No scanea redes
« en: 21-05-2017, 06:42 (Domingo) »
Muy buenas, el sistema operativo que uso es windows 10, el router es Home station ADSL ADB P DG A4001N , detallo: Le puse al router OpenWrt Barrier Breaker 14.07 entro al router desde luci me fijé y ya tenia los drivers instalados de mi tp link tl wn722n
los cuales son estos:
kmod-ath9k-htc
kmod-usb-ohci
kmod-usb2
kmod-usb-core
ya los tenia...., pues conecte en la entrada usb del router mi tp link y no lo detecta lo que hice fue abrir el programa putty y poner los siguientes comandos wifi detect > /etc/config/wireless      cat /etc/config/wireless
al ponerlos sali del programa putty y fui a la página de configuracion de Openwrt del router (luci) y vi que ya aparecia mi tp link tl wn722n por el nombre radi01 le doy a scan para buscar la red y se queda todo en blanco, sigue buscando pero no encuentra nada me han  dicho que tienes que borrar las redes en modo cliente ect... antes de empezar la busquedad de redes pero he echo hasta eso y nada no doy con la tecla llevo comiendome la cabeza bastante dias espero vuestra ayuda un saludo ???



peperfus

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #1 en: 21-05-2017, 11:31 (Domingo) »
Hola

Yo tengo el mismo pincho; estoy intentando ponérselo al livebox arv7519rw22 desde hacer varios días y me está dando muchos problemas; aunque alguna vez sí conseguí hacerlo funcionar, pero de forma inestable.

Lo último que me han comentado es que puede ser por fallo de alimentación. Tal vez no reciba la suficiente electricidad (supongo que es cuestión de miliamperios, porque creo que los 5V son constantes). Y me han sugerido a probarlo con un hub usb externo alimentado por corriente. No tengo ninguno a mano, pero seguramente lo probaré en los próximos días, en cuanto pille alguno.

Por otro lado, otra cosa que estoy intentando probar es compilar una imagen de openwrt con el driver incluido (en la mía no venía). Aunque no sé si lo conseguiré, pero por probar....


¿Has editado el archivo /etc/config/wireless y le has quitado la linea de disable?

fran1992

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #2 en: 21-05-2017, 17:15 (Domingo) »
Hola, gracias por contestar lo de fallo de alimentacion no tengo ni idea pero he visto en foros que no debe ser porque hay gente que le ha funcionado ala perfeccion esta antena y el router, lo que dices de editar... pues no lo sé soy nuevo en este tema el comando ese me suena lo que ago con ese comando/etc/config/wireless es ponerlo en putty despues con  cat /etc/config/wireless para que me detecte el tp link lo de quitar la linea de disable nosé tampoco pero me podrias explicar ese metodo por probar...

agsmjandro

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #3 en: 21-05-2017, 19:28 (Domingo) »
te as conectado al router por ssh? editas el archivo /etc/config/wirelles con vi o nano, depende de cuanta memoria libre tengas, otra opcion es conectarte con el Winscp al router y editar los archivos desde notepad o notepad++ y luego que lo suba

fran1992

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #4 en: 22-05-2017, 03:27 (Lunes) »
Si, me he conectado al router por shh con putty , explicadme más detalladamente por favor si no os importa esque soy nuevo en el tema este , espero tu respuesta

peperfus

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #5 en: 22-05-2017, 15:29 (Lunes) »
una vez conectado haces:

nano /etc/config/wireless

luego borras la linea del disable (la linea entera)
sales con Ctrl+x grabando y lo vuelves a probar.
Si no te va, prueba ejecutar wifi reload
o reiniciar el router
suerte !

fran1992

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #6 en: 22-05-2017, 18:50 (Lunes) »
Hola peperfus, he escrito ese comando que me has dado en shh por putty y me sale un error... lo puse con vi en vez de nano y si me salio algo pero me lío bastante no soy tan experto haz el favor y explicame detalladamente... perdona mi ignorancia ???
  esto es lo que me sale siempre al darle a scanear redes en mi adaptador wifi usb.

 espero tu ayuda

peperfus

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #7 en: 22-05-2017, 22:56 (Lunes) »
el vi es un poquito más complicado, pero sabiendo un par de cositas te puedes apañar.

para pasar al modo edición pulsa i
luego cambias lo que quieras
luego pusas ESC
y luego :wq para salir grabando
o :q! para salir sin grabar (si no recuerdo mal)

Para instalarte el nano, primero actualiza repositorios:
opkg update
y luego lo instalas:
opkg install nano

fran1992

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #8 en: 22-05-2017, 23:18 (Lunes) »
Ahora si me busca, el problema es que al configurar todo la conexion a internet tanto como la emitida por el router como la del pc es muy inestable hice la prueba de velocidad en comparacion al usb conectado directamente ala pc y era infinitamente mejor...

Pteridium

  • Visitante
Re: Ayuda con OpenWrt No scanea redes
« Respuesta #9 en: 23-05-2017, 11:09 (Martes) »
Se cierra el hilo.

//FINAL Y MÁS DOS RESPUESTAS