Autor Tema: Ayuda con mi red de casa!!!!  (Leído 6760 veces)

0 Usuarios y 1 Visitante están viendo este tema.

eq7mavala

  • Visitante
Ayuda con mi red de casa!!!!
« en: 17-09-2012, 02:20 (Lunes) »
Buenas noches, tengo una red en casa un poco complicada y a veces tengo cortes o problemas (Sobre todo cortes con el tema de voip).

Les hago un esquema para que se sitúen:

Comtrend 5365 (Internet) ------- Alpha ADB P.DGA4001N --------- Comtrend hg536+ ------------- Huawei HG556 ----- D'Link DVG 5121SP
 (192.168.1.1)                   PLC's      (192.168.1.253)            Wifi      192.168.1.251/192.168.2.1    192.168.2.254             192.168.2.90


El comtrend 5365 esta de serie con el firmware de telefonica, no tiene nada especial excepto una regla de QOS con 512 kbps de alta prioridad desde y hasta la 192.168.1.251, para controlar el tema de VOIP.

La conexión entre 192.168.1.1 y 192.168.1.253, se realiza mediante una pareja de plc's de la marca comtrend 9020.

El alpha, esta configurado normal y corriente, solo tienen cambiada la IP, la clave y deshabilitado el DHCP, que se conecta mediante unas antenas externas al 192.168.1.251.

El comtrend 192.168.1.251 lleva una versión de OPENWRT, ahora mismo no recuerdo cual y esta como cliente de la red wifi del alpha (Con la IP 192.168.1.251) como WAN, del mismo modo tiene la subred (192.168.2.X, llevando la IP 192.168.2.1) como LAN, como especialidad solo tiene el paquete luci-app-qos, el cual tiene una regla de QOS, desde y hasta el 192.168.2.90, de 100 kbps para el tema del voip, para el que uso como codec G729A.

La conexion entre el alpha esta con una calidad de:

Signal:   -41 dBm (SNR 26 dBm)          Average:   -40 dBm (SNR 29 dBm)      Peak:   -37 dBm (SNR 30 dBm)

Y una tasa de transferencia:

Phy Rate:   54 MBit/s   Average:   53 MBit/s   Peak:   54 MBit/s


Los tiempos de respuesta entre el 192.168.2.1 y el 192.168.1.1 son de:


--- 192.168.1.1 ping statistics ---
117 packets transmitted, 116 received, 0% packet loss, time 116186ms
rtt min/avg/max/mdev = 4.345/7.052/22.851/3.107 ms

Lo cual me parece que esta bastante bien contando todas las etapas de la red.

En el huawei HG556 lo tengo solo como AP, servidor samba, servidor de descargas, como no consigo un firmware reciente con FPU, me he visto obligado a utilizar el amule, aquí en el tema de los puertos los tengo correctamente abiertos en el router final y en el router intermedio (192.168.2.1/192.168.1.251), pero si miro las conexiones del 192.168.2.1, las conexiones se realizan pero por un puerto diferente al establecido en amule, lo que me imposibilita un correcto funcionamiento de este.


Me gustaría poder solucionar todos los problemas de mi red, como son el tema de los microcortes o baja calidad en las llamadas VOIP, así como el tema de los puertos para el amule, un saludo y muchísimas gracias por adelantado.

PD: La conexión entre 192.168.2.1/192.168.2.251/192.168.2.90 se realiza mediante cable, los tiempos de respuesta al ping son de 1ms o inferiores...



Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4589
Re: Ayuda con mi red de casa!!!!
« Respuesta #1 en: 18-09-2012, 11:23 (Martes) »
Demasiados cacharros  ;D
No puedes prescindir, por ejemplo del alpha y usar en su lugar el hg556a ?
Del tema del voip, no tengo ni idea, lo lamento  ^-^
Valoraciones positivas en compra/venta:
146 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: Re: Ayuda con mi red de casa!!!!
« Respuesta #2 en: 18-09-2012, 23:13 (Martes) »
Buenas noches gracias por contestar ya solo todo lo escrito invita a no hacerlo jajaja

No puedo prescindir del alpha podria del comtrend que conecta con este, si pudiera ponerle un conector al hg556 pero es inviable, tengo un usb bastante bueno con chip ralink y toma de antena, pero no me lo detecta...

Me gustaria quitar el comtren asi como lo del voip, pero...

Muchas gracias

Enviado desde mi SXZ-PDX0-01 usando Tapatalk 2

Chumpy

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #3 en: 19-09-2012, 02:22 (Miércoles) »
Madre mía, cuanto más lo leo más me cuesta entenderlo.

Si quieres conseguir entrar en el correo de vez en cuando, tu instalación puede que esté bien.
Si quieres tener una conexión fluida es evidente que tienes un problema, es practicamente imposible que una conexión que tiene por medio un par de PLCs y DOS conexiones wifi  (incluidas 2 subredes) funciones de forma fluida y estable, y más teniendo en cuenta que los aparatos no son modelos de alto rendimiento, y cada uno, probablemente con un chipset y características distintos.

Deberías buscar la forma de reducir todo a 1 o como mucho 2 dispositivos intermedios (entre el que proporciona internet y el cliente), si fuera todo por cable bueno, pero con redes inalámbricas y sobre red eléctirca son un sin fin de variables y conflictos.

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #4 en: 19-09-2012, 10:06 (Miércoles) »
La opcion de cable o reducir elementos no es posible, como mucho elminar 1 paso, si es necesario comprar aparatos o similar los comprare, no es un problema...

Necesito 1 punto de acceso y otro que actue como repetidor, tengo 2 wrt54gl pero la conexion es nefasta, no me importa comprar elementos de red, recomendadme por favor, gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4589
Re: Ayuda con mi red de casa!!!!
« Respuesta #5 en: 19-09-2012, 10:16 (Miércoles) »
Si he entendido bien el esquema, con 1 PLC más, podrías eliminar el alpha y el comtrend, no (o al menos este último) ?
De ser así, yo lo haría. La inversión será mínima y ganarás en estabilidad y podrás meter todos los equipos sin problemas en la misma subred.
Acabo de poner una nueva compilación para el hg556a con FPU emulation: https://foro.seguridadwireless.net/openwrt/openwrt-en-huaweig-hg556a/msg253107/#msg253107  ^-^
Valoraciones positivas en compra/venta:
146 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #6 en: 19-09-2012, 12:07 (Miércoles) »
El problema es que esos que nombras hacen el enlace entre mi casa y la de un familiar con quien comparto red, vamos el me la cede... cuando llegue flasheo al canto, en esta compilacion podre poner un usb wifi?

Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4589
Re: Re: Ayuda con mi red de casa!!!!
« Respuesta #7 en: 19-09-2012, 12:20 (Miércoles) »
Pues debería poderse ... :P


Enviado desde mi CUBE U30GT-H usando Tapatalk 2
Valoraciones positivas en compra/venta:
146 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

Chumpy

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #8 en: 19-09-2012, 12:58 (Miércoles) »
Si no explicas con detalle como tienes cada cosa es dificil proponer soluciones pero.

Supongo que tu familiar,  tiene el Comtrend 5365 donde le viene bien para conectarse a internet y la alpha cerca de la ventana que mira hacia tu casa. ¿podríamos darle la vuelta a esta parte de la instalación? es decir, ponemos el 5365 a lado de la ventana y con PLC el volvería a tener internet en el salón, solo que tu no te conectarías a través de ellos, lo único que necesitarás, en principio, es una roseta de teléfono en la habitacion que tiene la ventana, pero puede ser un avance considerable.

¿Sería esto posible?

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #9 en: 19-09-2012, 15:01 (Miércoles) »
Pues no creo que haya toma de telefono, si no ya estaria solucionado... el tema del conexion entre los plcs yo diria que va muy bien, no tengo excesivo retardo mas menos 3-5 ms y creo que 0 perdida de paquetes, cosa que no ocurre con el enlace wifi...

Muchas gracias

Pd: es posible que el hg556 no pille el usb por el tipo de chip de este? Lleva un rt 5721 creo recordar, aunque para linux esta perfectamente soportado, asi que no se muy bien gracias

Chumpy

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #10 en: 19-09-2012, 16:43 (Miércoles) »
Pues no creo que haya toma de telefono, si no ya estaria solucionado... el tema del conexion entre los plcs yo diria que va muy bien, no tengo excesivo retardo mas menos 3-5 ms y creo que 0 perdida de paquetes, cosa que no ocurre con el enlace wifi...

El problema de los PLCs no es los problemas que ellos creen, si no los que añaden al resto de la red, supongo que las latencias desde el 5365 al hg536+ no son las mismas que desde la alpha al hg536+

Pero bueno, que ni no se puede quitar ese punto ya está, habrá que intentar atacar en otra parte.

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #11 en: 19-09-2012, 22:43 (Miércoles) »
Gracias por la ayuda!!!!!!  ;D

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4589
Re: Ayuda con mi red de casa!!!!
« Respuesta #12 en: 20-09-2012, 14:55 (Jueves) »
Pd: es posible que el hg556 no pille el usb por el tipo de chip de este? Lleva un rt 5721 creo recordar, aunque para linux esta perfectamente soportado, asi que no se muy bien gracias

Seguro que ese es el chipset wifi que lleva ?
Y que driver instalas ?
Valoraciones positivas en compra/venta:
146 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #13 en: 20-09-2012, 15:57 (Jueves) »
Me cole lleva un rt73, ya he puesto los drivers y excepto el problema de las dependencias el resto ok, tengo que mirar por qur se me queda colgado luci...

Alguna idea? Gracias

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4589
Re: Re: Ayuda con mi red de casa!!!!
« Respuesta #14 en: 20-09-2012, 17:08 (Jueves) »
Después de instalar el driver has generado la nueva configuración wireless (ojo si estás conectado por wifi que pierdes la conexión) ?
wifi detect > /etc/config/wireless


Enviado desde mi CUBE U30GT-H usando Tapatalk 2
Valoraciones positivas en compra/venta:
146 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #15 en: 25-09-2012, 09:00 (Martes) »
Conseguido en parte!

He instalado relayd en el comtrend, ya tengo todo bajo la misma subred, ahora he reorganizado las IPS de los dispositivos, el QOS del router adsl ya va directamente a la IP del ATA, el siguiente paso es instalarle un conector de antena SMA al HG556 y eliminar un dispositivo (El comtrend 5361 que hace de cliente), luego intentar hacer funcionar el tema del VOIP en este dispositivo...

Tener en el HG556 torren+mldonkey+VOIP seria genial, lo del voip jodido...

Por que sin antena externa la calidad del enlace del hg556 es de 50-60 %, con el comtrend entorno al 90%, siendo este B+G, si consigo lo de la antena en el HG556, tanto el emisor como el receptor son N, por lo que espero una mejora considerable en la calidad del enlace...

Que opinais?

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4589
Re: Re: Ayuda con mi red de casa!!!!
« Respuesta #16 en: 25-09-2012, 09:12 (Martes) »
No te fíes mucho de la calidad del enlace que te muestran los drivers.
Lo mejor para verificar el funcionamiento es que hagas test de velocidad (entre equipos de la red, y también con páginas como speedtest.net).
Yo siempre he obtenido mejores resultados (en velocidad y estabilidad) con chipset's atheros, que con broadcom :D

Enviado desde mi U30GT-H usando Tapatalk 2
Valoraciones positivas en compra/venta:
146 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #17 en: 25-09-2012, 09:20 (Martes) »
Llegados a este punto, me recomendáis un AP con chipset atheros que sea N y permita la conexión de una antena SMA...

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4589
Re: Ayuda con mi red de casa!!!!
« Respuesta #18 en: 25-09-2012, 09:54 (Martes) »
Llegados a este punto, me recomendáis un AP con chipset atheros que sea N y permita la conexión de una antena SMA...

Pues no, porque para eso, ya tienes el hg556a  ;)

Insisto, haz pruebas de rendimiento con el comtrend y después con el huawei.
Valoraciones positivas en compra/venta:
146 en Htcmania
194 en Har2mano
21 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

eq7mavala

  • Visitante
Re: Ayuda con mi red de casa!!!!
« Respuesta #19 en: 25-09-2012, 10:08 (Martes) »
Buenas de nuevo, entonces crees que sera mejor la conexion con la interna del hg que la externa direccional del comtrend? Es que para el tema del voip...

De todas formas verificare el tema del indicador de la conexion en abos, necesotaria que estiviera por debajo de -40 para no tener perdida de paquetes...

//FINAL Y MÁS DOS RESPUESTAS