Autor Tema: Astoria networks ARV7519  (Leído 94112 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Lesgar

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #120 en: 26-12-2013, 16:46 (Jueves) »
Hay otro punto mas accesible que soldar directamente a la flash. Lo estamos testando...
Barry Te mando un MP con información actualizada para que lo testes y nos cuentas.
En breve subiré un tutorial mas completo (la parte de como hacer un backup ya esta completa, falta terminar la de como cargar OpenWrt, el método actual es muy lento) mientas los que queráis probarlo enviar un MP
Gracias.
 



doblecero

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #121 en: 26-12-2013, 16:53 (Jueves) »
Juas, como avanza esto!!  >:(
Lesgar, ¿cual es eso otro método para acceder al bootloader?

barriteleves

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #122 en: 26-12-2013, 17:01 (Jueves) »
saludos compañero lesgardice:

Hay otro punto mas accesible que soldar directamente a la flash. Lo estamos testando...
Barry Te mando un MP con información actualizada para que lo testes y nos cuentas.
En breve subiré un tutorial mas completo (la parte de como hacer un backup ya esta completa, falta terminar la de como cargar OpenWrt, el método actual es muy lento) mientas los que queráis probarlo enviar un MP
Gracias.

grs miroy entre hoy y mañana dare una respuesta grs por todo vuestro estupendo  trabajo y el compañero gmtii un saludo

Lesgar

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #123 en: 26-12-2013, 21:25 (Jueves) »
El método en si no ha cambado, lo que pasa es que es un método lento y no esta exento de riesgos (hasta que se pueda activar el modo UART, hay riesgo de briquear el router).
Además es mas fácil hacer un corto en un punto de la pcb que hacerlo directamente en la flash.
De todas formas te mando toda a info por MP, por si quieres probarlo y ya nos comentas.
Una vez esté confirmado que todo funciona correctamente ya se publicará un tutoríal actualizado, así no hay riesgo de errores.

Aprovecho para dar las gracias a los verdaderos genios que han conseguido todo esto que son pteridium y gmtii.

Lesgar

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #124 en: 27-12-2013, 15:48 (Viernes) »
ACTUALIZACIÓN: Ya es posible poner el router en modo UART. >:( >:( >:(
Mas info "http://wiki.openwrt.org/toh/arcadyan/arv7519?s[]=livebox"

Mira tu por donde Papa Noel se había dejado "un regalito" en el saco.  ;D ;D ;D


barriteleves

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #125 en: 28-12-2013, 15:04 (Sábado) »
saludos compañero, comentado lo de mi post anterior, he intentado un par de consejor uno de ellos el metodo civilizado, y no se muy bien si lo he puenteado bien ya que despues al terminar de soldado uno de los cables se ha soltado, y no se bien donde va conectada la resistencia , pregunta, junto a la 153 o al contacto abierto que hay junto y seguido a la resistencia ya que un trozito de pista se ha levantado con el cable,

ademas podrias comentar como se pone en modo UART, con esos contacto que hay en la wiki , es cerrando el puente donde pone que se suelde, con solo uno de ellos se consigue o necesita alguno mas, el corto que hay que realizar como ???, saludos y aunque sea 28, tranquilo no suelo gastar inocentadas.

hawai50

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #126 en: 29-12-2013, 10:10 (Domingo) »
yo no he roto (de momento) ninguna pista, pero tengo la misma preguunta, con que otro punto hay que puentear los cables, se puentea con algun punto del negativo o masa?

barriteleves

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #127 en: 29-12-2013, 11:57 (Domingo) »
saludos compañero, hawai50, si efectivamente asi es mi duda, aunque esa pequeña pista como la punta de un alfiles es pequeña y el router aun arranca perfectamente por ahora , espero no se estropee, por que si no tendria que hacerme con otro, este router me parece bastante bueno, espero haber que resultados se consiguen con el .grs

gmtii

  • Visitante
Re:
« Respuesta #128 en: 30-12-2013, 23:44 (Lunes) »
buenas

adjunto un pack con uboot y firmwares para las dos revisiones de router conocidas, vr9 1.1 y 1.2

accediendo al modo uart ( hacer puentes temporalmente con dos soldaduras por ejemplo) podemos subir el uboot.asc y de ahí flashear el uboot definitivo (uboot nor). (en la wiki se ven claramente). si seguimos este camino no hay que andar haciendo cortos en la flash.

Saludos!

https://www.mediafire.com/?m0b5p2tzr9ii3af

Sent from my GT-P6810 using Tapatalk

barriteleves

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #129 en: 31-12-2013, 12:19 (Martes) »
hola vaya  estupendo un trabajo excelente, ahora si se ven claramente, eso era lo que pensaba,

bien, una pregunta que me ha surgido en la resistencia 152, aunque parece no se necesaria, si queria recuperar ese porcion de pista si me puede hacer medir en continuidad entre el puente que junto a la cpu y laresitencia 152, si tiene coninuidad para meter un cable sin puentear nada y si tiene conexion tambien con la resistnecia153 ya comento que el router arranca bien por lo menos en los led no presenta ninguna anomalia,  haber si el proximo dia puenteo esos dos y subo algun uboot y firmware para pruebas saludos y grs feliz año nuevo

hawai50

  • Visitante
Direcciones de memoria
« Respuesta #130 en: 03-01-2014, 14:19 (Viernes) »
Gracias gmtii por el aporte, voy a flashear mi arv7519 por uart, pero antes me gustaria asegurarme bien de todo, para no meter la pata. La semana pasada me cargue uno por un problema de cortocircuito de un cable, que salia de una de las resistencias. Ya solo me queda un router y no me la juego.

Necesitaria que alguien me confirmara las direcciones de memoria donde hay que cargar el u-boot_nor.bin al proceder por UART, y tambien si este segundo uboot tiene ftp, o loady, o como se comunica con el terminal. Estaria bien saber donde hay que dirigir la carga de las imagenes, y cual es la diferencia entre los dos archivos que pones en el comprimido: me refiero a los initframs y a los .image

Gracias a todos por este excelente trbajo

buenas

adjunto un pack con uboot y firmwares para las dos revisiones de router conocidas, vr9 1.1 y 1.2

accediendo al modo uart ( hacer puentes temporalmente con dos soldaduras por ejemplo) podemos subir el uboot.asc y de ahí flashear el uboot definitivo (uboot nor). (en la wiki se ven claramente). si seguimos este camino no hay que andar haciendo cortos en la flash.

Saludos!

https://www.mediafire.com/?m0b5p2tzr9ii3af

Sent from my GT-P6810 using Tapatalk

P.D.:
He probado varias veces de flashear el fichero u-boot_uart_ram.asc (lo hago desde windows7 con hyperterminal, con un copiar-pegar desde el fichero de texto abierto con notepad y tambien probado con un editor hexadecimal) y transmite bien, pero cuando ya se acaba la transmision a los 12 minutos, no se resetea el router con el boot uart. Algo estare haciendo mal, o el archivo no es el que deberia ser?
« Última modificación: 03-01-2014, 15:19 (Viernes) por hawai50 »

gmtii

  • Visitante
Re:
« Respuesta #131 en: 03-01-2014, 17:38 (Viernes) »
Buenas

En un par de horas lo verifico y te comento.

Que versión de router tienes? 1.1 o 1.2?

Saludos y feliz año.

Enviado desde mi Nexus 4 mediante Tapatalk

hawai50

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #132 en: 03-01-2014, 23:01 (Viernes) »
Mi router es del 2013, por lo tanto debe ser la version 1.2.
Una cosa, para intentar recuperar el otro router estropeado, me gustaria saber donde esta el fusible de estos trastos. Es un componente de plastico rectangular y blanco que esta justo detras del conector de alimentacion?
« Última modificación: 03-01-2014, 23:10 (Viernes) por hawai50 »

elmasvital

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #133 en: 04-01-2014, 00:07 (Sábado) »
Si has hecho un corto no busques "fusibles" porque no los vas a encontrar. Has podido quemar cualquier transistor o micro... Enciende el router al menos? Si no enciende igual se ha estropeado "simplemente" los reguladores de tensión.

Lesgar

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #134 en: 04-01-2014, 16:32 (Sábado) »
No te compliques, desde el brnboot puedes flashear el uboot. No es necesario activar el uart.
Desde brnboot "U" "0" "Y" lo cargar por x módem y reinicias

barriteleves

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #135 en: 04-01-2014, 22:21 (Sábado) »
hola compañero dice:

Mi router es del 2013, por lo tanto debe ser la version 1.2.
Una cosa, para intentar recuperar el otro router estropeado, me gustaria saber donde esta el fusible de estos trastos. Es un componente de plastico rectangular y blanco que esta justo detras del conector de alimentacion?

he mirado la placa y tienes justo detras del interruptor general el F8 es un fusible, y quizas tengas alguno mas en todos lo que tengas suelen tener asi segrigrafiados con una F y el numero que corresponda, son como una pastilla restangular negra, parecen diosdos, pero no lo son. suerte puedes medirlo con un polimetro haber si te da continuidad, pica bien con la punta aveces la soldadura tiene algo de barniz o la capa que hechen en fabrica y no dan continuidad pero si arrimas el soldador despues ya hacen buen contacto suerte

nota. ampliacion: tambien tienes otro el F7 justo detras del Usb esta entre los rj45 yrj11. ademas he visto dos componentes blancos restangulares como el que tu mencionas que pone T5, en estos son T4 y T8 justo hay ponevarios FB19 ect puenden ser tambien fusibles, de esto ultimo no estoy seguro ya que mis conocimientos de electronica son bastante antiguados.
« Última modificación: 04-01-2014, 22:36 (Sábado) por barriteleves »

Lesgar

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #136 en: 04-01-2014, 22:37 (Sábado) »
Tambien hay otro detras del usb entre los puertos rj11 y los rj 45. Serigrafiado con F7.
Suerte

hawai50

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #137 en: 05-01-2014, 18:19 (Domingo) »
ya vi lo de los fusibles, marcados con la letra F. Los comprobe con el tester y estaban bien. Finalmente vi que a la caja blanca de detras de la entrada de alimentacion (marcado con la letra T, transformador de choque, supongo) le sobresalia por abajo una gotita de algo fundido de color negro, sobre la placa. Supongo que la causa de la averia es que se fundio la bobina esa. No consegui desoldarla porque esta puesta casi de forma hermetica, asi que ya en plan forense la hice saltar con un destornillador fino, para ver si se desprendia solo la carcasa blanca, pero se rompieron los tres cablecillos de la bobina, en plan irrecuperable.  Asi que dentro de poco vamos al funeral de este esplendido arv7519, muerto por la causa. El evento tendra lugar en la deixalleria de la ciudad, para el que quiera asistir XD .

hawai50

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #138 en: 05-01-2014, 18:26 (Domingo) »
Amigo Lesgar, podrias explicar un poco mas o indicar donde encontrar la informacion, para flashear desde brnboot? Se hace atraves de la web interface presionando el boton de reset al encender, o atraves de telnet con hyperterminal?
A ver si alguien se anima y los reyes magos nos traen ya un manualillo...
Saludos y gracias
« Última modificación: 05-01-2014, 18:26 (Domingo) por hawai50 »

barriteleves

  • Visitante
Re: Astoria networks ARV7519
« Respuesta #139 en: 05-01-2014, 20:25 (Domingo) »
hola compañero dice:

ya vi lo de los fusibles, marcados con la letra F. Los comprobe con el tester y estaban bien. Finalmente vi que a la caja blanca de detras de la entrada de alimentacion (marcado con la letra T, transformador de choque, supongo) le sobresalia por abajo una gotita de algo fundido de color negro, sobre la placa. Supongo que la causa de la averia es que se fundio la bobina esa. No consegui desoldarla porque esta puesta casi de forma hermetica, asi que ya en plan forense la hice saltar con un destornillador fino, para ver si se desprendia solo la carcasa blanca, pero se rompieron los tres cablecillos de la bobina, en plan irrecuperable.  Asi que dentro de poco vamos al funeral de este esplendido arv7519, muerto por la causa. El evento tendra lugar en la deixalleria de la ciudad, para el que quiera asistir XD .

animo que ese componente es facil de sustituir supongo que es una bobina de filtro del rizado posible que pueda meter la fuente por lo que con otra te vale haber si encunetro una que te pueda vale en los viejos que tengo que sea doble como esa son dos bobina juntas una para cada contacto positivo y nevativo. venga no le tieres aunque que esta vivo suerte