Autor Tema: Aislar wlan de lan  (Leído 4314 veces)

0 Usuarios y 1 Visitante están viendo este tema.

taik

  • Visitante
Aislar wlan de lan
« en: 05-10-2012, 22:27 (Viernes) »
Estoy intentando configurar un H553 para que la wifi vaya en una red distinta a la de la Lan. Estoy siguiendo este turorial:

http://wiki.openwrt.org/doc/recipes/routedap

Me parece bastante sencillo pero no consigo que me funcione. Si la wlan tiene de red 192.168.2.0/24 y la lan 192.168.0.0/24 no entiendo como puedo conectarme por ssh al router desde la wlan cuando yo estoy en una red distinta.

[desde 192.168.2.2] $ ssh root@192.168.0.250
root@192.168.0.250's password: *****


Las máscaras de red deberían impedirlo y el firewall también... ¿no? No lo entiendo  ???

Aquí dejo mis configuraciones:

root@RT-VF:/etc/config# cat network

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config interface 'lan'
   option ifname 'eth1'
#   option type 'bridge'
   option proto 'static'
   option netmask '255.255.255.0'
   option ipaddr '192.168.0.250'
   option gateway '192.168.0.1'
   option dns '8.8.8.8 8.8.4.4'

config 'interface' 'wifi'
   option 'proto' 'static'
   option 'ipaddr' '192.168.2.1'
   option 'netmask' '255.255.255.0'

config interface 'wan'
   option ifname 'eth0'
   option proto 'dhcp'

root@RT-VF:/etc/config# cat wireless

config wifi-device 'wl0'
   option type 'broadcom'
   option channel '11'
   option txpower '24'
   option hwmode '11bg'

config wifi-iface
   option device 'wl0'
   option network 'wifi'
   option mode 'ap'
   option ssid 'RT-ONO'
   option encryption 'psk'
   option key 'xxxxxxxxxxxxx'


root@RT-VF:/etc/config# cat firewall
config defaults
   option syn_flood   1
   option input      ACCEPT
   option output      ACCEPT
   option forward      REJECT
# Uncomment this line to disable ipv6 rules
#   option disable_ipv6   1

config zone
   option name      lan
   option network      'lan'
   option input      ACCEPT
   option output      ACCEPT
   option forward      REJECT

config zone
   option name      wan
   option network      'wan'
   option input      REJECT
   option output      ACCEPT
   option forward      REJECT
   option masq      1
   option mtu_fix      1

config 'zone'
   option 'name' 'wifi'
   option 'input' 'ACCEPT'
   option 'ouput' 'ACCEPT'
   option 'forward' 'REJECT'

config forwarding
   option src      wifi
   option dest      wan
config fowarding
   option src      lan
   option dest      wifi
config forwarding
   option src      lan
   option dest      wan

[...]



taik

  • Visitante
Re: Aislar wlan de lan
« Respuesta #1 en: 05-10-2012, 22:51 (Viernes) »
Después de dos horas mirando creo que el fallo es por un elemento en la red LAN que está haciendo de WAN, haciendo que desde la WLAN se tenga acceso a la LAN.

Gracias por la inspiración :D