Autor Tema: Aircrack-ng en OpenWrt White Rusian 0.9 ( WRT54GL )  (Leído 4635 veces)

0 Usuarios y 1 Visitante están viendo este tema.

z1rr0s1s

  • Visitante
Aircrack-ng en OpenWrt White Rusian 0.9 ( WRT54GL )
« en: 21-10-2009, 17:44 (Miércoles) »
Wenas seguí los pasos de varios manuales como:
http://www.tuto-fr.com/tutoriaux/crack-wep/aircrack-wrt54g-openwrt.php

Bien instale el cifs, monte una carpeta compartida, instale aircrack-ng, wl...
Segun pone en el tuto hay que instalar wl para poder poner la interfaz eth1 en modo monitor.

Citar
root@OpenWrt:~# iwconfig           
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11-DS  ESSID:"" 
          Mode:Managed  Frequency:2.462 GHz  Tx-Power:off   
          RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:off

Para poner en modo monitor habria que ejecutar wl monitor 1:

ejecuto y obtengo el siguiente resultado con iwconfig:

Citar
eth1      IEEE 802.11-DS  ESSID:"" 
          Mode:Monitor  Frequency:2.457 GHz  Tx-Power:off   
          RTS thr=2347 B   Fragment thr=2346 B   
          Encryption key:off

Ahora pone en el manual que hay que hacer un ifup prism0 para activar la interfaz que crea iwconfig, pero lo ejecuto, hago un iwconfig/ifconfig y no aparece.

Into arrancar airodump-ng guardando lo capturado en mi carpeta cifs y error:

Citar
root@OpenWrt:~# airodump-ng -w /tmp/cifs/ prism0
prism0 is not a network interface.
root@OpenWrt:~#

No existe la interfaz prism0, intento con eth1:

Citar
root@OpenWrt:~# airodump-ng -w /tmp/cifs/cap eth1

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211
or ARPHRD_IEEE80211_PRISM instead.  Make sure RFMON is enabled:
run 'ifconfig eth1 up; iwconfig eth1 mode Monitor channel <#>'


A alguien le ha pasado? Que puedo mirar...

Un saludo  ;)



Dresi

  • Visitante
Re: Aircrack-ng en OpenWrt White Rusian 0.9 ( WRT54GL )
« Respuesta #1 en: 05-11-2009, 23:20 (Jueves) »
root@OpenWrt:~# airodump-ng -w /tmp/cifs/cap eth1

ARP linktype is set to 1 (Ethernet) - expected ARPHRD_IEEE80211
or ARPHRD_IEEE80211_PRISM instead.  Make sure RFMON is enabled:
run 'ifconfig eth1 up; iwconfig eth1 mode Monitor channel <#>'

yo de ahi extraeria que tienes que hacer algo como asi (hago un mini-script)

#/bin/sh
ifconfig eth1 down
iwconfig eth1 mode Monitor channel 1
ifconfig eth1 up


Suponiendo que el canal del wifi que quieres auditar sea el 1
el problema es que segun tu tu interfaz es eth1, y no prism0