Autor Tema: [Tutorial] OpenWrt en Western Digital My Net N750  (Leído 36702 veces)

0 Usuarios y 1 Visitante están viendo este tema.

vk496

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #100 en: 19-06-2015, 08:57 (Viernes) »
Tengo kernel 3.10.28 con r39598

Salu2



Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 2069
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #101 en: 19-06-2015, 12:26 (Viernes) »
Tengo kernel 3.10.28 con r39598

Salu2

Ahí llevas un regalito: WD-N750-WRT-Repository-3.10.28-1.zip

Comenta luego si te ha funcionado o no...  ;)
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #102 en: 19-06-2015, 12:39 (Viernes) »
Tengo kernel 3.10.28 con r39598

Salu2

Ahí llevas un regalito: WD-N750-WRT-Repository-3.10.28-1.zip

Comenta luego si te ha funcionado o no...  ;)

Yo también me lo bajo. Que tengo esa misma compilación y kernel.

Nunca se sabe cuando pueda hacer falta ...  ;D

Gracias Tki2000  ;)
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vk496

  • Visitante
Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #103 en: 19-06-2015, 13:14 (Viernes) »
Tengo kernel 3.10.28 con r39598

Salu2

Ahí llevas un regalito: WD-N750-WRT-Repository-3.10.28-1.zip

Comenta luego si te ha funcionado o no...  ;)
Gracias, de perlas!

Sin embargo, sigo teniendo el mismo problema que antes, no me quiere cargar los módulos del kernel. Si tienes la imagen para flashear que coincide con el kernel de esos paquetes, te lo agradecería.


He intentado compilar el firmware con muchos paquetes, pero glib2 me peta y no me deja continuar (12h compilando para esto jajajaja)

Salu2

Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 2069
Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #104 en: 19-06-2015, 14:21 (Viernes) »
Tengo kernel 3.10.28 con r39598

Salu2

Ahí llevas un regalito: WD-N750-WRT-Repository-3.10.28-1.zip

Comenta luego si te ha funcionado o no...  ;)
Gracias, de perlas!

Sin embargo, sigo teniendo el mismo problema que antes, no me quiere cargar los módulos del kernel. Si tienes la imagen para flashear que coincide con el kernel de esos paquetes, te lo agradecería.


He intentado compilar el firmware con muchos paquetes, pero glib2 me peta y no me deja continuar (12h compilando para esto jajajaja)

Salu2

Para cargar los módulos del kernel vas a tener que usar nodeps. Evidentemente el hash de mi kernel no coincide con el hash del compilado por jar229, pero siendo la misma versión del kernel debería funcionar forzando las dependencias.
Mírate este hilo: [Tutorial] Cómo intentar instalar paquetes dependientes del kernel

¿Qué sistema estás usando para compilar? Yo tuve que cambiar de un Ubuntu 12.10 a un 14.04 para compilar algunas cosas de CC.
A lo mejor te falta alguna biblioteca para compilar. Aparte de las expuestas en el hilo de compilación de OpenWrt, he tenido que añadir varias más, para compilar todos los paquetes (no sabría decirte cuáles, ya que lo iba solucionando sobre la marcha).
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

vk496

  • Visitante
Re: Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #105 en: 20-06-2015, 11:40 (Sábado) »
Tengo kernel 3.10.28 con r39598

Salu2

Ahí llevas un regalito: WD-N750-WRT-Repository-3.10.28-1.zip

Comenta luego si te ha funcionado o no...  ;)
Gracias, de perlas!

Sin embargo, sigo teniendo el mismo problema que antes, no me quiere cargar los módulos del kernel. Si tienes la imagen para flashear que coincide con el kernel de esos paquetes, te lo agradecería.


He intentado compilar el firmware con muchos paquetes, pero glib2 me peta y no me deja continuar (12h compilando para esto jajajaja)

Salu2

Para cargar los módulos del kernel vas a tener que usar nodeps. Evidentemente el hash de mi kernel no coincide con el hash del compilado por jar229, pero siendo la misma versión del kernel debería funcionar forzando las dependencias.
Mírate este hilo: [Tutorial] Cómo intentar instalar paquetes dependientes del kernel

¿Qué sistema estás usando para compilar? Yo tuve que cambiar de un Ubuntu 12.10 a un 14.04 para compilar algunas cosas de CC.
A lo mejor te falta alguna biblioteca para compilar. Aparte de las expuestas en el hilo de compilación de OpenWrt, he tenido que añadir varias más, para compilar todos los paquetes (no sabría decirte cuáles, ya que lo iba solucionando sobre la marcha).
Vale, ya lo he arreglado.

Resulta que si usaba opkg para instalar pptpd y kmod-mppe, el módulo kernel no llegaba a cargarse bien. Lo que hice fue instalar solo kmod-mppe. Luego "insmod" para instalar el módulo. Y por último modprobe. Es decir, cada módulo de kernel uno a uno.

Con esto ya tenía el módulo rulando. Sin embargo, me sucede una cosa muy rara con pptpd.

Después de dejarlo configurado, cuando intento conectarme, "peta". Es decir, la sesión ssh deja de responder y me desconecta (el router no se reinicia). Y para colmo, logread y dmesg no devuelve nada que indique la causa del problema (he probado arrancar pptpd forzando el parámetro -d (debug)). También me aseguré de que todos los módulos kernel estén cargados, y nada.

Edito: He encontrado la causa del problema.

Es necesaria la dependencia ip_tunnel.

Pero me resulta imposible cargarla:

Código: [Seleccionar]
root@OpenWrt:/mnt/sda2/n750/n750# opkg install kmod-iptunnel_3.10.28-1_ar71xx.ipk --force-depends
Installing kmod-iptunnel (3.10.28-1) to root...
Configuring kmod-iptunnel.
kmod: failed to insert /lib/modules/3.10.28/ip_tunnel.ko
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-iptunnel:
 *      kernel (= 3.10.28-1-5b5632bfc9db9a66e77d773a6eee4112) *

No puede instalar el módulo porque

Código: [Seleccionar]
[ 1092.310000] ip_tunnel: Unknown symbol __secpath_destroy (err 0)
Sospecho que hacia falta algún parámetro extra o algo durante la compilación del kernel. No se me ocurren más ideas para hacerlo andar :(

EDITO2: Si que se reinicia. Por eso no puedo saber lo que devuelven los logs :(

Salu2

Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 2069
Re: Re: Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #106 en: 20-06-2015, 21:23 (Sábado) »
Tengo kernel 3.10.28 con r39598

Salu2

Ahí llevas un regalito: WD-N750-WRT-Repository-3.10.28-1.zip

Comenta luego si te ha funcionado o no...  ;)
Gracias, de perlas!

Sin embargo, sigo teniendo el mismo problema que antes, no me quiere cargar los módulos del kernel. Si tienes la imagen para flashear que coincide con el kernel de esos paquetes, te lo agradecería.


He intentado compilar el firmware con muchos paquetes, pero glib2 me peta y no me deja continuar (12h compilando para esto jajajaja)

Salu2

Para cargar los módulos del kernel vas a tener que usar nodeps. Evidentemente el hash de mi kernel no coincide con el hash del compilado por jar229, pero siendo la misma versión del kernel debería funcionar forzando las dependencias.
Mírate este hilo: [Tutorial] Cómo intentar instalar paquetes dependientes del kernel

¿Qué sistema estás usando para compilar? Yo tuve que cambiar de un Ubuntu 12.10 a un 14.04 para compilar algunas cosas de CC.
A lo mejor te falta alguna biblioteca para compilar. Aparte de las expuestas en el hilo de compilación de OpenWrt, he tenido que añadir varias más, para compilar todos los paquetes (no sabría decirte cuáles, ya que lo iba solucionando sobre la marcha).
Vale, ya lo he arreglado.

Resulta que si usaba opkg para instalar pptpd y kmod-mppe, el módulo kernel no llegaba a cargarse bien. Lo que hice fue instalar solo kmod-mppe. Luego "insmod" para instalar el módulo. Y por último modprobe. Es decir, cada módulo de kernel uno a uno.

Con esto ya tenía el módulo rulando. Sin embargo, me sucede una cosa muy rara con pptpd.

Después de dejarlo configurado, cuando intento conectarme, "peta". Es decir, la sesión ssh deja de responder y me desconecta (el router no se reinicia). Y para colmo, logread y dmesg no devuelve nada que indique la causa del problema (he probado arrancar pptpd forzando el parámetro -d (debug)). También me aseguré de que todos los módulos kernel estén cargados, y nada.

Edito: He encontrado la causa del problema.

Es necesaria la dependencia ip_tunnel.

Pero me resulta imposible cargarla:

Código: [Seleccionar]
root@OpenWrt:/mnt/sda2/n750/n750# opkg install kmod-iptunnel_3.10.28-1_ar71xx.ipk --force-depends
Installing kmod-iptunnel (3.10.28-1) to root...
Configuring kmod-iptunnel.
kmod: failed to insert /lib/modules/3.10.28/ip_tunnel.ko
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-iptunnel:
 *      kernel (= 3.10.28-1-5b5632bfc9db9a66e77d773a6eee4112) *

No puede instalar el módulo porque

Código: [Seleccionar]
[ 1092.310000] ip_tunnel: Unknown symbol __secpath_destroy (err 0)
Sospecho que hacia falta algún parámetro extra o algo durante la compilación del kernel. No se me ocurren más ideas para hacerlo andar :(

EDITO2: Si que se reinicia. Por eso no puedo saber lo que devuelven los logs :(

Salu2

A ver si mañana puedo subir la imagen compilada. No sé lo que tienes instalado, pero puede que conservando las variables no tengas que reinstalar. De todas formas, mira lo que hayas instalado, y mételo con los ficheros a conservar junto con el backup, para restaurarlo después.
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 2069
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #107 en: 21-06-2015, 17:55 (Domingo) »
Creo, que esta es la compilación, a la que se corresponden los paquetes del repositorio que puse unos posts antes:

openwrt-ar71xx-generic-mynet-n750-squashfs-r39584.zip
« Última modificación: 21-06-2015, 17:56 (Domingo) por Tki2000 »
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

vk496

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #108 en: 13-07-2016, 23:44 (Miércoles) »
Buenas. A raíz de que mi USB se corrompió, decidí recompilar el firmware a una version mas actual ya que me ponía con el tema. Este lleva:

FPU, LUCi, soporte para sistemas ext, fat16, fat32, ntfs, soporte USB, screen.


Desconozco las diferencias que hay entre un firmware para routers que vienen con el original y los que ya tienen OpenWRT, por lo que recomiendo que solo se use a los que tienen OpenWRT (y a la espera de que alguien eche una luz sobre el tema)

Enlace: https://www.mediafire.com/folder/mxc8z31meb6v0/n750

Salu2
« Última modificación: 16-07-2016, 16:49 (Sábado) por vk496 »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #109 en: 14-07-2016, 09:10 (Jueves) »
Buenas. A raíz de que mi USB se corrompió, decidí recompilar el firmware a una version mas actual ya que me ponía con el tema. Este lleva:

FPU, LUCi, soporte para sistemas ext, fat16, fat32, ntfs, soporte USB, screen.


Desconozco las diferencias que hay entre un firmware para routers que vienen con el original y los que ya tienen OpenWRT, por lo que recomiendo que solo se use a los que tienen OpenWRT (y a la espera de que alguien eche una luz sobre el tema)

Enlace: https://www.mediafire.com/folder/mxc8z31meb6v0/n750

PD: Aun no he podido probarlo. Y tampoco sé donde puedo encontrar la revision exacta de la compilacion

Salu2

La compilación exacta, te la dice cuando estableces una conexión por ssh o a través de LuCi.

Gracias por compartirla  ;)
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vk496

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #110 en: 16-07-2016, 16:50 (Sábado) »
Ya lo he flasheado y todo perfecto.

Es la r49818

Salu2

vk496

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #111 en: 13-06-2017, 19:12 (Martes) »
Para los que tengáis este cacharro y no lo actualicéis desde el 2014... va siendo hora  ^-^ ^-^ ^-^

https://downloads.lede-project.org/releases/17.01.2/targets/ar71xx/generic/lede-17.01.2-ar71xx-generic-mynet-n750-squashfs-sysupgrade.bin

Probado desde OpenWRT a LEDE y todo perfecto.

Salu2

Conectado Tki2000

  • Moderador
  • *
  • Mensajes: 2069
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #112 en: 14-06-2017, 09:37 (Miércoles) »
Para los que tengáis este cacharro y no lo actualicéis desde el 2014... va siendo hora  ^-^ ^-^ ^-^

https://downloads.lede-project.org/releases/17.01.2/targets/ar71xx/generic/lede-17.01.2-ar71xx-generic-mynet-n750-squashfs-sysupgrade.bin

Probado desde OpenWRT a LEDE y todo perfecto.

Salu2

El mío va como un reloj suizo, con la r39584 y el repo entero compilado por mí, así que ya que funciona, no lo toco.
Tiene mogollón de cosas personalizadas... >:D
No habrás entendido algo, hasta que seas capaz de explicárselo a tu abuela...
Hacemos pantallas con píxeles casi invisibles, para luego ampliar la letra porque no la vemos... Bonita paradoja...
Creamos analfabetos tecnológicos con una velocidad pasmosa. Todo el mundo "maneja" tecnología, casi nadie sabe lo que tiene entre las manos, pero todo el mundo opina.
El analfabetismo, antes, pasaba desapercibido. Ahora, se transmite por Internet y las redes sociales.
Los dispositivos táctiles y las pantallas pequeñas son una lacra para la información relevante y el desarrollo de interfaces de usuario.
Trabajar sin la nube debería ser una prestación de los IoT, no un bug.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4596
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #113 en: 17-06-2017, 10:27 (Sábado) »
Para los que tengáis este cacharro y no lo actualicéis desde el 2014... va siendo hora  ^-^ ^-^ ^-^

https://downloads.lede-project.org/releases/17.01.2/targets/ar71xx/generic/lede-17.01.2-ar71xx-generic-mynet-n750-squashfs-sysupgrade.bin

Probado desde OpenWRT a LEDE y todo perfecto.

Salu2

Un día de estos ... lo actualizo  ;D

Gracias por confirmar que va bien con LEDE  >:(
Valoraciones positivas en compra/venta:
157 en Htcmania
207 en Har2mano
23 en elchapuzasinformatico
12 en gsmspain
 ....
 
Mis equipos en venta: https://drive.google.com/open?id=1Zi_bqLSfg_qCT8sx6JhPaWVvSeZXpcka

vk496

  • Visitante
Re: [Tutorial] OpenWrt en Western Digital My Net N750
« Respuesta #114 en: 17-06-2017, 16:00 (Sábado) »
Para los que tengáis este cacharro y no lo actualicéis desde el 2014... va siendo hora  ^-^ ^-^ ^-^

https://downloads.lede-project.org/releases/17.01.2/targets/ar71xx/generic/lede-17.01.2-ar71xx-generic-mynet-n750-squashfs-sysupgrade.bin

Probado desde OpenWRT a LEDE y todo perfecto.

Salu2

Un día de estos ... lo actualizo  ;D

Gracias por confirmar que va bien con LEDE  >:(

Con el VH4032N probé a hacer lo mismo y la cosa no fue bien. No terminaba nunca la actualización de firmware y ahora parece que está brickeado. Tendré que sacar hueco para recuperarlo.

Salu2

//FINAL Y MÁS DOS RESPUESTAS