Autor Tema: [Solucionado] Samba TP-LINK TL-WDR3600 OpenWrt Attitude Adjustment 12.09  (Leído 4127 veces)

0 Usuarios y 1 Visitante están viendo este tema.

machiminax

  • Visitante
Mi equipo es el siguiente

Código: [Seleccionar]
Router Model TP-LINK TL-WDR3600/4300/4310
Firmware Version OpenWrt Attitude Adjustment 12.09 / LuCI 0.11.1 Release (0.11.1)
Kernel Version 3.3.8

En su momento configure todo usando esta guia
https://foro.seguridadwireless.net/openwrt/instalacion-%28facil%29-de-openwrt-en-huawei-553/

No se que ha ocurrido que ahora la carpeta que comparto por samba no tiene permisos de escritura.
Mi problema es que cambio la configuracion pero al acceder a la carpeta la configuracion se "reinicia" por asi decirlo.

Accedo al router con putty y tecleo

Código: [Seleccionar]
/etc/init.d/samba stop
nano /etc/samba/smb.conf cambio la configuracion y la guardo.
para confirmar que este correcto vuelvo a teclear nano /etc/samba/smb.conf y confirmo que guardo la nueva configuracion
/etc/init.d/samab restart

Y aqui es cuando si accedo a la carpeta compartida sigo sin tener permisos de escritura.
vuelvo a putty

Código: [Seleccionar]
/etc/init.d/samba stop
nano /etc/samba/smb.conf

Y veo que la configuracion sigue siendo la misma de antes de la modificion.

Dejo mi configuracion:

Código: [Seleccionar]
[global]
netbios name = OpenWrt
display charset = UTF-8
interfaces = 127.0.0.1/8 lo 192.168.27.1/24 br-lan
server string = OpenWrt
unix charset = UTF-8
workgroup = WORKGROUP
browseable = yes
deadtime = 30
domain master = yes
encrypt passwords = true
enable core files = no
guest account = nobody
guest ok = yes
invalid users = root
local master = yes
load printers = no
map to guest = Bad User
max protocol = SMB2
min receivefile size = 16384
null passwords = yes
obey pam restrictions = yes
os level = 20
passdb backend = smbpasswd
preferred master = yes
printable = no
security = user
smb encrypt = disabled
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY IPTOS_LOWDELAY
syslog = 2
use sendfile = yes
writeable = yes


[homes]
comment     = Home Directories
browsable   = no
read only   = no
create mode = 0750

[pyload]
path = /mnt/sdb1
read only = no
guest ok = yes

Un dato que no se si influye es que mi router tiene exroot siguiendo este tutorial.




Agradeceria cualquier ayuda que me podais dar.


« Última modificación: 06-01-2015, 18:39 (Martes) por machiminax »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
No te estará pasando esto: https://foro.seguridadwireless.net/openwrt/%28faq%29-preguntas-mas-comunes-sobre-openwrt/#post_FAQ_Config_Reinit ?

Pon por aquí la salida del comando (debes ejecutarlo desde una conexión ssh):

Código: [Seleccionar]
df -h

machiminax

  • Visitante
Gracias por contestar.
Lo del firmware no creo que sea porque hace casi un año que no toco nada.
Hice todo desde cero siguiendo el tutorial del huawei y le coloque pyload aparte de hacer el exroot.
Desde entonces no cambie nada.
Ademas no hace falta reiniciar el router.Hago la modificacion y reinicio el servicio samba y ya me pierde la nueva configuracion.

Código: [Seleccionar]
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    4.7G     87.3M      4.3G   2% /
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    61.9M    924.0K     61.0M   1% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/sda1                 4.7G     87.3M      4.3G   2% /overlay
overlayfs:/overlay        4.7G     87.3M      4.3G   2% /
/dev/sdb1                29.7G     15.5G     12.8G  55% /mnt/sdb1
root@OpenWrt:~#


Mi carpeta compartida por samba tiene la siguiente estructura:


Código: [Seleccionar]
\\OPENWRT\pyload\1_PYLOAD
\\OPENWRT\pyload\2_TORRENTS


Dentro de las subcarpetas puedo crear archivos pero en la carpeta raiz no.
¿Alguna otra idea?
Gracias por ayudarme,un saludo.


« Última modificación: 05-01-2015, 20:50 (Lunes) por machiminax »

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
El fichero que tienes que editar es /etc/config/samba

El otro que estás 'tocando' déjalo estar tranquilo (no me extraña que no te guarde los cambios)  ;D

machiminax

  • Visitante
Gracias , creo que me lie con la rpi que cambia algunos directorios.

Una ultima cosa he colocado lo siguiente:

Código: [Seleccionar]
        option 'path' '/mnt/sdb1'
        option 'name' 'pyload'
        option 'writeable' 'yes'
        option 'guest_ok' 'yes'
        option 'create_mask' '0777'
        option 'directory_mask' '0777'

Pero sigue dejandome crear archivos solo en carpetas interiores no en la raiz.
¿Podrias decirme como seria la configuracion correcta?
Gracias de nuevo.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Código: [Seleccionar]
chmod 777 /mnt/sdb1

machiminax

  • Visitante
Muchisimas gracias , ahora funciona perfectamente.

Desconectado jar229

  • Moderador
  • *
  • Mensajes: 4604
Re: [Solucionado] Samba TP-LINK TL-WDR3600 OpenWrt Attitude Adjustment 12.09
« Respuesta #7 en: 06-01-2015, 19:38 (Martes) »
 ;)